FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > EPEL Development

 
 
LinkBack Thread Tools
 
Old 05-22-2012, 02:18 PM
Justin Brown
 
Default EL6: rubygems-stomp && mcollective

Hello,
I'm running EL 6.2 and encountered a dependency problem with two EPEL packages.
In some security configurations (stomp+ssl), mcollective requires the stomp rubygem (i.e. rubygem-stomp). Unfortunately, mcollective 2.0.0 (current version upstream and in EPEL) requires version >=1.20 of stomp. (The current version of stomp is 1.2.2, but the version in EPEL is 1.1.8.)

Currently, the rubygem-stomp RPM gets pulled in as a dependency of mcollective. I have to install rubygems, remove 1.1.8, and install 1.2.2. It's ugly, and I'm unable to manage rubygems through Puppet due to my network proxy. It would be extremely helpful to have the correct version in EPEL.

Would it be possible to generate a new package for rubygem-stomp that includes version 1.2.2?
I apologize if this is the wrong forum for this request.

Thanks,
Justin
========
Package Info:
Installed PackagesName * * * *: rubygem-stompArch * * * *: noarch
Version * * : 1.1.8Release * * : 1.el6Size * * * *: 79 kRepo * * * *: installedFrom repo * : epel
Installed PackagesName * * * *: mcollective
Arch * * * *: noarchVersion * * : 2.0.0Release * * : 1.el6Size * * * *: 16 kRepo * * * *: installedFrom repo * : epel





_______________________________________________
epel-devel-list mailing list
epel-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/epel-devel-list
 

Thread Tools




All times are GMT. The time now is 09:27 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org