FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > EPEL Development

 
 
LinkBack Thread Tools
 
Old 10-18-2011, 11:42 PM
Jérôme Benoit
 
Default duplicity on EPEL4

On Tue, 18 Oct 2011 15:04:26 -0700
Toshio Kuratomi <a.badger@gmail.com> wrote:


> > How other python package in EPEL 4 handle subprocess requirement ?
> > So I can jump on my bug and fix the .spec file.
> >
> You can either make do without duplicity on EPEL4

Well ... is EPEL policy include : We can ship borken package, user just
have to not use them.

I don't think so.

> change the code to
> not use subprocess,

Not a good idea.

> or change the code to use a replacement -- for
> instance pyhton-kitchen provides a compat subprocess module.
>
> Something like:
> try:
> import subprocess
> except ImportError:
> from kitchen.pycompat27 import subprocess
>
> will likely work for you.

Sound great, a conditional patch to apply in the .spec file.
Will work on it ASAP.

Thks.

--
Jérôme Benoit aka fraggle
La Météo du Net - http://grenouille.com
OpenPGP Key ID : 9FE9161D
Key fingerprint : 9CA4 0249 AF57 A35B 34B3 AC15 FAA0 CB50 9FE9 161D
_______________________________________________
epel-devel-list mailing list
epel-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/epel-devel-list
 

Thread Tools




All times are GMT. The time now is 09:45 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org