FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > EPEL Development

 
 
LinkBack Thread Tools
 
Old 06-02-2011, 02:23 AM
Daniel Mirchandani
 
Default Subversion bindings for Python 2.6

I have installed the "python26" package on my CentOS 5.6 box and it's
working quite well. I am trying to use the subversion bindings from
within a Python 2.6 script. Since the official "subversion" package
only installs bindings for Python 2.4, I added the file
"/usr/lib/python2.6/site-packages/svn.pth" with the line:

/usr/lib/python2.4/site-packages

I get the following warnings when I attempt running the Python 2.6
script which tells me this isn't the best solution:

/usr/lib/python2.4/site-packages/libsvn/fs.py:7: RuntimeWarning:
Python C API version mismatch for module _fs: This Python has API
version 1013, module _fs has version 1012.
import _fs
/usr/lib/python2.4/site-packages/libsvn/fs.py:7: RuntimeWarning:
Python C API version mismatch for module swig_runtime_data4: This
Python has API version 1013, module swig_runtime_data4 has version
1012.
import _fs
/usr/lib/python2.4/site-packages/libsvn/core.py:7: RuntimeWarning:
Python C API version mismatch for module _core: This Python has API
version 1013, module _core has version 1012.
import _core
/usr/lib/python2.4/site-packages/libsvn/delta.py:7: RuntimeWarning:
Python C API version mismatch for module _delta: This Python has API
version 1013, module _delta has version 1012.
import _delta
/usr/lib/python2.4/site-packages/libsvn/repos.py:7: RuntimeWarning:
Python C API version mismatch for module _repos: This Python has API
version 1013, module _repos has version 1012.
import _repos

Are there any plans to create a separate package for the subversion
bindings for Python 2.6? I understand I can download SWIG and build
the bindings myself, but I'd prefer an RPM solution if one exists.

Dan Mirchandani

By the way, I'm the same person who asked about later versions of Trac
on CentOS 5. I ended up using the "python26-distribute" package and
executing `easy_install-2.6 Trac`, which ended up working very well.

_______________________________________________
epel-devel-list mailing list
epel-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/epel-devel-list
 
Old 06-02-2011, 04:42 PM
Sergio Pascual
 
Default Subversion bindings for Python 2.6

Hi,

this repo contains trac for python-2.6

http://repos.fedorapeople.org/repos/npmccallum/trac/

but it doesn't include the subversion bindings (apparently the owner uses git)

regards

2011/6/2 Daniel Mirchandani <chromus@gmail.com>:
> I have installed the "python26" package on my CentOS 5.6 box and it's
> working quite well. I am trying to use the subversion bindings from
> within a Python 2.6 script. Since the official "subversion" package
> only installs bindings for Python 2.4, I added the file
> "/usr/lib/python2.6/site-packages/svn.pth" with the line:
>
> /usr/lib/python2.4/site-packages
>
> I get the following warnings when I attempt running the Python 2.6
> script which tells me this isn't the best solution:
>
> /usr/lib/python2.4/site-packages/libsvn/fs.py:7: RuntimeWarning:
> Python C API version mismatch for module _fs: This Python has API
> version 1013, module _fs has version 1012.
> *import _fs
> /usr/lib/python2.4/site-packages/libsvn/fs.py:7: RuntimeWarning:
> Python C API version mismatch for module swig_runtime_data4: This
> Python has API version 1013, module swig_runtime_data4 has version
> 1012.
> *import _fs
> /usr/lib/python2.4/site-packages/libsvn/core.py:7: RuntimeWarning:
> Python C API version mismatch for module _core: This Python has API
> version 1013, module _core has version 1012.
> *import _core
> /usr/lib/python2.4/site-packages/libsvn/delta.py:7: RuntimeWarning:
> Python C API version mismatch for module _delta: This Python has API
> version 1013, module _delta has version 1012.
> *import _delta
> /usr/lib/python2.4/site-packages/libsvn/repos.py:7: RuntimeWarning:
> Python C API version mismatch for module _repos: This Python has API
> version 1013, module _repos has version 1012.
> *import _repos
>
> Are there any plans to create a separate package for the subversion
> bindings for Python 2.6? I understand I can download SWIG and build
> the bindings myself, but I'd prefer an RPM solution if one exists.
>
> Dan Mirchandani
>
> By the way, I'm the same person who asked about later versions of Trac
> on CentOS 5. I ended up using the "python26-distribute" package and
> executing `easy_install-2.6 Trac`, which ended up working very well.
>
> _______________________________________________
> epel-devel-list mailing list
> epel-devel-list@redhat.com
> https://www.redhat.com/mailman/listinfo/epel-devel-list
>

_______________________________________________
epel-devel-list mailing list
epel-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/epel-devel-list
 

Thread Tools




All times are GMT. The time now is 04:16 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org