FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > EPEL Development

 
 
LinkBack Thread Tools
 
Old 03-23-2011, 12:36 AM
Chris Adams
 
Default RHEL 5.6 and PHP 5.3

Now that RHEL 5.6 has added PHP 5.3 (php53-* packages), is there any
plan on what to do with the EPEL PHP packages? If I did my query right,
it looks like the following EPEL packages are built for PHP 5.1 only (by
source RPM):

libpuzzle
php-extras
php-facedetect
php-idn
php-magickwand
php-pecl-Fileinfo
php-pecl-geoip
php-pecl-gmagick
php-pecl-imagick
php-pecl-json
php-pecl-lzf
php-pecl-mailparse
php-pecl-mongo
php-pecl-radius
php-pecl-runkit
php-pecl-xdebug
php-pecl-zip

It looks like almost all would just need to be rebuilt (or rather a
php53-foo package added I guess), but there would need to be a different
php-extras (the source RPM is tied to the specific PHP version).

--
Chris Adams <cmadams@hiwaay.net>
Systems and Network Administrator - HiWAAY Internet Services
I don't speak for anybody but myself - that's enough trouble.

_______________________________________________
epel-devel-list mailing list
epel-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/epel-devel-list
 
Old 03-25-2011, 12:59 PM
Rainer Traut
 
Default RHEL 5.6 and PHP 5.3

Am 23.03.2011 02:36, schrieb Chris Adams:

Now that RHEL 5.6 has added PHP 5.3 (php53-* packages), is there any
plan on what to do with the EPEL PHP packages? If I did my query right,
it looks like the following EPEL packages are built for PHP 5.1 only (by
source RPM):

libpuzzle
php-extras
php-facedetect
php-idn
php-magickwand
php-pecl-Fileinfo
php-pecl-geoip
php-pecl-gmagick
php-pecl-imagick
php-pecl-json
php-pecl-lzf
php-pecl-mailparse
php-pecl-mongo
php-pecl-radius
php-pecl-runkit
php-pecl-xdebug
php-pecl-zip



I think phpMyAdmin has the same problem:

yum install phpMyAdmin.noarch
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package phpMyAdmin.noarch 0:2.11.11.3-1.el5 set to be updated
--> Processing Dependency: php-mcrypt >= 4.1.0 for package: phpMyAdmin
--> Processing Dependency: php-mysql >= 4.1.0 for package: phpMyAdmin
--> Processing Dependency: php >= 4.1.0 for package: phpMyAdmin
--> Processing Dependency: php-mbstring >= 4.1.0 for package: phpMyAdmin
--> Running transaction check
---> Package php.x86_64 0:5.1.6-27.el5_5.3 set to be updated
--> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php
--> Processing Dependency: php-cli = 5.1.6-27.el5_5.3 for package: php
---> Package php-mbstring.x86_64 0:5.1.6-27.el5_5.3 set to be updated
---> Package php-mcrypt.x86_64 0:5.1.6-5.el5 set to be updated
--> Processing Dependency: libmcrypt.so.4()(64bit) for package: php-mcrypt
---> Package php-mysql.x86_64 0:5.1.6-27.el5_5.3 set to be updated
--> Processing Dependency: php-pdo for package: php-mysql
--> Running transaction check
---> Package libmcrypt.x86_64 0:2.5.7-5.el5 set to be updated
---> Package php-cli.x86_64 0:5.1.6-27.el5_5.3 set to be updated
---> Package php-common.x86_64 0:5.1.6-27.el5_5.3 set to be updated
---> Package php-pdo.x86_64 0:5.1.6-27.el5_5.3 set to be updated
--> Processing Conflict: php53-common conflicts php-common
--> Finished Dependency Resolution
php53-common-5.3.3-1.el5_6.1.x86_64 from installed has depsolving problems
--> php53-common conflicts with php-common
Error: php53-common conflicts with php-common

Rainer

_______________________________________________
epel-devel-list mailing list
epel-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/epel-devel-list
 
Old 03-25-2011, 01:11 PM
Chris Adams
 
Default RHEL 5.6 and PHP 5.3

Once upon a time, Rainer Traut <tr.ml@gmx.de> said:
> Am 23.03.2011 02:36, schrieb Chris Adams:
> >Now that RHEL 5.6 has added PHP 5.3 (php53-* packages), is there any
> >plan on what to do with the EPEL PHP packages? If I did my query right,
> >it looks like the following EPEL packages are built for PHP 5.1 only (by
> >source RPM):
> >
> > libpuzzle
> > php-extras
> > php-facedetect
> > php-idn
> > php-magickwand
> > php-pecl-Fileinfo
> > php-pecl-geoip
> > php-pecl-gmagick
> > php-pecl-imagick
> > php-pecl-json
> > php-pecl-lzf
> > php-pecl-mailparse
> > php-pecl-mongo
> > php-pecl-radius
> > php-pecl-runkit
> > php-pecl-xdebug
> > php-pecl-zip
> >
>
> I think phpMyAdmin has the same problem:

The problem is not phpMyAdmin itself (it doesn't require a specific
version of PHP), but php-mcrypt (which comes from php-extras, listed
above).

Oh wait, also anything with a Requires like "php-mysql >= 4.1.0" won't
work, because the RHEL php53-mysql package doesn't provide "php-mysql".
The RHEL php53 package doesn't even provide "php", so all kinds of
dependencies are going to fail.

Anybody have any ideas on how to untangle this? Is it going to even be
possible to use EPEL PHP packages with RHEL 5.6 PHP 5.3?
--
Chris Adams <cmadams@hiwaay.net>
Systems and Network Administrator - HiWAAY Internet Services
I don't speak for anybody but myself - that's enough trouble.

_______________________________________________
epel-devel-list mailing list
epel-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/epel-devel-list
 
Old 03-25-2011, 02:16 PM
Kevin Fenzi
 
Default RHEL 5.6 and PHP 5.3

On Fri, 25 Mar 2011 09:11:44 -0500
Chris Adams <cmadams@hiwaay.net> wrote:

> The problem is not phpMyAdmin itself (it doesn't require a specific
> version of PHP), but php-mcrypt (which comes from php-extras, listed
> above).
>
> Oh wait, also anything with a Requires like "php-mysql >= 4.1.0" won't
> work, because the RHEL php53-mysql package doesn't provide
> "php-mysql". The RHEL php53 package doesn't even provide "php", so
> all kinds of dependencies are going to fail.
>
> Anybody have any ideas on how to untangle this? Is it going to even
> be possible to use EPEL PHP packages with RHEL 5.6 PHP 5.3?

It's going to take people creating, submitting, reviewing php53 based
parallel installable packages I think. ;(

Just like we had with the python26 stack.

kevin
_______________________________________________
epel-devel-list mailing list
epel-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/epel-devel-list
 
Old 03-26-2011, 10:42 AM
Jan-Frode Myklebust
 
Default RHEL 5.6 and PHP 5.3

On 2011-03-25, Kevin Fenzi <kevin@scrye.com> wrote:
> It's going to take people creating, submitting, reviewing php53 based
> parallel installable packages I think. ;(=20

AFAIK the PHP and PHP53 packages from RHEL should not be installed
together, so parallel installable packages shouldn't be necessary.
Duplicate and mutually exclusive versions is probably the solution,
and should be easier than having to worry about same version packages
built for different PHPs.


-jf

_______________________________________________
epel-devel-list mailing list
epel-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/epel-devel-list
 

Thread Tools




All times are GMT. The time now is 07:59 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org