FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > EPEL Development

 
 
LinkBack Thread Tools
 
Old 03-14-2011, 07:52 PM
Kevin Fenzi
 
Default Meeting summary/minutes from today's EPEL sig meeting (2011-03-14)

==================================
#fedora-meeting: EPEL (2011-03-14)
==================================

Meeting started by nirik at 20:30:06 UTC. The full logs are available at
http://meetbot.fedoraproject.org/fedora-meeting/2011-03-14/epel.2011-03-14-20.30.log.html

Meeting summary
---------------
* init process/agenda (nirik, 20:30:06)

* DST / meeting time (nirik, 20:33:25)
* AGREED: Keep meetings at 20:30 UTC for now. (nirik, 20:35:54)

* Wiki repaving (nirik, 20:38:17)

* clamav (nirik, 20:40:16)

* Open Floor (nirik, 20:42:00)

Meeting ended at 20:51:40 UTC.




Action Items
------------





Action Items, by person
-----------------------
* **UNASSIGNED**
* (none)




People Present (lines said)
---------------------------
* nirik (43)
* nb (5)
* Jeff_S (5)
* smooge (4)
* zodbot (3)
* tremble (2)
* rsc (1)
--
20:30:06 <nirik> #startmeeting EPEL (2011-03-14)
20:30:06 <zodbot> Meeting started Mon Mar 14 20:30:06 2011 UTC. The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:30:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:30:06 <nirik> #meetingname epel
20:30:06 <nirik> #topic init process/agenda
20:30:06 <zodbot> The meeting name has been set to 'epel'
20:30:35 <nirik> anyone around for a quick epel meeting?
20:30:38 <rsc> Robert Scheck (robert)
20:30:49 * tremble lurks
20:31:03 <nirik> I had the following items: *DST change/meeting time, *wiki revamp progress, *clamav news.
20:31:09 <nirik> nb: you around?
20:31:19 <Jeff_S> nirik: hi
20:32:27 <nirik> ok anyone have anything aside from the items I already mentioned:
20:32:29 <nirik> I had the following items: *DST change/meeting time, *wiki revamp progress, *clamav news.
20:33:13 <nirik> ok, lets go ahead and get started and hopefully it will be a quick meeting.
20:33:25 <nirik> #topic DST / meeting time
20:33:41 <nirik> so, DST happened in the US. It's going to happen in EU in a few weeks.
20:33:51 <nirik> do we want to keep at 20UTC?
20:33:54 <nirik> or move?
20:34:36 <nirik> I'm fine with 20UTC
20:34:40 <Jeff_S> I'm fine to stay how it is now
20:35:12 <nirik> sorry, 20:30UTC
20:35:32 <smooge> I am fine with right now. I hate DST, I hate moving meetings, I am sweating pure hate today
20:35:35 <nirik> if no one yells, I will just say keep it at that.
20:35:54 <nirik> #agreed Keep meetings at 20:30 UTC for now.
20:35:57 <Jeff_S> smooge: I hate you too if that makes you feel better
20:36:03 <nirik> smooge: is that like pure concentrated evil?
20:36:14 <smooge> yes.. don't touch it
20:36:31 <tremble> may want to ping the .fr ambassadors, check to see if/when they plan on shifting.
20:37:10 <nirik> shaiton: you still around? do you know if the fedora-fr meeting intends to move with the daylight savings time or not?
20:38:06 <nirik> we can revisit if they move.
20:38:17 <nirik> #topic Wiki repaving
20:38:24 <nirik> I didn't get much done on this over the last week.
20:38:33 <nirik> But I will put in what I have later today or tomorrow.
20:38:40 <nirik> then we can build out from that.
20:38:58 <nirik> if anyone wants to help, I'll work on it in #epel.
20:39:05 <nirik> anything else on wiki?
20:40:16 <nirik> #topic clamav
20:40:34 <nirik> We found a interested party from the mailing list to help out with clamav and amavisd-new.
20:40:46 <nirik> nb is mentoring him in the packaging process.
20:41:16 <nirik> so, hopefully we are close to a clamav+amavisd-new that work together and don't case eye strain when looking at the spec.
20:41:37 <nirik> so, talk with them if you notice any problems.
20:42:00 <nirik> #topic Open Floor
20:42:03 <nirik> Any other items?
20:44:56 <nirik> ok, will end in a minute then.
20:45:34 <Jeff_S> nirik: thanks, that was fast! I took a phone call and missed the whole thing
20:45:57 <nirik> did you have anything to bring up?
20:46:14 <Jeff_S> nope, I'm happy
20:46:37 <smooge> I was looking for otehr amavis spec files .. i
20:46:52 <smooge> if we are using DAG for one.. I figured I would check for others.
20:47:27 <nirik> I think the new guy got it working ok with the clamav we have...
20:47:33 <nirik> we just needed to add a wrapper thing.
20:48:04 * nb here
20:48:20 <nirik> nb: any clam news to report I didn't yet?
20:48:27 <nb> janfrode is working on it
20:48:35 <nb> i think he is having problems with the requires/obsoletes
20:48:49 <nb> but i wonder if it is because he isn't yum localinstall'ing all of the rpms in one transaction
20:49:43 <nirik> ok, we can get it figured out of band...
20:49:53 <nirik> I just hope the light at the end of the clamav tunnel isn't a train.
20:50:05 <nb> yeah
20:50:42 <nirik> ok, anything else before we close?
20:51:36 <nirik> ok, thanks for coming everyone!
20:51:40 <nirik> #endmeeting
_______________________________________________
epel-devel-list mailing list
epel-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/epel-devel-list
 
Old 03-15-2011, 10:38 AM
Jan-Frode Myklebust
 
Default Meeting summary/minutes from today's EPEL sig meeting (2011-03-14)

On 2011-03-14, Kevin Fenzi <kevin@scrye.com> wrote:
> * clamav (nirik, 20:40:16)
> 20:40:16 <nirik> #topic clamav
> 20:48:35 <nb> i think he is having problems with the requires/obsoletes
> 20:48:49 <nb> but i wonder if it is because he isn't yum localinstall'ing a=
> ll of the rpms in one transaction

I'm unable to figure out the dependency problems for
old clamav-filesystem on RHEL5.

# yum localinstall clamav-db-0.97-8.el5.x86_64.rpm clamd-0.97-8.el5.x86_64.rpm clamav-0.97-8.el5.x86_64.rpm
Setting up Local Package Process
Examining clamav-0.97-8.el5.x86_64.rpm: clamav-0.97-8.el5.x86_64
Marking clamav-0.97-8.el5.x86_64.rpm as an update to clamav-0.95.1-1.el5.x86_64
Examining clamav-db-0.97-8.el5.x86_64.rpm: clamav-db-0.97-8.el5.x86_64
Marking clamav-db-0.97-8.el5.x86_64.rpm to be installed
Examining clamd-0.97-8.el5.x86_64.rpm: clamd-0.97-8.el5.x86_64
Marking clamd-0.97-8.el5.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package clamav.x86_64 0:0.97-8.el5 set to be updated
---> Package clamav-db.x86_64 0:0.97-8.el5 set to be updated
---> Package clamd.x86_64 0:0.97-8.el5 set to be updated
--> Processing Conflict: clamav-filesystem conflicts clamav > 0.95.1-1.el5
--> Finished Dependency Resolution
clamav-filesystem-0.95.1-1.el5.x86_64 from installed has depsolving problems
--> clamav-filesystem conflicts with clamav
Error: clamav-filesystem conflicts with clamav
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

This was with clamav-db obsoleting and providing clamav-filesystem:

Provides: clamav-filesystem = %{version}-%{release}
Obsoletes: clamav-filesystem < %{version}-%{release}

I'm now wondering if there might be a problem with the old
clamav-filesystem package. It has some conflicts listed (which
I don't know what means":

# rpm -q --queryformat 'CONFLICTS: %{CONFLICTS}
CONFLICTVERSION: %{CONFLICTVERSION}
CONFLICTFLAGS: %{CONFLICTFLAGS}
CONFLICTNAME: %{CONFLICTNAME}
' clamav-filesystem
CONFLICTS: clamav
CONFLICTVERSION: 0.95.1-1.el5
CONFLICTFLAGS: 2
CONFLICTNAME: clamav

Looking at the old spec-file, it the clamav-filesystem package has:

Conflicts: %name < %version-%release
Conflicts: %name > %version-%release

http://fpaste.org/6PwF/

But -- I still don't understand why this isn't resolved when upgrading
clamav-db obsoletes and provides clamav-filesystem. Is the problem maybe
that during the upgrade both packages will be installed, and that
triggers this conflict ?

Any suggestions for how to fix this ?


-jf

_______________________________________________
epel-devel-list mailing list
epel-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/epel-devel-list
 
Old 03-15-2011, 10:45 AM
Michael Schwendt
 
Default Meeting summary/minutes from today's EPEL sig meeting (2011-03-14)

On Tue, 15 Mar 2011 12:38:24 +0100, Jan-Frode wrote:

> I'm now wondering if there might be a problem with the old
> clamav-filesystem package. It has some conflicts listed (which
> I don't know what means":
>
> # rpm -q --queryformat 'CONFLICTS: %{CONFLICTS}
CONFLICTVERSION: %{CONFLICTVERSION}
CONFLICTFLAGS: %{CONFLICTFLAGS}
CONFLICTNAME: %{CONFLICTNAME}
' clamav-filesystem
> CONFLICTS: clamav
> CONFLICTVERSION: 0.95.1-1.el5
> CONFLICTFLAGS: 2
> CONFLICTNAME: clamav
>
> Looking at the old spec-file, it the clamav-filesystem package has:
>
> Conflicts: %name < %version-%release
> Conflicts: %name > %version-%release

You can use the "rpm -q --conflicts ..." query instead of constructing
the very complex queryformat above.

_______________________________________________
epel-devel-list mailing list
epel-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/epel-devel-list
 
Old 03-15-2011, 10:57 AM
Jan-Frode Myklebust
 
Default Meeting summary/minutes from today's EPEL sig meeting (2011-03-14)

On 2011-03-15, Jan-Frode Myklebust <janfrode@tanso.net> wrote:
>
> Looking at the old spec-file, it the clamav-filesystem package has:
>
> Conflicts: %name < %version-%release
> Conflicts: %name > %version-%release
>
> http://fpaste.org/6PwF/
>
> But -- I still don't understand why this isn't resolved when upgrading
> clamav-db obsoletes and provides clamav-filesystem. Is the problem maybe
> that during the upgrade both packages will be installed, and that
> triggers this conflict ?

That seems to be it.. "yum localinstall *" fails, while "rpm -Uvh --test *"
seems OK with the packages.

> Any suggestions for how to fix this ?


-jf

_______________________________________________
epel-devel-list mailing list
epel-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/epel-devel-list
 
Old 03-15-2011, 11:18 AM
seth vidal
 
Default Meeting summary/minutes from today's EPEL sig meeting (2011-03-14)

On Tue, 2011-03-15 at 12:38 +0100, Jan-Frode Myklebust wrote:
> On 2011-03-14, Kevin Fenzi <kevin@scrye.com> wrote:
> > * clamav (nirik, 20:40:16)
> > 20:40:16 <nirik> #topic clamav
> > 20:48:35 <nb> i think he is having problems with the requires/obsoletes
> > 20:48:49 <nb> but i wonder if it is because he isn't yum localinstall'ing a=
> > ll of the rpms in one transaction
>
> I'm unable to figure out the dependency problems for
> old clamav-filesystem on RHEL5.
>
> # yum localinstall clamav-db-0.97-8.el5.x86_64.rpm clamd-0.97-8.el5.x86_64.rpm clamav-0.97-8.el5.x86_64.rpm
> Setting up Local Package Process
> Examining clamav-0.97-8.el5.x86_64.rpm: clamav-0.97-8.el5.x86_64
> Marking clamav-0.97-8.el5.x86_64.rpm as an update to clamav-0.95.1-1.el5.x86_64
> Examining clamav-db-0.97-8.el5.x86_64.rpm: clamav-db-0.97-8.el5.x86_64
> Marking clamav-db-0.97-8.el5.x86_64.rpm to be installed
> Examining clamd-0.97-8.el5.x86_64.rpm: clamd-0.97-8.el5.x86_64
> Marking clamd-0.97-8.el5.x86_64.rpm to be installed
> Resolving Dependencies
> --> Running transaction check
> ---> Package clamav.x86_64 0:0.97-8.el5 set to be updated
> ---> Package clamav-db.x86_64 0:0.97-8.el5 set to be updated
> ---> Package clamd.x86_64 0:0.97-8.el5 set to be updated
> --> Processing Conflict: clamav-filesystem conflicts clamav > 0.95.1-1.el5
> --> Finished Dependency Resolution
> clamav-filesystem-0.95.1-1.el5.x86_64 from installed has depsolving problems
> --> clamav-filesystem conflicts with clamav
> Error: clamav-filesystem conflicts with clamav
> You could try using --skip-broken to work around the problem
> You could try running: package-cleanup --problems
> package-cleanup --dupes
> rpm -Va --nofiles --nodigest
> The program package-cleanup is found in the yum-utils package.
>
> This was with clamav-db obsoleting and providing clamav-filesystem:
>
> Provides: clamav-filesystem = %{version}-%{release}
> Obsoletes: clamav-filesystem < %{version}-%{release}
>
> I'm now wondering if there might be a problem with the old
> clamav-filesystem package. It has some conflicts listed (which
> I don't know what means":
>
> # rpm -q --queryformat 'CONFLICTS: %{CONFLICTS}
CONFLICTVERSION: %{CONFLICTVERSION}
CONFLICTFLAGS: %{CONFLICTFLAGS}
CONFLICTNAME: %{CONFLICTNAME}
' clamav-filesystem
> CONFLICTS: clamav
> CONFLICTVERSION: 0.95.1-1.el5
> CONFLICTFLAGS: 2
> CONFLICTNAME: clamav
>
> Looking at the old spec-file, it the clamav-filesystem package has:
>
> Conflicts: %name < %version-%release
> Conflicts: %name > %version-%release
>
> http://fpaste.org/6PwF/
>
> But -- I still don't understand why this isn't resolved when upgrading
> clamav-db obsoletes and provides clamav-filesystem. Is the problem maybe
> that during the upgrade both packages will be installed, and that
> triggers this conflict ?
>
> Any suggestions for how to fix this ?
>

What version of yum in el5 is it? We fixed a book specifically about
obsoletes in localinstall runs.

-sv


_______________________________________________
epel-devel-list mailing list
epel-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/epel-devel-list
 
Old 03-15-2011, 11:28 AM
Jan-Frode Myklebust
 
Default Meeting summary/minutes from today's EPEL sig meeting (2011-03-14)

On 2011-03-15, Michael Schwendt <mschwendt@gmail.com> wrote:
>
> You can use the "rpm -q --conflicts ..." query instead of constructing
> the very complex queryformat above.

Yes, thanks. It seems there must be something different with
RPM or YUM between RHEL5 and RHEL6 here:

RHEL5# rpm -q --conflicts clamav-filesystem
clamav < 0.95.1-1.el5
clamav > 0.95.1-1.el5

RHEL5# rpm -Uvh --test clamav-0.97-8.el5.x86_64.rpm clamav-db-0.97-8.el5.x86_64.rpm clamd-0.97-8.el5.x86_64.rpm
Preparing... ########################################### [100%]

RHEL5# yum localinstall clamav-0.97-8.el5.x86_64.rpm clamav-db-0.97-8.el5.x86_64.rpm clamd-0.97-8.el5.x86_64.rpm

Error: clamav-filesystem conflicts with clamav


RHEL6# rpm -q --conflicts clamav-filesystem
clamav < 0.96.1-1401.el6
clamav > 0.96.1-1401.el6

RHEL6# # rpm -Uvh --test clamav-0.97-7.el6.x86_64.rpm clamav-db-0.97-7.el6.x86_64.rpm clamd-0.97-7.el6.x86_64.rpm
Forbereder... ########################################### [100%]

RHEL6# yum localinstall clamav-0.97-7.el6.x86_64.rpm clamav-db-0.97-7.el6.x86_64.rpm clamd-0.97-7.el6.x86_64.rpm
================================================== ==============================================
Package Arch Version Repository Size
================================================== ==============================================
Installing:
clamav-db x86_64 0.97-7.el6 /clamav-db-0.97-7.el6.x86_64 26 M
replacing clamav-data.noarch 0.96.1-1401.el6
replacing clamav-update.x86_64 0.96.1-1401.el6
clamd x86_64 0.97-7.el6 /clamd-0.97-7.el6.x86_64 395 k
replacing clamav-scanner.noarch 0.96.1-1401.el6
replacing clamav-scanner-upstart.noarch 0.96.1-1401.el6
replacing clamav-server.x86_64 0.96.1-1401.el6
replacing clamav-server-sysvinit.noarch 0.96.1-1401.el6
Updating:
clamav x86_64 0.97-7.el6 /clamav-0.97-7.el6.x86_64 15 M
replacing clamav-filesystem.noarch 0.96.1-1401.el6
replacing clamav-lib.x86_64 0.96.1-1401.el6

Transaction Summary
================================================== ==============================================
Install 2 Package(s)
Upgrade 1 Package(s)



-jf

_______________________________________________
epel-devel-list mailing list
epel-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/epel-devel-list
 
Old 03-15-2011, 11:49 AM
Jan-Frode Myklebust
 
Default Meeting summary/minutes from today's EPEL sig meeting (2011-03-14)

On 2011-03-15, seth vidal <skvidal@fedoraproject.org> wrote:
>
> What version of yum in el5 is it? We fixed a book specifically about
> obsoletes in localinstall runs.

Latest RHEL5-version, yum-3.2.22-33.el5.


-jf

_______________________________________________
epel-devel-list mailing list
epel-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/epel-devel-list
 
Old 03-15-2011, 11:56 AM
Jan-Frode Myklebust
 
Default Meeting summary/minutes from today's EPEL sig meeting (2011-03-14)

On 2011-03-15, seth vidal <skvidal@fedoraproject.org> wrote:
>
> What version of yum in el5 is it? We fixed a book specifically about
> obsoletes in localinstall runs.

Running against a proper yum repo fixed it, so it was a
localinstall-bug I was hitting. Thanks!


-jf

_______________________________________________
epel-devel-list mailing list
epel-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/epel-devel-list
 

Thread Tools




All times are GMT. The time now is 11:17 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org