Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   EPEL Development (http://www.linux-archive.org/epel-development/)
-   -   epel beta report: 20110110 changes (http://www.linux-archive.org/epel-development/474774-epel-beta-report-20110110-changes.html)

EPEL Beta Report 01-10-2011 05:15 PM

epel beta report: 20110110 changes
 
Compose started at Mon Jan 10 17:37:27 UTC 2011

Broken deps for x86_64
----------------------------------------------------------
asterisk-ices-1.6.2.12-0.1.rc1.el6.x86_64 requires ices
asterisk-ldap-fds-1.6.2.12-0.1.rc1.el6.x86_64 requires fedora-ds-base
bodhi-server-0.7.4-1.el6.noarch requires python-turboflot
byobu-3.21-1.el6.noarch requires python26
callweaver-zaptel-1.2.1-2.el6.x86_64 requires libtonezone.so.1.0()(64bit)
callweaver-zaptel-1.2.1-2.el6.x86_64 requires zaptel >= 0:1.4.0-1
claws-mail-plugins-dillo-3.7.6-1.el6.x86_64 requires dillo
cobbler-2.0.10-1.el6.noarch requires fence-agents
dh-make-0.55-2.el6.noarch requires debhelper
dnssec-tools-1.7-3.el6.x86_64 requires perl(QWizard)
drbdlinks-1.18-2.el6.noarch requires heartbeat
fvwm-2.5.30-2.el6.x86_64 requires xlockmore
fvwm-2.5.30-2.el6.x86_64 requires /usr/bin/mimeopen
gajim-0.13.4-1.el6.noarch requires python-kerberos
getdata-devel-0.6.2-1.el6.i686 requires gcc-gfortran(x86-32)
gspiceui-0.9.97-1.el6.x86_64 requires gwave
1:java-1.6.0-openjdk-plugin-1.6.0.0-1.21.b17.el6.x86_64 requires java-1.6.0-openjdk = 1:1.6.0.0-1.21.b17.el6
metagoofil-1.4b-1.el6.noarch requires /usr/bin/libextractor-extract
mnemosyne-1.2.1-1.el6.noarch requires PyQt
mon-1.2.0-6.el6.x86_64 requires perl(Authen::Radius)
mon-1.2.0-6.el6.x86_64 requires perl(Net::Telnet)
openxcap-1.1.2-1.el6.noarch requires python-twisted-web2
orbited-0.7.10-5.el6.noarch requires python-daemon
perl-Net-Telnet-Cisco-1.10-3.el6.noarch requires perl(Net::Telnet) >= 0:3.02
poky-depends-6-6.el6.noarch requires qemu >= 0:0.8.2
poky-scripts-6-6.el6.noarch requires distcc
poky-scripts-6-6.el6.noarch requires distcc-server
pygrace-0.4-3.el6.noarch requires grace
pyjamas-desktop-0.7-5.el6.noarch requires hulahop
pymol-1.3-3.20100705svn3911.el6.x86_64 requires python-numeric
pypop-0.7.0-5.el6.x86_64 requires python-numeric
python-kiwi-gazpacho-1.9.26-1.el6.noarch requires gazpacho >= 0:0.6.6
python-twill-0.9-4.el6.noarch requires python-clientform
python-twill-0.9-4.el6.noarch requires python-mechanize
pyvnc2swf-0.9.5-8.el6.noarch requires x11vnc
ruby-json-gui-1.4.3-3.el6.x86_64 requires ruby(gtk2)
rubygem-json-gui-1.4.3-3.el6.x86_64 requires ruby(gtk2)
rubygem-merb-slices-1.0.15-1.el6.noarch requires rubygem(merb-core)
spamassassin-FuzzyOcr-3.6.0-4.el6.noarch requires ocrad
starplot-contrib-3-3.el6.noarch requires starplot
starplot-gliese3-0.95-4.el6.noarch requires starplot >= 0:0.95
starplot-gliese3-0.95-4.el6.noarch requires starplot >= 0:0.95
starplot-yale5-0.95-4.el6.noarch requires starplot >= 0:0.95
starplot-yale5-0.95-4.el6.noarch requires starplot >= 0:0.95
tcl-tclvfs-20080503-4.el6.x86_64 requires tcl-trf
timidity++-2.13.2-21.el6.x86_64 requires soundfont2-default
tucan-0.3.9-0.3.alpha.el6.noarch requires tesseract
vidalia-0.2.10-1.el6.x86_64 requires tor
viewvc-1.1.8-1.el6.noarch requires cvsgraph
vtun-3.0.1-9.el6.x86_64 requires systemd-units
webacula-5.0.2-1.el6.noarch requires php-ZendFramework >= 0:1.8.3
wordpress-mu-plugin-bad-behavior-2.0.36-1.el6.noarch requires wordpress-mu
wordpress-mu-plugin-defaults-1.2.3-4.el6.noarch requires wordpress-mu



Broken deps for ppc64
----------------------------------------------------------
RabbIT-4.1-9.el6.noarch requires java >= 1:1.6.0
arduino-0021-1.el6.noarch requires rxtx
arduino-0021-1.el6.noarch requires java >= 1:1.6.0
asterisk-ices-1.6.2.12-0.1.rc1.el6.ppc64 requires ices
asterisk-ldap-fds-1.6.2.12-0.1.rc1.el6.ppc64 requires fedora-ds-base
blacs-mpich2-1.1-39.el6.1.ppc64 requires libmpich.so.1.2()(64bit)
bodhi-server-0.7.4-1.el6.noarch requires python-turboflot
byobu-3.21-1.el6.noarch requires python26
callweaver-zaptel-1.2.1-2.el6.ppc64 requires libtonezone.so.1.0()(64bit)
callweaver-zaptel-1.2.1-2.el6.ppc64 requires zaptel >= 0:1.4.0-1
cglib-2.2-5.el6.noarch requires objectweb-asm
cglib-2.2-5.el6.noarch requires java >= 0:1.6.0
claws-mail-plugins-dillo-3.7.6-1.el6.ppc64 requires dillo
cobbler-2.0.10-1.el6.noarch requires fence-agents
dh-make-0.55-2.el6.noarch requires debhelper
dnsjava-2.0.6-7.el6.noarch requires java >= 0:1.7
dnssec-tools-1.7-3.el6.ppc64 requires perl(QWizard)
drbdlinks-1.18-2.el6.noarch requires heartbeat
eclipse-phpeclipse-1.2.1-5.el6.noarch requires htmlparser
eclipse-phpeclipse-1.2.1-5.el6.noarch requires eclipse-platform >= 0:3.4
eclipse-texlipse-1.3.0-4.20090829cvs.el6.noarch requires eclipse-platform
eclipse-veditor-0.6.3-4.el6.noarch requires eclipse-platform
electric-8.09-1.el6.noarch requires java-1.6.0-openjdk
fvwm-2.5.30-2.el6.ppc64 requires xlockmore
fvwm-2.5.30-2.el6.ppc64 requires /usr/bin/mimeopen
gajim-0.13.4-1.el6.noarch requires python-kerberos
gromacs-mpich2-4.0.7-1.el6.ppc64 requires libmpich.so.1.2()(64bit)
gromacs-mpich2-4.0.7-1.el6.ppc64 requires mpich2
gromacs-mpich2-devel-4.0.7-1.el6.ppc64 requires mpich2-devel
idm-console-framework-1.1.5-1.el6.noarch requires java >= 1:1.6.0
jcharts-0.7.5-4.el6.noarch requires java >= 1:1.6.0
jcharts-0.7.5-4.el6.noarch requires batik
jettison-1.2-1.el6.noarch requires java >= 1:1.6.0
jfreechart-swt-1.0.13-1.el6.noarch requires eclipse-swt
joda-time-1.6-3.tzdata2008i.el6.noarch requires java > 0:1.5.0
metagoofil-1.4b-1.el6.noarch requires /usr/bin/libextractor-extract
mnemosyne-1.2.1-1.el6.noarch requires PyQt
mon-1.2.0-6.el6.ppc64 requires perl(Authen::Radius)
mon-1.2.0-6.el6.ppc64 requires perl(Net::Telnet)
openxcap-1.1.2-1.el6.noarch requires python-twisted-web2
orbited-0.7.10-5.el6.noarch requires python-daemon
orsa-mpich2-0.7.0-13.el6.ppc64 requires libmpichcxx.so.1.2()(64bit)
orsa-mpich2-0.7.0-13.el6.ppc64 requires libmpich.so.1.2()(64bit)
orsa-mpich2-0.7.0-13.el6.ppc64 requires mpich2
perl-Net-Telnet-Cisco-1.10-3.el6.noarch requires perl(Net::Telnet) >= 0:3.02
poky-depends-6-6.el6.noarch requires qemu >= 0:0.8.2
poky-scripts-6-6.el6.noarch requires distcc
poky-scripts-6-6.el6.noarch requires distcc-server
pygrace-0.4-3.el6.noarch requires grace
pyjamas-desktop-0.7-5.el6.noarch requires hulahop
pymol-1.3-3.20100705svn3911.el6.ppc64 requires python-numeric
pypop-0.7.0-5.el6.ppc64 requires python-numeric
python-kiwi-gazpacho-1.9.26-1.el6.noarch requires gazpacho >= 0:0.6.6
python-twill-0.9-4.el6.noarch requires python-clientform
python-twill-0.9-4.el6.noarch requires python-mechanize
pyvnc2swf-0.9.5-8.el6.noarch requires x11vnc
ruby-json-gui-1.4.3-3.el6.ppc64 requires ruby(gtk2)
rubygem-json-gui-1.4.3-3.el6.ppc64 requires ruby(gtk2)
rubygem-merb-slices-1.0.15-1.el6.noarch requires rubygem(merb-core)
scalapack-mpich2-1.7.5-10.el6.ppc64 requires libmpich.so.1.2()(64bit)
spamassassin-FuzzyOcr-3.6.0-4.el6.noarch requires ocrad
starplot-contrib-3-3.el6.noarch requires starplot
starplot-gliese3-0.95-4.el6.noarch requires starplot >= 0:0.95
starplot-gliese3-0.95-4.el6.noarch requires starplot >= 0:0.95
starplot-yale5-0.95-4.el6.noarch requires starplot >= 0:0.95
starplot-yale5-0.95-4.el6.noarch requires starplot >= 0:0.95
tcl-tclvfs-20080503-4.el6.ppc64 requires tcl-trf
tigase-server-5.0.4-1.el6.noarch requires java >= 0:1.6.0
tigase-utils-3.3.10-1.el6.noarch requires java >= 0:1.6.0
tigase-xmltools-3.3.5-1.el6.noarch requires java >= 1:1.6.0
timidity++-2.13.2-21.el6.ppc64 requires soundfont2-default
tucan-0.3.9-0.3.alpha.el6.noarch requires tesseract
vecmath-0-2.20090922cvs.el6.noarch requires java >= 1:1.6.0
vidalia-0.2.10-1.el6.ppc64 requires tor
viewvc-1.1.8-1.el6.noarch requires cvsgraph
vtun-3.0.1-9.el6.ppc64 requires systemd-units
webacula-5.0.2-1.el6.noarch requires php-ZendFramework >= 0:1.8.3
wordpress-mu-plugin-bad-behavior-2.0.36-1.el6.noarch requires wordpress-mu
wordpress-mu-plugin-defaults-1.2.3-4.el6.noarch requires wordpress-mu
xom-1.0-5.6.el6.noarch requires icu4j



Broken deps for i386
----------------------------------------------------------
asterisk-ices-1.6.2.12-0.1.rc1.el6.i686 requires ices
asterisk-ldap-fds-1.6.2.12-0.1.rc1.el6.i686 requires fedora-ds-base
bodhi-server-0.7.4-1.el6.noarch requires python-turboflot
byobu-3.21-1.el6.noarch requires python26
callweaver-zaptel-1.2.1-2.el6.i686 requires libtonezone.so.1.0
callweaver-zaptel-1.2.1-2.el6.i686 requires zaptel >= 0:1.4.0-1
claws-mail-plugins-dillo-3.7.6-1.el6.i686 requires dillo
cobbler-2.0.10-1.el6.noarch requires fence-agents
dh-make-0.55-2.el6.noarch requires debhelper
dnssec-tools-1.7-3.el6.i686 requires perl(QWizard)
drbdlinks-1.18-2.el6.noarch requires heartbeat
fvwm-2.5.30-2.el6.i686 requires /usr/bin/mimeopen
fvwm-2.5.30-2.el6.i686 requires xlockmore
gajim-0.13.4-1.el6.noarch requires python-kerberos
gspiceui-0.9.97-1.el6.i686 requires gwave
1:java-1.6.0-openjdk-plugin-1.6.0.0-1.21.b17.el6.i686 requires java-1.6.0-openjdk = 1:1.6.0.0-1.21.b17.el6
metagoofil-1.4b-1.el6.noarch requires /usr/bin/libextractor-extract
mnemosyne-1.2.1-1.el6.noarch requires PyQt
mon-1.2.0-6.el6.i686 requires perl(Net::Telnet)
mon-1.2.0-6.el6.i686 requires perl(Authen::Radius)
openxcap-1.1.2-1.el6.noarch requires python-twisted-web2
orbited-0.7.10-5.el6.noarch requires python-daemon
perl-Net-Telnet-Cisco-1.10-3.el6.noarch requires perl(Net::Telnet) >= 0:3.02
poky-depends-6-6.el6.noarch requires qemu >= 0:0.8.2
poky-scripts-6-6.el6.noarch requires distcc
poky-scripts-6-6.el6.noarch requires distcc-server
pygrace-0.4-3.el6.noarch requires grace
pyjamas-desktop-0.7-5.el6.noarch requires hulahop
pymol-1.3-3.20100705svn3911.el6.i686 requires python-numeric
pypop-0.7.0-5.el6.i686 requires python-numeric
python-kiwi-gazpacho-1.9.26-1.el6.noarch requires gazpacho >= 0:0.6.6
python-twill-0.9-4.el6.noarch requires python-clientform
python-twill-0.9-4.el6.noarch requires python-mechanize
pyvnc2swf-0.9.5-8.el6.noarch requires x11vnc
ruby-json-gui-1.4.3-3.el6.i686 requires ruby(gtk2)
rubygem-json-gui-1.4.3-3.el6.i686 requires ruby(gtk2)
rubygem-merb-slices-1.0.15-1.el6.noarch requires rubygem(merb-core)
spamassassin-FuzzyOcr-3.6.0-4.el6.noarch requires ocrad
starplot-contrib-3-3.el6.noarch requires starplot
starplot-gliese3-0.95-4.el6.noarch requires starplot >= 0:0.95
starplot-gliese3-0.95-4.el6.noarch requires starplot >= 0:0.95
starplot-yale5-0.95-4.el6.noarch requires starplot >= 0:0.95
starplot-yale5-0.95-4.el6.noarch requires starplot >= 0:0.95
tcl-tclvfs-20080503-4.el6.i686 requires tcl-trf
timidity++-2.13.2-21.el6.i686 requires soundfont2-default
tucan-0.3.9-0.3.alpha.el6.noarch requires tesseract
vidalia-0.2.10-1.el6.i686 requires tor
viewvc-1.1.8-1.el6.noarch requires cvsgraph
vtun-3.0.1-9.el6.i686 requires systemd-units
webacula-5.0.2-1.el6.noarch requires php-ZendFramework >= 0:1.8.3
wordpress-mu-plugin-bad-behavior-2.0.36-1.el6.noarch requires wordpress-mu
wordpress-mu-plugin-defaults-1.2.3-4.el6.noarch requires wordpress-mu



New package clamav-unofficial-sigs
Scripts to download unoffical clamav signatures
New package drupal6-job_scheduler
Simple API for scheduling tasks
New package perl-AnyEvent-AIO
Truly asynchronous file and directrory I/O
New package perl-AnyEvent-BDB
Truly asynchronous Berkeley DB access
New package perl-Event-RPC
Event based transparent Client/Server RPC framework
New package qmmp
Qt-based multimedia player
New package xpaint
An X Window System image editing or paint program
Updated Packages:

ReviewBoard-1.5.2-20.el6
------------------------
* Mon Jan 10 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.5.2-20
- Add message to upgrade script to alert users that manual edits may be
- required if using mod_wsgi

* Mon Jan 10 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.5.2-19
- Important Updates
- Users using existing WSGI configurations must update their configuration
- for authentication with the new API to work.
- New Features
- Added SSH key management for SSH-backed repositories
- Authentication failures when setting up repositories are now more useful
- Added our own SSH replacement for standardizing on behavior and working
- around OpenSSH limitations
- The Repository page in the administration UI now talks about API Tokens
- and links to the GitHub Account page for Git repositories, making it
- easier to set up a GitHub repository
- API Fixes
- Fixed logging in on requests using HTTP Basic Auth
- Fixed wrong responses when performing a request requiring authentication
- as an anonymous user
- Fixed anonymous access to the API when anonymous access is enabled
- Fixed replies to screenshot comments in the new web API
- Fixed removing screenshots from review requests
- Changed the request when doing a HTTP PUT on a review request draft
- Fixed search queries in /api/users/
- Bug Fixes
- Fixed a problem with SSH host checking on Git repositories
- Fixed support for private GitHub repositories
- The API Token for GitHub repositories are now extracted properly in the
- Repository page in the administration UI
- Fixed extra whitespace highlight toggling
- Images on the dashboard are now cached, reducing the number of requests
- made to the server
- Disabled auto-complete and default values for the repository
- username/password fields
- Support for Amazon S3 now works again with new versions of Django
- Storages
- Authentication with the new API now works with new Apache+wsgi setups
- Fixed some rewrite rule for fastcgi
- Fix 404 errors with newly generated lighttpd.conf files
- Fixed errrors when passing a non-integer value for ?show_submitted= on
- the dashboard or other review request listings
- Fixed a crash when attempting to log SSH-related problems
- The contributed svn-hook-postcommit-review script wasn't parsing the
- base path correctly
- Release Notes
- http://www.reviewboard.org/docs/releasenotes/dev/reviewboard/1.5.2/


monotone-0.99.1-2.el6
---------------------
* Sun Jan 09 2011 Thomas Moschny <thomas.moschny@gmx.de> - 0.99.1-2
- Add patch for failing tests on ppc64.

* Sun Oct 31 2010 Thomas Moschny <thomas.moschny@gmx.de> - 0.99.1-1
- Update to 0.99.1.
- Remove patch already applied upstream.

* Fri Oct 29 2010 Thomas Moschny <thomas.moschny@gmx.de> - 0.99-1
- Update to 0.99.
- Remove patch already applied upstream.
- Add patch for monotone bug #100.
- Include the monotone manpage in the package.
- Specfile cleanups.


python-djblets-0.6.7-12.el6
---------------------------
* Mon Jan 10 2011 Stephen Gallagher <sgallagh@redhat.com> - 0.6.7-12
- New upstream release 0.6.7
- djblets.datagrid:
- The datagrids now use a RequestContext when rendering cells, allowing
- the columns or templates to access data from context processors.

- djblets.siteconfig:
- The form body of a siteconfig settings page can now be replaced.
- It's now stored in the "form_content" block.

- SiteConfigurationManager no longer crashes if trying to clear
- the cache for a SiteConfiguration that no longer exists.

- djblets.testing:
- The Selenium test suite has been updated to support Django 1.2's
- multi-database support. Previously, fixtures would fail to load
- if using the new settings.DATABASES variable.

- djblets.util:
- The @augment_method_from decorator wasn't properly calling up the
- decorator chain, preventing some decorators from being invoked. This
- has been fixed to ensure all decorators are called.
-
- djblets.webapi:
- Due to the @augment_method_from breakage listed above, webapi
- decorators could fail to add their own checks, causing various
- problems in field checking and authentication. This is now fixed.

- The Permission Denied (HTTP 403) errors being returned weren't
- sufficient for clients that weren't authenticated. Now, an
- unauthenticated client will instead see Not Logged In (HTTP 401)
- errors.
-
- The HTTP_AUTHORIZATION header is now checked on all requests. When
- provided by the client, it will be used for authentication. This
- means that clients can now force a login from their very first
- request on, instead of requiring a HTTP 401 Unauthorized being
- sent out first.
-
- This will also prevent multiple logins across different requests
- from the same client, when the HTTP_AUTHORIZATION header is passed
- on each request. This makes requests less heavy-weight and prevents
- the last_login timestamp on the User from being updated on each
- request.
-
- As part of this change, any webapps manually using the
- @webapi_login_required decorator without the new resource code
- will no longer support HTTP Basic auth. However, this was never
- a supported feature anyway, and was more there by accident.
-
- The 'api_format' parameter in requests is now treated specially
- and doesn't trigger any invalid attribute errors during field
- validation.
-
- WebAPIResource.delete now uses get_object instead of fetching
- the object directly, which simplifies the function and guarantees
- that the correct object is used (especially when a resource
- overrides get_object).
-
- Redirects now preserve any special parameters ("callback",
- "_method", "expand", and "api_format") passed to the request.
- This works around problems in HTTP implementations that don't
- allow the caller to know that redirects occurred (such as major
- browsers), which would lead to this information being stripped and
- the wrong results being returned.
-
- The "expand" parameter for expanding links in payloads is now
- supported for POST and PUT requests.


torque-2.5.4-1.el6
------------------
* Sun Jan 09 2011 Steve Traylen <steve.traylen@cern.ch> - 2.5.4-1
- New upstream 2.5.4
Drop patches: torque-cond-touch.patch rhbz#528060 and
torque-start-start.patch rhbz#643194 since both upstream.


Summary:
Added Packages: 7
Removed Packages: 0
Modified Packages: 4

_______________________________________________
epel-devel-list mailing list
epel-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/epel-devel-list

Dan Horák 01-11-2011 01:32 PM

epel beta report: 20110110 changes
 
EPEL Beta Report p*še v Po 10. 01. 2011 v 18:15 +0000:
> Compose started at Mon Jan 10 17:37:27 UTC 2011
>
> Broken deps for x86_64
> ----------------------------------------------------------
> 1:java-1.6.0-openjdk-plugin-1.6.0.0-1.21.b17.el6.x86_64 requires java-1.6.0-openjdk = 1:1.6.0.0-1.21.b17.el6

does anybody know what's broken here?


Dan


_______________________________________________
epel-devel-list mailing list
epel-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/epel-devel-list

Michael Schwendt 01-11-2011 01:47 PM

epel beta report: 20110110 changes
 
On Tue, 11 Jan 2011 15:32:25 +0100, Dan wrote:

> EPEL Beta Report p*še v Po 10. 01. 2011 v 18:15 +0000:
> > Compose started at Mon Jan 10 17:37:27 UTC 2011
> >
> > Broken deps for x86_64
> > ----------------------------------------------------------
> > 1:java-1.6.0-openjdk-plugin-1.6.0.0-1.21.b17.el6.x86_64 requires java-1.6.0-openjdk = 1:1.6.0.0-1.21.b17.el6
>
> does anybody know what's broken here?

Just from the looks of it, is java-1.6.0-openjdk-plugin obsolete but
missing a proper "Obsoletes" tag? What package EVRs do you see if you
run some queries?

_______________________________________________
epel-devel-list mailing list
epel-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/epel-devel-list

Kevin Fenzi 01-11-2011 03:19 PM

epel beta report: 20110110 changes
 
On Tue, 11 Jan 2011 15:47:22 +0100
Michael Schwendt <mschwendt@gmail.com> wrote:

> On Tue, 11 Jan 2011 15:32:25 +0100, Dan wrote:
>
> > EPEL Beta Report p*še v Po 10. 01. 2011 v 18:15 +0000:
> > > Compose started at Mon Jan 10 17:37:27 UTC 2011
> > >
> > > Broken deps for x86_64
> > > ----------------------------------------------------------
> > > 1:java-1.6.0-openjdk-plugin-1.6.0.0-1.21.b17.el6.x86_64
> > > requires java-1.6.0-openjdk = 1:1.6.0.0-1.21.b17.el6
> >
> > does anybody know what's broken here?
>
> Just from the looks of it, is java-1.6.0-openjdk-plugin obsolete but
> missing a proper "Obsoletes" tag? What package EVRs do you see if you
> run some queries?

We dug into this as the request of the java-1.6.0-openjdk folks, who
are getting a broken dep report about it. :)

- The plugin was shipped in beta2, but they decided they didn't want to
support it in 6.0, so it was supposed to be removed.

- They added obsoletes, but not provides to the main java-1.6.0-openjdk
package.

- They failed to remove the old plugin package from rhn channels with
6.0. It's in the optional channel. ;(

So, nothing epel can do here. They either need to fix the
java-1.6.0-openjdk package or (better imho), just stop shipping the old
plugin that could never be installed or work. ;)

kevin
_______________________________________________
epel-devel-list mailing list
epel-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/epel-devel-list

Michael Schwendt 01-11-2011 03:55 PM

epel beta report: 20110110 changes
 
On Tue, 11 Jan 2011 09:19:18 -0700, Kevin wrote:

> > > > Broken deps for x86_64
> > > > ----------------------------------------------------------
> > > > 1:java-1.6.0-openjdk-plugin-1.6.0.0-1.21.b17.el6.x86_64
> > > > requires java-1.6.0-openjdk = 1:1.6.0.0-1.21.b17.el6

> - They added obsoletes, but not provides to the main java-1.6.0-openjdk
> package.

Which can't be the full story, because accurate Obsoletes would have
prevented this broken dep already. Perhaps they've messed up the EVR range
of the Obsoletes tag?

Additional Provides would not be necessary (and would be incorrect
actually, for a feature that got removed and _not_ moved from one
package to another).

_______________________________________________
epel-devel-list mailing list
epel-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/epel-devel-list

Kevin Fenzi 01-11-2011 04:12 PM

epel beta report: 20110110 changes
 
On Tue, 11 Jan 2011 17:55:37 +0100
Michael Schwendt <mschwendt@gmail.com> wrote:

> On Tue, 11 Jan 2011 09:19:18 -0700, Kevin wrote:
>
> > > > > Broken deps for x86_64
> > > > > ----------------------------------------------------------
> > > > > 1:java-1.6.0-openjdk-plugin-1.6.0.0-1.21.b17.el6.x86_64
> > > > > requires java-1.6.0-openjdk = 1:1.6.0.0-1.21.b17.el6
>
> > - They added obsoletes, but not provides to the main
> > java-1.6.0-openjdk package.
>
> Which can't be the full story, because accurate Obsoletes would have
> prevented this broken dep already. Perhaps they've messed up the EVR
> range of the Obsoletes tag?

$ repoquery java-1.6.0-openjdk-plugin
java-1.6.0-openjdk-plugin-1:1.6.0.0-1.21.b17.el6.x86_64
$ repoquery java-1.6.0-openjdk
java-1.6.0-openjdk-1:1.6.0.0-1.31.b17.el6_0.x86_64
$ repoquery --obsoletes java-1.6.0-openjdk
java-1.6.0-openjdk-plugin <= 1:1.6.0.0-1.31.b17.el6_0

kevin
_______________________________________________
epel-devel-list mailing list
epel-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/epel-devel-list

Michael Schwendt 01-11-2011 04:41 PM

epel beta report: 20110110 changes
 
On Tue, 11 Jan 2011 10:12:41 -0700, Kevin wrote:

> > > > > > Broken deps for x86_64
> > > > > > ----------------------------------------------------------
> > > > > > 1:java-1.6.0-openjdk-plugin-1.6.0.0-1.21.b17.el6.x86_64
> > > > > > requires java-1.6.0-openjdk = 1:1.6.0.0-1.21.b17.el6
> >
> > > - They added obsoletes, but not provides to the main
> > > java-1.6.0-openjdk package.
> >
> > Which can't be the full story, because accurate Obsoletes would have
> > prevented this broken dep already. Perhaps they've messed up the EVR
> > range of the Obsoletes tag?
>
> $ repoquery java-1.6.0-openjdk-plugin
> java-1.6.0-openjdk-plugin-1:1.6.0.0-1.21.b17.el6.x86_64
> $ repoquery java-1.6.0-openjdk
> java-1.6.0-openjdk-1:1.6.0.0-1.31.b17.el6_0.x86_64
> $ repoquery --obsoletes java-1.6.0-openjdk
> java-1.6.0-openjdk-plugin <= 1:1.6.0.0-1.31.b17.el6_0

Hmmm, funny. Why would mash's depchecker look at an obsolete package?

_______________________________________________
epel-devel-list mailing list
epel-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/epel-devel-list


All times are GMT. The time now is 11:52 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.