FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > EPEL Development

 
 
LinkBack Thread Tools
 
Old 12-24-2010, 07:45 AM
Erinn Looney-Triggs
 
Default Broken puppet dependency

I think, not real sure about RPM hierarchies etc. Here is the output for
RHEL 6 x64 EPEL:

erinn@sb ~ $ sudo yum install puppet
Loaded plugins: rhnplugin
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package puppet.noarch 0:0.25.5-1.el6 set to be updated
--> Processing Dependency: facter >= 1.5 for package:
puppet-0.25.5-1.el6.noarch
--> Processing Dependency: ruby-shadow for package:
puppet-0.25.5-1.el6.noarch
--> Processing Dependency: ruby-augeas for package:
puppet-0.25.5-1.el6.noarch
--> Processing Dependency: ruby(selinux) for package:
puppet-0.25.5-1.el6.noarch
--> Running transaction check
---> Package facter.noarch 0:1.5.8-1.el6 set to be updated
---> Package puppet.noarch 0:0.25.5-1.el6 set to be updated
--> Processing Dependency: ruby(selinux) for package:
puppet-0.25.5-1.el6.noarch
---> Package ruby-augeas.x86_64 0:0.3.0-1.el6 set to be updated
--> Processing Dependency: augeas-libs >= 0.5.1 for package:
ruby-augeas-0.3.0-1.el6.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.8.0)(64bit) for
package: ruby-augeas-0.3.0-1.el6.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.1.0)(64bit) for
package: ruby-augeas-0.3.0-1.el6.x86_64
--> Processing Dependency: libaugeas.so.0()(64bit) for package:
ruby-augeas-0.3.0-1.el6.x86_64
---> Package ruby-shadow.x86_64 0:1.4.1-13.el6 set to be updated
--> Running transaction check
---> Package augeas-libs.x86_64 0:0.7.2-3.el6 set to be updated
---> Package puppet.noarch 0:0.25.5-1.el6 set to be updated
--> Processing Dependency: ruby(selinux) for package:
puppet-0.25.5-1.el6.noarch
--> Finished Dependency Resolution
Error: Package: puppet-0.25.5-1.el6.noarch (epel)
Requires: ruby(selinux)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

-Erinn

_______________________________________________
epel-devel-list mailing list
epel-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/epel-devel-list
 
Old 12-24-2010, 10:29 AM
Ricky Zhou
 
Default Broken puppet dependency

On 2010-12-23 11:45:53 PM, Erinn Looney-Triggs wrote:
> I think, not real sure about RPM hierarchies etc. Here is the output for
> RHEL 6 x64 EPEL:
...
> Error: Package: puppet-0.25.5-1.el6.noarch (epel)
> Requires: ruby(selinux)
> You could try using --skip-broken to work around the problem
> You could try running: rpm -Va --nofiles --nodigest
Interesting, ruby(selinux) should be provided by the libselinux-ruby
package from the rhel6-optional repo. Do you have that repo enabled?

Thanks,
Ricky
_______________________________________________
epel-devel-list mailing list
epel-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/epel-devel-list
 
Old 12-24-2010, 12:43 PM
Todd Zullinger
 
Default Broken puppet dependency

Ricky Zhou wrote:
> Interesting, ruby(selinux) should be provided by the libselinux-ruby
> package from the rhel6-optional repo. Do you have that repo
> enabled?

This seems to be a FAQ. :/

I've have 4 or 5 private queries about it and seen a few more on
various lists and in IRC.

--
Todd OpenPGP -> KeyID: 0xBEAF0CE3 | URL: www.pobox.com/~tmz/pgp
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~
If quitters never win, and winners never quit, then who is the fool
who said "Quit while you're ahead?"

_______________________________________________
epel-devel-list mailing list
epel-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/epel-devel-list
 

Thread Tools




All times are GMT. The time now is 05:57 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org