FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > EPEL Development

 
 
LinkBack Thread Tools
 
Old 10-26-2010, 08:45 PM
"jeff@ocjtech.us"
 
Default OpenAIS in RHEL6?

Anyone know what's up with OpenAIS in RHEL6? I'm trying to build
Asterisk 1.8 for EPEL6 but I get the following:

DEBUG backend.py:656: /usr/bin/yum --installroot
/var/lib/mock/dist-6E-epel-build-912363-134279/root/ install
'radiusclient-ng-devel' 'graphviz-gd' 'net-snmp-devel' 'graphviz'
'freetds-devel' 'spandsp-devel >= 0.0.5-0.1.pre4' 'gsm-devel'
'mISDN-devel' 'neon-devel' 'openldap-devel' 'libical-devel'
'libss7-devel >= 1.0.1' 'speex-devel >= 1.2' 'portaudio-devel >= 19'
'latex2html' 'openssl-devel' 'automake' 'unixODBC-devel' 'gtk2-devel'
'libtermcap-devel' 'alsa-lib-devel' 'libresample-devel' 'mysql-devel'
'lua-devel' 'dahdi-tools-libs >= 2.0.0' 'openais-devel'
'libtool-ltdl-devel' 'jack-audio-connection-kit-devel' 'libcap-devel'
'postgresql-devel' 'libpri-devel >= 1.4.12' 'dahdi-tools-devel >=
2.0.0' 'curl-devel' 'ncurses-devel' 'iksemel-devel' 'doxygen'
'sqlite-devel' 'libogg-devel' 'libvorbis-devel' 'bluez-libs-devel'
'libedit-devel' 'lm_sensors-devel' 'libusb-devel' 'newt-devel'
'autoconf' 'libxml2-devel'
DEBUG util.py:294: Executing command: /usr/bin/yum --installroot
/var/lib/mock/dist-6E-epel-build-912363-134279/root/ install
'radiusclient-ng-devel' 'graphviz-gd' 'net-snmp-devel' 'graphviz'
'freetds-devel' 'spandsp-devel >= 0.0.5-0.1.pre4' 'gsm-devel'
'mISDN-devel' 'neon-devel' 'openldap-devel' 'libical-devel'
'libss7-devel >= 1.0.1' 'speex-devel >= 1.2' 'portaudio-devel >= 19'
'latex2html' 'openssl-devel' 'automake' 'unixODBC-devel' 'gtk2-devel'
'libtermcap-devel' 'alsa-lib-devel' 'libresample-devel' 'mysql-devel'
'lua-devel' 'dahdi-tools-libs >= 2.0.0' 'openais-devel'
'libtool-ltdl-devel' 'jack-audio-connection-kit-devel' 'libcap-devel'
'postgresql-devel' 'libpri-devel >= 1.4.12' 'dahdi-tools-devel >=
2.0.0' 'curl-devel' 'ncurses-devel' 'iksemel-devel' 'doxygen'
'sqlite-devel' 'libogg-devel' 'libvorbis-devel' 'bluez-libs-devel'
'libedit-devel' 'lm_sensors-devel' 'libusb-devel' 'newt-devel'
'autoconf' 'libxml2-devel'
DEBUG util.py:260: Error: Package: openaislib-devel-1.1.1-5.el6.x86_64 (build)
DEBUG util.py:260: Requires: libSaClm.so.3()(64bit)
DEBUG util.py:260: Error: Package: openaislib-devel-1.1.1-5.el6.x86_64 (build)
DEBUG util.py:260: Requires: libSaAmf.so.3()(64bit)
DEBUG util.py:260: Error: Package: openaislib-devel-1.1.1-5.el6.x86_64 (build)
DEBUG util.py:260: Requires: libSaCkpt.so.3()(64bit)
DEBUG util.py:260: Error: Package: openaislib-devel-1.1.1-5.el6.x86_64 (build)
DEBUG util.py:260: Requires: libSaLck.so.3()(64bit)
DEBUG util.py:260: Error: Package: openaislib-devel-1.1.1-5.el6.x86_64 (build)
DEBUG util.py:260: Requires: openaislib = 1.1.1-5.el6
DEBUG util.py:260: Error: Package: openaislib-devel-1.1.1-5.el6.x86_64 (build)
DEBUG util.py:260: Requires: libSaTmr.so.3()(64bit)
DEBUG util.py:260: Error: Package: openaislib-devel-1.1.1-5.el6.x86_64 (build)
DEBUG util.py:260: Requires: libSaEvt.so.3()(64bit)
DEBUG util.py:260: You could try using --skip-broken to work around
the problem
DEBUG util.py:260: Error: Package: openaislib-devel-1.1.1-5.el6.x86_64 (build)
DEBUG util.py:260: Requires: libSaMsg.so.3()(64bit)
DEBUG util.py:260: You could try running: rpm -Va --nofiles --nodigest
DEBUG util.py:333: Child returncode was: 1

Full build is here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=2555848

--
Jeff Ollie

_______________________________________________
epel-devel-list mailing list
epel-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/epel-devel-list
 
Old 10-26-2010, 10:03 PM
Jose Pedro Oliveira
 
Default OpenAIS in RHEL6?

On 2010-10-26 21:45, jeff@ocjtech.us wrote:
> Anyone know what's up with OpenAIS in RHEL6? I'm trying to build
> Asterisk 1.8 for EPEL6 but I get the following:
---[snip]---
> DEBUG util.py:260: Error: Package: openaislib-devel-1.1.1-5.el6.x86_64 (build)
> DEBUG util.py:260: Requires: libSaClm.so.3()(64bit)
> DEBUG util.py:260: Error: Package: openaislib-devel-1.1.1-5.el6.x86_64 (build)
> DEBUG util.py:260: Requires: libSaAmf.so.3()(64bit)
> DEBUG util.py:260: Error: Package: openaislib-devel-1.1.1-5.el6.x86_64 (build)
> DEBUG util.py:260: Requires: libSaCkpt.so.3()(64bit)
> DEBUG util.py:260: Error: Package: openaislib-devel-1.1.1-5.el6.x86_64 (build)
> DEBUG util.py:260: Requires: libSaLck.so.3()(64bit)
> DEBUG util.py:260: Error: Package: openaislib-devel-1.1.1-5.el6.x86_64 (build)
> DEBUG util.py:260: Requires: openaislib = 1.1.1-5.el6
> DEBUG util.py:260: Error: Package: openaislib-devel-1.1.1-5.el6.x86_64 (build)
> DEBUG util.py:260: Requires: libSaTmr.so.3()(64bit)
> DEBUG util.py:260: Error: Package: openaislib-devel-1.1.1-5.el6.x86_64 (build)
> DEBUG util.py:260: Requires: libSaEvt.so.3()(64bit)
> DEBUG util.py:260: You could try using --skip-broken to work around
> the problem
> DEBUG util.py:260: Error: Package: openaislib-devel-1.1.1-5.el6.x86_64 (build)
> DEBUG util.py:260: Requires: libSaMsg.so.3()(64bit)
> DEBUG util.py:260: You could try running: rpm -Va --nofiles --nodigest
> DEBUG util.py:333: Child returncode was: 1
>
> Full build is here:
>
> http://koji.fedoraproject.org/koji/taskinfo?taskID=2555848

This a problem similar to the rt3 perl requirements (see the
previous tread in this mailing list). But in your case the
situation is even worse: you have the openaislib-devel package
there but no openaislib package (argh! it's insane!).

For a temporary solution, enable the optional workstation repo
and yum should be able to find the openaislib package.

----------

[rhel-beta-optional]
...
baseurl=ftp://ftp.redhat.com/pub/redhat/rhel/beta/6Workstation-beta2/optional/x86_64/os/
...

-----------

Regards,
jpo
--
Josť Pedro Oliveira
* mailto:jpo@di.uminho.pt *

_______________________________________________
epel-devel-list mailing list
epel-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/epel-devel-list
 
Old 10-26-2010, 11:42 PM
"jeff@ocjtech.us"
 
Default OpenAIS in RHEL6?

On Tue, Oct 26, 2010 at 5:03 PM, Jose Pedro Oliveira <jpo@di.uminho.pt> wrote:
>
> This a problem similar to the rt3 perl requirements (see the
> previous tread in this mailing list). But in your case the
> situation is even worse: you have the openaislib-devel package
> there but no openaislib package (argh! it's insane!).
>
> For a temporary solution, enable the optional workstation repo
> and yum should be able to find the openaislib package.

Is that something that can be done on the Koji side of things? I
don't actually have any RHEL6 boxes locally (and probably won't until
CentOS 6 is available).

--
Jeff Ollie

_______________________________________________
epel-devel-list mailing list
epel-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/epel-devel-list
 

Thread Tools




All times are GMT. The time now is 02:15 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org