FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > EPEL Development

 
 
LinkBack Thread Tools
 
Old 09-13-2010, 12:34 AM
Michael Stahnke
 
Default rubygem-rack in epel and fedora

I'd like to bump rubygem-rack to the latest (1.2.1) in Rawhide and
EPEL. I was worried about EPEL and even started making a seperate
branch for a rack1 package, but according to my queries, the only
packages requiring rack in EPEL are:



EPEL:

stahnma@tyr /home/stahnma> repoquery -q --whatrequires "rubygem(rack)"
rubygem-sinatra-1:1.0-2.el5.noarch
rubygem-shotgun-0:0.4-1.el5.noarch



F13:

stahnma@olive /home/stahnma> repoquery --whatrequires "rubygem(rack)"
rubygem-actionpack-1:2.3.5-1.fc13.noarch
rubygem-actionpack-1:2.3.5-2.fc13.noarch
rubygem-merb-core-0:1.0.15-1.fc13.noarch
rubygem-shotgun-0:0.4-1.fc13.noarch
rubygem-sinatra-1:0.9.4-2.fc12.noarch
rubygem-sinatra-1:1.0-1.fc13.noarch
rubygem-thin-0:1.2.5-5.fc13.i686


There are some API changes between rack-0.9 and rack-1.2, but mostly
semantics. For rawhide/fedora, I am pretty sure it will be ok. What
are the thoughts for this update in EPEL? It would allow sinatra,
shotgun, and possibly a new (parallel) version of rails.

stahnma

_______________________________________________
epel-devel-list mailing list
epel-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/epel-devel-list
 
Old 09-13-2010, 12:31 PM
Michal Fojtik
 
Default rubygem-rack in epel and fedora

On 12/09/10 19:34 -0500, Michael Stahnke wrote:

I'd like to bump rubygem-rack to the latest (1.2.1) in Rawhide and
EPEL. I was worried about EPEL and even started making a seperate
branch for a rack1 package, but according to my queries, the only
packages requiring rack in EPEL are:



EPEL:

stahnma@tyr /home/stahnma> repoquery -q --whatrequires "rubygem(rack)"
rubygem-sinatra-1:1.0-2.el5.noarch
rubygem-shotgun-0:0.4-1.el5.noarch



F13:

stahnma@olive /home/stahnma> repoquery --whatrequires "rubygem(rack)"
rubygem-actionpack-1:2.3.5-1.fc13.noarch
rubygem-actionpack-1:2.3.5-2.fc13.noarch
rubygem-merb-core-0:1.0.15-1.fc13.noarch
rubygem-shotgun-0:0.4-1.fc13.noarch
rubygem-sinatra-1:0.9.4-2.fc12.noarch
rubygem-sinatra-1:1.0-1.fc13.noarch
rubygem-thin-0:1.2.5-5.fc13.i686


FYI: when I tried to use rack-1.2.1 with new Rack I got:
(same error for Rails 2.3.5)

<snip>
/usr/lib/ruby/gems/1.8/gems/rack-1.2.1/lib/rack/utils.rb:138:in `union': can't convert Array into String (TypeError)
from /usr/lib/ruby/gems/1.8/gems/rack-1.2.1/lib/rack/utils.rb:138
</snip>

I'll contact Sinatra upstream to fix it.

-- Michal

--
--------------------------------------------------------
Michal Fojtik, mfojtik@redhat.com
Deltacloud API: http://deltacloud.org
--------------------------------------------------------

_______________________________________________
epel-devel-list mailing list
epel-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/epel-devel-list
 

Thread Tools




All times are GMT. The time now is 09:33 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org