Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Edubuntu User (http://www.linux-archive.org/edubuntu-user/)
-   -   video settings from ltsp4.2 dont work in Hardy (http://www.linux-archive.org/edubuntu-user/82556-video-settings-ltsp4-2-dont-work-hardy.html)

Kai Wollweber 05-05-2008 06:11 PM

video settings from ltsp4.2 dont work in Hardy
 
Hello,

in one classroom we use a bunch of older igel terminals. On LTSP 4.2. they
work fine with XDMCP and the following configuration from lts.conf:

[igel1]
X_SERVER = nsc
X_COLOR_DEPTH = 16
X_MODE_0 = 1024x768
X_VERTREFRESH = 56-75
X_HORZSYNC = 31-83

These settings are critical under LTSP 4.2. Any changes cause a failure of the
xserver.

With ubuntu 8.04 I tried the same config and several variations including vesa
X_SERVER and different video settings but none of them worked.

On boot following the "ubuntu-screen" with the progress bar the video switches
to black screen with blinking cursor in the upper left corner. Finally the
screen is totally black. This reminds me of the xserver trials on the boot
process of LTSP 4, if no valid video setting could be found.

On the server the message from ldminfod repeates until infinity:

May 5 12:32:47 pardosa2 ldminfod[2214]: connect from 192.168.0.223
(192.168.0.223)
May 5 12:33:53 pardosa2 ldminfod[2221]: connect from 192.168.0.223
(192.168.0.223)
May 5 12:41:12 pardosa2 ldminfod[2243]: connect from 192.168.0.223
(192.168.0.223)
May 5 12:49:17 pardosa2 ldminfod[2250]: connect from 192.168.0.223
(192.168.0.223)

Other terminals work fine without specific settings in lts.conf. I am sure
that lts.conf is read correctly cause i can change the settings of the other
terminals.

I need help how to explore the failing boot process (which xserver is choosen?
which modeline is generated?) but I don't know how to explore these
information nor how to alter the video-settings systematically.

TIA for any hints.
--
Kai Wollweber
Integrierte Gesamtschule
Eckernförde

--
edubuntu-users mailing list
edubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/edubuntu-users

Oliver Grawert 05-05-2008 06:28 PM

video settings from ltsp4.2 dont work in Hardy
 
hi,
Am Montag, den 05.05.2008, 20:11 +0200 schrieb Kai Wollweber:
> Hello,
>
> in one classroom we use a bunch of older igel terminals. On LTSP 4.2. they
> work fine with XDMCP and the following configuration from lts.conf:
>
> [igel1]
> X_SERVER = nsc
> X_COLOR_DEPTH = 16
> X_MODE_0 = 1024x768
> X_VERTREFRESH = 56-75
> X_HORZSYNC = 31-83
>
"nsc" was replaced by "amd" some years ago and is now replaced by the
"geode" driver ...
sadly the geode situation is a mess atm but we're working on a fix
thought hardy-updates [1] (note that 4.2 is three years old which is
ancient in the OSS world, the amd/geode/nsc driver was "fixed" at some
point for the OLPC X0 laptops which broke it on pretty much every other
system around the time of gutsy development.
a fixed driver and xorg package is in the ppa [2] that is menitioned in
the bugreport and testing would be appreciated to be sure we really get
a solid version into hardy-updates for 8.04.1)

> On the server the message from ldminfod repeates until infinity:
>
> May 5 12:32:47 pardosa2 ldminfod[2214]: connect from 192.168.0.223
> (192.168.0.223)
> May 5 12:33:53 pardosa2 ldminfod[2221]: connect from 192.168.0.223
> (192.168.0.223)
> May 5 12:41:12 pardosa2 ldminfod[2243]: connect from 192.168.0.223
> (192.168.0.223)
> May 5 12:49:17 pardosa2 ldminfod[2250]: connect from 192.168.0.223
> (192.168.0.223)
this is (you probably did guess that already) ldm trying to start but X
failing so it tries to start over and over ...

> Other terminals work fine without specific settings in lts.conf. I am sure
> that lts.conf is read correctly cause i can change the settings of the other
> terminals.
>
> I need help how to explore the failing boot process (which xserver is choosen?
> which modeline is generated?) but I don't know how to explore these
> information nor how to alter the video-settings systematically.

set SCREEN_07=ldm and SCREEN_02=shell in case you want to have a shell
login on the client ... the ldm.log lies in /var/log on the client
together with the Xorg.6.log

ciao
oli

[1]
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-geode/+bug/214119

[2]
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-geode/+bug/214119/comments/20

--
edubuntu-users mailing list
edubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/edubuntu-users


All times are GMT. The time now is 10:17 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.