Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Edubuntu User (http://www.linux-archive.org/edubuntu-user/)
-   -   ssh issue with LDM (http://www.linux-archive.org/edubuntu-user/610290-ssh-issue-ldm.html)

David Hopkins 12-14-2011 11:05 PM

ssh issue with LDM
 
All,

I am beginning to suspect this issue is because ssh isn't resolving
names correctly? Timing

ssh myserver

from a shell (ALT-CTL-F2) takes about 30 seconds to resolve myserver.
However, ssh any_other_server returns immediately. So, why wouldn't
myserver resolve quickly? This is true from any of the servers ..
they do not resolve their names quickly. On all of them, the local
(thin client) /etc/hosts has the form

127.0.0.1 localhost
127.0.0.2 ltsp50
192.168.0.254 server

where the thin client is lstp50 ... but ... server is not defined in
DNS, only in the thin clients /etc/hosts. Logging in at the console
for any account also works.

This is very very very confusing and unfortunately, come tomorrow
morning is going to be a major issue.

Sincerely,
Dave Hopkins



On Wed, Dec 14, 2011 at 6:13 PM, David Hopkins <dahopkins429@gmail.com> wrote:
> We are having a major issue with thin client authentication. It
> started just after lunch time today. Authentication works fine from
> console and on terminal, but ssh takes a very long time to connect.
> One server (out of 5) can still connect though the login process takes
> quite a while to complete. *However, it is shorter than the other
> servers, so we suspect it is a timeout issue with LDM.
>
> From a shell at the thin client I can ssh to any system and
> authenticate. *However, trying to ssh from a shell at the client to
> the ltsp server that the client is connected to takes a very long
> time. *The response at the GUI login screen is "no response from
> server, restarting". We have already updated the sshkeys and
> completely rebuilt the image but this hasn't resolved the issue. How
> does LDM use ssh for authentication? Is there a reason ssh would have
> to be routed? *And .. why would ssh to any system except the system
> that the client booted from take so long? *We have enabled
> IP_Forwarding at the clients for localapps and that also works if that
> information is of any use.
>
> Any help is greatly appreciated!
>
> Sincerely,
> Dave Hopkins

--
edubuntu-users mailing list
edubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/edubuntu-users


All times are GMT. The time now is 01:27 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.