FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor


 
 
LinkBack Thread Tools
 
Old 01-31-2008, 12:42 PM
ugh ugher
 
Default Local Apps

What is the status of local apps? Is there a how to yet?


__________________________________________________ __________________________________
Looking for last minute shopping deals?
Find them fast with Yahoo! Search. http://tools.search.yahoo.com/newsearch/category.php?category=shopping

--
edubuntu-devel mailing list
edubuntu-devel@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/edubuntu-devel
 
Old 09-10-2010, 04:11 PM
Kees
 
Default Local Apps

I am trying to install firefox as a local app (following this guide:
https://help.ubuntu.com/community/UbuntuLTSPKarmicLocalAppsFirefox)
However I get stuck at the first hurdle. When I am trying to update apt
in the chroot environment it seems like it has no internet access in
there. Probably something I have done wrong in my network setup (one
nic). When I do 'sudo chroot /opt/ltsp/i386 route' or 'sudo chroot
/opt/ltsp/i386 ifconfig' both commands complain about lack of network
support.

I can log in on via ltsp and run firefox there without any problems. But
I don't seem to be able to install it as a local app.

I am not even sure where I should look for this one. If anyone can help
me that would be much appreciated.

Kees

--
edubuntu-users mailing list
edubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/edubuntu-users
 
Old 09-10-2010, 04:27 PM
"Jonathan Carter (highvoltage)"
 
Default Local Apps

Hi Kees

On 10/09/2010 12:11, Kees wrote:
> I am trying to install firefox as a local app (following this guide:
> https://help.ubuntu.com/community/UbuntuLTSPKarmicLocalAppsFirefox)
> However I get stuck at the first hurdle. When I am trying to update apt
> in the chroot environment it seems like it has no internet access in
> there. Probably something I have done wrong in my network setup (one
> nic). When I do 'sudo chroot /opt/ltsp/i386 route' or 'sudo chroot
> /opt/ltsp/i386 ifconfig' both commands complain about lack of network
> support.
>
> I can log in on via ltsp and run firefox there without any problems. But
> I don't seem to be able to install it as a local app.
>
> I am not even sure where I should look for this one. If anyone can help
> me that would be much appreciated.

The nameservers are probably not set in the chroot, try this before you
do the 'sudo chroot...' step:

sudo cp /etc/resolv.conf /opt/ltsp/i386/etc/

-Jonathan

--
edubuntu-users mailing list
edubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/edubuntu-users
 
Old 09-10-2010, 10:53 PM
Kees
 
Default Local Apps

On 11/09/10 00:27, Jonathan Carter (highvoltage) wrote:
> Hi Kees
>
> On 10/09/2010 12:11, Kees wrote:
>> I am trying to install firefox as a local app (following this guide:
>> https://help.ubuntu.com/community/UbuntuLTSPKarmicLocalAppsFirefox)
>> However I get stuck at the first hurdle. When I am trying to update apt
>> in the chroot environment it seems like it has no internet access in
>> there. Probably something I have done wrong in my network setup (one
>> nic). When I do 'sudo chroot /opt/ltsp/i386 route' or 'sudo chroot
>> /opt/ltsp/i386 ifconfig' both commands complain about lack of network
>> support.
>>
>> I can log in on via ltsp and run firefox there without any problems. But
>> I don't seem to be able to install it as a local app.
>>
>> I am not even sure where I should look for this one. If anyone can help
>> me that would be much appreciated.
>
> The nameservers are probably not set in the chroot, try this before you
> do the 'sudo chroot...' step:
>
> sudo cp /etc/resolv.conf /opt/ltsp/i386/etc/
>
> -Jonathan
>

That worked, thanks. The only problem I have now that I get a warning
about http://ftpmaster.internal/, is that normal?

Thanks,

Kees



--
edubuntu-users mailing list
edubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/edubuntu-users
 
Old 09-10-2010, 11:16 PM
Kees
 
Default Local Apps

On 11/09/10 06:53, Kees wrote:
> On 11/09/10 00:27, Jonathan Carter (highvoltage) wrote:
>> Hi Kees
>>
>> On 10/09/2010 12:11, Kees wrote:
>>> I am trying to install firefox as a local app (following this guide:
>>> https://help.ubuntu.com/community/UbuntuLTSPKarmicLocalAppsFirefox)
>>> However I get stuck at the first hurdle. When I am trying to update apt
>>> in the chroot environment it seems like it has no internet access in
>>> there. Probably something I have done wrong in my network setup (one
>>> nic). When I do 'sudo chroot /opt/ltsp/i386 route' or 'sudo chroot
>>> /opt/ltsp/i386 ifconfig' both commands complain about lack of network
>>> support.
>>>
>>> I can log in on via ltsp and run firefox there without any problems. But
>>> I don't seem to be able to install it as a local app.
>>>
>>> I am not even sure where I should look for this one. If anyone can help
>>> me that would be much appreciated.
>>
>> The nameservers are probably not set in the chroot, try this before you
>> do the 'sudo chroot...' step:
>>
>> sudo cp /etc/resolv.conf /opt/ltsp/i386/etc/
>>
>> -Jonathan
>>
>
> That worked, thanks. The only problem I have now that I get a warning
> about http://ftpmaster.internal/, is that normal?
>
> Thanks,
>
> Kees
>
>

Hmmm, it obviously is a problem, when trying to install firefox it is
trying to fetch packages from ftpmaster.internal and it can't do so, as
it does not seem to exist. I suspect something went wrong during my
install, I got some strange errors/warnings when shutting down, but as
everything worked I just left it.

Any ideas?

Kees

--
edubuntu-users mailing list
edubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/edubuntu-users
 
Old 09-12-2010, 11:07 PM
"Jonathan Carter (highvoltage)"
 
Default Local Apps

Hi Kees

On 10/09/2010 18:53, Kees wrote:
>> The nameservers are probably not set in the chroot, try this before you
>> do the 'sudo chroot...' step:
>
> That worked, thanks. The only problem I have now that I get a warning
> about http://ftpmaster.internal/, is that normal?

Also do a:
cp /etc/apt/sources.list /opt/ltsp/i386/etc/

then:
sudo chroot /opt/ltsp/i386 apt-get update

before doing the firefox install part.

-Jonathan

--
edubuntu-users mailing list
edubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/edubuntu-users
 
Old 09-17-2010, 12:47 PM
Kees
 
Default Local Apps

On 13/09/10 07:07, Jonathan Carter (highvoltage) wrote:
> Hi Kees
>
> On 10/09/2010 18:53, Kees wrote:
>>> The nameservers are probably not set in the chroot, try this before you
>>> do the 'sudo chroot...' step:
>>
>> That worked, thanks. The only problem I have now that I get a warning
>> about http://ftpmaster.internal/, is that normal?
>
> Also do a:
> cp /etc/apt/sources.list /opt/ltsp/i386/etc/
>
> then:
> sudo chroot /opt/ltsp/i386 apt-get update
>
> before doing the firefox install part.
>
> -Jonathan
>

That did the trick,

Thank you,

Kees


--
edubuntu-users mailing list
edubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/edubuntu-users
 
Old 09-21-2010, 08:17 AM
Kees
 
Default Local Apps

OK,

I seem to have serious problems with this Local Apps thing. Am now
trying to install openoffice as a local app. Doing:

sudo chroot /opt/ltsp/i386 apt-get install openoffice.org

and keep getting the same problems, have attached the log file of the
third try.

Have you got any idea what if going wrong here? I suspect that these
three lines is what the problem is, but are not sure, not do I know how
to resolve this:

----
Can not write log, openpty() failed (/dev/pts not mounted?)
Setting up openjdk-6-jre-headless (6b18-1.8.1-0ubuntu1) ...
the java command requires a mounted proc fs (/proc).
----

Thanks,

Kees
Reading package lists...
Building dependency tree...
Reading state information...
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_US.utf8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
openoffice.org is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 48 not upgraded.
13 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Can not write log, openpty() failed (/dev/pts not mounted?)
Setting up openjdk-6-jre-headless (6b18-1.8.1-0ubuntu1) ...
the java command requires a mounted proc fs (/proc).
dpkg: error processing openjdk-6-jre-headless (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of openjdk-6-jre:
openjdk-6-jre depends on openjdk-6-jre-headless (>= 6b18-1.8.1-0ubuntu1); however:
Package openjdk-6-jre-headless is not configured yet.
dpkg: error processing openjdk-6-jre (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of default-jre:
default-jre depends on openjdk-6-jre (>=
b14); however:
Package openjdk-6-jre is not configured yet.
dpkg: error processing default-jre (--configure):
dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
dpkg: dependency problems prevent configuration of openoffice.org-java-common:
openoffice.org-java-common depends on default-jre | gcj-jre | java-gcj-compat | openjdk-6-jre | sun-java5-jre | sun-java6-jre | java5-runtime | jre; however:
Package default-jre is not configured yet.
Package gcj-jre is not installed.
Package java-gcj-compat is not installed.
Package openjdk-6-jre is not configured yet.
Package sun-java5-jre is not installed.
Package sun-java6-jre is not installed.
Package java5-runtime is not installed.
Package default-jre which provides java5-runtime is not configured yet.
Package openjdk-6-jre which provides java5-runtime is not configured yet.
Package jre is not installed.
dpkg: error processing openoffice.org-java-common (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of openoffice.org-base:
openoffice.org-base depends on default-jre | gcj-jre | java-gcj-compat | openjdk-6-jre | sun-java5-jre | sun-java6-jre | java5-runtime | jre; however:
Package default-jre is not configured yet.
Package gcj-jre is not installed.
Package java-gcj-compat is not installed.
Package openjdk-6-jre is not configured yet.
Package sun-java5-jre is not installed.
Package sun-java6-jre is not installed.
Package java5-runtime is not installed.
Package default-jre which provides java5-runtime is not configured yet.
Package openjdk-6-jre which provides java5-runtime is not configured yet.
Package jre is not installed.
openoffice.org-base depends on openoffice.org-java-common (>= 1:3.2.0~); however:
Package openoffice.org-java-common is not configured yet.
dpkg: error processing openoffice.org-base (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of openoffice.org-report-builder-bin:
openoffice.org-report-builder-bin depends on openoffice.org-base (>= 2.3.0~src680m225); however:
Package openoffice.org-base is not configured yet.
dpkg: error processing openoffice.org-report-builder-bin (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of openoffice.org-officebean:
openoffice.org-officebean depends on default-jre | gcj-jre | java-gcj-compat (>= 1.0.77-4) | openjdk-6-jre | sun-java5-jre | sun-java6-jre | java5-runtime | jre; however:
Package default-jre is not configured yet.
Package gcj-jre is not installed.
Package java-gcj-compat is not installed.
Package openjdk-6-jre is not configured yet.
Package sun-java5-jre is not installed.
Package sun-java6-jre is not installed.
Package java5-runtime is not installed.
Package default-jre which provides java5-runtime is not configured yet.
Package openjdk-6-jre which provides java5-runtime is not configured yet.
Package jre is not installed.
openoffice.org-officebean depends on openoffice.org-java-common (>= 1:3.2.0~); however:
Package openoffice.org-java-common is not configured yet.
dpkg: error processing openoffice.org-officebean (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of openoffice.org-filter-mobiledev:
openoffice.org-filter-mobiledev depends on default-jre | gcj-jre | java-gcj-compat | openjdk-6-jre | sun-java5-jre | sun-java6-jre | java5-runtime | jre; however:
Package default-jre is not configured yet.
Package gcj-jre is not installed.
Package java-gcj-compat is not installed.
Package openjdk-6-jre is not configured yet.
Package sun-java5-jre is not installed.
Package sun-java6-jre is not installed.
Package java5-runtime is not installed.
Package default-jre which provides java5-runtime is not configured yet.
Package openjdk-6-jre which provides java5-runtime is not configured yet.
Package jre is not installed.
openoffice.org-filter-mobiledev depends on openoffice.org-java-common; however:
Package openoffice.org-java-common is not configured yet.
dpkg: error processing openoffice.org-filter-mobiledev (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of openoffice.org:
openoffice.org depends on openoffice.org-base; however:
Package openoffice.org-base is not configured yet.
openoffice.org depends on openoffice.org-report-builder-bin; however:
Package openoffice.org-report-builder-bin is not configured yet.
openoffice.org depends on openoffice.org-officebean; however:
Package openoffice.org-officebean is not configured yet.
openoffice.org depends on openoffice.org-filter-mobiledev; however:
Package openoffice.org-filter-mobiledev is not configured yet.
openoffice.org depends on openoffice.org-java-common (>= 1:3.2.0~); however:
Package openoffice.org-java-common is not configured yet.
dpkg: error processing openoffice.org (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of default-jre-headless:
default-jre-headless depends on openjdk-6-jre-headless (>= 6b14); however:
Package openjdk-6-jre-headless is not configured yet.
dpkg: error processing default-jre-headless (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of ca-certificates-java:
ca-certificates-java depends on openjdk-6-jre-headless (>= 6b16-1.6.1-2) | java6-runtime-headless; however:
Package openjdk-6-jre-headless is not configured yet.
Package java6-runtime-headless is not installed.
Package openjdk-6-jre-headless which provides java6-runtime-headless is not configured yet.
Package default-jre-headless which provides java6-runtime-headless is not configured yet.
dpkg: error processing ca-certificates-java (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
5-java:
libservlet2.5-java depends on default-jre-headless | java2-runtime-headless | java5-runtime-headless | java6-runtime-headless; however:
Package default-jre-headless is not configured yet.
Package java2-runtime-headless is not installed.
Package openjdk-6-jre-headless which provides java2-runtime-headless is not configured yet.
Package default-jre-headless which provides java2-runtime-headless is not configured yet.
Package java5-runtime-headless is not installed.
Package openjdk-6-jre-headless which provides java5-runtime-headless is not configured yet.
Package default-jre-headless which provides java5-runtime-headless is not configured yet.
Package java6-runtime-headless is not installed.
Package openjdk-6-jre-headless which provides java6-runtime-headless is not configured yet.
Package default-jre-headless which provides java6-runtime-headless is not configured yet.
dpkg: error processing libservlet2.5-java (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libhsqldb-java:
libhsqldb-java depends on default-jre-headless | java2-runtime-headless; however:
Package default-jre-headless is not configured yet.
Package java2-runtime-headless is not installed.
Package openjdk-6-jre-headless which provides java2-runtime-headless is not configured yet.
Package default-jre-headless which provides java2-runtime-headless is not configured yet.
libhsqldb-java depends on libservlet2.5-java; however:
Package libservlet2.5-java is not configured yet.
dpkg: error processing libhsqldb-java (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
Errors were encountered while processing:
openjdk-6-jre-headless
openjdk-6-jre
default-jre
openoffice.org-java-common
openoffice.org-base
openoffice.org-report-builder-bin
openoffice.org-officebean
openoffice.org-filter-mobiledev
openoffice.org
default-jre-headless
ca-certificates-java
libservlet2.5-java
libhsqldb-java
E: Sub-process /usr/bin/dpkg returned an error code (1)
--
edubuntu-users mailing list
edubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/edubuntu-users
 
Old 09-21-2010, 03:24 PM
"Marc Gariépy"
 
Default Local Apps

Hello,


On Tue, 2010-09-21 at 16:17 +0800, Kees wrote:
> OK,
>
> I seem to have serious problems with this Local Apps thing. Am now
> trying to install openoffice as a local app. Doing:
>
> sudo chroot /opt/ltsp/i386 apt-get install openoffice.org
Try :
sudo chroot /opt/ltsp/i386
mount -t proc proc /proc
export LTSP_HANDLE_DAEMONS=false
apt-get install openoffice.org
umount /proc
>
> and keep getting the same problems, have attached the log file of the
> third try.
>
> Have you got any idea what if going wrong here? I suspect that these
> three lines is what the problem is, but are not sure, not do I know how
> to resolve this:
>
> ----
> Can not write log, openpty() failed (/dev/pts not mounted?)
> Setting up openjdk-6-jre-headless (6b18-1.8.1-0ubuntu1) ...
> the java command requires a mounted proc fs (/proc).
> ----
>
> Thanks,
>
> Kees


--
edubuntu-users mailing list
edubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/edubuntu-users
 
Old 01-15-2011, 06:39 PM
dgroos
 
Default Local Apps

Thanks Marc, this solution to install openoffice in the Lucid chroot worked
for me.
David


Marc Gariépy wrote:
>
> Hello,
>
>
> On Tue, 2010-09-21 at 16:17 +0800, Kees wrote:
>> OK,
>>
>> I seem to have serious problems with this Local Apps thing. Am now
>> trying to install openoffice as a local app. Doing:
>>
>> sudo chroot /opt/ltsp/i386 apt-get install openoffice.org
> Try :
> sudo chroot /opt/ltsp/i386
> mount -t proc proc /proc
> export LTSP_HANDLE_DAEMONS=false
> apt-get install openoffice.org
> umount /proc
>>
>> and keep getting the same problems, have attached the log file of the
>> third try.
>>
>> Have you got any idea what if going wrong here? I suspect that these
>> three lines is what the problem is, but are not sure, not do I know how
>> to resolve this:
>>
>> ----
>> Can not write log, openpty() failed (/dev/pts not mounted?)
>> Setting up openjdk-6-jre-headless (6b18-1.8.1-0ubuntu1) ...
>> the java command requires a mounted proc fs (/proc).
>> ----
>>
>> Thanks,
>>
>> Kees
>
>
> --
> edubuntu-users mailing list
> edubuntu-users@lists.ubuntu.com
> Modify settings or unsubscribe at:
> https://lists.ubuntu.com/mailman/listinfo/edubuntu-users
>
>

--
View this message in context: http://old.nabble.com/Local-Apps-tp29678553p30676130.html
Sent from the edubuntu-users mailing list archive at Nabble.com.


--
edubuntu-users mailing list
edubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/edubuntu-users
 

Thread Tools




All times are GMT. The time now is 03:13 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org