Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Device-mapper Development (http://www.linux-archive.org/device-mapper-development/)
-   -   multipath device with name '1' (http://www.linux-archive.org/device-mapper-development/641103-multipath-device-name-1-a.html)

Rudy Gevaert 03-05-2012 03:52 PM

multipath device with name '1'
 
Hello,

From time to time I get a multipath device called '1':

1 dm-4 DELL,MD32xx
size=50G features='3 queue_if_no_path pg_init_retries 50' hwhandler='1
rdac' wp=rw

`-+- policy='round-robin 0' prio=-1 status=enabled
|- 0:0:0:1 sdd 8:48 failed undef running
`- 0:0:1:1 sde 8:64 failed undef running


This happens when I unmap/map luns to a specific host.

I am seeing this on machines connected through fibre channel to an IBM
DS3400, but also on a machine direct attached to a Dell MD3200.


1 dm-6 IBM,1726-4xx FAStT
size=550G features='1 queue_if_no_path' hwhandler='1 rdac' wp=rw
`-+- policy='round-robin 0' prio=-1 status=enabled
`- 1:0:0:15 sdh 8:112 failed undef running

I haven't been able to remove the device from the listing. I can remove
it from device mapper, but as soon as I rescan the bus it appears again.


The only way to get rid of the multipath (so it stays away) is to reboot
the machine.


The main concern with this device I have is that some scripts (like when
you recreate initramfs) go and check all the devices. And when it
checks this device the process hangs...


Has anybody seen this before?

root@cyrprd2:~# uname -a
Linux cyrprd2 2.6.32-5-amd64 #1 SMP Tue Jun 14 09:42:28 UTC 2011 x86_64
GNU/Linux




Thanks,

Rudy

--
dm-devel mailing list
dm-devel@redhat.com
https://www.redhat.com/mailman/listinfo/dm-devel


All times are GMT. The time now is 07:59 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.