FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Device-mapper Development

 
 
LinkBack Thread Tools
 
Old 09-14-2011, 10:46 AM
Gianluca Cecchi
 
Default multipathd & EMC Clariion CX-4

On Wed, Sep 14, 2011 at 11:58 AM, NEVEU Stephane wrote:
> Hi all,
>
>
>
> I'm experiencing problems trying to set up a multipathd config with a EMC
> Clariion CX-4 Storage.
>
> It seems that the CX4 is actually active/passive regarding SPs. My server
> *has QLogic Fiber Cards. My multipath-tools version is 0.4.8.
...
>
> ****************************** hardware_handler******** "1 emc"

> ****************************** product_blacklist*********** LUN_Z
>
> *************** }

>

Hi,
for other purposes I came to this document that refers to a CLARiiON
CX4-480 with CentOS 5.5:
http://www.nxnt.org/2010/08/multipath-linux-and-emc-clariion/
I don't know how does it match your config, but it seems that the
possibly relevant configuration differences are

hardware_handler "1 alua"
and
product_blacklist LUNZ (without the underscore...)

HIH,
Gianluca

--
dm-devel mailing list
dm-devel@redhat.com
https://www.redhat.com/mailman/listinfo/dm-devel
 
Old 09-14-2011, 11:16 AM
NEVEU Stephane
 
Default multipathd & EMC Clariion CX-4

Thanks for your link, nevertheless I made those changes about alua an LUNZ but it seems that it's getting worse :
multipath -v2 -d gives :
sdg: checker msg is "directio checker reports path is down"
sdm: checker msg is "directio checker reports path is down"
sde: checker msg is "directio checker reports path is down"
sdk: checker msg is "directio checker reports path is down"
sdc: checker msg is "directio checker reports path is down"
sdi: checker msg is "directio checker reports path is down"
create: mpath0 (360026b905367200012a8666a06b52fbc) DELL ,PERC 6/i
[size=148G][features=0][hwhandler=0]
\_ round-robin 0 [prio=1][undef]
\_ 3:2:0:0 sda 8:0 [undef][ready]


--
Stéphane Neveu
Ingénieur Opensource / RedHat Technical Manager
THALES - Critical Information Systems
DIVISION Security Solutions & Services / Server Mgmt
Tél 01 73 17 03 15
--


-----Message d'origine-----
De*: dm-devel-bounces@redhat.com [mailto:dm-devel-bounces@redhat.com] De la part de Gianluca Cecchi
Envoyé*: mercredi 14 septembre 2011 12:46
À*: device-mapper development
Objet*: Re: [dm-devel] multipathd & EMC Clariion CX-4

On Wed, Sep 14, 2011 at 11:58 AM, NEVEU Stephane wrote:
> Hi all,
>
>
>
> I'm experiencing problems trying to set up a multipathd config with a EMC
> Clariion CX-4 Storage.
>
> It seems that the CX4 is actually active/passive regarding SPs. My server
> *has QLogic Fiber Cards. My multipath-tools version is 0.4.8.
...
>
> ****************************** hardware_handler******** "1 emc"

> ****************************** product_blacklist*********** LUN_Z
>
> *************** }

>

Hi,
for other purposes I came to this document that refers to a CLARiiON
CX4-480 with CentOS 5.5:
http://www.nxnt.org/2010/08/multipath-linux-and-emc-clariion/
I don't know how does it match your config, but it seems that the
possibly relevant configuration differences are

hardware_handler "1 alua"
and
product_blacklist LUNZ (without the underscore...)

HIH,
Gianluca

--
dm-devel mailing list
dm-devel@redhat.com
https://www.redhat.com/mailman/listinfo/dm-devel

--
dm-devel mailing list
dm-devel@redhat.com
https://www.redhat.com/mailman/listinfo/dm-devel
 
Old 09-14-2011, 11:39 AM
Hannes Reinecke
 
Default multipathd & EMC Clariion CX-4

On 09/14/2011 11:58 AM, NEVEU Stephane wrote:

Hi all,

I'm experiencing problems trying to set up a multipathd config with
a EMC Clariion CX-4 Storage.

It seems that the CX4 is actually active/passive regarding SPs. My
server has QLogic Fiber Cards. My multipath-tools version is 0.4.8.

Here is my multipath.conf :

##

## This is a template multipath-tools configuration file

## Uncomment the lines relevent to your environment

##

defaults {

user_friendly_names yes

}

blacklist {

#devnode "*"

devnode "^(ram|raw|loop|fd|md|dm-|sr|scd|st)[0-9]*"

devnode "^hd[a-z][[0-9]*]"

devnode "^cciss!c[0-9]d[0-9]*[p[0-9]*]"

}

devices {

device {

vendor "DGC "

product "*"

That is wrong. The configuration file doesn't allow for regular
expressions or wildcards. Please use the correct name ('RAID 5') here.

And 'directio' is most certainly wrong here.

What's wrong with the default setting? It should work out of the box
without configuration file at all ...


Cheers,

Hannes
--
Dr. Hannes Reinecke zSeries & Storage
hare@suse.de +49 911 74053 688
SUSE LINUX Products GmbH, Maxfeldstr. 5, 90409 Nürnberg
GF: J. Hawn, J. Guild, F. Imendörffer, HRB 16746 (AG Nürnberg)

--
dm-devel mailing list
dm-devel@redhat.com
https://www.redhat.com/mailman/listinfo/dm-devel
 
Old 09-14-2011, 12:00 PM
NEVEU Stephane
 
Default multipathd & EMC Clariion CX-4

Dear Hannes,

You are right ! many thanks ! I moved away multipath.conf from the etc folder and restarted multipath-tools and everything works fine :

NDO (36006016017402600f2ed610b62cde011) dm-8 DGC ,RAID 5
[size=50G][features=1 queue_if_no_path][hwhandler=1 emc]
\_ round-robin 0 [prio=2][active]
\_ 2:0:0:1 sdd 8:48 [active][ready]
\_ 5:0:0:1 sdj 8:144 [active][ready]
\_ round-robin 0 [prio=0][enabled]
\_ 2:0:1:1 sdg 8:96 [active][ready]
\_ 5:0:1:1 sdm 8:192 [active][ready]
NAGIOS (360060160174026000c984cc67acde011) dm-6 DGC ,RAID 5
[size=40G][features=1 queue_if_no_path][hwhandler=1 emc]
\_ round-robin 0 [prio=2][active]
\_ 2:0:1:2 sdh 8:112 [active][ready]
\_ 5:0:1:2 sdn 8:208 [active][ready]
\_ round-robin 0 [prio=0][enabled]
\_ 2:0:0:2 sde 8:64 [active][ready]
\_ 5:0:0:2 sdk 8:160 [active][ready]
NPCD (360060160174026008cf8cef961cde011) dm-7 DGC ,RAID 5
[size=100G][features=1 queue_if_no_path][hwhandler=1 emc]
\_ round-robin 0 [prio=2][active]
\_ 2:0:1:0 sdf 8:80 [active][ready]
\_ 5:0:1:0 sdl 8:176 [active][ready]
\_ round-robin 0 [prio=0][enabled]
\_ 2:0:0:0 sdc 8:32 [active][ready]
\_ 5:0:0:0 sdi 8:128 [active][ready]

Does it automatically recognize symbolic links (pointing to /dev/dm-*) in /dev/mapper/ folder ?

--
Stéphane Neveu
Ingénieur Opensource / RedHat Technical Manager
THALES - Critical Information Systems
DIVISION Security Solutions & Services / Server Mgmt
Tél 01 73 17 03 15
--


-----Message d'origine-----
De*: dm-devel-bounces@redhat.com [mailto:dm-devel-bounces@redhat.com] De la part de Hannes Reinecke
Envoyé*: mercredi 14 septembre 2011 13:40
À*: device-mapper development
Objet*: Re: [dm-devel] multipathd & EMC Clariion CX-4

On 09/14/2011 11:58 AM, NEVEU Stephane wrote:
> Hi all,
>
> I'm experiencing problems trying to set up a multipathd config with
> a EMC Clariion CX-4 Storage.
>
> It seems that the CX4 is actually active/passive regarding SPs. My
> server has QLogic Fiber Cards. My multipath-tools version is 0.4.8.
>
> Here is my multipath.conf :
>
> ##
>
> ## This is a template multipath-tools configuration file
>
> ## Uncomment the lines relevent to your environment
>
> ##
>
> defaults {
>
> user_friendly_names yes
>
> }
>
> blacklist {
>
> #devnode "*"
>
> devnode "^(ram|raw|loop|fd|md|dm-|sr|scd|st)[0-9]*"
>
> devnode "^hd[a-z][[0-9]*]"
>
> devnode "^cciss!c[0-9]d[0-9]*[p[0-9]*]"
>
> }
>
> devices {
>
> device {
>
> vendor "DGC "
>
> product "*"
>
That is wrong. The configuration file doesn't allow for regular
expressions or wildcards. Please use the correct name ('RAID 5') here.
And 'directio' is most certainly wrong here.

What's wrong with the default setting? It should work out of the box
without configuration file at all ...

Cheers,

Hannes
--
Dr. Hannes Reinecke zSeries & Storage
hare@suse.de +49 911 74053 688
SUSE LINUX Products GmbH, Maxfeldstr. 5, 90409 Nürnberg
GF: J. Hawn, J. Guild, F. Imendörffer, HRB 16746 (AG Nürnberg)

--
dm-devel mailing list
dm-devel@redhat.com
https://www.redhat.com/mailman/listinfo/dm-devel

--
dm-devel mailing list
dm-devel@redhat.com
https://www.redhat.com/mailman/listinfo/dm-devel
 
Old 09-15-2011, 12:46 PM
NEVEU Stephane
 
Default multipathd & EMC Clariion CX-4

Hi all,

Actually it works on only one server (I'm actually running a cluster..), the second node is not showing anything when trying multipath -ll.
I tried to remove / reboot / reinstall multipath-tools but I still see this error message in dmesg :
device-mapper: ioctl: error adding target to table
device-mapper: table: 251:13: multipath: error getting table
.
.
.
many times.
There is no linked wwn created in /dev/mapper of course whereas everything's working find on the first node..
Any idea ?

Thank you by avance,


-----Message d'origine-----
De*: dm-devel-bounces@redhat.com [mailto:dm-devel-bounces@redhat.com] De la part de NEVEU Stephane
Envoyé*: mercredi 14 septembre 2011 14:00
À*: device-mapper development
Objet*: Re: [dm-devel] multipathd & EMC Clariion CX-4

Dear Hannes,

You are right ! many thanks ! I moved away multipath.conf from the etc folder and restarted multipath-tools and everything works fine :

NDO (36006016017402600f2ed610b62cde011) dm-8 DGC ,RAID 5
[size=50G][features=1 queue_if_no_path][hwhandler=1 emc]
\_ round-robin 0 [prio=2][active]
\_ 2:0:0:1 sdd 8:48 [active][ready]
\_ 5:0:0:1 sdj 8:144 [active][ready]
\_ round-robin 0 [prio=0][enabled]
\_ 2:0:1:1 sdg 8:96 [active][ready]
\_ 5:0:1:1 sdm 8:192 [active][ready]
NAGIOS (360060160174026000c984cc67acde011) dm-6 DGC ,RAID 5
[size=40G][features=1 queue_if_no_path][hwhandler=1 emc]
\_ round-robin 0 [prio=2][active]
\_ 2:0:1:2 sdh 8:112 [active][ready]
\_ 5:0:1:2 sdn 8:208 [active][ready]
\_ round-robin 0 [prio=0][enabled]
\_ 2:0:0:2 sde 8:64 [active][ready]
\_ 5:0:0:2 sdk 8:160 [active][ready]
NPCD (360060160174026008cf8cef961cde011) dm-7 DGC ,RAID 5
[size=100G][features=1 queue_if_no_path][hwhandler=1 emc]
\_ round-robin 0 [prio=2][active]
\_ 2:0:1:0 sdf 8:80 [active][ready]
\_ 5:0:1:0 sdl 8:176 [active][ready]
\_ round-robin 0 [prio=0][enabled]
\_ 2:0:0:0 sdc 8:32 [active][ready]
\_ 5:0:0:0 sdi 8:128 [active][ready]

Does it automatically recognize symbolic links (pointing to /dev/dm-*) in /dev/mapper/ folder ?

--
Stéphane Neveu
Ingénieur Opensource / RedHat Technical Manager
THALES - Critical Information Systems
DIVISION Security Solutions & Services / Server Mgmt
Tél 01 73 17 03 15
--


-----Message d'origine-----
De*: dm-devel-bounces@redhat.com [mailto:dm-devel-bounces@redhat.com] De la part de Hannes Reinecke
Envoyé*: mercredi 14 septembre 2011 13:40
À*: device-mapper development
Objet*: Re: [dm-devel] multipathd & EMC Clariion CX-4

On 09/14/2011 11:58 AM, NEVEU Stephane wrote:
> Hi all,
>
> I'm experiencing problems trying to set up a multipathd config with
> a EMC Clariion CX-4 Storage.
>
> It seems that the CX4 is actually active/passive regarding SPs. My
> server has QLogic Fiber Cards. My multipath-tools version is 0.4.8.
>
> Here is my multipath.conf :
>
> ##
>
> ## This is a template multipath-tools configuration file
>
> ## Uncomment the lines relevent to your environment
>
> ##
>
> defaults {
>
> user_friendly_names yes
>
> }
>
> blacklist {
>
> #devnode "*"
>
> devnode "^(ram|raw|loop|fd|md|dm-|sr|scd|st)[0-9]*"
>
> devnode "^hd[a-z][[0-9]*]"
>
> devnode "^cciss!c[0-9]d[0-9]*[p[0-9]*]"
>
> }
>
> devices {
>
> device {
>
> vendor "DGC "
>
> product "*"
>
That is wrong. The configuration file doesn't allow for regular
expressions or wildcards. Please use the correct name ('RAID 5') here.
And 'directio' is most certainly wrong here.

What's wrong with the default setting? It should work out of the box
without configuration file at all ...

Cheers,

Hannes
--
Dr. Hannes Reinecke zSeries & Storage
hare@suse.de +49 911 74053 688
SUSE LINUX Products GmbH, Maxfeldstr. 5, 90409 Nürnberg
GF: J. Hawn, J. Guild, F. Imendörffer, HRB 16746 (AG Nürnberg)

--
dm-devel mailing list
dm-devel@redhat.com
https://www.redhat.com/mailman/listinfo/dm-devel

--
dm-devel mailing list
dm-devel@redhat.com
https://www.redhat.com/mailman/listinfo/dm-devel

--
dm-devel mailing list
dm-devel@redhat.com
https://www.redhat.com/mailman/listinfo/dm-devel
 
Old 09-15-2011, 02:49 PM
NEVEU Stephane
 
Default multipathd & EMC Clariion CX-4

Ok, solved by a update-initramfs.

Cordialement,

[@@THALES GROUP RESTRICTED@@]
--
Stéphane Neveu
Ingénieur Opensource / RedHat Technical Manager
THALES - Critical Information Systems
DIVISION Security Solutions & Services / Server Mgmt
Tél 01 73 17 03 15
--


-----Message d'origine-----
De*: dm-devel-bounces@redhat.com [mailto:dm-devel-bounces@redhat.com] De la part de NEVEU Stephane
Envoyé*: jeudi 15 septembre 2011 14:47
À*: device-mapper development
Objet*: Re: [dm-devel] multipathd & EMC Clariion CX-4

Hi all,

Actually it works on only one server (I'm actually running a cluster..), the second node is not showing anything when trying multipath -ll.
I tried to remove / reboot / reinstall multipath-tools but I still see this error message in dmesg :
device-mapper: ioctl: error adding target to table
device-mapper: table: 251:13: multipath: error getting table
.
.
.
many times.
There is no linked wwn created in /dev/mapper of course whereas everything's working find on the first node..
Any idea ?

Thank you by avance,


-----Message d'origine-----
De*: dm-devel-bounces@redhat.com [mailto:dm-devel-bounces@redhat.com] De la part de NEVEU Stephane
Envoyé*: mercredi 14 septembre 2011 14:00
À*: device-mapper development
Objet*: Re: [dm-devel] multipathd & EMC Clariion CX-4

Dear Hannes,

You are right ! many thanks ! I moved away multipath.conf from the etc folder and restarted multipath-tools and everything works fine :

NDO (36006016017402600f2ed610b62cde011) dm-8 DGC ,RAID 5
[size=50G][features=1 queue_if_no_path][hwhandler=1 emc]
\_ round-robin 0 [prio=2][active]
\_ 2:0:0:1 sdd 8:48 [active][ready]
\_ 5:0:0:1 sdj 8:144 [active][ready]
\_ round-robin 0 [prio=0][enabled]
\_ 2:0:1:1 sdg 8:96 [active][ready]
\_ 5:0:1:1 sdm 8:192 [active][ready]
NAGIOS (360060160174026000c984cc67acde011) dm-6 DGC ,RAID 5
[size=40G][features=1 queue_if_no_path][hwhandler=1 emc]
\_ round-robin 0 [prio=2][active]
\_ 2:0:1:2 sdh 8:112 [active][ready]
\_ 5:0:1:2 sdn 8:208 [active][ready]
\_ round-robin 0 [prio=0][enabled]
\_ 2:0:0:2 sde 8:64 [active][ready]
\_ 5:0:0:2 sdk 8:160 [active][ready]
NPCD (360060160174026008cf8cef961cde011) dm-7 DGC ,RAID 5
[size=100G][features=1 queue_if_no_path][hwhandler=1 emc]
\_ round-robin 0 [prio=2][active]
\_ 2:0:1:0 sdf 8:80 [active][ready]
\_ 5:0:1:0 sdl 8:176 [active][ready]
\_ round-robin 0 [prio=0][enabled]
\_ 2:0:0:0 sdc 8:32 [active][ready]
\_ 5:0:0:0 sdi 8:128 [active][ready]

Does it automatically recognize symbolic links (pointing to /dev/dm-*) in /dev/mapper/ folder ?

--
Stéphane Neveu
Ingénieur Opensource / RedHat Technical Manager
THALES - Critical Information Systems
DIVISION Security Solutions & Services / Server Mgmt
Tél 01 73 17 03 15
--


-----Message d'origine-----
De*: dm-devel-bounces@redhat.com [mailto:dm-devel-bounces@redhat.com] De la part de Hannes Reinecke
Envoyé*: mercredi 14 septembre 2011 13:40
À*: device-mapper development
Objet*: Re: [dm-devel] multipathd & EMC Clariion CX-4

On 09/14/2011 11:58 AM, NEVEU Stephane wrote:
> Hi all,
>
> I'm experiencing problems trying to set up a multipathd config with
> a EMC Clariion CX-4 Storage.
>
> It seems that the CX4 is actually active/passive regarding SPs. My
> server has QLogic Fiber Cards. My multipath-tools version is 0.4.8.
>
> Here is my multipath.conf :
>
> ##
>
> ## This is a template multipath-tools configuration file
>
> ## Uncomment the lines relevent to your environment
>
> ##
>
> defaults {
>
> user_friendly_names yes
>
> }
>
> blacklist {
>
> #devnode "*"
>
> devnode "^(ram|raw|loop|fd|md|dm-|sr|scd|st)[0-9]*"
>
> devnode "^hd[a-z][[0-9]*]"
>
> devnode "^cciss!c[0-9]d[0-9]*[p[0-9]*]"
>
> }
>
> devices {
>
> device {
>
> vendor "DGC "
>
> product "*"
>
That is wrong. The configuration file doesn't allow for regular
expressions or wildcards. Please use the correct name ('RAID 5') here.
And 'directio' is most certainly wrong here.

What's wrong with the default setting? It should work out of the box
without configuration file at all ...

Cheers,

Hannes
--
Dr. Hannes Reinecke zSeries & Storage
hare@suse.de +49 911 74053 688
SUSE LINUX Products GmbH, Maxfeldstr. 5, 90409 Nürnberg
GF: J. Hawn, J. Guild, F. Imendörffer, HRB 16746 (AG Nürnberg)

--
dm-devel mailing list
dm-devel@redhat.com
https://www.redhat.com/mailman/listinfo/dm-devel

--
dm-devel mailing list
dm-devel@redhat.com
https://www.redhat.com/mailman/listinfo/dm-devel

--
dm-devel mailing list
dm-devel@redhat.com
https://www.redhat.com/mailman/listinfo/dm-devel

--
dm-devel mailing list
dm-devel@redhat.com
https://www.redhat.com/mailman/listinfo/dm-devel
 

Thread Tools




All times are GMT. The time now is 07:29 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org