FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Device-mapper Development

 
 
LinkBack Thread Tools
 
Old 03-23-2011, 12:44 PM
Степан Фёдоров
 
Default dm-ioband max-bw and min-bw

Hello!
I have some questions about dm-ioband module.
My m-ioband patch version is 1.14.0 on SLES11SP1*2.6.32.29-0.3-xen kernel.
/dev/mapper/1id-22-109 is a multipath device. In normal case, block device performance test shows 500-600Mb/sec on this device.

Next i do next commands:
echo "0 $(blockdev --getsize /dev/mapper/1id-22-109) ioband /dev/mapper/1id-22-109 0 0 0 none range-bw 0 :10000:50000" |dmsetup create iob-22-109

in /dev/mapper i see iob-22-109 device. OK.
My*block device performance test shows on this device about 50Mb/sec.
dmsetup table shows me:iob-22-109: 0 10485760 ioband 253:5 0 4 192 none range-bw 12288 :10000:50000
for this device.
All this is OK, and next i want to change somthing. I*do:dmsetup message iob-22-109 0 max-bw 70000
My block device performance test shows now on this device about 500-600Mb/sec, and dmsetup table shows:
iob-22-109: 0 10485760 ioband 253:5 0 4 192 none range-bw 12288 :10000:0
As you can see - maximum bandwidth value, resets to zero after setting it to 70Mb by "dmsetup message ..." command.

If next i change min-bw by same way - it also rests to zero instead right value.
My question: is this a bug in some software, or just a result of something wrong in my actions?

Thank you!

--
dm-devel mailing list
dm-devel@redhat.com
https://www.redhat.com/mailman/listinfo/dm-devel
 
Old 03-28-2011, 08:06 PM
Степан Фёдоров
 
Default dm-ioband max-bw and min-bw

May be my previous message was not delivered, so i repeat it now:

2011/3/23 Степан Фёдоров <stepan.fedorov@clodo.ru>:
> Hello!
> I have some questions about dm-ioband module.
> My m-ioband patch version is 1.14.0 on SLES11SP1*2.6.32.29-0.3-xen kernel.
> /dev/mapper/1id-22-109 is a multipath device. In normal case, block device
> performance test shows 500-600Mb/sec on this device.
> Next i do next commands:
> echo "0 $(blockdev --getsize /dev/mapper/1id-22-109) ioband
> /dev/mapper/1id-22-109 0 0 0 none range-bw 0 :10000:50000" |dmsetup create
> iob-22-109
> in /dev/mapper i see iob-22-109 device. OK.
> My*block device performance test shows on this device about 50Mb/sec.
> dmsetup table shows me:
> iob-22-109: 0 10485760 ioband 253:5 0 4 192 none range-bw 12288 :10000:50000
> for this device.
> All this is OK, and next i want to change somthing. I*do:
> dmsetup message iob-22-109 0 max-bw 70000
> My block device performance test shows now on this device about
> 500-600Mb/sec, and dmsetup table shows:
> iob-22-109: 0 10485760 ioband 253:5 0 4 192 none range-bw 12288 :10000:0
> As you can see - maximum bandwidth value, resets to zero after setting it to
> 70Mb by "dmsetup message ..." command.
> If next i change min-bw by same way - it also rests to zero instead right
> value.
> My question: is this a bug in some software, or just a result of something
> wrong in my actions?
> Thank you!
>

--
dm-devel mailing list
dm-devel@redhat.com
https://www.redhat.com/mailman/listinfo/dm-devel
 

Thread Tools




All times are GMT. The time now is 06:47 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org