Quite a lot of churn but I think it is for the better in the end.
(I developed these changes on Wednesday but just got around to getting
them sent out now)
Mike Snitzer (7):
document low hanging fruit to help improve code readability
Improve name used for "persistent store" in 'struct dm_multisnap'
Avoid exception store being confused with snapshot 's'
Avoid struct members with the name 'dm'
rename snapid members to use 'snapid' names
move individual dm_multisnap 'flags' values
Removed remaining 'struct dm_exception_store' FIXMEs.