FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Device-mapper Development

 
 
LinkBack Thread Tools
 
Old 06-03-2008, 10:35 PM
Christopher
 
Default qla4xxx & "device-mapper: table: 253:0: multipath: error getting device" error

Hi,

I'm on my second atempt to configure iSCSI (Dell EqualLogic PS5000XV) on
linux (CentOS 5.1 x86_64). The first ended in a total caos and kernel
panic I didn't manage to recover from. No biggie, since it's a new
server (actually will be two identical running a cluster with iSCSI as
shared storage).


I've got a dualport QLogic iSCSI HBA QLE4062C card. I am trying to
configure my server to use multipath to the EqualLogic, but i'm not
confident it's safe to put it in production since I get this error in my
message log (dmesg) when what I believe is correct configuration gives
me lots of these:


device-mapper: table: 253:0: multipath: error getting device
device-mapper: ioctl: error adding target to table

First I used the drivers from QLogic and thought it was a bug in the
driver, but after I removed them the system loaded the kernel provided
qla4xxx driver and the error still showed in my log.


Is this a but in device-mapper-multipath or is it my config?

For more info on this, see my open-iscsi post on google groups:
http://groups.google.com/group/open-iscsi/browse_thread/thread/8bf139d774eab658



I posted there first, but ppl in the group told me to go to dm-devel.

/Christopher

--
dm-devel mailing list
dm-devel@redhat.com
https://www.redhat.com/mailman/listinfo/dm-devel
 

Thread Tools




All times are GMT. The time now is 01:39 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org