Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian User (http://www.linux-archive.org/debian-user/)
-   -   Initializing XFRM netlink socket? (http://www.linux-archive.org/debian-user/97660-initializing-xfrm-netlink-socket.html)

"Michal R. Hoffmann" 05-29-2008 07:16 PM

Initializing XFRM netlink socket?
 
Hi,

I tried to google it out, but no success. The following message appears
on the console repeatedly:

Initializing XFRM netlink socket
which is quite annoying. Normally I use Gnome so I don't notice that but
from time to time I switch to the text console and each few seconds I'm
bothered with the message. What is the cause and how can I fix it?


Please, help!
--
Michal R. Hoffmann


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

"Michal R. Hoffmann" 05-30-2008 06:58 PM

Initializing XFRM netlink socket?
 
On 29/05/08 20:16, Michal R. Hoffmann wrote:

Hi,

I tried to google it out, but no success. The following message appears
on the console repeatedly:

Initializing XFRM netlink socket
which is quite annoying. Normally I use Gnome so I don't notice that but
from time to time I switch to the text console and each few seconds I'm
bothered with the message. What is the cause and how can I fix it?




Oh, I forgot to give some details, sorry

Debian Sid, kernel 2.6.25.4.

Kind regards,
Michal R. Hoffmann


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Florian Kulzer 05-31-2008 02:25 PM

Initializing XFRM netlink socket?
 
On Fri, May 30, 2008 at 19:58:22 +0100, Michal R. Hoffmann wrote:
> On 29/05/08 20:16, Michal R. Hoffmann wrote:
>> Hi,
>>
>> I tried to google it out, but no success. The following message appears
>> on the console repeatedly:
>> Initializing XFRM netlink socket
>> which is quite annoying. Normally I use Gnome so I don't notice that
>> but from time to time I switch to the text console and each few seconds
>> I'm bothered with the message. What is the cause and how can I fix it?
>>
>
> Oh, I forgot to give some details, sorry
>
> Debian Sid, kernel 2.6.25.4.

To get rid of the most annoying symptom, the messages appearing on the
console, it might be enough to adjust the kernel printk parameters. See
the comments in /etc/sysctl.conf for more information.

I am not sure why these messages are generated at all or whether they
are cause for concern. Maybe you have activated some very verbose INET
debugging options in your kernel. You could try if a stock Debian kernel
produces the same messages. (The way you specify your kernel version
suggests that you are using a custom-compiled one.)

--
Regards, | http://users.icfo.es/Florian.Kulzer
Florian |


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

"Michal R. Hoffmann" 06-06-2008 11:07 PM

Initializing XFRM netlink socket?
 
On 31/05/08 15:25, Florian Kulzer wrote:

On Fri, May 30, 2008 at 19:58:22 +0100, Michal R. Hoffmann wrote:

On 29/05/08 20:16, Michal R. Hoffmann wrote:

Hi,

I tried to google it out, but no success. The following message appears
on the console repeatedly:

Initializing XFRM netlink socket
which is quite annoying. Normally I use Gnome so I don't notice that
but from time to time I switch to the text console and each few seconds
I'm bothered with the message. What is the cause and how can I fix it?




Oh, I forgot to give some details, sorry

Debian Sid, kernel 2.6.25.4.


To get rid of the most annoying symptom, the messages appearing on the
console, it might be enough to adjust the kernel printk parameters. See
the comments in /etc/sysctl.conf for more information.

I am not sure why these messages are generated at all or whether they
are cause for concern. Maybe you have activated some very verbose INET
debugging options in your kernel. You could try if a stock Debian kernel
produces the same messages. (The way you specify your kernel version
suggests that you are using a custom-compiled one.)



It took some time as I could not restart my PC last few days to try
stock kernel - unfortunately the stock kernel doesn't work for me. But I
found the reason for the message - it was Openswan package fault. Or
mine - I haven't installed openswan kernel patch, which would probably
fix it. As I do not use Openswan (it was installed along with kvpn) I
just removed the package and it helped.


Thanks for suggestions anyway,

--
Kind regards
Michal R. Hoffmann


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org


All times are GMT. The time now is 04:41 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.