FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 05-24-2008, 09:48 AM
"sathiya moorthy"
 
Default how to upgrade dependency packages

Hi,

I downloaded a debian package ( .deb file ), and then i tried installing that using dpkg, and i got the errors like.,

** system has this package with this version, and this package requires updated version



Error shown is

depends on libasound2 (>> 1.0.16); however:
* Version of libasound2 on system is 1.0.13-2.

What needs to be done ?

--
sathiyamoorthy
 
Old 05-24-2008, 04:59 PM
"Mumia W.."
 
Default how to upgrade dependency packages

On 05/24/2008 04:48 AM, sathiya moorthy wrote:

Hi,

I downloaded a debian package ( .deb file ), and then i tried installing
that using dpkg, and i got the errors like.,

system has this package with this version, and this package requires
updated version


Error shown is

depends on libasound2 (>> 1.0.16); however:
Version of libasound2 on system is 1.0.13-2.

What needs to be done ?




You probably have to upgrade libasound2 first, but this might be done
automatically by "aptitude."


What is the .deb you're trying to install? What distribution are you
running?




--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 05-25-2008, 12:57 AM
"Douglas A. Tutty"
 
Default how to upgrade dependency packages

On Sat, May 24, 2008 at 03:18:37PM +0530, sathiya moorthy wrote:
> I downloaded a debian package ( .deb file ), and then i tried installing
> that using dpkg, and i got the errors like.,

Why?
>
> system has this package with this version, and this package requires
> updated version
>
>
> Error shown is
>
> depends on libasound2 (>> 1.0.16); however:
> Version of libasound2 on system is 1.0.13-2.
>
> What needs to be done ?
>

dpkg installs individual debs. However, you need some kind of package
manager to grab the debs and have dpkg install them in the correct
order. If you want to be that package manager, feel free. You'll have
to check the dependancies of eacy package you want to install
recursively.

Why not just use aptitude?

Doug.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 05-25-2008, 06:55 PM
Mihira Fernando
 
Default how to upgrade dependency packages

On Sunday 25 May 2008 06:27:27 Douglas A. Tutty wrote:
> On Sat, May 24, 2008 at 03:18:37PM +0530, sathiya moorthy wrote:
> > I downloaded a debian package ( .deb file ), and then i tried installing
> > that using dpkg, and i got the errors like.,
>
> Why?
This could be a third party software they give out only as deb file.

>
> > system has this package with this version, and this package requires
> > updated version
> >
> >
> > Error shown is
> >
> > depends on libasound2 (>> 1.0.16); however:
> > Version of libasound2 on system is 1.0.13-2.
> >
> > What needs to be done ?
>
> dpkg installs individual debs. However, you need some kind of package
> manager to grab the debs and have dpkg install them in the correct
> order. If you want to be that package manager, feel free. You'll have
> to check the dependancies of eacy package you want to install
> recursively.
>
> Why not just use aptitude?
>
> Doug.
Can aptitude be used to install a single deb file from a folder ? if so, whats
the syntax ? also does it automatically check for dependencies ?

Mihira.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 05-25-2008, 07:06 PM
Ron Johnson
 
Default how to upgrade dependency packages

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 05/25/08 13:55, Mihira Fernando wrote:
> On Sunday 25 May 2008 06:27:27 Douglas A. Tutty wrote:
>> On Sat, May 24, 2008 at 03:18:37PM +0530, sathiya moorthy wrote:
>>> I downloaded a debian package ( .deb file ), and then i tried installing
>>> that using dpkg, and i got the errors like.,
>> Why?
> This could be a third party software they give out only as deb file.
>
>>> system has this package with this version, and this package requires
>>> updated version
>>>
>>>
>>> Error shown is
>>>
>>> depends on libasound2 (>> 1.0.16); however:
>>> Version of libasound2 on system is 1.0.13-2.
>>>
>>> What needs to be done ?
>> dpkg installs individual debs. However, you need some kind of package
>> manager to grab the debs and have dpkg install them in the correct
>> order. If you want to be that package manager, feel free. You'll have
>> to check the dependancies of eacy package you want to install
>> recursively.
>>
>> Why not just use aptitude?
>>
>> Doug.
> Can aptitude be used to install a single deb file from a folder ? if so, whats
> the syntax ? also does it automatically check for dependencies ?

No need to use eviltude. Try this:

$ apt-cache policy libasound2

- --
Ron Johnson, Jr.
Jefferson LA USA

ESPN makes baseball players better.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFIObi1S9HxQb37XmcRAraTAKC1uzodEXfEYm+YahNx4l vAw/oimQCggUUm
Axlp+ZEH47fzVqT/cvXYM94=
=XrcA
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 05-25-2008, 08:48 PM
Mihira Fernando
 
Default how to upgrade dependency packages

On Monday 26 May 2008 00:36:29 Ron Johnson wrote:
[snip]
> No need to use eviltude.
^^^^^
>
[snip]
> --
> Ron Johnson, Jr.
> Jefferson LA USA

I thought only M$ was evil. Didn't know that Debian has evil components
too..

Mihira


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 02:39 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org