FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 05-19-2008, 10:16 AM
Brent Clark
 
Default perlmagick woes

HI

I run a very minimalistick debian setup on my machines. One of the
developers requested that I install perlmagick for some graphics
manilpulation etc.


But the problem I have is that on install, the range and the type of
dependancies are ludecris (e.g. iceweasel).


Would anyone have a solution as to how I can get perlmagick installed,
but with out having to install x libs etc,


If anyone could help, it would be most appreciated.

Regards
Brent Clark

P.s. Here is my doings below.

root@fred:/tmp# dpkg -i perlmagick_6.3.7.9.dfsg1-2+b2_amd64.deb
Selecting previously deselected package perlmagick.
(Reading database ... 49624 files and directories currently installed.)
Unpacking perlmagick (from perlmagick_6.3.7.9.dfsg1-2+b2_amd64.deb) ...
dpkg: dependency problems prevent configuration of perlmagick:
perlmagick depends on libmagick10; however:
Package libmagick10 is not installed.
dpkg: error processing perlmagick (--install):
dependency problems - leaving unconfigured
Processing triggers for man-db ...
Errors were encountered while processing:
perlmagick
root@fred:/tmp# apt-get install libmagick10
Reading package lists... Done
Building dependency tree
Reading state information... Done

You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies.
libmagick10: Depends: libcairo2 (>= 1.2.4) but it is not going to be
installed
Depends: libdjvulibre21 (>= 3.5.20) but it is not going
to be installed
Depends: libfontconfig1 (>= 2.4.0) but it is not going to
be installed
Depends: libglib2.0-0 (>= 2.12.0) but it is not going to
be installed
Depends: libgraphviz4 (>= 2.18) but it is not going to be
installed
Depends: libgtk2.0-0 (>= 2.12.0) but it is not going to
be installed

Depends: libilmbase6 but it is not going to be installed
Depends: libopenexr6 (>= 1.6.1) but it is not going to be
installed

Depends: libpixman-1-0 but it is not going to be installed
Depends: librsvg2-2 (>= 2.18.1) but it is not going to be
installed
Depends: libwmf0.2-7 (>= 0.2.8.4) but it is not going to
be installed

Depends: libxrender1 but it is not going to be installed
Recommends: ghostscript but it is not installable
Recommends: gsfonts but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or
specify a solution).

root@fred:/tmp# apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done

Correcting dependencies...Done
The following packages were automatically installed and are no longer
required:

libmagick9 libio-zlib-perl python2.4 python2.4-minimal
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
dictionaries-common djview4 djvulibre-desktop djvulibre-plugin
fontconfig fontconfig-config gsfonts hicolor-icon-theme iceweasel
libatk1.0-0 libatk1.0-data libaudio2 libcairo2 libcroco3 libcupsys2
libdatrie0 libdjvulibre21 libdrm2 libfontconfig1 libfontenc1 libfs6
libgd2-noxpm libgl1-mesa-glx libglib2.0-0 libglib2.0-data libgraphviz4
libgsf-1-114 libgsf-1-common libgtk2.0-0 libgtk2.0-bin
libgtk2.0-common libhunspell-1.2-0 libilmbase6 libmagick10 libmng1
libnspr4-0d libnss3-1d libopenexr6 libpango1.0-0 libpango1.0-common
libpixman-1-0 libqt4-core libqt4-dbus libqt4-designer libqt4-gui
libqt4-network libqt4-qt3support libqt4-script libqt4-sql
libqt4-sql-mysql libqt4-svg libqt4-test libqt4-xml libqtcore4
librsvg2-2 libthai-data libthai0 libwmf0.2-7 libxaw7 libxcomposite1
libxcursor1 libxdamage1 libxfixes3 libxfont1 libxft2 libxi6
libxinerama1 libxmu6 libxp6 libxpm4 libxrandr2 libxrender1 libxslt1.1
libxtrap6 libxtst6 libxv1 libxxf86dga1 libxxf86misc1 libxxf86vm1
myspell-en-us qt4-qtconfig shared-mime-info x-ttcidfont-conf
x11-session-utils x11-utils x11-xfs-utils x11-xserver-utils xdg-utils
xfonts-encodings xfonts-utils xsltproc xutils xutils-dev

Suggested packages:
ispell emacsen-common jed-extra djvulibre-bin iceweasel-gnome-support
latex-xft-fonts xprint mozplugger nas cupsys-common libgd-tools
librsvg2-common libwmf-bin html2ps ttf-kochi-gothic ttf-kochi-mincho
ttf-thryomanes ttf-baekmuk ttf-arphic-gbsn00lp ttf-arphic-bsmi00lp
ttf-arphic-gkai00mp ttf-arphic-bkai00mp libqt4-dev librsvg2-bin
mesa-utils desktop-file-utils libgnome2-0 exo-utils libexo-0.3-0

libgnomevfs2-bin kdelibs4c2a konqueror
Recommended packages:
ghostscript
The following NEW packages will be installed
dictionaries-common djview4 djvulibre-desktop djvulibre-plugin
fontconfig fontconfig-config gsfonts hicolor-icon-theme iceweasel
libatk1.0-0 libatk1.0-data libaudio2 libcairo2 libcroco3 libcupsys2
libdatrie0 libdjvulibre21 libdrm2 libfontconfig1 libfontenc1 libfs6
libgd2-noxpm libgl1-mesa-glx libglib2.0-0 libglib2.0-data libgraphviz4
libgsf-1-114 libgsf-1-common libgtk2.0-0 libgtk2.0-bin
libgtk2.0-common libhunspell-1.2-0 libilmbase6 libmagick10 libmng1
libnspr4-0d libnss3-1d libopenexr6 libpango1.0-0 libpango1.0-common
libpixman-1-0 libqt4-core libqt4-dbus libqt4-designer libqt4-gui
libqt4-network libqt4-qt3support libqt4-script libqt4-sql
libqt4-sql-mysql libqt4-svg libqt4-test libqt4-xml libqtcore4
librsvg2-2 libthai-data libthai0 libwmf0.2-7 libxaw7 libxcomposite1
libxcursor1 libxdamage1 libxfixes3 libxfont1 libxft2 libxi6
libxinerama1 libxmu6 libxp6 libxpm4 libxrandr2 libxrender1 libxslt1.1
libxtrap6 libxtst6 libxv1 libxxf86dga1 libxxf86misc1 libxxf86vm1
myspell-en-us qt4-qtconfig shared-mime-info x-ttcidfont-conf
x11-session-utils x11-utils x11-xfs-utils x11-xserver-utils xdg-utils
xfonts-encodings xfonts-utils xsltproc xutils xutils-dev

0 upgraded, 93 newly installed, 0 to remove and 6 not upgraded.
1 not fully installed or removed.
Need to get 49.0MB of archives.
After this operation, 144MB of additional disk space will be used.
Do you want to continue [Y/n]? n
Abort.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 05-19-2008, 01:22 PM
Robin
 
Default perlmagick woes

2008/5/19 Brent Clark <brentgclarklist@gmail.com>:

HI



I run a very minimalistick debian setup on my machines. One of the developers requested that I install perlmagick for some graphics manilpulation etc.



But the problem I have is that on install, the range and the type of dependancies are ludecris (e.g. iceweasel).



Would anyone have a solution as to how I can get perlmagick installed, but with out having to install x libs etc,



If anyone could help, it would be most appreciated.



Regards

Brent Clark





Install from source?* http://www.imagemagick.org/script/perl-magick.php

--
rob


http://www.worldcommunitygrid.org/team/viewTeamInfo.do?teamId=82BS4ZCMFR1
 
Old 05-19-2008, 02:17 PM
Peter Kuma
 
Default perlmagick woes

Brent Clark wrote:
> HI
>
> I run a very minimalistick debian setup on my machines. One of the
> developers requested that I install perlmagick for some graphics
> manilpulation etc.
>
> But the problem I have is that on install, the range and the type of
> dependancies are ludecris (e.g. iceweasel).
>
> Would anyone have a solution as to how I can get perlmagick installed,
> but with out having to install x libs etc,
>
> If anyone could help, it would be most appreciated.
>
> Regards
> Brent Clark
>
> P.s. Here is my doings below.
>
> root@fred:/tmp# dpkg -i perlmagick_6.3.7.9.dfsg1-2+b2_amd64.deb
> Selecting previously deselected package perlmagick.
> (Reading database ... 49624 files and directories currently installed.)
> Unpacking perlmagick (from perlmagick_6.3.7.9.dfsg1-2+b2_amd64.deb) ...
> dpkg: dependency problems prevent configuration of perlmagick:
> perlmagick depends on libmagick10; however:
> Package libmagick10 is not installed.
> dpkg: error processing perlmagick (--install):
> dependency problems - leaving unconfigured
> Processing triggers for man-db ...
> Errors were encountered while processing:
> perlmagick
> root@fred:/tmp# apt-get install libmagick10
> Reading package lists... Done
> Building dependency tree Reading state information... Done
> You might want to run 'apt-get -f install' to correct these:
> The following packages have unmet dependencies.
> libmagick10: Depends: libcairo2 (>= 1.2.4) but it is not going to be
> installed
> Depends: libdjvulibre21 (>= 3.5.20) but it is not going to
> be installed
> Depends: libfontconfig1 (>= 2.4.0) but it is not going to
> be installed
> Depends: libglib2.0-0 (>= 2.12.0) but it is not going to
> be installed
> Depends: libgraphviz4 (>= 2.18) but it is not going to be
> installed
> Depends: libgtk2.0-0 (>= 2.12.0) but it is not going to be
> installed
> Depends: libilmbase6 but it is not going to be installed
> Depends: libopenexr6 (>= 1.6.1) but it is not going to be
> installed
> Depends: libpixman-1-0 but it is not going to be installed
> Depends: librsvg2-2 (>= 2.18.1) but it is not going to be
> installed
> Depends: libwmf0.2-7 (>= 0.2.8.4) but it is not going to
> be installed
> Depends: libxrender1 but it is not going to be installed
> Recommends: ghostscript but it is not installable
> Recommends: gsfonts but it is not going to be installed
> E: Unmet dependencies. Try 'apt-get -f install' with no packages (or
> specify a solution).
> root@fred:/tmp# apt-get -f install
> Reading package lists... Done
> Building dependency tree Reading state information... Done
> Correcting dependencies...Done
> The following packages were automatically installed and are no longer
> required:
> libmagick9 libio-zlib-perl python2.4 python2.4-minimal
> Use 'apt-get autoremove' to remove them.
> The following extra packages will be installed:
> dictionaries-common djview4 djvulibre-desktop djvulibre-plugin
> fontconfig fontconfig-config gsfonts hicolor-icon-theme iceweasel
> libatk1.0-0 libatk1.0-data libaudio2 libcairo2 libcroco3 libcupsys2
> libdatrie0 libdjvulibre21 libdrm2 libfontconfig1 libfontenc1 libfs6
> libgd2-noxpm libgl1-mesa-glx libglib2.0-0 libglib2.0-data libgraphviz4
> libgsf-1-114 libgsf-1-common libgtk2.0-0 libgtk2.0-bin
> libgtk2.0-common libhunspell-1.2-0 libilmbase6 libmagick10 libmng1
> libnspr4-0d libnss3-1d libopenexr6 libpango1.0-0 libpango1.0-common
> libpixman-1-0 libqt4-core libqt4-dbus libqt4-designer libqt4-gui
> libqt4-network libqt4-qt3support libqt4-script libqt4-sql
> libqt4-sql-mysql libqt4-svg libqt4-test libqt4-xml libqtcore4
> librsvg2-2 libthai-data libthai0 libwmf0.2-7 libxaw7 libxcomposite1
> libxcursor1 libxdamage1 libxfixes3 libxfont1 libxft2 libxi6
> libxinerama1 libxmu6 libxp6 libxpm4 libxrandr2 libxrender1 libxslt1.1
> libxtrap6 libxtst6 libxv1 libxxf86dga1 libxxf86misc1 libxxf86vm1
> myspell-en-us qt4-qtconfig shared-mime-info x-ttcidfont-conf
> x11-session-utils x11-utils x11-xfs-utils x11-xserver-utils xdg-utils
> xfonts-encodings xfonts-utils xsltproc xutils xutils-dev
> Suggested packages:
> ispell emacsen-common jed-extra djvulibre-bin iceweasel-gnome-support
> latex-xft-fonts xprint mozplugger nas cupsys-common libgd-tools
> librsvg2-common libwmf-bin html2ps ttf-kochi-gothic ttf-kochi-mincho
> ttf-thryomanes ttf-baekmuk ttf-arphic-gbsn00lp ttf-arphic-bsmi00lp
> ttf-arphic-gkai00mp ttf-arphic-bkai00mp libqt4-dev librsvg2-bin
> mesa-utils desktop-file-utils libgnome2-0 exo-utils libexo-0.3-0
> libgnomevfs2-bin kdelibs4c2a konqueror
> Recommended packages:
> ghostscript
> The following NEW packages will be installed
> dictionaries-common djview4 djvulibre-desktop djvulibre-plugin
> fontconfig fontconfig-config gsfonts hicolor-icon-theme iceweasel
> libatk1.0-0 libatk1.0-data libaudio2 libcairo2 libcroco3 libcupsys2
> libdatrie0 libdjvulibre21 libdrm2 libfontconfig1 libfontenc1 libfs6
> libgd2-noxpm libgl1-mesa-glx libglib2.0-0 libglib2.0-data libgraphviz4
> libgsf-1-114 libgsf-1-common libgtk2.0-0 libgtk2.0-bin
> libgtk2.0-common libhunspell-1.2-0 libilmbase6 libmagick10 libmng1
> libnspr4-0d libnss3-1d libopenexr6 libpango1.0-0 libpango1.0-common
> libpixman-1-0 libqt4-core libqt4-dbus libqt4-designer libqt4-gui
> libqt4-network libqt4-qt3support libqt4-script libqt4-sql
> libqt4-sql-mysql libqt4-svg libqt4-test libqt4-xml libqtcore4
> librsvg2-2 libthai-data libthai0 libwmf0.2-7 libxaw7 libxcomposite1
> libxcursor1 libxdamage1 libxfixes3 libxfont1 libxft2 libxi6
> libxinerama1 libxmu6 libxp6 libxpm4 libxrandr2 libxrender1 libxslt1.1
> libxtrap6 libxtst6 libxv1 libxxf86dga1 libxxf86misc1 libxxf86vm1
> myspell-en-us qt4-qtconfig shared-mime-info x-ttcidfont-conf
> x11-session-utils x11-utils x11-xfs-utils x11-xserver-utils xdg-utils
> xfonts-encodings xfonts-utils xsltproc xutils xutils-dev
> 0 upgraded, 93 newly installed, 0 to remove and 6 not upgraded.
> 1 not fully installed or removed.
> Need to get 49.0MB of archives.
> After this operation, 144MB of additional disk space will be used.
> Do you want to continue [Y/n]? n
> Abort.
>
>

If you want to install it as a debian package, you can try building from
source as described here:
http://www.debian.org/doc/manuals/apt-howto/ch-sourcehandling.en.html.

You should be able to change some of the dependencies using the
--without-* ./configure flags in debian/rules directory and subsequently
amending the list of dependencies in debian/control and
debian/<subpackage>/debian/control.

debtree is a handy tool for inspecting the dependency tree. It seems to
me that librsvg2-2 and libgraphviz4 generate most additional
dependencies. Also it does not make much sense why libmagick10 depends
on libgtk2.

Peter Kuma


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 05-19-2008, 02:20 PM
"Javier Barroso"
 
Default perlmagick woes

You could probe without Recommends, I don't sure:
aptitude -s -R install perlmagick

On Mon, May 19, 2008 at 12:16 PM, Brent Clark <brentgclarklist@gmail.com> wrote:

HI



I run a very minimalistick debian setup on my machines. One of the developers requested that I install perlmagick for some graphics manilpulation etc.



But the problem I have is that on install, the range and the type of dependancies are ludecris (e.g. iceweasel).



Would anyone have a solution as to how I can get perlmagick installed, but with out having to install x libs etc,



If anyone could help, it would be most appreciated.



Regards

Brent Clark



P.s. Here is my doings below.



root@fred:/tmp# dpkg -i perlmagick_6.3.7.9.dfsg1-2+b2_amd64.deb

Selecting previously deselected package perlmagick.

(Reading database ... 49624 files and directories currently installed.)

Unpacking perlmagick (from perlmagick_6.3.7.9.dfsg1-2+b2_amd64.deb) ...

dpkg: dependency problems prevent configuration of perlmagick:

perlmagick depends on libmagick10; however:

*Package libmagick10 is not installed.

dpkg: error processing perlmagick (--install):

dependency problems - leaving unconfigured

Processing triggers for man-db ...

Errors were encountered while processing:

perlmagick

root@fred:/tmp# apt-get install libmagick10

Reading package lists... Done

Building dependency tree * * * Reading state information... Done

You might want to run 'apt-get -f install' to correct these:

The following packages have unmet dependencies.

*libmagick10: Depends: libcairo2 (>= 1.2.4) but it is not going to be installed

* * * * * * *Depends: libdjvulibre21 (>= 3.5.20) but it is not going to be installed

* * * * * * *Depends: libfontconfig1 (>= 2.4.0) but it is not going to be installed

* * * * * * *Depends: libglib2.0-0 (>= 2.12.0) but it is not going to be installed

* * * * * * *Depends: libgraphviz4 (>= 2.18) but it is not going to be installed

* * * * * * *Depends: libgtk2.0-0 (>= 2.12.0) but it is not going to be installed

* * * * * * *Depends: libilmbase6 but it is not going to be installed

* * * * * * *Depends: libopenexr6 (>= 1.6.1) but it is not going to be installed

* * * * * * *Depends: libpixman-1-0 but it is not going to be installed

* * * * * * *Depends: librsvg2-2 (>= 2.18.1) but it is not going to be installed

* * * * * * *Depends: libwmf0.2-7 (>= 0.2.8.4) but it is not going to be installed

* * * * * * *Depends: libxrender1 but it is not going to be installed

* * * * * * *Recommends: ghostscript but it is not installable

* * * * * * *Recommends: gsfonts but it is not going to be installed

E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

root@fred:/tmp# apt-get -f install

Reading package lists... Done

Building dependency tree * * * Reading state information... Done

Correcting dependencies...Done

The following packages were automatically installed and are no longer required:

*libmagick9 libio-zlib-perl python2.4 python2.4-minimal

Use 'apt-get autoremove' to remove them.

The following extra packages will be installed:

*dictionaries-common djview4 djvulibre-desktop djvulibre-plugin fontconfig fontconfig-config gsfonts hicolor-icon-theme iceweasel

*libatk1.0-0 libatk1.0-data libaudio2 libcairo2 libcroco3 libcupsys2 libdatrie0 libdjvulibre21 libdrm2 libfontconfig1 libfontenc1 libfs6

*libgd2-noxpm libgl1-mesa-glx libglib2.0-0 libglib2.0-data libgraphviz4 libgsf-1-114 libgsf-1-common libgtk2.0-0 libgtk2.0-bin

*libgtk2.0-common libhunspell-1.2-0 libilmbase6 libmagick10 libmng1 libnspr4-0d libnss3-1d libopenexr6 libpango1.0-0 libpango1.0-common

*libpixman-1-0 libqt4-core libqt4-dbus libqt4-designer libqt4-gui libqt4-network libqt4-qt3support libqt4-script libqt4-sql

*libqt4-sql-mysql libqt4-svg libqt4-test libqt4-xml libqtcore4 librsvg2-2 libthai-data libthai0 libwmf0.2-7 libxaw7 libxcomposite1

*libxcursor1 libxdamage1 libxfixes3 libxfont1 libxft2 libxi6 libxinerama1 libxmu6 libxp6 libxpm4 libxrandr2 libxrender1 libxslt1.1

*libxtrap6 libxtst6 libxv1 libxxf86dga1 libxxf86misc1 libxxf86vm1 myspell-en-us qt4-qtconfig shared-mime-info x-ttcidfont-conf

*x11-session-utils x11-utils x11-xfs-utils x11-xserver-utils xdg-utils xfonts-encodings xfonts-utils xsltproc xutils xutils-dev

Suggested packages:

*ispell emacsen-common jed-extra djvulibre-bin iceweasel-gnome-support latex-xft-fonts xprint mozplugger nas cupsys-common libgd-tools

*librsvg2-common libwmf-bin html2ps ttf-kochi-gothic ttf-kochi-mincho ttf-thryomanes ttf-baekmuk ttf-arphic-gbsn00lp ttf-arphic-bsmi00lp

*ttf-arphic-gkai00mp ttf-arphic-bkai00mp libqt4-dev librsvg2-bin mesa-utils desktop-file-utils libgnome2-0 exo-utils libexo-0.3-0

*libgnomevfs2-bin kdelibs4c2a konqueror

Recommended packages:

*ghostscript

The following NEW packages will be installed

*dictionaries-common djview4 djvulibre-desktop djvulibre-plugin fontconfig fontconfig-config gsfonts hicolor-icon-theme iceweasel

*libatk1.0-0 libatk1.0-data libaudio2 libcairo2 libcroco3 libcupsys2 libdatrie0 libdjvulibre21 libdrm2 libfontconfig1 libfontenc1 libfs6

*libgd2-noxpm libgl1-mesa-glx libglib2.0-0 libglib2.0-data libgraphviz4 libgsf-1-114 libgsf-1-common libgtk2.0-0 libgtk2.0-bin

*libgtk2.0-common libhunspell-1.2-0 libilmbase6 libmagick10 libmng1 libnspr4-0d libnss3-1d libopenexr6 libpango1.0-0 libpango1.0-common

*libpixman-1-0 libqt4-core libqt4-dbus libqt4-designer libqt4-gui libqt4-network libqt4-qt3support libqt4-script libqt4-sql

*libqt4-sql-mysql libqt4-svg libqt4-test libqt4-xml libqtcore4 librsvg2-2 libthai-data libthai0 libwmf0.2-7 libxaw7 libxcomposite1

*libxcursor1 libxdamage1 libxfixes3 libxfont1 libxft2 libxi6 libxinerama1 libxmu6 libxp6 libxpm4 libxrandr2 libxrender1 libxslt1.1

*libxtrap6 libxtst6 libxv1 libxxf86dga1 libxxf86misc1 libxxf86vm1 myspell-en-us qt4-qtconfig shared-mime-info x-ttcidfont-conf

*x11-session-utils x11-utils x11-xfs-utils x11-xserver-utils xdg-utils xfonts-encodings xfonts-utils xsltproc xutils xutils-dev

0 upgraded, 93 newly installed, 0 to remove and 6 not upgraded.

1 not fully installed or removed.

Need to get 49.0MB of archives.

After this operation, 144MB of additional disk space will be used.

Do you want to continue [Y/n]? n

Abort.





--

To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 02:48 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org