FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 05-16-2008, 07:51 PM
"Manu Hack"
 
Default apt-get dist-upgrade failure

Hi,

I decided to upgrade my etch box to lenny/sid but an apt-get dist-upgrade got stuck. *Please let me know what could be done here.

Thanks a lot.

Manu



$ sudo apt-get update
Hit http://ftp.debian.org etch Release.gpg
Hit http://ftp.debian.org testing Release.gpg
Hit http://ftp.debian.org etch Release
Hit http://security.debian.org etch/updates Release.gpg
Hit http://ftp.debian.org testing Release
Hit http://security.debian.org etch/updates Release
Ign http://ftp.debian.org etch/main Packages/DiffIndex
Ign http://ftp.debian.org etch/main Sources/DiffIndex
Hit http://ftp.debian.org etch/main Packages
Hit http://ftp.debian.org etch/main Sources
Hit http://ftp.debian.org testing/main Packages/DiffIndex
Hit http://ftp.debian.org testing/contrib Packages/DiffIndex
Hit http://ftp.debian.org testing/non-free Packages/DiffIndex
Ign http://security.debian.org etch/updates/main Packages/DiffIndex
Ign http://security.debian.org etch/updates/main Sources/DiffIndex
Hit http://security.debian.org etch/updates/main Packages
Hit http://security.debian.org etch/updates/main Sources
Reading package lists... Done
$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
libbonobo2-0: Depends: libbonobo2-common (= 2.22.0-1) but 2.14.0-3 is installed
E: Unmet dependencies. Try using -f.
$ sudo apt-get -f dist-upgrade
Reading package lists... Done
Building dependency tree... Done
Correcting dependencies... Done
Calculating upgrade... Done
The following packages will be REMOVED:
libcamel1.2-8 libebook1.2-5 libgssapi2 libnss3-0d libopal-2.2.0 libpci2 libpt-plugins-alsa libpt-plugins-v4l libssp0
The following NEW packages will be installed:
acpi-support-base bsd-mailx eject filters g++-4.2 gcc-4.2 grub-common gs gs-common gs-gpl hal hal-info kdebase-bin-kde3
libavcodec1d libavformat1d libavutil1d libbind9-30 libc-ares1 libcamel1.2-11 libccid libcdio7 libcrypto++7 libcurl3-gnutls
libdevmapper1.02.1 libdirectfb-1.0-0 libdirectfb-extra libdmx1 libdns32 libebml0 libebook1.2-9 libecal1.2-7 libedata-cal1.2-6
libegroupwise1.2-13 libfaad0 libflac8 libfreebob0 libgdata-google1.2-1 libgdata1.2-1 libgif4 libgssglue1 libiec61883-0
libilmbase6 libisc32 libisccc30 libisccfg30 libiso9660-5 libiw29 libjack0 libjasper1 libltdl3 liblwres30 liblzo2-2 libmatroska0
libnetpbm10 libnss3-1d libobparser16 libobrender16 libopal-2.2 libopenexr6 libpam-gnome-keyring libpci3 libpcsclite1
libpostproc1d libpq5 libpt-1.10.10 libpt-1.10.10-plugins-alsa libpt-1.10.10-plugins-v4l librarian0 libsamplerate0 libsmbios-bin
libsmbios1 libsmbiosxml1 libsnack2 libsoup2.4-1 libsox-fmt-alsa libsox-fmt-base libsox0 libspeexdsp1 libsplashy1 libssh2-1
libstdc++6-4.2-dev libts-0.0-0 libx86-1 linux-image-2.6.24-1-686 netcat-traditional netpbm nvclock openssh-blacklist pcscd
pm-utils psfontmgr python-sepolgen tcl8.5 tk8.5 uuid-runtime vim-gnome x11-apps x11-session-utils x11-utils x11-xfs-utils
x11-xkb-utils x11-xserver-utils xauth xinit xorg-docs xserver-xorg-video-intel
The following packages will be upgraded:
acpi acpi-support acpid alsa-base alsa-tools alsa-utils amsn amule amule-common anacron apmd at bc bind9-host bootchart busybox
ca-certificates chameleon-cursor-theme comixcursors console-tools cowsay cpp-4.1 cpufrequtils cron crystalcursors
cyrus-sasl2-doc dc debfoster debian-archive-keyring dhcp3-client dhcp3-common dictionaries-common dmidecode dnsutils
docbook-xml docker dselect ed ekiga evolution-data-server evolution-data-server-common exim4-base exim4-config
exim4-daemon-light exuberant-ctags feh finger g++ g++-4.1 galeon galeon-common gcc gcc-4.1 gcc-4.1-base giblib1 gnome-doc-utils
gnome-keyring gnu-efi gnupg gpgv grub grub-splashimages gsfonts gzip hdparm hibernate hicolor-icon-theme hostname hotkey-setup
iamerican ibritish iceweasel imlib-base imlib11 info initramfs-tools initscripts installation-report iptables iputils-ping
ispell kdebase-bin kdebase-data kdelibs-data kdelibs4c2a kdm klibc-utils klogd laptop-detect less lesstif2 lftp liba52-0.7.4
libaa1 libapm1 libapr1 libarts1c2a libartsc0 libaudio2 libavahi-qt3-1 libblkid1 libbonobo2-common libcaca0 libcdparanoia0
libconsole libcpufreq0 libcucul0 libcurl3 libdb4.2 libdb4.3 libdb4.4 libdc1394-13 libdvbpsi4 libdvdnav4 libdvdread3
libedata-book1.2-2 libedit2 libevent1 libflash-mozplugin libflash0c2 libfontenc1 libfribidi0 libgc1c2 libgcj7-jar libgd2-noxpm
libglibmm-2.4-1c2a libgnome-desktop-2 libgnomecups1.0-1 libgnomeprint2.2-0 libgnomeprint2.2-data libgnomeprintui2.2-0
libgnomeprintui2.2-common libgnutls13 libgpmg1 libgsm1 libgtk2.0-bin libgtop2-common libhtml-tagset-perl libidn11 libimlib2
libjack0.100.0-0 libklibc liblcms1 libldap2 liblircclient0 liblockfile1 liblogfile-rotate-perl liblua50 liblualib50 libmad0
libmodplug0c2 libmpeg2-4 libmysqlclient15off libnfsidmap2 libogg0 libpaper1 libqt3-mt libraw1394-8 librpcsecgss3 librplay3
libruby1.8 libsdl-image1.2 libsdl1.2debian libsdl1.2debian-alsa libsmbclient libsoup2.2-8 libspeex1 libss2 libstdc++6-4.1-dev
libsvga1 libsysfs2 libt1-5 libtar libtasn1-3-bin libtheora0 libtwolame0 libungif4g libuuid1 libvcdinfo0 libvlc0 libvolume-id0
libvorbis0a libvorbisenc2 libvorbisfile3 libwrap0 libwraster3 libxaw7 libxdmcp6 libxfont1 libxkbfile1 libxml2-utils libxmu6
libxmuu1 libxosd2 libxpm4 libxslt1.1 libxss1 libxt6 libxul-common libxul0d libxv1 libxvmc1 libxxf86dga1 links2
linux-headers-2.6.18-6 linux-headers-2.6.18-6-686 linux-image-2.6-686 linux-image-2.6.18-6-686 linux-sound-base
linux-uvc-source login lsof lynx m4 mailx makedev manpages mawk menu menu-xdg mktemp module-assistant module-init-tools motion
mount mpack mpg123 mplayer mplayer-skin-blue mtools mtr-tiny mysql-common nano ncurses-base ncurses-term net-tools netbase
netcat nfs-common ntp ntpdate obconf openbox openbox-themes openbsd-inetd openssh-client openssh-server openssl pciutils
pcmcia-cs pcmciautils pidentd policycoreutils portmap powermgmt-base procps reportbug rxvt screen
selinux-policy-refpolicy-targeted sharutils sox strace sudo sysklogd sysv-rc sysvinit sysvinit-utils tar tasksel tasksel-data
tcl8.4 tcltls tcpd tk8.4 toshset traceroute type-handling udev update-inetd usbutils uswsusp util-linux vbetool vim vim-common
vim-full vim-gui-common vim-runtime vim-tiny vlc vlc-nox w3m wamerican wget whois wireless-tools wmcalclock wmtimer wmweather
wmwork wpasupplicant xbase-clients xfonts-100dpi xfonts-75dpi xfonts-base xfonts-encodings xfonts-utils xkb-data xml-core xorg
xpdf xpdf-common xpdf-reader xpdf-utils xscreensaver xserver-xorg xserver-xorg-core xserver-xorg-input-all
xserver-xorg-input-evdev xserver-xorg-input-kbd xserver-xorg-input-mouse xserver-xorg-input-synaptics xserver-xorg-input-wacom
xserver-xorg-video-all xserver-xorg-video-apm xserver-xorg-video-ark xserver-xorg-video-ati xserver-xorg-video-chips
xserver-xorg-video-cirrus xserver-xorg-video-cyrix xserver-xorg-video-dummy xserver-xorg-video-fbdev xserver-xorg-video-glint
xserver-xorg-video-i128 xserver-xorg-video-i740 xserver-xorg-video-i810 xserver-xorg-video-imstt xserver-xorg-video-mga
xserver-xorg-video-neomagic xserver-xorg-video-newport xserver-xorg-video-nsc xserver-xorg-video-nv
xserver-xorg-video-rendition xserver-xorg-video-s3 xserver-xorg-video-s3virge xserver-xorg-video-savage
xserver-xorg-video-siliconmotion xserver-xorg-video-sis xserver-xorg-video-sisusb xserver-xorg-video-tdfx
xserver-xorg-video-tga xserver-xorg-video-trident xserver-xorg-video-tseng xserver-xorg-video-v4l xserver-xorg-video-vesa
xserver-xorg-video-vga xserver-xorg-video-via xserver-xorg-video-vmware xserver-xorg-video-voodoo xsltproc xterm xutils
xutils-dev yelp
365 upgraded, 106 newly installed, 9 to remove and 0 not upgraded.
198 not fully installed or removed.
Need to get 0B/282MB of archives.
After this operation, 219MB of additional disk space will be used.
Do you want to continue [Y/n]? y
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_ALL to default locale: No such file or directory
Extracting templates from packages: 100%
Preconfiguring packages ...
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
(Reading database ... 64289 files and directories currently installed.)
Preparing to replace libbonobo2-common 2.14.0-3 (using .../libbonobo2-common_2.22.0-1_all.deb) ...
Unpacking replacement libbonobo2-common ...
dpkg: error processing /var/cache/apt/archives/libbonobo2-common_2.22.0-1_all.deb (--unpack):
unable to make backup link of `./usr/share/locale/tr/LC_MESSAGES/libbonobo-2.0.mo' before installing new version: Operation not permitted
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/libbonobo2-common_2.22.0-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
 
Old 05-16-2008, 08:39 PM
Ron Johnson
 
Default apt-get dist-upgrade failure

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 05/16/08 14:51, Manu Hack wrote:
> Hi,
>
> I decided to upgrade my etch box to lenny/sid but an apt-get
> dist-upgrade got stuck. Please let me know what could be done here.
>
> Thanks a lot.

IMO, Etch and Lenny/Testing are far enough apart, that running a
combined Stable/Testing system is bound to cause you troubles. Just
like the ones you just ran into.

Choose Lenny or Etch.

- --
Ron Johnson, Jr.
Jefferson LA USA

ESPN makes baseball players better.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFILfEHS9HxQb37XmcRAgSSAJ4kPBqK/Nbf2ZSXip24AQT0TEk5xgCfYIs9
dSVCp5HMYWmgvnWqymsJWR8=
=XktX
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 05-16-2008, 08:48 PM
Francis Earl
 
Default apt-get dist-upgrade failure

On Friday 16 May 2008 1:39:35 Ron Johnson wrote:
> On 05/16/08 14:51, Manu Hack wrote:
> > Hi,
> >
> > I decided to upgrade my etch box to lenny/sid but an apt-get
> > dist-upgrade got stuck. Please let me know what could be done here.
> >
> > Thanks a lot.

It says to try 'apt-get -f install'. Have you tried that?

> IMO, Etch and Lenny/Testing are far enough apart, that running a
> combined Stable/Testing system is bound to cause you troubles. Just
> like the ones you just ran into.
>
> Choose Lenny or Etch.

He stated he is choosing Lenny... this is a dist-upgrade from etch -> lenny.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 05-16-2008, 08:54 PM
Ron Johnson
 
Default apt-get dist-upgrade failure

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 05/16/08 15:48, Francis Earl wrote:
> On Friday 16 May 2008 1:39:35 Ron Johnson wrote:
[snip]
>>
>> Choose Lenny or Etch.
>
> He stated he is choosing Lenny... this is a dist-upgrade from etch -> lenny.

So it did. I'll go hide in the corner now.

- --
Ron Johnson, Jr.
Jefferson LA USA

ESPN makes baseball players better.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFILfSDS9HxQb37XmcRAo3QAKDa1zKz/bkun6jExFW8TLXUT7e+aQCfeYx4
voA10ygiAyt7xV7BJfAPBJY=
=sQk0
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 05-16-2008, 09:06 PM
Preston Boyington
 
Default apt-get dist-upgrade failure

Manu Hack wrote:

Hi,

I decided to upgrade my etch box to lenny/sid but an apt-get
dist-upgrade got stuck. Please let me know what could be done here.


Thanks a lot.

Manu




i wonder if you could do this:

dpkg -i --force-overwrite
/var/cache/apt/archives/libbonobo2-common_2.22.0-1_all.deb


i've had to use --force-overwrite from time to time...


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 05-16-2008, 10:31 PM
"Manu Hack"
 
Default apt-get dist-upgrade failure

On Fri, May 16, 2008 at 5:06 PM, Preston Boyington <preston.lists@gmail.com> wrote:

Manu Hack wrote:


Hi,



I decided to upgrade my etch box to lenny/sid but an apt-get dist-upgrade got stuck. *Please let me know what could be done here.



Thanks a lot.



Manu








i wonder if you could do this:



dpkg -i --force-overwrite /var/cache/apt/archives/libbonobo2-common_2.22.0-1_all.deb



i've had to use --force-overwrite from time to time...
Forgot to reply all.

Still getting the same error of
dpkg: error processing /var/cache/apt/archives/libbonobo2-common_2.22.0-1_all.deb (--unpack):


unable to make backup link of `./usr/share/locale/tr/LC_MESSAGES/libbonobo-2.0.mo' before installing new version: Operation not permitted
dpkg-deb: subprocess paste killed by signal (Broken pipe)

Got the same error with apt-get -f install

And the file
/usr/share/locale/tr/LC_MESSAGES/libbonobo-2.0.mo

is so weird that even sudo rm* /usr/share/locale/tr/LC_MESSAGES/libbonobo-2.0.mo said I don't have the permission to do so.* (Operation not permitted)

Manu
 
Old 05-17-2008, 01:05 AM
Raj Kiran Grandhi
 
Default apt-get dist-upgrade failure

Manu Hack wrote:



On Fri, May 16, 2008 at 5:06 PM, Preston Boyington
<preston.lists@gmail.com <mailtoreston.lists@gmail.com>> wrote:


Manu Hack wrote:

Hi,

I decided to upgrade my etch box to lenny/sid but an apt-get
dist-upgrade got stuck. Please let me know what could be done here.

Thanks a lot.

Manu



i wonder if you could do this:

dpkg -i --force-overwrite
/var/cache/apt/archives/libbonobo2-common_2.22.0-1_all.deb

i've had to use --force-overwrite from time to time...


Forgot to reply all.

Still getting the same error of

dpkg: error processing /var/cache/apt/archives/libbonobo2-common_2.22.0-1_all.deb (--unpack):


unable to make backup link of `./usr/share/locale/tr/LC_MESSAGES/libbonobo-2.0.mo <http://libbonobo-2.0.mo/>' before installing new version: Operation not permitted
dpkg-deb: subprocess paste killed by signal (Broken pipe)

Got the same error with apt-get -f install

And the file

/usr/share/locale/tr/LC_MESSAGES/libbonobo-2.0.mo

is so weird that even sudo rm
/usr/share/locale/tr/LC_MESSAGES/libbonobo-2.0.mo
said I don't have the permission to do so.
(Operation not permitted)


Please elaborate on what you mean by 'weird'. Is it a symbolic link or a
regular file?


Try becoming root with 'sudo -i' and remove that file. root should be
able to delete any regular file irrespective of whether it is being used
or not. Nobody tells root he can't do something (outside of some special
directories). You should suspect something seriously wrong if your
system behaves otherwise.


For your present problem with locales, install localepurge and get rid
of all the locales that you don't care about.



--
Raj Kiran Grandhi
--
Politics is for the moment. An equation is for eternity.
-- Albert Einstein


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 05-17-2008, 01:17 AM
Mike Bird
 
Default apt-get dist-upgrade failure

On Fri May 16 2008 18:05:57 Raj Kiran Grandhi wrote:
> Manu Hack wrote:
> > is so weird that even sudo rm
> > /usr/share/locale/tr/LC_MESSAGES/libbonobo-2.0.mo
> > said I don't have the permission to do so.
> > (Operation not permitted)
>
> Try becoming root with 'sudo -i' and remove that file. root should be
> able to delete any regular file irrespective of whether it is being used
> or not. Nobody tells root he can't do something (outside of some special
> directories). You should suspect something seriously wrong if your
> system behaves otherwise.

That's not quite true. Attributes such as immutable are
sometimes set by malware or disk errors. OP please show
us the output of the following two commands:

file /usr/share/locale/tr/LC_MESSAGES/libbonobo-2.0.mo
lsattr -d /usr/share/locale/tr/LC_MESSAGES/libbonobo-2.0.mo

--Mike Bird


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 05-23-2008, 08:54 PM
"Manu Hack"
 
Default apt-get dist-upgrade failure

Sorry guys, haven't been able to use that box until now.

On 5/16/08, Mike Bird <mgb-debian@yosemite.net> wrote:
On Fri May 16 2008 18:05:57 Raj Kiran Grandhi wrote:

> Manu Hack wrote:
> > is so weird that even sudo rm
> > /usr/share/locale/tr/LC_MESSAGES/libbonobo-2.0.mo

> > said I don't have the permission to do so.
> > (Operation not permitted)
>

> Try becoming root with 'sudo -i' and remove that file. root should be
> able to delete any regular file irrespective of whether it is being used

> or not. Nobody tells root he can't do something (outside of some special
> directories). You should suspect something seriously wrong if your
> system behaves otherwise.


That's not quite true.**Attributes such as immutable are

sometimes set by malware or disk errors.**OP please show
us the output of the following two commands:


file /usr/share/locale/tr/LC_MESSAGES/libbonobo-2.0.mo

/usr/share/locale/tr/LC_MESSAGES/libbonobo-2.0.mo: GNU message catalog (little endian), revision 0, 106 messages


lsattr -d /usr/share/locale/tr/LC_MESSAGES
suSDiadAc-ZXEj-tT- /usr/share/locale/tr/LC_MESSAGES/libbonobo-2.0.m

What's happening?

Manu
 
Old 05-23-2008, 10:07 PM
Mike Bird
 
Default apt-get dist-upgrade failure

On Fri May 23 2008 13:54:59 Manu Hack wrote:
> > That's not quite true. Attributes such as immutable are
> > sometimes set by malware or disk errors. OP please show
> > us the output of the following two commands:
> >
> > file /usr/share/locale/tr/LC_MESSAGES/libbonobo-2.0.mo
>
> /usr/share/locale/tr/LC_MESSAGES/libbonobo-2.0.mo: GNU message catalog
> (little endian), revision 0, 106 messages
>
> lsattr -d /usr/share/locale/tr/LC_MESSAGES
>
> suSDiadAc-ZXEj-tT- /usr/share/locale/tr/LC_MESSAGES/libbonobo-2.0.m
>
> What's happening?

The file attributes are complete garbage. Probably a minor
hardware glitch. Remove all attributes and try the upgrade
again. Here's the command, and yes the "=" is surrounded
by spaces.

"chattr = /usr/share/locale/tr/LC_MESSAGES/libbonobo-2.0.mo"

--Mike Bird


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 01:12 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org