FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 05-12-2008, 11:06 PM
Sia Neriman
 
Default exim bug

hi
i use lenny and have this error
The following partially installed packages will be configured:
exim4-daemon-light
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Do you want to continue? [Y/n/?] y
Writing extended state information... Done
Setting up exim4-daemon-light (4.69-2+b1) ...
Starting MTA:exim: incompatible command-line options or arguments
invoke-rc.d: initscript exim4, action "start" failed.
dpkg: error processing exim4-daemon-light (--configure):
subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
exim4-daemon-light
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up exim4-daemon-light (4.69-2+b1) ...
Starting MTA:exim: incompatible command-line options or arguments
invoke-rc.d: initscript exim4, action "start" failed.
dpkg: error processing exim4-daemon-light (--configure):
subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
exim4-daemon-light
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Reading task descriptions... Done

how can i fix it?

best regards


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 05-13-2008, 12:56 AM
"Todd A. Jacobs"
 
Default exim bug

On Tue, May 13, 2008 at 01:06:26AM +0200, Sia Neriman wrote:

> how can i fix it?

I had the same problem. Running dpkg-reconfigure didn't help, either, so
I replaced exim with postfix. I did not, however, file a bug...sounds
like someone may need to do that.

--
"Oh, look: rocks!"
-- Doctor Who, "Destiny of the Daleks"


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 05-13-2008, 05:44 AM
Jaime Tarrant
 
Default exim bug

Todd A. Jacobs wrote:

On Tue, May 13, 2008 at 01:06:26AM +0200, Sia Neriman wrote:


how can i fix it?


I had the same problem. Running dpkg-reconfigure didn't help, either, so
I replaced exim with postfix. I did not, however, file a bug...sounds
like someone may need to do that.

I have version 4.69-5+b1 installed and don't have the problem, although
I do recall seeing it recently. It seems the fix is on the way.



--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 05-13-2008, 10:55 AM
Chris Bannister
 
Default exim bug

On Tue, May 13, 2008 at 01:06:26AM +0200, Sia Neriman wrote:
> hi
> i use lenny and have this error
> The following partially installed packages will be configured:
> exim4-daemon-light
> 0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
> Need to get 0B of archives. After unpacking 0B will be used.
> Do you want to continue? [Y/n/?] y
> Writing extended state information... Done
> Setting up exim4-daemon-light (4.69-2+b1) ...
> Starting MTA:exim: incompatible command-line options or arguments
> invoke-rc.d: initscript exim4, action "start" failed.

This has been discussed quite a lot already on this list.
Install apt-listbugs if you are running Lenny or Sid.

> how can i fix it?

You can install exim4-base from Sid.

It is advisable to subscribe to this list *and* read the posts. Problems
like your one are discussed on this list, saving much heartache.

--
Chris.
======
"One, with God, is always a majority, but many a martyr has been burned
at the stake while the votes were being counted." -- Thomas B. Reed


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 05-13-2008, 05:18 PM
Simon Brandmair
 
Default exim bug

On Tue, 13 May 2008 14:30:15 +0200 Chris Bannister wrote:

> On Tue, May 13, 2008 at 01:06:26AM +0200, Sia Neriman wrote:
>> hi
>> i use lenny and have this error
>> The following partially installed packages will be configured:
>> exim4-daemon-light
>> 0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
>> Need to get 0B of archives. After unpacking 0B will be used. Do you
>> want to continue? [Y/n/?] y
>> Writing extended state information... Done Setting up
>> exim4-daemon-light (4.69-2+b1) ... Starting MTA:exim: incompatible
>> command-line options or arguments invoke-rc.d: initscript exim4, action
>> "start" failed.
>
> This has been discussed quite a lot already on this list. Install
> apt-listbugs if you are running Lenny or Sid.
>
> It is advisable to subscribe to this list *and* read the posts. Problems
> like your one are discussed on this list, saving much heartache.

And check the bug reports: http://bugs.debian.org/cgi-bin/bugreport.cgi?
bug=477194

Simon


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 05:11 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org