FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 05-08-2008, 06:23 PM
Nigel Henry
 
Default How to set QTDIR environment variable

I'm trying to build pdfedit, which isn't available for Etch. I've already
dealt with some deps (libboost-dev, libboost-iostreams-dev,
libboost-iostreams1.33.1, and libt1-dev), but ./configure is complaining
about the gui about the QT gui as below.

checking whether we want to build PDFedit gui... yes
configure error: QTDIR environment variable must be set

I'm sure I've dealt with these QT problems before, but could someone refresh
my memory please as to how to set the QTDIR environment variable.

Many thanks for any help.

Nigel.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 05-08-2008, 08:08 PM
Hugo Vanwoerkom
 
Default How to set QTDIR environment variable

Nigel Henry wrote:
I'm trying to build pdfedit, which isn't available for Etch. I've already
dealt with some deps (libboost-dev, libboost-iostreams-dev,
libboost-iostreams1.33.1, and libt1-dev), but ./configure is complaining
about the gui about the QT gui as below.


checking whether we want to build PDFedit gui... yes
configure error: QTDIR environment variable must be set

I'm sure I've dealt with these QT problems before, but could someone refresh
my memory please as to how to set the QTDIR environment variable.


Many thanks for any help.



Normally you set QTDIR to where Qt is.

So incase of qt3:

set QTDIR=/usr/share/qt3

Hugo


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 05-08-2008, 08:57 PM
Nigel Henry
 
Default How to set QTDIR environment variable

On Thursday 08 May 2008 22:08, Hugo Vanwoerkom wrote:
> Nigel Henry wrote:
> > I'm trying to build pdfedit, which isn't available for Etch. I've already
> > dealt with some deps (libboost-dev, libboost-iostreams-dev,
> > libboost-iostreams1.33.1, and libt1-dev), but ./configure is complaining
> > about the gui about the QT gui as below.
> >
> > checking whether we want to build PDFedit gui... yes
> > configure error: QTDIR environment variable must be set
> >
> > I'm sure I've dealt with these QT problems before, but could someone
> > refresh my memory please as to how to set the QTDIR environment variable.
> >
> > Many thanks for any help.
>
> Normally you set QTDIR to where Qt is.
>
> So incase of qt3:
>
> set QTDIR=/usr/share/qt3
>
> Hugo

Thanks for the help Hugo. I Ran ./configure as:
./configure QTDIR=/usr/share/qt3

This got me a bit further, but now ./configure is complaining again. This time
with the following output.

checking whether we want to build PDFedit gui... yes
configure: QMAKESPEC environment variable is not set
- default will be used.
checking for QT qmake... configure: error: unable to find qmake for QT3

I may have to give up on this. I got pdfedit working on an archlinux install,
but when editing a .pdf, it was hitting the redline (99% cpu) , which is why
I wanted to try pdfedit on some other distros. I've also got Lenny available
on the same drive. I'll have a look to see if pdfedit is available there.

Thanks again for your help.

Nigel.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 05-08-2008, 10:42 PM
Hugo Vanwoerkom
 
Default How to set QTDIR environment variable

Nigel Henry wrote:

On Thursday 08 May 2008 22:08, Hugo Vanwoerkom wrote:

Nigel Henry wrote:

I'm trying to build pdfedit, which isn't available for Etch. I've already
dealt with some deps (libboost-dev, libboost-iostreams-dev,
libboost-iostreams1.33.1, and libt1-dev), but ./configure is complaining
about the gui about the QT gui as below.

checking whether we want to build PDFedit gui... yes
configure error: QTDIR environment variable must be set

I'm sure I've dealt with these QT problems before, but could someone
refresh my memory please as to how to set the QTDIR environment variable.

Many thanks for any help.

Normally you set QTDIR to where Qt is.

So incase of qt3:

set QTDIR=/usr/share/qt3

Hugo


Thanks for the help Hugo. I Ran ./configure as:
./configure QTDIR=/usr/share/qt3

This got me a bit further, but now ./configure is complaining again. This time
with the following output.


checking whether we want to build PDFedit gui... yes
configure: QMAKESPEC environment variable is not set
- default will be used.
checking for QT qmake... configure: error: unable to find qmake for QT3

I may have to give up on this. I got pdfedit working on an archlinux install,
but when editing a .pdf, it was hitting the redline (99% cpu) , which is why
I wanted to try pdfedit on some other distros. I've also got Lenny available
on the same drive. I'll have a look to see if pdfedit is available there.




Don't give up.
You just need qmake:

apt-get install qt3-dev-tools

"Qt3 development tools

This package contains all tools that are necessary to build programs
that are written using Qt3. These are: qmake, uic and moc. For Qt3
development, you most likely want to install this package. "


Hugo












--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 05-11-2008, 11:46 AM
Nigel Henry
 
Default How to set QTDIR environment variable

On Friday 09 May 2008 00:42, Hugo Vanwoerkom wrote:
> Nigel Henry wrote:
> > On Thursday 08 May 2008 22:08, Hugo Vanwoerkom wrote:

> >> Normally you set QTDIR to where Qt is.
> >>
> >> So incase of qt3:
> >>
> >> set QTDIR=/usr/share/qt3
> >>
> >> Hugo
> >
> > Thanks for the help Hugo. I Ran ./configure as:
> > ./configure QTDIR=/usr/share/qt3
> >
> > This got me a bit further, but now ./configure is complaining again. This
> > time with the following output.
> >
> > checking whether we want to build PDFedit gui... yes
> > configure: QMAKESPEC environment variable is not set
> > - default will be used.
> > checking for QT qmake... configure: error: unable to find qmake for QT3
> >
> > I may have to give up on this. I got pdfedit working on an archlinux
> > install, but when editing a .pdf, it was hitting the redline (99% cpu) ,
> > which is why I wanted to try pdfedit on some other distros. I've also got
> > Lenny available on the same drive. I'll have a look to see if pdfedit is
> > available there.
>
> Don't give up.
> You just need qmake:
>
> apt-get install qt3-dev-tools
>
> "Qt3 development tools
>
> This package contains all tools that are necessary to build programs
> that are written using Qt3. These are: qmake, uic and moc. For Qt3
> development, you most likely want to install this package. "
>
> Hugo

Hi Hugo. Sorry for the delay in replying. It's been a real bundle of fun
installing this package.

Installing qt3-dev-tools got ./configure to run to completion. Make ran for
ages then stopped, complaining about missing headers (qimage.h, and
qpixmap.h), so I had a look in synaptic, and found libqt3-headers, and
installed the package, then looked in /usr/include, and yes, the qt3 dir was
there, containing all the headers. Run make again. Still complaining about
the same headers as before.

Back in synaptic I had a look at the rest of the qt3 libs. Libqt3-mt-dev
looked a likely candidate, so read the description for it. Aha! It said if
you have compile problems try installing libqt3-compat-headers, which I did,
along with libqt3-mt-dev, just in case that was also needed. Ran make again,
and it ran for a bit (no complaints about header files), but then stopped
again, which by now I'm expecting it to.

Now what's the problem. This is a good one. Make has cd'd to
pdfedit-0.4.1/src/qsa dir, and needs to run ./configure again as there is a
configure2 directory there, and trying to run ./configure again, complains
that QTDIR path is not set, which is obvious, as I ran ./configure as:
./configure QTDIR=/usr/share/qt3, which was a one shot thing.

I usually read the README, and INSTALL files for packages I'm going to build,
but for some unknown reason hadn't done so for pdfedit. Next step, read the
README, as I'm really stuck now. Not many lines down it says set the
environment variable QTDIR as:
export QTDIR=/usr/share/qt3, so from within the pdfedit-0.4.1 dir I do just
that, then just for fun run ./configure, which now doesn't complain about
QTDIR.

So far so good, so lets give make another go, which promptly picks up where it
left off, with no complaints, and runs ./configure again for configure2. Make
appears to be happy now, and is compiling away like a mad thing, but it's
going on for ages, so I cycle down to town to pick up a few beers.

How long make was running for I don't know, but I was out for about an hour,
and when I got back it had run to completion. Su to root, make install, job
done, as long as the program works, which it does.

Of course the whole object of building it from source on Etch, was because of
the seeming problem with pdfedit that I saw with the version I'd installed on
Archlinux, which was from their repo's. Annoyingly the same problem exists,
if it is a problem, when adding text to a pdf form, on Etch (same machine
1.3Ghz).

The problem, for what it's worth, is that I have a form that requires 14
entries. The first bit of text entered causes CPU to hit 99%, but only for a
few seconds before the text shows up on the form, the next bit of text
entered takes longer before it shows up on the form, and subsequent text
entries take longer and longer, with the last one (which was only the
number"8") taking 2mins 20secs, before the "8" was added to the form.

I think this is a case, where it would have been quicker to get the IBM
golfball out of storage, type out the form, and put it back into storage.

Anyway, as usual I've learned a bit more. Using cups-pdf to save the HTML form
as a .pdf. The "fun" building an app that uses qt for the GUI, and using
pdfedit (as slow as it is) to fill in the form. Last thing is to write down
the packages needed to build qt based apps, not forgetting the command to set
the environment variable QTDIR.

Sorry if this has rambled on a bit.

Thanks for your help.

Nigel.



--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 03:56 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org