FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 05-05-2008, 06:04 PM
"Miguel Gaiowski"
 
Default Issue with VMware

Hey all,

So I installed VMware server, had to use the any-any update for I use the 2.6.24 kernel and
when I try to run it, it says that same message as before running the vmware-conifig.pl tool.

I also tried VMware Workstation trial, and that didn't work either.


I tried running vmware-config.pl after running the any-any update several
times, and I get the same message.

Does anyone know what might be the problem?

Thanks in advance

[]s

--
Miguel Fco. A. de Mattos Gaiowski
 
Old 05-05-2008, 06:34 PM
"Mirco Piccin"
 
Default Issue with VMware

Hi

> So I installed VMware server, had to use the any-any update for I use the
> 2.6.24 kernel and
> when I try to run it, it says that same message as before running the
> vmware-conifig.pl tool.

I'm running about the same kernel (2.6.24-1-686).
I'm running also VMWare server rel. 1.0.5 (latest).
First i install VMWare Server with its installer (vmware-install.pl)
and then, when the installer fails creating modules, i use the
runme.pl included in vmware-any-any-update package (rel 116).

> I also tried VMware Workstation trial, and that didn't work either.
>
> I tried running vmware-config.pl after running the any-any update several
> times, and I get the same message.

Maybe posting error will help us.

Anyway, if you update often your system (as me), the problem you
encountered could be related to the current gcc version (different
from the one used to compile the kernel).
If so, you can recreate the link of /usr/bin/gcc to point to the right
gcc version, for example:

# ls -l /usr/bin/gcc*
lrwxrwxrwx 1 root root 7 2008-04-09 21:27 /usr/bin/gcc -> gcc-4.1
-rwxr-xr-x 1 root root 82064 2008-03-29 18:16 /usr/bin/gcc-3.4
-rwxr-xr-x 1 root root 195844 2008-03-10 00:10 /usr/bin/gcc-4.1
-rwxr-xr-x 1 root root 192252 2008-03-24 01:09 /usr/bin/gcc-4.2
-rwxr-xr-x 1 root root 207008 2008-04-02 05:04 /usr/bin/gcc-4.3

# rm /usr/bin/gcc
# ln -s /usr/bin/gcc-4.2 /usr/bin/gcc

(of course gcc version may be different).

...and the retry with the installer or with the any-any-update.
Or, better, you can force the use of a specific GCC version, but i
don't remember how do that in this case.

Hope it helps you.
Regards
M


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 05-05-2008, 08:20 PM
"Miguel Gaiowski"
 
Default Issue with VMware

On Mon, May 5, 2008 at 3:34 PM, Mirco Piccin <pictux@gmail.com> wrote:

Hi



> So I installed VMware server, had to use the any-any update for I use the

> 2.6.24 kernel and

> when I try to run it, it says that same message as before running the

> vmware-conifig.pl tool.



I'm running about the same kernel (2.6.24-1-686).
Same here.
*


I'm running also VMWare server rel. 1.0.5 (latest).
Again, same thing.
*



First i install VMWare Server with its installer (vmware-install.pl)

and then, when the installer fails creating modules, i use the

runme.pl included in vmware-any-any-update package (rel 116).


That's what I did.
*


> I also tried VMware Workstation trial, and that didn't work either.

>

> I tried running vmware-config.pl after running the any-any update several

> times, and I get the same message.



Maybe posting error will help us.


$ vmware
vmware is installed, but it has not been (correctly) configured
for this system. To (re-)configure it, invoke the following command:
/usr/bin/vmware-config.pl.
*


Anyway, if you update often your system (as me), the problem you

encountered could be related to the current gcc version (different

from the one used to compile the kernel).

If so, you can recreate the link of /usr/bin/gcc to point to the right

gcc version, for example:



# ls -l /usr/bin/gcc*

lrwxrwxrwx 1 root root * * *7 2008-04-09 21:27 /usr/bin/gcc -> gcc-4.1

-rwxr-xr-x 1 root root *82064 2008-03-29 18:16 /usr/bin/gcc-3.4

-rwxr-xr-x 1 root root 195844 2008-03-10 00:10 /usr/bin/gcc-4.1

-rwxr-xr-x 1 root root 192252 2008-03-24 01:09 /usr/bin/gcc-4.2

-rwxr-xr-x 1 root root 207008 2008-04-02 05:04 /usr/bin/gcc-4.3



# rm /usr/bin/gcc

# ln -s /usr/bin/gcc-4.2 /usr/bin/gcc



(of course gcc version may be different).



...and the retry with the installer or with the any-any-update.

Or, better, you can force the use of a specific GCC version, but i

don't remember how do that in this case.


This is what I did:

$: CC=gcc-4.1 ./runme.pl
*
This way it forces the compiler to be gcc-4.1





Hope it helps you.

Regards

M


Thanks for your help anyway.
*




--

To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org

with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org





--
Miguel Fco. A. de Mattos Gaiowski
 

Thread Tools




All times are GMT. The time now is 03:43 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org