FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 04-24-2008, 06:06 AM
andy
 
Default Unmet dependencies Xfce4

Hello

Can someone please advise on the best way to handle the following
situation of unmet dependencies:


$ sudo apt-get install xfce4-systemload-plugin xfce4-goodies
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
xfce4-systemload-plugin: Depends: libxfce4util-1 (>= 4.2.1-1) but it
is not going to be installed
Depends: libxfcegui4-3 (>= 4.2.1-1) but it is
not going to be installed

E: Broken packages


This is on a Lenny machine.

Many thanks

Andy


--

"If they can get you asking the wrong questions, they don't have to worry about the answers." - Thomas Pynchon, "Gravity's Rainbow"


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 04-24-2008, 06:21 AM
Sven Joachim
 
Default Unmet dependencies Xfce4

On 2008-04-24 08:06 +0200, andy wrote:

> Can someone please advise on the best way to handle the following
> situation of unmet dependencies:
>
> $ sudo apt-get install xfce4-systemload-plugin xfce4-goodies
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies.
> xfce4-systemload-plugin: Depends: libxfce4util-1 (>= 4.2.1-1) but it
> is not going to be installed
> Depends: libxfcegui4-3 (>= 4.2.1-1) but it
> is not going to be installed
> E: Broken packages
>
>
> This is on a Lenny machine.

I haven't investigated the situation, but in general it is better to use
aptitude rather then apt-get if you encounter such problems, because
aptitude is much more verbose about unmet dependencies and can try to
resolve them interactively.

Looking at packages.debian.org, xfce4-systemload-plugin depends on
libxfce4util4 (>= 4.4.1) and libxfcegui4-4 (>= 4.4.1) and has not been
upgraded since June 2007, so you probably have put some package on hold
or something like that.

Sven


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 04-24-2008, 04:13 PM
andy
 
Default Unmet dependencies Xfce4

Sven Joachim wrote:

On 2008-04-24 08:06 +0200, andy wrote:



Can someone please advise on the best way to handle the following
situation of unmet dependencies:

$ sudo apt-get install xfce4-systemload-plugin xfce4-goodies
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
xfce4-systemload-plugin: Depends: libxfce4util-1 (>= 4.2.1-1) but it
is not going to be installed
Depends: libxfcegui4-3 (>= 4.2.1-1) but it
is not going to be installed
E: Broken packages


This is on a Lenny machine.



I haven't investigated the situation, but in general it is better to use
aptitude rather then apt-get if you encounter such problems, because
aptitude is much more verbose about unmet dependencies and can try to
resolve them interactively.

Looking at packages.debian.org, xfce4-systemload-plugin depends on
libxfce4util4 (>= 4.4.1) and libxfcegui4-4 (>= 4.4.1) and has not been
upgraded since June 2007, so you probably have put some package on hold
or something like that.

Sven



As I only use apt-get, I don't see how I could have put a package on
hold. Also, I was under the impression that one should not mix apt-get
and other package retrieval systems for the reasons that these unmet
dependencies seem to suggest.


So, might I merely go ahead and manually install these two missing
libraries or is that likely to result in Xfce4 melt-down?


Cheers

Andy

--

"If they can get you asking the wrong questions, they don't have to worry about the answers." - Thomas Pynchon, "Gravity's Rainbow"


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 04-26-2008, 01:21 AM
Daniel Burrows
 
Default Unmet dependencies Xfce4

On Thu, Apr 24, 2008 at 07:06:15AM +0100, andy <geek_show@dsl.pipex.com> was heard to say:
> Can someone please advise on the best way to handle the following
> situation of unmet dependencies:
>
> $ sudo apt-get install xfce4-systemload-plugin xfce4-goodies
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies.
> xfce4-systemload-plugin: Depends: libxfce4util-1 (>= 4.2.1-1) but it is
> not going to be installed
> Depends: libxfcegui4-3 (>= 4.2.1-1) but it is
> not going to be installed
> E: Broken packages

Have you tried resolving these explicitly?

apt-get install xfce4-systemload-plugin xfce4-goodies
libxfce4util-1 libxfcegui4-3

Did you check what version of each package is available and that the
versions satisfy the dependencies? e.g., using something like this:

apt-cache madison xfce4-systemload-plugin xfce4-goodies

Daniel


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 04-26-2008, 08:59 AM
andy
 
Default Unmet dependencies Xfce4

Daniel Burrows wrote:

On Thu, Apr 24, 2008 at 07:06:15AM +0100, andy <geek_show@dsl.pipex.com> was heard to say:

Can someone please advise on the best way to handle the following
situation of unmet dependencies:


$ sudo apt-get install xfce4-systemload-plugin xfce4-goodies
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
xfce4-systemload-plugin: Depends: libxfce4util-1 (>= 4.2.1-1) but it is
not going to be installed
Depends: libxfcegui4-3 (>= 4.2.1-1) but it is
not going to be installed

E: Broken packages



Have you tried resolving these explicitly?

apt-get install xfce4-systemload-plugin xfce4-goodies

libxfce4util-1 libxfcegui4-3

Did you check what version of each package is available and that the
versions satisfy the dependencies? e.g., using something like this:

apt-cache madison xfce4-systemload-plugin xfce4-goodies

Daniel




Daniel

I followed your suggestions. This is the output for running aptitude
install xfce4-goodies:


$ sudo aptitude install xfce4-goodies
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Reading task descriptions... Done
The following packages are BROKEN:
libxfce4util4 libxfcegui4-4
The following NEW packages will be installed:
hddtemp{a} libsensors4{a} libxfce4util-1{a} libxfcegui4-3{a}
lm-sensors{a} mousepad{a} thunar-media-tags-plugin{a} xfce4-artwork{a}
xfce4-battery-plugin{a} xfce4-clipman-plugin{a} xfce4-cpufreq-plugin{a}
xfce4-cpugraph-plugin{a} xfce4-diskperf-plugin{a} xfce4-fsguard-plugin{a}
xfce4-genmon-plugin{a} xfce4-goodies xfce4-mailwatch-plugin{a}
xfce4-minicmd-plugin{a} xfce4-mount-plugin{a} xfce4-netload-plugin{a}
xfce4-notes-plugin{a} xfce4-quicklauncher-plugin{a}
xfce4-screenshooter-plugin{a} xfce4-sensors-plugin{a}
xfce4-smartbookmark-plugin{a} xfce4-systemload-plugin{a}
xfce4-verve-plugin{a} xfce4-wavelan-plugin{a} xfce4-weather-plugin{a}
0 packages upgraded, 29 newly installed, 0 to remove and 2 not upgraded.
Need to get 4046kB of archives. After unpacking 10.2MB will be used.
The following packages have unmet dependencies:
libxfcegui4-4: Conflicts: libxfcegui4-3 but 4.2.2-1 is to be installed.
libxfce4util4: Conflicts: libxfce4util-1 but 4.2.2-1 is to be installed.
Resolving dependencies...
The following actions will resolve these dependencies:

Install the following packages:
xfce4-systemload-plugin [0.4.2-1 (testing, testing)]

Keep the following packages at their current version:
libxfce4util-1 [Not Installed]
libxfcegui4-3 [Not Installed]

Score is 38


I've searched all over the place, but cannot find any reference to how I
should interpret a score of 38. But given that there are still unmet
dependencies and package conflicts, I am a little gun-shy to proceed
without understanding more fully what will be the likely outcome, or a
more sane workaround.


Any thoughts?

Cheers

Andy

--

"If they can get you asking the wrong questions, they don't have to worry about the answers." - Thomas Pynchon, "Gravity's Rainbow"


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 04-26-2008, 06:12 PM
Daniel Burrows
 
Default Unmet dependencies Xfce4

On Sat, Apr 26, 2008 at 09:59:09AM +0100, andy <geek_show@dsl.pipex.com> was heard to say:
> I followed your suggestions. This is the output for running aptitude
> install xfce4-goodies:
>
> $ sudo aptitude install xfce4-goodies
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Reading extended state information
> Initializing package states... Done
> Reading task descriptions... Done
> The following packages are BROKEN:
> libxfce4util4 libxfcegui4-4
> The following NEW packages will be installed:
> hddtemp{a} libsensors4{a} libxfce4util-1{a} libxfcegui4-3{a}
> lm-sensors{a} mousepad{a} thunar-media-tags-plugin{a} xfce4-artwork{a}
> xfce4-battery-plugin{a} xfce4-clipman-plugin{a} xfce4-cpufreq-plugin{a}
> xfce4-cpugraph-plugin{a} xfce4-diskperf-plugin{a} xfce4-fsguard-plugin{a}
> xfce4-genmon-plugin{a} xfce4-goodies xfce4-mailwatch-plugin{a}
> xfce4-minicmd-plugin{a} xfce4-mount-plugin{a} xfce4-netload-plugin{a}
> xfce4-notes-plugin{a} xfce4-quicklauncher-plugin{a}
> xfce4-screenshooter-plugin{a} xfce4-sensors-plugin{a}
> xfce4-smartbookmark-plugin{a} xfce4-systemload-plugin{a}
> xfce4-verve-plugin{a} xfce4-wavelan-plugin{a} xfce4-weather-plugin{a}
> 0 packages upgraded, 29 newly installed, 0 to remove and 2 not upgraded.
> Need to get 4046kB of archives. After unpacking 10.2MB will be used.
> The following packages have unmet dependencies:
> libxfcegui4-4: Conflicts: libxfcegui4-3 but 4.2.2-1 is to be installed.
> libxfce4util4: Conflicts: libxfce4util-1 but 4.2.2-1 is to be installed.

That says it wants to install libxfce4-3 and libxfce4util-1, but they
conflict with packages that are already on your system.

> Resolving dependencies...
> The following actions will resolve these dependencies:
>
> Install the following packages:
> xfce4-systemload-plugin [0.4.2-1 (testing, testing)]
>
> Keep the following packages at their current version:
> libxfce4util-1 [Not Installed]
> libxfcegui4-3 [Not Installed]

This says that all the broken dependencies can be resolved by
installing xfce4-systemload-plugin and by not installing
libxfce4util-1 or libxfcegui4-3. You can enter "o" at the prompt
to get a more detailed breakdown of the reasons behind each choice
aptitude made.

I'm not sure why it's showing "install xfce4-systemload-plugin"
as a choice: it looks to me like that's already being installed!
If you can add

-o Aptitude::ProblemResolver::Trace-File=/tmp/some-file-or-other

to the command line and send me the file it writes out, I'd be curious
to see what's happening. (aptitude-create-state-bundle would also be
interesting, but it produces a much bigger file that's harder to email)

> Score is 38

This is a blinkenlights feature, mostly. Scores are relevant in that
aptitude makes an effort to present high-scored solutions first, and the
scores are set so that "reasonable" solutions hopefully float to the
top. But absolute scores don't have any real meaning; what matters when
the resolver is running is the relative scores of packages.

If you just press "enter" or enter "y" at the prompt, aptitude will
apply its solution to the current state and give you another prompt
showing what will really be installed or removed.

Daniel


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 04-26-2008, 08:59 PM
andy
 
Default Unmet dependencies Xfce4

Daniel Burrows wrote:

On Sat, Apr 26, 2008 at 09:59:09AM +0100, andy <geek_show@dsl.pipex.com> was heard to say:

I followed your suggestions. This is the output for running aptitude
install xfce4-goodies:


$ sudo aptitude install xfce4-goodies
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Reading task descriptions... Done
The following packages are BROKEN:
libxfce4util4 libxfcegui4-4
The following NEW packages will be installed:
hddtemp{a} libsensors4{a} libxfce4util-1{a} libxfcegui4-3{a}
lm-sensors{a} mousepad{a} thunar-media-tags-plugin{a} xfce4-artwork{a}
xfce4-battery-plugin{a} xfce4-clipman-plugin{a} xfce4-cpufreq-plugin{a}
xfce4-cpugraph-plugin{a} xfce4-diskperf-plugin{a} xfce4-fsguard-plugin{a}
xfce4-genmon-plugin{a} xfce4-goodies xfce4-mailwatch-plugin{a}
xfce4-minicmd-plugin{a} xfce4-mount-plugin{a} xfce4-netload-plugin{a}
xfce4-notes-plugin{a} xfce4-quicklauncher-plugin{a}
xfce4-screenshooter-plugin{a} xfce4-sensors-plugin{a}
xfce4-smartbookmark-plugin{a} xfce4-systemload-plugin{a}
xfce4-verve-plugin{a} xfce4-wavelan-plugin{a} xfce4-weather-plugin{a}
0 packages upgraded, 29 newly installed, 0 to remove and 2 not upgraded.
Need to get 4046kB of archives. After unpacking 10.2MB will be used.
The following packages have unmet dependencies:
libxfcegui4-4: Conflicts: libxfcegui4-3 but 4.2.2-1 is to be installed.
libxfce4util4: Conflicts: libxfce4util-1 but 4.2.2-1 is to be installed.



That says it wants to install libxfce4-3 and libxfce4util-1, but they
conflict with packages that are already on your system.



Resolving dependencies...
The following actions will resolve these dependencies:

Install the following packages:
xfce4-systemload-plugin [0.4.2-1 (testing, testing)]

Keep the following packages at their current version:
libxfce4util-1 [Not Installed]
libxfcegui4-3 [Not Installed]



This says that all the broken dependencies can be resolved by
installing xfce4-systemload-plugin and by not installing
libxfce4util-1 or libxfcegui4-3. You can enter "o" at the prompt
to get a more detailed breakdown of the reasons behind each choice
aptitude made.

I'm not sure why it's showing "install xfce4-systemload-plugin"
as a choice: it looks to me like that's already being installed!
If you can add

-o Aptitude::ProblemResolver::Trace-File=/tmp/some-file-or-other

to the command line and send me the file it writes out, I'd be curious
to see what's happening. (aptitude-create-state-bundle would also be
interesting, but it produces a much bigger file that's harder to email)



Score is 38



This is a blinkenlights feature, mostly. Scores are relevant in that
aptitude makes an effort to present high-scored solutions first, and the
scores are set so that "reasonable" solutions hopefully float to the
top. But absolute scores don't have any real meaning; what matters when
the resolver is running is the relative scores of packages.

If you just press "enter" or enter "y" at the prompt, aptitude will
apply its solution to the current state and give you another prompt
showing what will really be installed or removed.

Daniel



Thanks Daniel As it so happens U removed all of the xfce4 libraries and then reinstalled from scratch using aptitude and specifying the libraries and packages required from scratch. This seemed to work pretty well really.


So, am pleased to report that I am using Xfce4 whilst typing this, listening to Comus in Rhythmbox, and enjoying the various benefits of xfce4-goodies.

Thank you aptitude

Andy



--

"If they can get you asking the wrong questions, they don't have to worry about the answers." - Thomas Pynchon, "Gravity's Rainbow"


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 03:22 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org