Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian User (http://www.linux-archive.org/debian-user/)
-   -   badblock can not be detected (http://www.linux-archive.org/debian-user/72874-badblock-can-not-detected.html)

04-20-2008 02:21 AM

badblock can not be detected
 
Hi,

I have an hard drive that connects to my laptop through the USB 2.0 interface.it was bought at 2006. some months before, it started to report error on read. I reformatted it use the

mkfs.ext3 -c /dev/sda1

But it didn't detected any badblock.
then I copied some files to it, then read out, it shown the error:

usb 5-4.3: reset high speed USB device using ehci_hcd and address 5
sd 0:0:0:0: [sda] Result: hostbyte=0x07 driverbyte=0x00
end_request: I/O error, dev sda, sector 214814735
usb 5-4.3: reset high speed USB device using ehci_hcd and address 5

I think that's because there are some badblocks on the disk, so I ran

fsck.ext3 -c /dev/sda1

but this time it still didn't find out any badblock.

any idea about it? thanks.


__________________________________________________ ________
Sent from Yahoo! Mail.
A Smarter Email http://uk.docs.yahoo.com/nowyoucan.html

"Adrian Levi" 04-20-2008 06:21 AM

badblock can not be detected
 
On 20/04/2008, gdstm-lnxmlsts@yahoo.com <gdstm-lnxmlsts@yahoo.com> wrote:
> Hi,
>
> I have an hard drive that connects to my laptop through the USB 2.0 interface.it was bought at 2006. some months before, it started to report error on read. I reformatted it use the
>
> mkfs.ext3 -c /dev/sda1
>
> But it didn't detected any badblock.
> then I copied some files to it, then read out, it shown the error:
>
> usb 5-4.3: reset high speed USB device using ehci_hcd and address 5
> sd 0:0:0:0: [sda] Result: hostbyte=0x07 driverbyte=0x00
> end_request: I/O error, dev sda, sector 214814735
> usb 5-4.3: reset high speed USB device using ehci_hcd and address 5
>
> I think that's because there are some badblocks on the disk, so I ran
>
> fsck.ext3 -c /dev/sda1
>
> but this time it still didn't find out any badblock.
>
> any idea about it? thanks.

The error could also be due to faulty hardware.

Adrian

--
24x7x365 != 24x7x52 Stupid or bad maths?
<erno> hm. I've lost a machine.. literally _lost_. it responds to
ping, it works completely, I just can't figure out where in my
apartment it is.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

04-21-2008 06:23 PM

badblock can not be detected
 
Thanks. maybe you are right. when I tried to use different usb to ide adapter to connect the hard drive, things became different. but there still has some errors when reading or writing.

--- On Sun, 20/4/08, Adrian Levi <adrian.levi@gmail.com> wrote:

> From: Adrian Levi <adrian.levi@gmail.com>
> Subject: Re: badblock can not be detected
> To: debian-user@lists.debian.org
> Date: Sunday, 20 April, 2008, 7:21 AM
> On 20/04/2008, gdstm-lnxmlsts@yahoo.com
> <gdstm-lnxmlsts@yahoo.com> wrote:
> > Hi,
> >
> > I have an hard drive that connects to my laptop
> through the USB 2.0 interface.it was bought at 2006. some
> months before, it started to report error on read. I
> reformatted it use the
> >
> > mkfs.ext3 -c /dev/sda1
> >
> > But it didn't detected any badblock.
> > then I copied some files to it, then read out, it
> shown the error:
> >
> > usb 5-4.3: reset high speed USB device using ehci_hcd
> and address 5
> > sd 0:0:0:0: [sda] Result: hostbyte=0x07
> driverbyte=0x00
> > end_request: I/O error, dev sda, sector 214814735
> > usb 5-4.3: reset high speed USB device using ehci_hcd
> and address 5
> >
> > I think that's because there are some badblocks
> on the disk, so I ran
> >
> > fsck.ext3 -c /dev/sda1
> >
> > but this time it still didn't find out any
> badblock.
> >
> > any idea about it? thanks.
>
> The error could also be due to faulty hardware.
>
> Adrian
>
> --
> 24x7x365 != 24x7x52 Stupid or bad maths?
> <erno> hm. I've lost a machine.. literally
> _lost_. it responds to
> ping, it works completely, I just can't figure out
> where in my
> apartment it is.
>
>
> --
> To UNSUBSCRIBE, email to
> debian-user-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact
> listmaster@lists.debian.org


__________________________________________________ ________
Sent from Yahoo! Mail.
A Smarter Email http://uk.docs.yahoo.com/nowyoucan.html

Brian McKee 04-21-2008 06:53 PM

badblock can not be detected
 
On 21-Apr-08, at 2:23 PM, gdstm-lnxmlsts@yahoo.com wrote:

Thanks. maybe you are right. when I tried to use different usb to
ide adapter to connect the hard drive, things became different. but
there still has some errors when reading or writing.




Note that modern hard drives remap bad sectors when they can. Your
reformatting might be reassigning a bunch of bad blocks, then it's
finding more when it tries to read the next time....


Brian

04-21-2008 09:20 PM

badblock can not be detected
 
Oh dear, that's quite a bad news.
that's what I have encountered. when I heard the noise of hard drive reset, and checked the dmesg to make sure about it, I reformatted the hard drive, then copy my data in again, it worked. but after some days, it starts to tell me about read error again.
so, this means the hard drive has died, right?



--- On Mon, 21/4/08, Brian McKee <map@map-heb.com> wrote:

> From: Brian McKee <map@map-heb.com>
> Subject: Re: badblock can not be detected
> To: gdstm-lnxmlsts@yahoo.com
> Cc: debian-user@lists.debian.org
> Date: Monday, 21 April, 2008, 7:53 PM
> On 21-Apr-08, at 2:23 PM, gdstm-lnxmlsts@yahoo.com wrote:
>
> > Thanks. maybe you are right. when I tried to use
> different usb to
> > ide adapter to connect the hard drive, things became
> different. but
> > there still has some errors when reading or writing.
> >
>
> Note that modern hard drives remap bad sectors when they
> can. Your
> reformatting might be reassigning a bunch of bad blocks,
> then it's
> finding more when it tries to read the next time....
>
> Brian


__________________________________________________ ________
Sent from Yahoo! Mail.
A Smarter Email http://uk.docs.yahoo.com/nowyoucan.html

"Adrian Levi" 04-22-2008 10:06 AM

badblock can not be detected
 
On 22/04/2008, gdstm-lnxmlsts@yahoo.com <gdstm-lnxmlsts@yahoo.com> wrote:
> Oh dear, that's quite a bad news.
> that's what I have encountered. when I heard the noise of hard drive reset, and checked the dmesg to make sure about it, I reformatted the hard drive, then copy my data in again, it worked. but after some days, it starts to tell me about read error again.
> so, this means the hard drive has died, right?

Install smartmontools and interrogate the smart data on the drive, if
it reports a reallocated sector count and it keeps growing you know
your drive is on it's way out. A static reallocated sector count
doesn't necessarily mean your drive is bad but if that count keeps
growing it's not a good sign.

Adrian

--
24x7x365 != 24x7x52 Stupid or bad maths?
<erno> hm. I've lost a machine.. literally _lost_. it responds to
ping, it works completely, I just can't figure out where in my
apartment it is.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Brian McKee 04-22-2008 02:36 PM

badblock can not be detected
 
On 22-Apr-08, at 6:06 AM, Adrian Levi wrote:

On 22/04/2008, gdstm-lnxmlsts@yahoo.com <gdstm-lnxmlsts@yahoo.com>
wrote:

Oh dear, that's quite a bad news.
that's what I have encountered. when I heard the noise of hard
drive reset, and checked the dmesg to make sure about it, I
reformatted the hard drive, then copy my data in again, it worked.
but after some days, it starts to tell me about read error again.

so, this means the hard drive has died, right?


Install smartmontools and interrogate the smart data on the drive, if
it reports a reallocated sector count and it keeps growing you know
your drive is on it's way out. A static reallocated sector count
doesn't necessarily mean your drive is bad but if that count keeps
growing it's not a good sign.


Note that I don't believe smartmontools will work thru the USB
interface - you'll have to use the native SATA or ATA interface (e.g.
install it in a tower)


Brian

"Douglas A. Tutty" 04-29-2008 05:51 PM

badblock can not be detected
 
On Mon, Apr 21, 2008 at 02:20:48PM -0700, gdstm-lnxmlsts@yahoo.com wrote:
> Oh dear, that's quite a bad news.
> that's what I have encountered. when I heard the noise of hard drive reset, and checked the dmesg to make sure about it, I reformatted the hard drive, then copy my data in again, it worked. but after some days, it starts to tell me about read error again.
> so, this means the hard drive has died, right?
>

Assuming an ext2/3 fs, try e2fsck -c -c (the second c does a
non-destructive read-write test of the filesystem).

Doug.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org


All times are GMT. The time now is 05:24 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.