FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 04-17-2008, 04:49 PM
Frank
 
Default CD burning stopped working

On Thu, 17 Apr 2008 11:17:11 -0500
"Mumia W.." <paduille.4061.mumia.w+nospam@earthlink.net> wrote:

> On 04/17/2008 10:33 AM, Frank wrote:
> >
> > Running Sid/Lenny -- after recent updates, CD burning on my machine has
> > stopped working.
>
> My experience has always been that both cdrecord and wodim need to be
> suid-root. The wodim manual page supports this too.
>
> Probably you had previously made wodim suid-root, but that was lost when
> wodim was upgraded. Use 'dpkg-statoverride' to permanently set the suid
> flag for wodim.

Bingo. I had forgotten about that. Thanks very much.


--

Change the world one loan at a time - visit Kiva.org to find out how







--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 04-17-2008, 05:11 PM
Andrew Sackville-West
 
Default CD burning stopped working

On Thu, Apr 17, 2008 at 11:33:36AM -0400, Frank wrote:
>
>
> Running Sid/Lenny -- after recent updates, CD burning on my machine has
> stopped working.
> Normaly I use Gnomebaker...I have reinstalled it and wodim but that was
> not a solution.
>
> The script burn-cd gives me this:
>
> frank@debian:~$ burn-cd -i
> * Checking programs... [ok]
> mkisofs: version 2.01
> cdrecord: version 2.01.01a03-dvd
> isoinfo: version 1.1.7.1
> growisofs: version 7.1
> * Looking for a disk in drive... [unknown]
> Device: /dev/hdc
> .....
> wodim: Operation not permitted. Warning: Cannot raise RLIMIT_MEMLOCK
> limits.scsidev: '/dev/hdc' devname: '/dev/hdc'
> scsibus: -2 target: -2 lun: -2
> wodim: Permission denied.
> Cannot open SCSI driver!
> For possible targets try 'wodim --devices' or 'wodim -scanbus'.
> For possible transport specifiers try 'wodim dev=help'.
> For IDE/ATAPI devices configuration, see the file README.ATAPI.setup from
> the wodim documentation.
> TOC Type: 1 = CD-ROM
>
> Using Wodim to check the config doesn't work as a user...but does work as
> root.
>

...

>
> It appears permissions are at the root of the problem...but the only
> things that has changed lately are the updates on Sid...and the
> installation of the package SANE for my new scanner.
>
>
> Does anybody have any idea what is going on??

are you in the cdrom group? just in case...

A
 
Old 04-18-2008, 01:35 AM
Frank McCormick
 
Default CD burning stopped working

On Thu, 17 Apr 2008 10:11:46 -0700
Andrew Sackville-West <andrew@farwestbilliards.com> wrote:

> On Thu, Apr 17, 2008 at 11:33:36AM -0400, Frank wrote:
> >
> >
> > Running Sid/Lenny -- after recent updates, CD burning on my machine has
> > stopped working.
> > Normaly I use Gnomebaker...I have reinstalled it and wodim but that was
> > not a solution.


>
> are you in the cdrom group? just in case...

Yes I was..but it's been suggested wodim has to run with suid set and
that solved my problem. The one thing I don't know is how that got
changed. Weird but stranger things have happened.

--
Frank M


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 04-18-2008, 07:42 AM
Andrei Popescu
 
Default CD burning stopped working

On Thu, Apr 17, 2008 at 09:35:43PM -0400, Frank McCormick wrote:
> On Thu, 17 Apr 2008 10:11:46 -0700
> Andrew Sackville-West <andrew@farwestbilliards.com> wrote:
>
> > On Thu, Apr 17, 2008 at 11:33:36AM -0400, Frank wrote:
> > >
> > >
> > > Running Sid/Lenny -- after recent updates, CD burning on my machine has
> > > stopped working.
> > > Normaly I use Gnomebaker...I have reinstalled it and wodim but that was
> > > not a solution.
>
>
> >
> > are you in the cdrom group? just in case...
>
> Yes I was..but it's been suggested wodim has to run with suid set and
> that solved my problem. The one thing I don't know is how that got
> changed. Weird but stranger things have happened.

I'm not sure this was your problem:

$ ls -l /usr/bin/wodim
-rwxr-xr-x 1 root root 350984 2008-03-17 23:30 /usr/bin/wodim

and I can burn CDs (I use k3b) without any issues.

Regards,
Andrei
--
If you can't explain it simply, you don't understand it well enough.
(Albert Einstein)
 
Old 04-18-2008, 01:21 PM
Frank McCormick
 
Default CD burning stopped working

On Fri, 18 Apr 2008 10:42:46 +0300
Andrei Popescu <andreimpopescu@gmail.com> wrote:


> > Andrew Sackville-West <andrew@farwestbilliards.com> wrote:
> >
> > > On Thu, Apr 17, 2008 at 11:33:36AM -0400, Frank wrote:
> > > >
> > > >
> > > > Running Sid/Lenny -- after recent updates, CD burning on my
> > > > machine has stopped working.
> >
> > it's been suggested wodim has to run with suid set and
> > that solved my problem.
>
> I'm not sure this was your problem:
>
> $ ls -l /usr/bin/wodim
> -rwxr-xr-x 1 root root 350984 2008-03-17 23:30 /usr/bin/wodim
>
> and I can burn CDs (I use k3b) without any issues.



Interesting. I've just installed the cdrecord docs and I'll have a look.
I am beginning to suspect the problem goes deeper than I thought.

--
Frank M


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 04-18-2008, 01:24 PM
Frank
 
Default CD burning stopped working

On Fri, 18 Apr 2008 10:42:46 +0300
Andrei Popescu <andreimpopescu@gmail.com> wrote:

>
> I'm not sure this was your problem:
>
> $ ls -l /usr/bin/wodim
> -rwxr-xr-x 1 root root 350984 2008-03-17 23:30 /usr/bin/wodim
>
> and I can burn CDs (I use k3b) without any issues.



I've installed cdrecord docs and will take a look. Maybe the problem
goes deeper.

(earlier reply sent from wrong account)

Frank M

--

Change the world one loan at a time - visit Kiva.org to find out how







--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 04-18-2008, 03:51 PM
Andrei Popescu
 
Default CD burning stopped working

On Fri, Apr 18, 2008 at 09:21:53AM -0400, Frank McCormick wrote:
> On Fri, 18 Apr 2008 10:42:46 +0300
> Andrei Popescu <andreimpopescu@gmail.com> wrote:
>
>
> > > Andrew Sackville-West <andrew@farwestbilliards.com> wrote:
> > >
> > > > On Thu, Apr 17, 2008 at 11:33:36AM -0400, Frank wrote:
> > > > >
> > > > >
> > > > > Running Sid/Lenny -- after recent updates, CD burning on my
> > > > > machine has stopped working.
> > >
> > > it's been suggested wodim has to run with suid set and
> > > that solved my problem.
> >
> > I'm not sure this was your problem:
> >
> > $ ls -l /usr/bin/wodim
> > -rwxr-xr-x 1 root root 350984 2008-03-17 23:30 /usr/bin/wodim
> >
> > and I can burn CDs (I use k3b) without any issues.
>
>
>
> Interesting. I've just installed the cdrecord docs and I'll have a look.
> I am beginning to suspect the problem goes deeper than I thought.

The author of cdrecord will always say you need to set it suid, even if
you don't really need to (IIRC this has been a major disagreement with
the Debian maintainer and has contributed to the fact that we have wodim
now). Beware though that wodim and cdrecord are quite different.

Regards,
Andrei
--
If you can't explain it simply, you don't understand it well enough.
(Albert Einstein)
 

Thread Tools




All times are GMT. The time now is 04:21 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org