Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian User (http://www.linux-archive.org/debian-user/)
-   -   does iceweasel have java plugin? (http://www.linux-archive.org/debian-user/709750-does-iceweasel-have-java-plugin.html)

Steve Kleene 10-04-2012 06:02 PM

does iceweasel have java plugin?
 
Using iceweasel, I am failing to connect to my university's VPN website.
This was working a few years ago. There's a point when the site tries to
install Jupiter Network Connect. All I get at that point now is an error:
"JRE not installed/Java is disabled".

I do have Java packages installed (gcj-4.4-jre, sun-java6-bin, etc.). In
/usr/lib/iceweasel/plugins, I see:

libjavaplugin.so -> /etc/alternatives/iceweasel-javaplugin.so

which in turn points to:

/usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so

However, if I do about:plugins in iceweasel, it lists nothing for java or
libnpjp2. I thought those should be displayed with about:plugins. The
system is up-to-date Wheezy, with iceweasel 10.0.7esr-2.

So can the browser use java/JRE or not? And if not, how can I fix that?

Thanks.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: loom.20121004T195939-628@post.gmane.org">http://lists.debian.org/loom.20121004T195939-628@post.gmane.org

Steve Kleene 10-04-2012 11:37 PM

does iceweasel have java plugin?
 
Using iceweasel, I am failing to connect to my university's VPN website.
This was working a few years ago. There's a point when the site tries to
install Jupiter Network Connect. All I get at that point now is an error:
"JRE not installed/Java is disabled".

I do have Java packages installed (gcj-4.4-jre, sun-java6-bin, etc.). In
/usr/lib/iceweasel/plugins, I see:

libjavaplugin.so -> /etc/alternatives/iceweasel-javaplugin.so

which in turn points to:

/usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so

However, if I do about:plugins in iceweasel, it lists nothing for java or
libnpjp2. I thought those should be displayed with about:plugins. The
system is up-to-date Wheezy, with iceweasel 10.0.7esr-2.

So can the browser use java/JRE or not? And if not, how can I fix that?

Thanks.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: loom.20121005T013705-537@post.gmane.org">http://lists.debian.org/loom.20121005T013705-537@post.gmane.org

Brad Rogers 10-05-2012 06:56 AM

does iceweasel have java plugin?
 
On Thu, 4 Oct 2012 18:02:30 +0000 (UTC)
Steve Kleene <skdeb@syrano.acb.uc.edu> wrote:

Hello Steve,

>So can the browser use java/JRE or not? And if not, how can I fix that?

Yes, but the Sun plugin and Sun JRE are fading away. Look for the
icedtea plugin and the openjdk jre.

--
Regards _
/ ) "The blindingly obvious is
/ _)rad never immediately apparent"
Does she always shout at you, does she tell you what to do
Family Life - Sham 69

Steve Kleene 10-05-2012 07:23 PM

does iceweasel have java plugin?
 
On Thu, 4 Oct 2012, I wrote:

>> Using iceweasel, I am failing to connect to my university's VPN website.
>> This was working a few years ago. There's a point when the site tries to
>> install Jupiter Network Connect. All I get at that point now is an error:
>> "JRE not installed/Java is disabled".

On Fri, 5 Oct 2012, Brad Rogers responded:

> Look for the icedtea plugin and the openjdk jre.

I tried those, and I no longer get the java errors. Unfortunately, VPN still
doesn't finish, but that looks like a different problem. Thanks.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: loom.20121005T212324-327@post.gmane.org">http://lists.debian.org/loom.20121005T212324-327@post.gmane.org

"Michael P. Soulier" 10-10-2012 03:16 PM

does iceweasel have java plugin?
 
On 04/10/12 Steve Kleene said:

> Using iceweasel, I am failing to connect to my university's VPN website.
> This was working a few years ago. There's a point when the site tries to
> install Jupiter Network Connect. All I get at that point now is an error:
> "JRE not installed/Java is disabled".
>
> I do have Java packages installed (gcj-4.4-jre, sun-java6-bin, etc.). In
> /usr/lib/iceweasel/plugins, I see:
>
> libjavaplugin.so -> /etc/alternatives/iceweasel-javaplugin.so

Interesting.

Try symlinking from /usr/lib/mozilla/plugins/ instead. I have plugins there
that are working fine.

Mike

Steve Kleene 10-11-2012 02:44 PM

does iceweasel have java plugin?
 
On Thu, 4 Oct 2012 23:37:36 +0000, I wrote:
>> I do have Java packages installed (gcj-4.4-jre, sun-java6-bin, etc.). In
>> /usr/lib/iceweasel/plugins, I see:
>>
>> libjavaplugin.so -> /etc/alternatives/iceweasel-javaplugin.so
>>
>> which in turn points to:
>>
>> /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so

On Wed Oct 10 11:16:52 2012, Michael P. Soulier replied:

> Try symlinking from /usr/lib/mozilla/plugins/ instead. I have plugins there
> that are working fine.

I see I have plugins there too. I don't really know which ones are called by
iceweasel, but it all seems to work now in any case. Thanks.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: loom.20121011T164341-462@post.gmane.org">http://lists.debian.org/loom.20121011T164341-462@post.gmane.org


All times are GMT. The time now is 10:43 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.