FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 09-26-2012, 02:14 PM
Marek Pawinski
 
Default Unable to run skype on amd64

Hi,

I had Skype 4x installed on Squeeze amd64 6.0x, don't remember when I
installed it.


Anyway it would run but I could not get the sound right. I think I
installed it from the Skype website.


I purged Skype and tried to install the Debian Wiki way


Non-Multi-Arch (traditional way, also works in Squeeze)


and receive this error message when I run it:

(<unknown>:23967): Gtk-WARNING **:
/usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class:
ELFCLASS64


Some distro's like my rear output and some only work in my front output
for the mic.


Can't find anything on Google particularly related to Skype with this
error message.


Cheers
Marek




--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Archive: 50630DD5.5040306@pawinski.co.za">http://lists.debian.org/50630DD5.5040306@pawinski.co.za
 
Old 09-27-2012, 06:58 AM
lee
 
Default Unable to run skype on amd64

Marek Pawinski <linux@pawinski.co.za> writes:

> (<unknown>:23967): Gtk-WARNING **:
> /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class:
> ELFCLASS64

You might need to install ia32-libs-gtk.


--
Debian testing amd64


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 871uho6jg7.fsf@yun.yagibdah.de">http://lists.debian.org/871uho6jg7.fsf@yun.yagibdah.de
 
Old 09-27-2012, 10:50 AM
Josť Luis Segura Lucas
 
Default Unable to run skype on amd64

The skype official amd64 package are only a i386 version with some
dependencies like ia32-libs and so on.

If you have enabled multiarch on your machine, you can install the i386
version package and use aptitude/apt-get to install all its dependencies
on the i386 architecture:

apt-get install libXXXXXX:i386

What dependencies do you need? I don't remember, but when you install
skype:i386 you will be prompted with the unsatisfied dependencies.

If you didn't enable multiarch, sorry, I can't help you :-(

Best regards.

On 26/09/12 16:14, Marek Pawinski wrote:
> Hi,
>
> I had Skype 4x installed on Squeeze amd64 6.0x, don't remember when I
> installed it.
>
> Anyway it would run but I could not get the sound right. I think I
> installed it from the Skype website.
>
> I purged Skype and tried to install the Debian Wiki way
>
>
> Non-Multi-Arch (traditional way, also works in Squeeze)
>
>
> and receive this error message when I run it:
>
> (<unknown>:23967): Gtk-WARNING **:
> /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class:
> ELFCLASS64
>
> Some distro's like my rear output and some only work in my front output
> for the mic.
>
> Can't find anything on Google particularly related to Skype with this
> error message.
>
> Cheers
> Marek
>
>
>
>
 
Old 09-27-2012, 11:23 AM
Alberto Luaces
 
Default Unable to run skype on amd64

Just to complete Josť Luis' answer, this is the output of the computer
where I did not yet enabled multiarch:

$ LANG=C aptitude show skype | grep Depends -A 2
Depends: lib32stdc++6 (>= 4.1.1-21), lib32asound2 (> 1.0.14), ia32-libs,
libc6-i386 (>= 2.7-1), lib32gcc1 (>= 1:4.1.1-21+ia32.libs.1.19),
ia32-libs-gtk

Please, verify that you have all those packages installed.

Josť Luis Segura Lucas writes:

> The skype official amd64 package are only a i386 version with some
> dependencies like ia32-libs and so on.
>
> If you have enabled multiarch on your machine, you can install the i386
> version package and use aptitude/apt-get to install all its dependencies
> on the i386 architecture:
>
> apt-get install libXXXXXX:i386
>
> What dependencies do you need? I don't remember, but when you install
> skype:i386 you will be prompted with the unsatisfied dependencies.
>
> If you didn't enable multiarch, sorry, I can't help you :-(
>
> Best regards.
>
> On 26/09/12 16:14, Marek Pawinski wrote:
>> Hi,
>>
>> I had Skype 4x installed on Squeeze amd64 6.0x, don't remember when I
>> installed it.
>>
>> Anyway it would run but I could not get the sound right. I think I
>> installed it from the Skype website.
>>
>> I purged Skype and tried to install the Debian Wiki way
>>
>>
>> Non-Multi-Arch (traditional way, also works in Squeeze)
>>
>>
>> and receive this error message when I run it:
>>
>> (<unknown>:23967): Gtk-WARNING **:
>> /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class:
>> ELFCLASS64
>>
>> Some distro's like my rear output and some only work in my front output
>> for the mic.
>>
>> Can't find anything on Google particularly related to Skype with this
>> error message.
>>
>> Cheers
>> Marek
>>
>>
>>
>>
>
>

--
Alberto


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 87sja3675v.fsf@eps142.cdf.udc.es">http://lists.debian.org/87sja3675v.fsf@eps142.cdf.udc.es
 

Thread Tools




All times are GMT. The time now is 01:56 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org