FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 08-20-2012, 02:24 PM
"Weaver"
 
Default libqt4 Broken

Hello all,

There seems to be issues with libqt4 in the latest update in unstable, on
i386.

Might pay to hold back on an update, if you have a heavy dependency on
these, until a fix comes through.

Copy and paste here, for those that might find it useful.
~~~~~~~~~~~~~~~~~~~~~~~~~~~
$ su
Password:
root@Telaman:/home/weaver# aptitude update
Hit http://ftp.au.debian.org unstable InRelease
Hit http://ftp.au.debian.org unstable/main i386 Packages/DiffIndex
Get: 1 http://www.debian-multimedia.org sid InRelease [32.3 kB]
Hit http://ftp.au.debian.org unstable/non-free i386 Packages/DiffIndex
Hit http://ftp.au.debian.org unstable/contrib i386 Packages/DiffIndex
Hit http://ftp.au.debian.org unstable/contrib Translation-en/DiffIndex
Hit http://ftp.au.debian.org unstable/main Translation-en/DiffIndex
Hit http://ftp.au.debian.org unstable/non-free Translation-en/DiffIndex
Hit http://www.debian-multimedia.org sid/main i386 Packages/DiffIndex
Hit http://www.debian-multimedia.org sid/non-free i386 Packages/DiffIndex
Ign http://www.debian-multimedia.org sid/main Translation-en_AU
Ign http://www.debian-multimedia.org sid/main Translation-en
Ign http://www.debian-multimedia.org sid/non-free Translation-en_AU
Ign http://www.debian-multimedia.org sid/non-free Translation-en
Fetched 32.3 kB in 10s (3,162 B/s)
Deleting obsolete downloaded files

root@Telaman:/home/weaver# aptitude safe-upgrade
The following packages will be upgraded:
gnome-keyring iputils-ping iputils-tracepath libpam-gnome-keyring
libqt4-dbus libqt4-designer libqt4-network libqt4-script
libqt4-scripttools libqt4-xml libqt4-xmlpatterns libqtcore4 libqtgui4
libwireshark-data libwireshark2 libwiretap2 libwsutil2 qdbus
wireshark wireshark-common wireshark-doc
The following partially installed packages will be configured:
libqt4-declarative libqt4-help libqt4-opengl libqt4-qt3support
libqt4-sql libqt4-sql-mysql libqt4-sql-sqlite libqt4-svg libqt4-test
21 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/32.3 MB of archives. After unpacking 3,067 kB will be freed.
Do you want to continue? [Y/n/?] Y
Reading changelogs... Done
Preconfiguring packages ...
(Reading database ... 512207 files and directories currently installed.)
Preparing to replace libqt4-scripttools:i386 4:4.8.2-2+b1 (using
.../libqt4-scripttools_4%3a4.8.2+dfsg-1_i386.deb) ...
Unpacking replacement libqt4-scripttools:i386 ...
Preparing to replace libqtgui4:i386 4:4.8.2-2+b1 (using
.../libqtgui4_4%3a4.8.2+dfsg-1_i386.deb) ...
Unpacking replacement libqtgui4:i386 ...
dpkg: unrecoverable fatal error, aborting:
fork failed: Cannot allocate memory
[ Rootkit Hunter version 1.4.0 ]
File updated: searched for 169 files, found 137
localepurge: Disk space freed in /usr/share/locale: 0 KiB
localepurge: Disk space freed in /usr/share/man: 0 KiB
localepurge: Disk space freed in /usr/share/gnome/help: 0 KiB
localepurge: Disk space freed in /usr/share/omf: 0 KiB
localepurge: Disk space freed in /usr/share/doc/kde/HTML: 0 KiB

Total disk space freed by localepurge: 0 KiB

E: Sub-process /usr/bin/dpkg returned an error code (2)
A package failed to install. Trying to recover:
dpkg: dependency problems prevent configuration of libqt4-sql-sqlite:i386:
libqt4-sql-sqlite:i386 depends on libqtcore4 (= 4:4.8.2+dfsg-1); however:
Version of libqtcore4:i386 on system is 4:4.8.2-2+b1.

dpkg: error processing libqt4-sql-sqlite:i386 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-sql:i386:
libqt4-sql:i386 depends on libqtcore4 (= 4:4.8.2+dfsg-1); however:
Version of libqtcore4:i386 on system is 4:4.8.2-2+b1.

dpkg: error processing libqt4-sql:i386 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-declarative:i386:
libqt4-declarative:i386 depends on libqt4-network (= 4:4.8.2+dfsg-1);
however:
Version of libqt4-network:i386 on system is 4:4.8.2-2+b1.
libqt4-declarative:i386 depends on libqt4-script (= 4:4.8.2+dfsg-1);
however:
Version of libqt4-script:i386 on system is 4:4.8.2-2+b1.
libqt4-declarative:i386 depends on libqt4-sql (= 4:4.8.2+dfsg-1); however:
Package libqt4-sql:i386 is not configured yet.
libqt4-declarative:i386 depends on libqt4-xmlpatterns (= 4:4.8.2+dfsg-1);
however:
Package libqt4-xmlpatterns:i386 is not installed.
libqt4-declarative:i386 depends on libqtcore4 (= 4:4.8.2+dfsg-1); however:
Version of libqtcore4:i386 on system is 4:4.8.2-2+b1.
libqt4-declarative:i386 depends on libqtgui4 (= 4:4.8.2+dfsg-1); however:
Package libqtgui4:i386 is not installed.

dpkg: error processing libqt4-declarative:i386 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-svg:i386:
libqt4-svg:i386 depends on libqtcore4 (= 4:4.8.2+dfsg-1); however:
Version of libqtcore4:i386 on system is 4:4.8.2-2+b1.
libqt4-svg:i386 depends on libqtgui4 (= 4:4.8.2+dfsg-1); however:
Package libqtgui4:i386 is not installed.

dpkg: error processing libqt4-svg:i386 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-sql-mysql:i386:
libqt4-sql-mysql:i386 depends on libqt4-sql (= 4:4.8.2+dfsg-1); however:
Package libqt4-sql:i386 is not configured yet.
libqt4-sql-mysql:i386 depends on libqtcore4 (= 4:4.8.2+dfsg-1); however:
Version of libqtcore4:i386 on system is 4:4.8.2-2+b1.

dpkg: error processing libqt4-sql-mysql:i386 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-opengl:i386:
libqt4-opengl:i386 depends on libqtcore4 (= 4:4.8.2+dfsg-1); however:
Version of libqtcore4:i386 on system is 4:4.8.2-2+b1.
libqt4-opengl:i386 depends on libqtgui4 (= 4:4.8.2+dfsg-1); however:
Package libqtgui4:i386 is not installed.

dpkg: error processing libqt4-opengl:i386 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-help:i386:
libqt4-help:i386 depends on libqt4-network (= 4:4.8.2+dfsg-1); however:
Version of libqt4-network:i386 on system is 4:4.8.2-2+b1.
libqt4-help:i386 depends on libqt4-sql (= 4:4.8.2+dfsg-1); however:
Package libqt4-sql:i386 is not configured yet.
libqt4-help:i386 depends on libqtcore4 (= 4:4.8.2+dfsg-1); however:
Version of libqtcore4:i386 on system is 4:4.8.2-2+b1.
libqt4-help:i386 depends on libqtgui4 (= 4:4.8.2+dfsg-1); however:
Package libqtgui4:i386 is not installed.

dpkg: error processing libqt4-help:i386 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-scripttools:i386:
libqt4-scripttools:i386 depends on libqt4-script (= 4:4.8.2+dfsg-1);
however:
Version of libqt4-script:i386 on system is 4:4.8.2-2+b1.
libqt4-scripttools:i386 depends on libqtcore4 (= 4:4.8.2+dfsg-1); however:
Version of libqtcore4:i386 on system is 4:4.8.2-2+b1.
libqt4-scripttools:i386 depends on libqtgui4 (= 4:4.8.2+dfsg-1); however:
Package libqtgui4:i386 is not installed.

dpkg: error processing libqt4-scripttools:i386 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-qt3support:i386:
libqt4-qt3support:i386 depends on libqt4-designer (= 4:4.8.2+dfsg-1);
however:
Version of libqt4-designer:i386 on system is 4:4.8.2-2+b1.
libqt4-qt3support:i386 depends on libqt4-network (= 4:4.8.2+dfsg-1);
however:
Version of libqt4-network:i386 on system is 4:4.8.2-2+b1.
libqt4-qt3support:i386 depends on libqt4-sql (= 4:4.8.2+dfsg-1); however:
Package libqt4-sql:i386 is not configured yet.
libqt4-qt3support:i386 depends on libqt4-xml (= 4:4.8.2+dfsg-1); however:
Version of libqt4-xml:i386 on system is 4:4.8.2-2+b1.
libqt4-qt3support:i386 depends on libqtcore4 (= 4:4.8.2+dfsg-1); however:
Version of libqtcore4:i386 on system is 4:4.8.2-2+b1.
libqt4-qt3support:i386 depends on libqtgui4 (= 4:4.8.2+dfsg-1); however:
Package libqtgui4:i386 is not installed.

dpkg: error processing libqt4-qt3support:i386 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-test:i386:
libqt4-test:i386 depends on libqtcore4 (= 4:4.8.2+dfsg-1); however:
Version of libqtcore4:i386 on system is 4:4.8.2-2+b1.

dpkg: error processing libqt4-test:i386 (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
libqt4-sql-sqlite:i386
libqt4-sql:i386
libqt4-declarative:i386
libqt4-svg:i386
libqt4-sql-mysql:i386
libqt4-opengl:i386
libqt4-help:i386
libqt4-scripttools:i386
libqt4-qt3support:i386
libqt4-test:i386

Current status: 10 broken [+1], 20 updates [-1].
root@Telaman:/home/weaver#

~~~~~~~~~~~~~~~~~~~~~~~~~~~
Regards,

Weaver.

--
"I invite you to name a society that created a secret prison
system, outside the rule of law, where torture takes place,
that sooner or later didn't turn the abuse against it's own
citizens. -- Naomi Wolf - October 11, 2007




--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: d1cbf70ed88b08a68e9f8ec13273323b.squirrel@fulvetta .riseup.net">http://lists.debian.org/d1cbf70ed88b08a68e9f8ec13273323b.squirrel@fulvetta .riseup.net
 
Old 08-20-2012, 03:04 PM
Sven Joachim
 
Default libqt4 Broken

On 2012-08-20 16:24 +0200, Weaver wrote:

> There seems to be issues with libqt4 in the latest update in unstable, on
> i386.

I don't think so, it upgraded fine here.

> Unpacking replacement libqtgui4:i386 ...
> dpkg: unrecoverable fatal error, aborting:
> fork failed: Cannot allocate memory

How much memory (physical and swap) does your machine have?

Cheers,
Sven


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 87zk5pzjsc.fsf@turtle.gmx.de">http://lists.debian.org/87zk5pzjsc.fsf@turtle.gmx.de
 
Old 08-20-2012, 07:43 PM
"Weaver"
 
Default libqt4 Broken

> On 2012-08-20 16:24 +0200, Weaver wrote:
>
>> There seems to be issues with libqt4 in the latest update in unstable,
>> on
>> i386.
>
> I don't think so, it upgraded fine here.
>
>> Unpacking replacement libqtgui4:i386 ...
>> dpkg: unrecoverable fatal error, aborting:
>> fork failed: Cannot allocate memory
>
> How much memory (physical and swap) does your machine have?

4.5Gb
Regards,

Weaver.

--
"I invite you to name a society that created a secret prison
system, outside the rule of law, where torture takes place,
that sooner or later didn't turn the abuse against it's own
citizens. -- Naomi Wolf - October 11, 2007


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 56d9fd18723dcb8722d16bb1e88cbbd7.squirrel@fruiteat er.riseup.net">http://lists.debian.org/56d9fd18723dcb8722d16bb1e88cbbd7.squirrel@fruiteat er.riseup.net
 
Old 08-21-2012, 06:29 PM
Sven Joachim
 
Default libqt4 Broken

On 2012-08-20 21:43 +0200, Weaver wrote:

>> On 2012-08-20 16:24 +0200, Weaver wrote:
>>
>>> There seems to be issues with libqt4 in the latest update in unstable,
>>> on
>>> i386.
>>
>> I don't think so, it upgraded fine here.
>>
>>> Unpacking replacement libqtgui4:i386 ...
>>> dpkg: unrecoverable fatal error, aborting:
>>> fork failed: Cannot allocate memory
>>
>> How much memory (physical and swap) does your machine have?
>
> 4.5Gb

That's quite a bit more than my old laptop has. Does it still fail if
you retry?

Cheers,
Sven


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 87y5l8gkt5.fsf@turtle.gmx.de">http://lists.debian.org/87y5l8gkt5.fsf@turtle.gmx.de
 
Old 08-21-2012, 10:47 PM
"Weaver"
 
Default libqt4 Broken

> On 2012-08-20 21:43 +0200, Weaver wrote:
>
>>> On 2012-08-20 16:24 +0200, Weaver wrote:
>>>
>>>> There seems to be issues with libqt4 in the latest update in unstable,
>>>> on
>>>> i386.
>>>
>>> I don't think so, it upgraded fine here.
>>>
>>>> Unpacking replacement libqtgui4:i386 ...
>>>> dpkg: unrecoverable fatal error, aborting:
>>>> fork failed: Cannot allocate memory
>>>
>>> How much memory (physical and swap) does your machine have?
>>
>> 4.5Gb
>
> That's quite a bit more than my old laptop has. Does it still fail if
> you retry?

I tried three times in all, but there was another release of libqt4 last
night and an update/upgrade was successful with those.
Regards and thanks,

Weaver.

--
"I invite you to name a society that created a secret prison
system, outside the rule of law, where torture takes place,
that sooner or later didn't turn the abuse against it's own
citizens. -- Naomi Wolf - October 11, 2007


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: d0f0250884b67091319187ed0be1b8e5.squirrel@fulvetta .riseup.net">http://lists.debian.org/d0f0250884b67091319187ed0be1b8e5.squirrel@fulvetta .riseup.net
 

Thread Tools




All times are GMT. The time now is 09:37 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org