FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 08-18-2012, 07:31 AM
Csanyi Pal
 
Default How to install SchoolTool 2.0 on Debian?

Hi,

I wish to install on my Debian GNU/Linux testing/sid system the
SchoolTool 2.0: http://book.schooltool.org/install-2_0.html

I realise that that I can't follow steps:

$ sudo add-apt-repository ppa:schooltool-owners/dev
$ sudo apt-get update

$ sudo apt-get install schooltool

because on debian there isn't such command:
add-apt-repository

$ sudo add-apt-repository ppa:schooltool-owners/dev
sudo: add-apt-repository: command not found

however if I edit my sources.list:
deb-src ppa:schooltool-owners/dev

and run
$ sudo aptitude update
I get messages:

E: Malformed line 25 in source list /etc/apt/sources.list (dist)
E: Malformed line 25 in source list /etc/apt/sources.list (dist)
E: The list of sources could not be read.
E: Malformed line 25 in source list /etc/apt/sources.list (dist)
E: The list of sources could not be read.
E: Malformed line 25 in source list /etc/apt/sources.list (dist)
E: Couldn't read list of package sources

So is there any solution on Debian to install SchoolTool 2.0?

--
Regards from Pal


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 871uj44pw7.fsf@gmail.com">http://lists.debian.org/871uj44pw7.fsf@gmail.com
 
Old 08-18-2012, 08:16 AM
"Chris"
 
Default How to install SchoolTool 2.0 on Debian?

Google search term, add ppa Debian
Google is your friend, learn how to use it...

Sent from my HTC.

----- Reply message -----
From: "Csanyi Pal" <csanyipal@gmail.com>
Date: Sat, Aug 18, 2012 2:31 am
Subject: How to install SchoolTool 2.0 on Debian?
To: <debian-user@lists.debian.org>

Hi,

I wish to install on my Debian GNU/Linux testing/sid system the
SchoolTool 2.0: http://book.schooltool.org/install-2_0.html

I realise that that I can't follow steps:

$ sudo add-apt-repository ppa:schooltool-owners/dev
$ sudo apt-get update

$ sudo apt-get install schooltool

because on debian there isn't such command:
add-apt-repository

$ sudo add-apt-repository ppa:schooltool-owners/dev
sudo: add-apt-repository: command not found

however if I edit my sources.list:
deb-src ppa:schooltool-owners/dev

and run
$ sudo aptitude update
I get messages:

E: Malformed line 25 in source list /etc/apt/sources.list (dist)
E: Malformed line 25 in source list /etc/apt/sources.list (dist)
E: The list of sources could not be read.
E: Malformed line 25 in source list /etc/apt/sources.list (dist)
E: The list of sources could not be read.
E: Malformed line 25 in source list /etc/apt/sources.list (dist)
E: Couldn't read list of package sources

So is there any solution on Debian to install SchoolTool 2.0?

--
Regards from Pal


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: http://lists.debian.org/871uj44pw7.fsf@gmail.com
 
Old 08-18-2012, 08:25 AM
Brian
 
Default How to install SchoolTool 2.0 on Debian?

On Sat 18 Aug 2012 at 09:31:52 +0200, Csanyi Pal wrote:

> I wish to install on my Debian GNU/Linux testing/sid system the
> SchoolTool 2.0: http://book.schooltool.org/install-2_0.html
>
> I realise that that I can't follow steps:
>
> $ sudo add-apt-repository ppa:schooltool-owners/dev
> $ sudo apt-get update
>
> $ sudo apt-get install schooltool
>
> because on debian there isn't such command:
> add-apt-repository

Correct.

> $ sudo add-apt-repository ppa:schooltool-owners/dev
> sudo: add-apt-repository: command not found
>
> however if I edit my sources.list:
> deb-src ppa:schooltool-owners/dev

Doesn't fit the pattern of other lines, does it? Try

http://ppa.launchpad.net/schooltool-owners/

in a browser and go from there to get a line which is not malformed.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: http://lists.debian.org/20120818082549.GF23049@desktop
 
Old 08-18-2012, 09:06 AM
Csanyi Pal
 
Default How to install SchoolTool 2.0 on Debian?

Brian <ad44@cityscape.co.uk> writes:

> On Sat 18 Aug 2012 at 09:31:52 +0200, Csanyi Pal wrote:
>
>> I wish to install on my Debian GNU/Linux testing/sid system the
>> SchoolTool 2.0: http://book.schooltool.org/install-2_0.html
>>
>> I realise that that I can't follow steps:
>>
>> $ sudo add-apt-repository ppa:schooltool-owners/dev
>> $ sudo apt-get update
>>
>> $ sudo apt-get install schooltool
>>
>> because on debian there isn't such command:
>> add-apt-repository
>
> Correct.
>
>> $ sudo add-apt-repository ppa:schooltool-owners/dev
>> sudo: add-apt-repository: command not found
>>
>> however if I edit my sources.list:
>> deb-src ppa:schooltool-owners/dev
>
> Doesn't fit the pattern of other lines, does it? Try
>
> http://ppa.launchpad.net/schooltool-owners/
>
> in a browser and go from there to get a line which is not malformed.

Here follows is what I did.

Downloaded the
http://blog.anantshri.info/content/uploads/2010/09/add-apt-repository.sh.txt
file.

Edited it to correspond the newest version of Ubuntu:
echo "deb http://ppa.launchpad.net/$ppa_name/ubuntu precise main" [snip]

In this line I replaced the word 'lucid' with 'precise'.

Copied this file to /usr/sbin.

Set up it's permissions so I have now:
$ ls -l /usr/sbin/add-apt-repository
-rwxr-xr-x 1 root root 723 aug 18 10:43 /usr/sbin/add-apt-repository

Run the script:
$ sudo add-apt-repository ppa:schooltool-owners/dev
schooltool-owners/dev
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring
--secret-keyring /tmp/tmp.y
irs4BqhK8 --trustdb-name /etc/apt//trustdb.gpg --keyring
/etc/apt/trusted.gpg --primary-keyring /et
c/apt/trusted.gpg --keyring
/etc/apt/trusted.gpg.d//debian-archive-squeeze-automatic.gpg --keyring
/etc/apt/trusted.gpg.d//debian-archive-squeeze-stable.gpg --keyring
/etc/apt/trusted.gpg.d//debian-
archive-wheezy-automatic.gpg --keyring
/etc/apt/trusted.gpg.d//debian-archive-wheezy-stable.gpg --k
eyserver keyserver.ubuntu.com --recv-keys C95C0E19386B7051
gpg: requesting key 386B7051 from hkp server keyserver.ubuntu.com
gpg: key 386B7051: public key "Launchpad PPA for SchoolTool Owners"
imported
gpg: Total number processed: 1
gpg: imported: 1 (RSA: 1)

$ sudo aptitude update

$ sudo aptitude install schooltool

but get:

The following NEW packages will be installed:
libjs-mochikit{a} python-openid{a} python-paste{a}
python-pastedeploy{a} python-pastescript{a} python-scgi{a}
python-schooltool{ab} python-schooltool.gradebook{ab}
python-schooltool.intervention{ab}
python-schooltool.lyceum.journal{ab} schooltool
0 packages upgraded, 11 newly installed, 0 to remove and 5 not
upgraded.
Need to get 5478 kB of archives. After unpacking 26.4 MB will be used.
The following packages have unmet dependencies:
python-schooltool.lyceum.journal :
Depends: python-zc.table which is a virtual package.
Depends: python-zodb but it is not going to be installed.
Depends: python-zope.browserpage (>= 3.10.1) which is a virtual
package.
Depends: python-zope.cachedescriptors but it is not going to be
installed.
Depends: python-zope.component but it is not going to be instal led.
Depends: python-zope.container which is a virtual package.
Depends: python-zope.formlib (>= 4) which is a virtual package.
Depends: python-zope.i18n but it is not going to be installed.
Depends: python-zope.i18nmessageid but it is not going to be installed.
Depends: python-zope.intid which is a virtual package.
Depends: python-zope.location but it is not going to be installed.
Depends: python-zope.publisher but it is not going to be installed.
Depends: python-zope.security but it is not going to be installed.
Depends: python-zope.traversing but it is not going to be installed.
Depends: python-zope.viewlet which is a virtual package.
python-schooltool.gradebook :
Depends: python-rwproperty which is a virtual package.
Depends: python-xlwt but it is not going to be installed.
Depends: python-z3c.form which is a virtual package.
Depends: python-z3c.optionstorage which is a virtual package.
Depends: python-zodb but it is not going to be installed.
Depends: python-zope.annotation which is a virtual package.
Depends: python-zope.app.form which is a virtual package.
Depends: python-zope.app.generations (>= 3.5) which is a virtual
package.
Depends: python-zope.browser but it is not going to be installed.
Depends: python-zope.browserpage (>= 3.10.1) which is a virtual
package.
Depends: python-zope.component but it is not going to be installed.
Depends: python-zope.componentvocabulary which is a virtual package.
Depends: python-zope.container which is a virtual package.
Depends: python-zope.event but it is not going to be installed.
Depends: python-zope.formlib (>= 4) which is a virtual package.
Depends: python-zope.html which is a virtual package.
Depends: python-zope.i18n but it is not going to be installed.
Depends: python-zope.i18nmessageid but it is not going to be installed.
Depends: python-zope.keyreference which is a virtual package.
Depends: python-zope.lifecycleevent which is a virtual package.
Depends: python-zope.location but it is not going to be installed.
Depends: python-zope.publisher but it is not going to be installed.
Depends: python-zope.schema but it is not going to be installed.
Depends: python-zope.security but it is not going to be installed.
Depends: python-zope.traversing but it is not going to be installed.
Depends: python-zope.viewlet which is a virtual package.
python-schooltool.intervention :
Depends: python-rwproperty which is a virtual package.
Depends: python-z3c.form which is a virtual package.
Depends: python-zc.catalog which is a virtual package.
Depends: python-zc.table which is a virtual package.
Depends: python-zodb but it is not going to be installed.
Depends: python-zope.annotation which is a virtual package.
Depends: python-zope.app.form which is a virtual package.
Depends: python-zope.app.generations which is a virtual package.
Depends: python-zope.authentication but it is not going to be
installed.
Depends: python-zope.browser but it is not going to be installed.
Depends: python-zope.browserpage (>= 3.10.1) which is a virtual
package.
Depends: python-zope.catalog which is a virtual package.
Depends: python-zope.component but it is not going to be installed.
Depends: python-zope.container which is a virtual package.
Depends: python-zope.dublincore which is a virtual package.
Depends: python-zope.formlib (>= 4) which is a virtual package.
Depends: python-zope.i18n but it is not going to be installed.
Depends: python-zope.i18nmessageid but it is not going to be installed.
Depends: python-zope.lifecycleevent which is a virtual package.
Depends: python-zope.location but it is not going to be installed.
Depends: python-zope.publisher but it is not going to be installed.
Depends: python-zope.schema but it is not going to be installed.
Depends: python-zope.security but it is not going to be installed.
Depends: python-zope.traversing but it is not going to be installed.
python-schooltool :
Depends: python-hurry.query which is a virtual package.
Depends: python-rwproperty which is a virtual package.
Depends: python-xlrd but it is not going to be installed.
Depends: python-xlwt but it is not going to be installed.
Depends: python-z3c.autoinclude (>= 0.3.4) which is a virtual package.
Depends: python-z3c.form (>= 2.0) which is a virtual package.
Depends: python-z3c.formui which is a virtual package.
Depends: python-z3c.macro which is a virtual package.
Depends: python-z3c.rml which is a virtual package.
Depends: python-z3c.template which is a virtual package.
Depends: python-zc.catalog which is a virtual package.
Depends: python-zc.datetimewidget which is a virtual package.
Depends: python-zc.resourcelibrary which is a virtual package.
Depends: python-zc.table which is a virtual package.
Depends: python-zodb but it is not going to be installed.
Depends: python-zope.annotation which is a virtual package.
Depends: python-zope.app.applicationcontrol which is a virtual package.
Depends: python-zope.app.appsetup which is a virtual package.
Depends: python-zope.app.basicskin which is a virtual package.
Depends: python-zope.app.broken which is a virtual package.
Depends: python-zope.app.component which is a virtual package.
Depends: python-zope.app.container which is a virtual package.
Depends: python-zope.app.content which is a virtual package.
Depends: python-zope.app.dependable which is a virtual package.
Depends: python-zope.app.error which is a virtual package.
Depends: python-zope.app.exception which is a virtual package.
Depends: python-zope.app.form which is a virtual package.
Depends: python-zope.app.generations (>= 3.5) which is a virtual
package.
Depends: python-zope.app.http which is a virtual package.
Depends: python-zope.app.locales which is a virtual package.
Depends: python-zope.app.principalannotation which is a virtual
package.
Depends: python-zope.app.publication which is a virtual package.
Depends: python-zope.app.schema which is a virtual package.
Depends: python-zope.app.security which is a virtual package.
Depends: python-zope.app.server which is a virtual package.
Depends: python-zope.app.testing which is a virtual package.
Depends: python-zope.app.wsgi which is a virtual package.
Depends: python-zope.authentication but it is not going to be
installed.
Depends: python-zope.browser but it is not going to be installed.
Depends: python-zope.browsermenu which is a virtual package.
Depends: python-zope.browserpage (>= 3.10.1) which is a virtual
package.
Depends: python-zope.cachedescriptors but it is not going to be
installed.
Depends: python-zope.catalog which is a virtual package.
Depends: python-zope.component (>= 3.8) but it is not going to be
installed.
Depends: python-zope.configuration but it is not going to be installed.
Depends: python-zope.container (>= 3.7.2) which is a virtual package.
Depends: python-zope.contentprovider which is a virtual package.
Depends: python-zope.dublincore (>= 3.7) which is a virtual package.
Depends: python-zope.event but it is not going to be installed.
Depends: python-zope.file which is a virtual package.
Depends: python-zope.filerepresentation which is a virtual package.
Depends: python-zope.formlib (>= 4.0) which is a virtual package.
Depends: python-zope.html which is a virtual package.
Depends: python-zope.i18n (>= 3.5) but it is not going to be installed.
Depends: python-zope.i18nmessageid but it is not going to be installed.
Depends: python-zope.intid which is a virtual package.
Depends: python-zope.keyreference which is a virtual package.
Depends: python-zope.lifecycleevent which is a virtual package.
Depends: python-zope.location but it is not going to be installed.
Depends: python-zope.login which is a virtual package.
Depends: python-zope.mimetype which is a virtual package.
Depends: python-zope.pagetemplate (>= 3.5) which is a virtual package.
Depends: python-zope.password which is a virtual package.
Depends: python-zope.proxy but it is not going to be installed.
Depends: python-zope.publisher (>= 3.6) but it is not going to be
installed.
Depends: python-zope.schema but it is not going to be installed.
Depends: python-zope.security but it is not going to be installed.
Depends: python-zope.securitypolicy which is a virtual package.
Depends: python-zope.server which is a virtual package.
Depends: python-zope.session which is a virtual package.
Depends: python-zope.site which is a virtual package.
Depends: python-zope.size which is a virtual package.
Depends: python-zope.tales which is a virtual package.
Depends: python-zope.testbrowser but it is not going to be installed.
Depends: python-zope.testing but it is not going to be installed.
Depends: python-zope.traversing (>= 3.13) but it is not going to be
installed.
Depends: python-zope.ucol which is a virtual package.
Depends: python-zope.viewlet which is a virtual package.
The following actions will resolve these dependencies:

Keep the following packages at their current version:
1) python-schooltool [Not Installed]
2) python-schooltool.gradebook [Not Installed]
3) python-schooltool.intervention [Not Installed]
4) python-schooltool.lyceum.journal [Not Installed]
5) schooltool [Not Installed]



Accept this solution? [Y/n/q/?]


So, SchoolTool 2.0 is not installable on Debian testing/sid?

--
Regards from Pal


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 87zk5s1se9.fsf@gmail.com">http://lists.debian.org/87zk5s1se9.fsf@gmail.com
 
Old 08-18-2012, 09:31 AM
Gary Dale
 
Default How to install SchoolTool 2.0 on Debian?

On 18/08/12 05:06 AM, Csanyi Pal wrote:

Brian<ad44@cityscape.co.uk> writes:


On Sat 18 Aug 2012 at 09:31:52 +0200, Csanyi Pal wrote:


I wish to install on my Debian GNU/Linux testing/sid system the
SchoolTool 2.0: http://book.schooltool.org/install-2_0.html

I realise that that I can't follow steps:

$ sudo add-apt-repository ppa:schooltool-owners/dev
$ sudo apt-get update

$ sudo apt-get install schooltool

because on debian there isn't such command:
add-apt-repository

Correct.


$ sudo add-apt-repository ppa:schooltool-owners/dev
sudo: add-apt-repository: command not found

however if I edit my sources.list:
deb-src ppa:schooltool-owners/dev

Doesn't fit the pattern of other lines, does it? Try

http://ppa.launchpad.net/schooltool-owners/

in a browser and go from there to get a line which is not malformed.

Here follows is what I did.

Downloaded the
http://blog.anantshri.info/content/uploads/2010/09/add-apt-repository.sh.txt
file.

Edited it to correspond the newest version of Ubuntu:
echo "deb http://ppa.launchpad.net/$ppa_name/ubuntu precise main" [snip]

In this line I replaced the word 'lucid' with 'precise'.

Copied this file to /usr/sbin.

Set up it's permissions so I have now:
$ ls -l /usr/sbin/add-apt-repository
-rwxr-xr-x 1 root root 723 aug 18 10:43 /usr/sbin/add-apt-repository

Run the script:
$ sudo add-apt-repository ppa:schooltool-owners/dev
schooltool-owners/dev
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring
--secret-keyring /tmp/tmp.y
irs4BqhK8 --trustdb-name /etc/apt//trustdb.gpg --keyring
/etc/apt/trusted.gpg --primary-keyring /et
c/apt/trusted.gpg --keyring
/etc/apt/trusted.gpg.d//debian-archive-squeeze-automatic.gpg --keyring
/etc/apt/trusted.gpg.d//debian-archive-squeeze-stable.gpg --keyring
/etc/apt/trusted.gpg.d//debian-
archive-wheezy-automatic.gpg --keyring
/etc/apt/trusted.gpg.d//debian-archive-wheezy-stable.gpg --k
eyserver keyserver.ubuntu.com --recv-keys C95C0E19386B7051
gpg: requesting key 386B7051 from hkp server keyserver.ubuntu.com
gpg: key 386B7051: public key "Launchpad PPA for SchoolTool Owners"
imported
gpg: Total number processed: 1
gpg: imported: 1 (RSA: 1)

$ sudo aptitude update

$ sudo aptitude install schooltool

but get:

The following NEW packages will be installed:
libjs-mochikit{a} python-openid{a} python-paste{a}
python-pastedeploy{a} python-pastescript{a} python-scgi{a}
python-schooltool{ab} python-schooltool.gradebook{ab}
python-schooltool.intervention{ab}
python-schooltool.lyceum.journal{ab} schooltool
0 packages upgraded, 11 newly installed, 0 to remove and 5 not
upgraded.
Need to get 5478 kB of archives. After unpacking 26.4 MB will be used.
The following packages have unmet dependencies:
python-schooltool.lyceum.journal :
Depends: python-zc.table which is a virtual package.
Depends: python-zodb but it is not going to be installed.
Depends: python-zope.browserpage (>= 3.10.1) which is a virtual
package.
Depends: python-zope.cachedescriptors but it is not going to be
installed.
Depends: python-zope.component but it is not going to be instal led.
Depends: python-zope.container which is a virtual package.
Depends: python-zope.formlib (>= 4) which is a virtual package.
Depends: python-zope.i18n but it is not going to be installed.
Depends: python-zope.i18nmessageid but it is not going to be installed.
Depends: python-zope.intid which is a virtual package.
Depends: python-zope.location but it is not going to be installed.
Depends: python-zope.publisher but it is not going to be installed.
Depends: python-zope.security but it is not going to be installed.
Depends: python-zope.traversing but it is not going to be installed.
Depends: python-zope.viewlet which is a virtual package.
python-schooltool.gradebook :
Depends: python-rwproperty which is a virtual package.
Depends: python-xlwt but it is not going to be installed.
Depends: python-z3c.form which is a virtual package.
Depends: python-z3c.optionstorage which is a virtual package.
Depends: python-zodb but it is not going to be installed.
Depends: python-zope.annotation which is a virtual package.
Depends: python-zope.app.form which is a virtual package.
Depends: python-zope.app.generations (>= 3.5) which is a virtual
package.
Depends: python-zope.browser but it is not going to be installed.
Depends: python-zope.browserpage (>= 3.10.1) which is a virtual
package.
Depends: python-zope.component but it is not going to be installed.
Depends: python-zope.componentvocabulary which is a virtual package.
Depends: python-zope.container which is a virtual package.
Depends: python-zope.event but it is not going to be installed.
Depends: python-zope.formlib (>= 4) which is a virtual package.
Depends: python-zope.html which is a virtual package.
Depends: python-zope.i18n but it is not going to be installed.
Depends: python-zope.i18nmessageid but it is not going to be installed.
Depends: python-zope.keyreference which is a virtual package.
Depends: python-zope.lifecycleevent which is a virtual package.
Depends: python-zope.location but it is not going to be installed.
Depends: python-zope.publisher but it is not going to be installed.
Depends: python-zope.schema but it is not going to be installed.
Depends: python-zope.security but it is not going to be installed.
Depends: python-zope.traversing but it is not going to be installed.
Depends: python-zope.viewlet which is a virtual package.
python-schooltool.intervention :
Depends: python-rwproperty which is a virtual package.
Depends: python-z3c.form which is a virtual package.
Depends: python-zc.catalog which is a virtual package.
Depends: python-zc.table which is a virtual package.
Depends: python-zodb but it is not going to be installed.
Depends: python-zope.annotation which is a virtual package.
Depends: python-zope.app.form which is a virtual package.
Depends: python-zope.app.generations which is a virtual package.
Depends: python-zope.authentication but it is not going to be
installed.
Depends: python-zope.browser but it is not going to be installed.
Depends: python-zope.browserpage (>= 3.10.1) which is a virtual
package.
Depends: python-zope.catalog which is a virtual package.
Depends: python-zope.component but it is not going to be installed.
Depends: python-zope.container which is a virtual package.
Depends: python-zope.dublincore which is a virtual package.
Depends: python-zope.formlib (>= 4) which is a virtual package.
Depends: python-zope.i18n but it is not going to be installed.
Depends: python-zope.i18nmessageid but it is not going to be installed.
Depends: python-zope.lifecycleevent which is a virtual package.
Depends: python-zope.location but it is not going to be installed.
Depends: python-zope.publisher but it is not going to be installed.
Depends: python-zope.schema but it is not going to be installed.
Depends: python-zope.security but it is not going to be installed.
Depends: python-zope.traversing but it is not going to be installed.
python-schooltool :
Depends: python-hurry.query which is a virtual package.
Depends: python-rwproperty which is a virtual package.
Depends: python-xlrd but it is not going to be installed.
Depends: python-xlwt but it is not going to be installed.
Depends: python-z3c.autoinclude (>= 0.3.4) which is a virtual package.
Depends: python-z3c.form (>= 2.0) which is a virtual package.
Depends: python-z3c.formui which is a virtual package.
Depends: python-z3c.macro which is a virtual package.
Depends: python-z3c.rml which is a virtual package.
Depends: python-z3c.template which is a virtual package.
Depends: python-zc.catalog which is a virtual package.
Depends: python-zc.datetimewidget which is a virtual package.
Depends: python-zc.resourcelibrary which is a virtual package.
Depends: python-zc.table which is a virtual package.
Depends: python-zodb but it is not going to be installed.
Depends: python-zope.annotation which is a virtual package.
Depends: python-zope.app.applicationcontrol which is a virtual package.
Depends: python-zope.app.appsetup which is a virtual package.
Depends: python-zope.app.basicskin which is a virtual package.
Depends: python-zope.app.broken which is a virtual package.
Depends: python-zope.app.component which is a virtual package.
Depends: python-zope.app.container which is a virtual package.
Depends: python-zope.app.content which is a virtual package.
Depends: python-zope.app.dependable which is a virtual package.
Depends: python-zope.app.error which is a virtual package.
Depends: python-zope.app.exception which is a virtual package.
Depends: python-zope.app.form which is a virtual package.
Depends: python-zope.app.generations (>= 3.5) which is a virtual
package.
Depends: python-zope.app.http which is a virtual package.
Depends: python-zope.app.locales which is a virtual package.
Depends: python-zope.app.principalannotation which is a virtual
package.
Depends: python-zope.app.publication which is a virtual package.
Depends: python-zope.app.schema which is a virtual package.
Depends: python-zope.app.security which is a virtual package.
Depends: python-zope.app.server which is a virtual package.
Depends: python-zope.app.testing which is a virtual package.
Depends: python-zope.app.wsgi which is a virtual package.
Depends: python-zope.authentication but it is not going to be
installed.
Depends: python-zope.browser but it is not going to be installed.
Depends: python-zope.browsermenu which is a virtual package.
Depends: python-zope.browserpage (>= 3.10.1) which is a virtual
package.
Depends: python-zope.cachedescriptors but it is not going to be
installed.
Depends: python-zope.catalog which is a virtual package.
Depends: python-zope.component (>= 3.8) but it is not going to be
installed.
Depends: python-zope.configuration but it is not going to be installed.
Depends: python-zope.container (>= 3.7.2) which is a virtual package.
Depends: python-zope.contentprovider which is a virtual package.
Depends: python-zope.dublincore (>= 3.7) which is a virtual package.
Depends: python-zope.event but it is not going to be installed.
Depends: python-zope.file which is a virtual package.
Depends: python-zope.filerepresentation which is a virtual package.
Depends: python-zope.formlib (>= 4.0) which is a virtual package.
Depends: python-zope.html which is a virtual package.
Depends: python-zope.i18n (>= 3.5) but it is not going to be installed.
Depends: python-zope.i18nmessageid but it is not going to be installed.
Depends: python-zope.intid which is a virtual package.
Depends: python-zope.keyreference which is a virtual package.
Depends: python-zope.lifecycleevent which is a virtual package.
Depends: python-zope.location but it is not going to be installed.
Depends: python-zope.login which is a virtual package.
Depends: python-zope.mimetype which is a virtual package.
Depends: python-zope.pagetemplate (>= 3.5) which is a virtual package.
Depends: python-zope.password which is a virtual package.
Depends: python-zope.proxy but it is not going to be installed.
Depends: python-zope.publisher (>= 3.6) but it is not going to be
installed.
Depends: python-zope.schema but it is not going to be installed.
Depends: python-zope.security but it is not going to be installed.
Depends: python-zope.securitypolicy which is a virtual package.
Depends: python-zope.server which is a virtual package.
Depends: python-zope.session which is a virtual package.
Depends: python-zope.site which is a virtual package.
Depends: python-zope.size which is a virtual package.
Depends: python-zope.tales which is a virtual package.
Depends: python-zope.testbrowser but it is not going to be installed.
Depends: python-zope.testing but it is not going to be installed.
Depends: python-zope.traversing (>= 3.13) but it is not going to be
installed.
Depends: python-zope.ucol which is a virtual package.
Depends: python-zope.viewlet which is a virtual package.
The following actions will resolve these dependencies:

Keep the following packages at their current version:
1) python-schooltool [Not Installed]
2) python-schooltool.gradebook [Not Installed]
3) python-schooltool.intervention [Not Installed]
4) python-schooltool.lyceum.journal [Not Installed]
5) schooltool [Not Installed]



Accept this solution? [Y/n/q/?]


So, SchoolTool 2.0 is not installable on Debian testing/sid?


There is no reason why it shouldn't be (in theory).

- You can try using apt-get instead of aptitude. Sometimes it allows
packages to be installed that aptitude rejects.
- You can try installing the packages that aptitude is complaining about
before trying to install schooltool.
- You can try answering N to the "accept this solution" question, in
which case aptitude will usually present you with another solution.





--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Archive: 502F60EF.1020302@rogers.com">http://lists.debian.org/502F60EF.1020302@rogers.com
 
Old 08-18-2012, 10:47 AM
Chris Bannister
 
Default How to install SchoolTool 2.0 on Debian?

On Sat, Aug 18, 2012 at 11:06:06AM +0200, Csanyi Pal wrote:
> Edited it to correspond the newest version of Ubuntu:
> echo "deb http://ppa.launchpad.net/$ppa_name/ubuntu precise main" [snip]
^^^^^^
cough, cough.

--
"If you're not careful, the newspapers will have you hating the people
who are being oppressed, and loving the people who are doing the
oppressing." --- Malcolm X


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: http://lists.debian.org/20120818104700.GA17742@tal
 
Old 08-18-2012, 10:58 AM
Slavko
 
Default How to install SchoolTool 2.0 on Debian?

Hi,

Dňa Sat, 18 Aug 2012 11:06:06 +0200 Csanyi Pal <csanyipal@gmail.com>
nap*sal:

> So, SchoolTool 2.0 is not installable on Debian testing/sid?

The Ubuntu PPAs are desired for Ubuntu. There are often problems with
dependencies, because Ubuntu grabs the sid repository. You can try to use
the repo for older ubuntu version (i am always confused from their names,
then i cannot suggest any).

In generally, i can to suggest to don't use them, but sometime there are
nice apps packaged.

I am using for this simple solution - i download the source packages
and rebuild them for Debian. Sometime there is needed to tweak (remove)
the versioned build dependencies (because they are useless used),
sometime it works as is and sometime removing versions does not help,
because the versioned dependencies are proper filled :-)

Take look for tools as dget and debuild (devscripts package) for this:

dget -u url_to_dsc_file

this will download and unpack (without verification) the source package in
current dir. Then cd to the unpacked dir and do some version mangle:

dch -l somestring
dch -r

This will change/add package name local suffix and prepare changelog for
release - both are not needed, but useful. You can use the "dch -i"
instead, to add 1 to the debian package version automatically, but i
prefer the local string suffix. Then try build binary package with:

debuild -b

It can fails for more reason, but mostly for missing build dependencies,
inspect them and solve by installing and/or changing/removing dependency
version in the debian/control file.

The result .deb package(s) will be placed in parent dir (../).

I am mostly doing this in /tmp dir, but be careful, it can be cleared upon
boot.

good luck :-)

--
s pozdravom

Slavko
http://slavino.sk
 
Old 08-18-2012, 12:04 PM
Csanyi Pal
 
Default How to install SchoolTool 2.0 on Debian?

Gary Dale <garydale@rogers.com> writes:

> On 18/08/12 05:06 AM, Csanyi Pal wrote:
>> Brian<ad44@cityscape.co.uk> writes:
>>
>>> On Sat 18 Aug 2012 at 09:31:52 +0200, Csanyi Pal wrote:
>>>
>>>> I wish to install on my Debian GNU/Linux testing/sid system the
>>>> SchoolTool 2.0: http://book.schooltool.org/install-2_0.html
>>>>
>>>> I realise that that I can't follow steps:
>>>>
>>>> $ sudo add-apt-repository ppa:schooltool-owners/dev
>>>> $ sudo apt-get update
>>>>
>>>> $ sudo apt-get install schooltool
>>>>
>>>> because on debian there isn't such command:
>>>> add-apt-repository
>>> Correct.
>>>
>>>> $ sudo add-apt-repository ppa:schooltool-owners/dev
>>>> sudo: add-apt-repository: command not found
>>>>
>>>> however if I edit my sources.list:
>>>> deb-src ppa:schooltool-owners/dev
>>> Doesn't fit the pattern of other lines, does it? Try
>>>
>>> http://ppa.launchpad.net/schooltool-owners/
>>>
>>> in a browser and go from there to get a line which is not malformed.
>> Here follows is what I did.
>>
>> Downloaded the
>> http://blog.anantshri.info/content/uploads/2010/09/add-apt-repository.sh.txt
>> file.
>>
>> Edited it to correspond the newest version of Ubuntu:
>> echo "deb http://ppa.launchpad.net/$ppa_name/ubuntu precise main" [snip]
>>
>> In this line I replaced the word 'lucid' with 'precise'.
>>
>> Copied this file to /usr/sbin.
>>
>> Set up it's permissions so I have now:
>> $ ls -l /usr/sbin/add-apt-repository
>> -rwxr-xr-x 1 root root 723 aug 18 10:43 /usr/sbin/add-apt-repository
>>
>> Run the script:
>> $ sudo add-apt-repository ppa:schooltool-owners/dev
>> schooltool-owners/dev
>> Executing: gpg --ignore-time-conflict --no-options --no-default-keyring
>> --secret-keyring /tmp/tmp.y
>> irs4BqhK8 --trustdb-name /etc/apt//trustdb.gpg --keyring
>> /etc/apt/trusted.gpg --primary-keyring /et
>> c/apt/trusted.gpg --keyring
>> /etc/apt/trusted.gpg.d//debian-archive-squeeze-automatic.gpg --keyring
>> /etc/apt/trusted.gpg.d//debian-archive-squeeze-stable.gpg --keyring
>> /etc/apt/trusted.gpg.d//debian-
>> archive-wheezy-automatic.gpg --keyring
>> /etc/apt/trusted.gpg.d//debian-archive-wheezy-stable.gpg --k
>> eyserver keyserver.ubuntu.com --recv-keys C95C0E19386B7051
>> gpg: requesting key 386B7051 from hkp server keyserver.ubuntu.com
>> gpg: key 386B7051: public key "Launchpad PPA for SchoolTool Owners"
>> imported
>> gpg: Total number processed: 1
>> gpg: imported: 1 (RSA: 1)
>>
>> $ sudo aptitude update
>>
>> $ sudo aptitude install schooltool
>>
>> but get:
>>
>> The following NEW packages will be installed:
>> libjs-mochikit{a} python-openid{a} python-paste{a}
>> python-pastedeploy{a} python-pastescript{a} python-scgi{a}
>> python-schooltool{ab} python-schooltool.gradebook{ab}
>> python-schooltool.intervention{ab}
>> python-schooltool.lyceum.journal{ab} schooltool
>> 0 packages upgraded, 11 newly installed, 0 to remove and 5 not
>> upgraded.
>> Need to get 5478 kB of archives. After unpacking 26.4 MB will be used.
>> The following packages have unmet dependencies:
>> python-schooltool.lyceum.journal :
>> Depends: python-zc.table which is a virtual package.
>> Depends: python-zodb but it is not going to be installed.

[snip]

>> Depends: python-zope.traversing (>= 3.13) but it is not going to be
>> installed.
>> Depends: python-zope.ucol which is a virtual package.
>> Depends: python-zope.viewlet which is a virtual package.
>> The following actions will resolve these dependencies:
>>
>> Keep the following packages at their current version:
>> 1) python-schooltool [Not Installed]
>> 2) python-schooltool.gradebook [Not Installed]
>> 3) python-schooltool.intervention [Not Installed]
>> 4) python-schooltool.lyceum.journal [Not Installed]
>> 5) schooltool [Not Installed]
>>
>>
>>
>> Accept this solution? [Y/n/q/?]
>>
>>
>> So, SchoolTool 2.0 is not installable on Debian testing/sid?
>
> There is no reason why it shouldn't be (in theory).
>
> - You can try using apt-get instead of aptitude. Sometimes it allows
> packages to be installed that aptitude rejects.

$ sudo apt-get install schooltool
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
schooltool :
Depends: python-schooltool (>= 1:1.9) but it is not going to be
installed
Recommends: python-schooltool.gradebook but it is not going to be
installed
Recommends: python-schooltool.lyceum.journal but it is not going to be
installed
Recommends: python-schooltool.intervention but it is not going to be
installed
E: Unable to correct problems, you have held broken packages.

> - You can try installing the packages that aptitude is complaining
> about before trying to install schooltool.

Tried that too and installed the installable packages but can't
installed those virtual packages only.

I get again message:
The following actions will resolve these dependencies:

Keep the following packages at their current version:
1) python-schooltool [Not Installed]
2) python-schooltool.gradebook [Not Installed]
3) python-schooltool.intervention [Not Installed]
4) python-schooltool.lyceum.journal [Not Installed]
5) schooltool [Not Installed]

Tried again apt-get:

$ sudo apt-get install schooltool
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
schooltool :
Depends: python-schooltool (>= 1:1.9) but it is not going to be
installed
Recommends: python-schooltool.gradebook but it is not going to be
installed
Recommends: python-schooltool.lyceum.journal but it is not going to be
installed
Recommends: python-schooltool.intervention but it is not going to be
installed
E: Unable to correct problems, you have held broken packages.


> - You can try answering N to the "accept this solution" question, in
> which case aptitude will usually present you with another solution.

Accept this solution? [Y/n/q/?] n

*** No more solutions available ***

So, SchoolTool 2.0 is not installable on Debian testing/sid?

--
Regards from Pal


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 87ehn4mmo3.fsf@gmail.com">http://lists.debian.org/87ehn4mmo3.fsf@gmail.com
 
Old 08-18-2012, 01:07 PM
"Chris"
 
Default How to install SchoolTool 2.0 on Debian?

It's not that its not installable, its just that if you don't know what you are doing, or won't take the time to understand the ramifications of your actions, then its just better left alone.

You can very posibly damage your current Debian system if you just willy nilly start adding repos that are not native to your Debian system.

My suggestion if you are Hell-bent on installing that app: switch to ubuntu. This way at least the repo will be somewhat compatible and you'll be using the OS the repo was intended for.


Sent from my HTC.

----- Reply message -----
From: "Csanyi Pal" <csanyipal@gmail.com>
Date: Sat, Aug 18, 2012 7:04 am
Subject: How to install SchoolTool 2.0 on Debian?
To: <debian-user@lists.debian.org>

Gary Dale <garydale@rogers.com> writes:

> On 18/08/12 05:06 AM, Csanyi Pal wrote:
>> Brian<ad44@cityscape.co.uk> *writes:
>>
>>> On Sat 18 Aug 2012 at 09:31:52 +0200, Csanyi Pal wrote:
>>>
>>>> I wish to install on my Debian GNU/Linux testing/sid system the
>>>> SchoolTool 2.0: http://book.schooltool.org/install-2_0.html
>>>>
>>>> I realise that that I can't follow steps:
>>>>
>>>> $ sudo add-apt-repository ppa:schooltool-owners/dev
>>>> $ sudo apt-get update
>>>>
>>>> $ sudo apt-get install schooltool
>>>>
>>>> because on debian there isn't such command:
>>>> add-apt-repository
>>> Correct.
>>>
>>>> $ sudo add-apt-repository ppa:schooltool-owners/dev
>>>> sudo: add-apt-repository: command not found
>>>>
>>>> however if I edit my sources.list:
>>>> deb-src ppa:schooltool-owners/dev
>>> Doesn't fit the pattern of other lines, does it? Try
>>>
>>> * * http://ppa.launchpad.net/schooltool-owners/
>>>
>>> in a browser and go from there to get a line which is not malformed.
>> Here follows is what I did.
>>
>> Downloaded the
>> http://blog.anantshri.info/content/uploads/2010/09/add-apt-repository.sh.txt
>> file.
>>
>> Edited it to correspond the newest version of Ubuntu:
>> echo "deb http://ppa.launchpad.net/$ppa_name/ubuntu precise main" [snip]
>>
>> In this line I replaced the word 'lucid' with 'precise'.
>>
>> Copied this file to /usr/sbin.
>>
>> Set up it's permissions so I have now:
>> $ ls -l /usr/sbin/add-apt-repository
>> -rwxr-xr-x 1 root root 723 aug * 18 10:43 /usr/sbin/add-apt-repository
>>
>> Run the script:
>> $ sudo add-apt-repository ppa:schooltool-owners/dev
>> schooltool-owners/dev
>> Executing: gpg --ignore-time-conflict --no-options --no-default-keyring
>> --secret-keyring /tmp/tmp.y
>> irs4BqhK8 --trustdb-name /etc/apt//trustdb.gpg --keyring
>> /etc/apt/trusted.gpg --primary-keyring /et
>> c/apt/trusted.gpg --keyring
>> /etc/apt/trusted.gpg.d//debian-archive-squeeze-automatic.gpg --keyring
>> /etc/apt/trusted.gpg.d//debian-archive-squeeze-stable.gpg --keyring
>> /etc/apt/trusted.gpg.d//debian-
>> archive-wheezy-automatic.gpg --keyring
>> /etc/apt/trusted.gpg.d//debian-archive-wheezy-stable.gpg --k
>> eyserver keyserver.ubuntu.com --recv-keys C95C0E19386B7051
>> gpg: requesting key 386B7051 from hkp server keyserver.ubuntu.com
>> gpg: key 386B7051: public key "Launchpad PPA for SchoolTool Owners"
>> imported
>> gpg: Total number processed: 1
>> gpg: * * * * * * * imported: 1 *(RSA: 1)
>>
>> $ sudo aptitude update
>>
>> $ sudo aptitude install schooltool
>>
>> but get:
>>
>> The following NEW packages will be installed:
>> * *libjs-mochikit{a} python-openid{a} python-paste{a}
>> * *python-pastedeploy{a} python-pastescript{a} python-scgi{a}
>> * *python-schooltool{ab} python-schooltool.gradebook{ab}
>> * *python-schooltool.intervention{ab}
>> * *python-schooltool.lyceum.journal{ab} schooltool
>> 0 packages upgraded, 11 newly installed, 0 to remove and 5 not
>> * *upgraded.
>> Need to get 5478 kB of archives. After unpacking 26.4 MB will be used.
>> The following packages have unmet dependencies:
>> * python-schooltool.lyceum.journal :
>> Depends: python-zc.table which is a virtual package.
>> Depends: python-zodb but it is not going to be installed.

[snip]

>> Depends: python-zope.traversing (>= 3.13) but it is not going to be
>> * *installed.
>> Depends: python-zope.ucol which is a virtual package.
>> Depends: python-zope.viewlet which is a virtual package.
>> The following actions will resolve these dependencies:
>>
>> * *Keep the following packages at their current version:
>> 1) * * python-schooltool [Not Installed]
>> 2) * * python-schooltool.gradebook [Not Installed]
>> 3) * * python-schooltool.intervention [Not Installed]
>> 4) * * python-schooltool.lyceum.journal [Not Installed]
>> 5) * * schooltool [Not Installed]
>>
>>
>>
>> Accept this solution? [Y/n/q/?]
>>
>>
>> So, SchoolTool 2.0 is not installable on Debian testing/sid?
>
> There is no reason why it shouldn't be (in theory).
>
> - You can try using apt-get instead of aptitude. Sometimes it allows
> packages to be installed that aptitude rejects.

$ sudo apt-get install schooltool
Reading package lists... Done
Building dependency tree * * *
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
schooltool :
Depends: python-schooltool (>= 1:1.9) but it is not going to be
installed
Recommends: python-schooltool.gradebook but it is not going to be
installed
Recommends: python-schooltool.lyceum.journal but it is not going to be
installed
Recommends: python-schooltool.intervention but it is not going to be
installed
E: Unable to correct problems, you have held broken packages.

> - You can try installing the packages that aptitude is complaining
> about before trying to install schooltool.

Tried that too and installed the installable packages but can't
installed those virtual packages only.

I get again message:
The following actions will resolve these dependencies:

* * Keep the following packages at their current version:
1) * * python-schooltool [Not Installed]
2) * * python-schooltool.gradebook [Not Installed]
3) * * python-schooltool.intervention [Not Installed]
4) * * python-schooltool.lyceum.journal [Not Installed]
5) * * schooltool [Not Installed]

Tried again apt-get:

$ sudo apt-get install schooltool
Reading package lists... Done
Building dependency tree * * *
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
schooltool :
Depends: python-schooltool (>= 1:1.9) but it is not going to be
installed
Recommends: python-schooltool.gradebook but it is not going to be
installed
Recommends: python-schooltool.lyceum.journal but it is not going to be
installed
Recommends: python-schooltool.intervention but it is not going to be
installed
E: Unable to correct problems, you have held broken packages.


> - You can try answering N to the "accept this solution" question, in
> which case aptitude will usually present you with another solution.

Accept this solution? [Y/n/q/?] n

*** No more solutions available ***

So, SchoolTool 2.0 is not installable on Debian testing/sid?

--
Regards from Pal


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: http://lists.debian.org/87ehn4mmo3.fsf@gmail.com
 
Old 08-18-2012, 03:58 PM
Gary Dale
 
Default How to install SchoolTool 2.0 on Debian?

On 18/08/12 08:04 AM, Csanyi Pal wrote:

Gary Dale<garydale@rogers.com> writes:


On 18/08/12 05:06 AM, Csanyi Pal wrote:

Brian<ad44@cityscape.co.uk> writes:


On Sat 18 Aug 2012 at 09:31:52 +0200, Csanyi Pal wrote:


I wish to install on my Debian GNU/Linux testing/sid system the
SchoolTool 2.0: http://book.schooltool.org/install-2_0.html

I realise that that I can't follow steps:

$ sudo add-apt-repository ppa:schooltool-owners/dev
$ sudo apt-get update

$ sudo apt-get install schooltool

because on debian there isn't such command:
add-apt-repository

Correct.


$ sudo add-apt-repository ppa:schooltool-owners/dev
sudo: add-apt-repository: command not found

however if I edit my sources.list:
deb-src ppa:schooltool-owners/dev

Doesn't fit the pattern of other lines, does it? Try

http://ppa.launchpad.net/schooltool-owners/

in a browser and go from there to get a line which is not malformed.

Here follows is what I did.

Downloaded the
http://blog.anantshri.info/content/uploads/2010/09/add-apt-repository.sh.txt
file.

Edited it to correspond the newest version of Ubuntu:
echo "deb http://ppa.launchpad.net/$ppa_name/ubuntu precise main" [snip]

In this line I replaced the word 'lucid' with 'precise'.

Copied this file to /usr/sbin.

Set up it's permissions so I have now:
$ ls -l /usr/sbin/add-apt-repository
-rwxr-xr-x 1 root root 723 aug 18 10:43 /usr/sbin/add-apt-repository

Run the script:
$ sudo add-apt-repository ppa:schooltool-owners/dev
schooltool-owners/dev
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring
--secret-keyring /tmp/tmp.y
irs4BqhK8 --trustdb-name /etc/apt//trustdb.gpg --keyring
/etc/apt/trusted.gpg --primary-keyring /et
c/apt/trusted.gpg --keyring
/etc/apt/trusted.gpg.d//debian-archive-squeeze-automatic.gpg --keyring
/etc/apt/trusted.gpg.d//debian-archive-squeeze-stable.gpg --keyring
/etc/apt/trusted.gpg.d//debian-
archive-wheezy-automatic.gpg --keyring
/etc/apt/trusted.gpg.d//debian-archive-wheezy-stable.gpg --k
eyserver keyserver.ubuntu.com --recv-keys C95C0E19386B7051
gpg: requesting key 386B7051 from hkp server keyserver.ubuntu.com
gpg: key 386B7051: public key "Launchpad PPA for SchoolTool Owners"
imported
gpg: Total number processed: 1
gpg: imported: 1 (RSA: 1)

$ sudo aptitude update

$ sudo aptitude install schooltool

but get:

The following NEW packages will be installed:
libjs-mochikit{a} python-openid{a} python-paste{a}
python-pastedeploy{a} python-pastescript{a} python-scgi{a}
python-schooltool{ab} python-schooltool.gradebook{ab}
python-schooltool.intervention{ab}
python-schooltool.lyceum.journal{ab} schooltool
0 packages upgraded, 11 newly installed, 0 to remove and 5 not
upgraded.
Need to get 5478 kB of archives. After unpacking 26.4 MB will be used.
The following packages have unmet dependencies:
python-schooltool.lyceum.journal :
Depends: python-zc.table which is a virtual package.
Depends: python-zodb but it is not going to be installed.

[snip]


Depends: python-zope.traversing (>= 3.13) but it is not going to be
installed.
Depends: python-zope.ucol which is a virtual package.
Depends: python-zope.viewlet which is a virtual package.
The following actions will resolve these dependencies:

Keep the following packages at their current version:
1) python-schooltool [Not Installed]
2) python-schooltool.gradebook [Not Installed]
3) python-schooltool.intervention [Not Installed]
4) python-schooltool.lyceum.journal [Not Installed]
5) schooltool [Not Installed]



Accept this solution? [Y/n/q/?]


So, SchoolTool 2.0 is not installable on Debian testing/sid?

There is no reason why it shouldn't be (in theory).

- You can try using apt-get instead of aptitude. Sometimes it allows
packages to be installed that aptitude rejects.

$ sudo apt-get install schooltool
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
schooltool :
Depends: python-schooltool (>= 1:1.9) but it is not going to be
installed
Recommends: python-schooltool.gradebook but it is not going to be
installed
Recommends: python-schooltool.lyceum.journal but it is not going to be
installed
Recommends: python-schooltool.intervention but it is not going to be
installed
E: Unable to correct problems, you have held broken packages.


- You can try installing the packages that aptitude is complaining
about before trying to install schooltool.

Tried that too and installed the installable packages but can't
installed those virtual packages only.

I get again message:
The following actions will resolve these dependencies:

Keep the following packages at their current version:
1) python-schooltool [Not Installed]
2) python-schooltool.gradebook [Not Installed]
3) python-schooltool.intervention [Not Installed]
4) python-schooltool.lyceum.journal [Not Installed]
5) schooltool [Not Installed]

Tried again apt-get:

$ sudo apt-get install schooltool
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
schooltool :
Depends: python-schooltool (>= 1:1.9) but it is not going to be
installed
Recommends: python-schooltool.gradebook but it is not going to be
installed
Recommends: python-schooltool.lyceum.journal but it is not going to be
installed
Recommends: python-schooltool.intervention but it is not going to be
installed
E: Unable to correct problems, you have held broken packages.



- You can try answering N to the "accept this solution" question, in
which case aptitude will usually present you with another solution.

Accept this solution? [Y/n/q/?] n

*** No more solutions available ***

So, SchoolTool 2.0 is not installable on Debian testing/sid?


I never said it would be an easy, one-step process. What's missing from
above are the error messages you got when you tried to install the
packages apt-get complained about.


For example, the main missing package appears to by python-schooltool.
What message did you get when you tried to install it?


Python-zodb looks like it may be another key package. What happened when
you tried to install it?



--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Archive: 502FBBC1.2070107@rogers.com">http://lists.debian.org/502FBBC1.2070107@rogers.com
 

Thread Tools




All times are GMT. The time now is 03:42 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org