FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 04-13-2008, 01:30 AM
Jude DaShiell
 
Default package conflict

Using unstable distribution installing bsdgames and emacs does not work
completely successfully. It's either one package or the other but not
both on the same machine. Probably both packages dependencies need
updating on the debian repositories so that whenever one is installed it
automatically uninstalls the other package. dpkg can't get a lock on
/var/lock/dpkg/ when you try to install both of these packages and this
happens in the install phase when dictionaries-common gets contacted and
asked to do some work.




--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 04-13-2008, 01:56 AM
Ron Johnson
 
Default package conflict

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 04/12/08 20:30, Jude DaShiell wrote:
> Using unstable distribution installing bsdgames and emacs does not work
> completely successfully. It's either one package or the other but not
> both on the same machine. Probably both packages dependencies need
> updating on the debian repositories so that whenever one is installed it
> automatically uninstalls the other package. dpkg can't get a lock on
> /var/lock/dpkg/ when you try to install both of these packages and this
> happens in the install phase when dictionaries-common gets contacted and
> asked to do some work.

Please paste the exact command used, plus error message.

Works for me...

# apt-get install bsdgames emacs
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
emacs22 emacs22-bin-common emacs22-common emacsen-common
Suggested packages:
emacs22-common-non-dfsg emacs22-el
The following NEW packages will be installed:
bsdgames emacs emacs22 emacs22-bin-common emacs22-common
emacsen-common
0 upgraded, 6 newly installed, 0 to remove and 443 not upgraded.
Need to get 17.3MB/18.3MB of archives.
After this operation, 63.6MB of additional disk space will be used.
Do you want to continue [Y/n]?
Get:1 ftp://mirrors.kernel.org unstable/main emacsen-common 1.4.17
[17.6kB]
Get:2 ftp://mirrors.kernel.org unstable/main emacs22-common 22.2+1-1
[14.5MB]
48% [2 emacs22-common 8323836/14.5MB 57%]

50% [2 emacs22-common 8734684/14.5MB 60%]

52% [2 emacs22-common 9139980/14.5MB 62%]

Get:3 ftp://mirrors.kernel.org unstable/main emacs22-bin-common
22.2+1-1 [161kB]
Get:4 ftp://mirrors.kernel.org unstable/main emacs22 22.2+1-1
[2585kB]
Get:5 ftp://mirrors.kernel.org unstable/main emacs 22.2+1-1 [19.0kB]

Fetched 17.3MB in 27s (624kB/s)

Reading package fields... Done
Reading package status... Done
Retrieving bug reports... Done
Parsing Found/Fixed information... Done
Selecting previously deselected package bsdgames.
(Reading database ... 240401 files and directories currently installed.)
Unpacking bsdgames (from .../bsdgames_2.17-14_i386.deb) ...
Selecting previously deselected package emacsen-common.
Unpacking emacsen-common (from .../emacsen-common_1.4.17_all.deb) ...
Selecting previously deselected package emacs22-common.
Unpacking emacs22-common (from .../emacs22-common_22.2+1-1_all.deb) ...
Selecting previously deselected package emacs22-bin-common.
Unpacking emacs22-bin-common (from
.../emacs22-bin-common_22.2+1-1_i386.deb) ...
Selecting previously deselected package emacs22.
Unpacking emacs22 (from .../emacs22_22.2+1-1_i386.deb) ...
Selecting previously deselected package emacs.
Unpacking emacs (from .../emacs_22.2+1-1_all.deb) ...
Setting up bsdgames (2.17-14) ...
Setting up emacsen-common (1.4.17) ...
emacsen-common: Handling install of emacsen flavor emacs
Setting up emacs22-common (22.2+1-1) ...
Setting up emacs22-bin-common (22.2+1-1) ...
Setting up emacs22 (22.2+1-1) ...
emacs-install emacs22
install/dictionaries-common: Byte-compiling for emacsen flavour emacs22
Wrote /usr/share/emacs22/site-lisp/dictionaries-common/debian-ispell.elc
Wrote /usr/share/emacs22/site-lisp/dictionaries-common/ispell.elc
Wrote /usr/share/emacs22/site-lisp/dictionaries-common/flyspell.elc
emacsen-common: Handling install of emacsen flavor emacs22
emacsen-common: byte-compiling for emacs22
Loading /etc/emacs22/site-start.d/00debian-vars.el (source)...
Loading /etc/emacs/site-start.d/50autoconf.el (source)...
Loading /etc/emacs/site-start.d/50dictionaries-common.el (source)...
Loading debian-ispell...
Loading /var/cache/dictionaries-common/emacsen-ispell-default.el
(source)...
Loading /var/cache/dictionaries-common/emacsen-ispell-dicts.el
(source)...
Loading /etc/emacs/site-start.d/50festival.el (source)...
Wrote /etc/emacs22/site-start.d/00debian-vars.elc
Wrote /usr/share/emacs22/site-lisp/debian-startup.elc
Setting up emacs (22.2+1-1) ...



- --
Ron Johnson, Jr.
Jefferson LA USA

We want... a Shrubbery!!
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFIAWhCS9HxQb37XmcRArJ3AJ9x2N/PB9RTniW3RHRGDl0ZldWFgQCfQnmN
602I6QWeegild8lFTqhaNBA=
=6Sa/
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 04-13-2008, 06:41 AM
NN_il_Confusionario
 
Default package conflict

On Sat, Apr 12, 2008 at 08:56:18PM -0500, Ron Johnson wrote:
> On 04/12/08 20:30, Jude DaShiell wrote:
> > dpkg can't get a lock on
> > /var/lock/dpkg/ when you try to install both of these packages and this
> > happens in the install phase when dictionaries-common gets contacted and
> > asked to do some work.
>
> Works for me...

dpkg had important recent changes in unstable. Do you run the same
version of dpkg ?

--
Chi usa software non libero avvelena anche te. Digli di smettere.
Informatica=arsenico: minime dosi in rari casi patologici, altrimenti letale.
Informatica=bomba: intelligente solo per gli stupidi che ci credono.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 04-13-2008, 06:54 AM
Ron Johnson
 
Default package conflict

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 04/13/08 01:41, NN_il_Confusionario wrote:
> On Sat, Apr 12, 2008 at 08:56:18PM -0500, Ron Johnson wrote:
>> On 04/12/08 20:30, Jude DaShiell wrote:
>>> dpkg can't get a lock on
>>> /var/lock/dpkg/ when you try to install both of these packages and this
>>> happens in the install phase when dictionaries-common gets contacted and
>>> asked to do some work.
>> Works for me...
>
> dpkg had important recent changes in unstable. Do you run the same
> version of dpkg ?

Am I too far behind current?

$ apt-cache policy dpkg
dpkg:
Installed: 1.14.16.6
Candidate: 1.14.18
Version table:
1.14.18 0
500 ftp://mirrors.kernel.org unstable/main Packages
*** 1.14.16.6 0
100 /var/lib/dpkg/status

- --
Ron Johnson, Jr.
Jefferson LA USA

We want... a Shrubbery!!
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFIAa42S9HxQb37XmcRAqP8AJ9jxcXymlr7+9kphj/iyBKSEooMgQCgiVGC
eMBPpQumSx2yQBW3ci5j1tE=
=HpAP
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 04-13-2008, 03:56 PM
NN_il_Confusionario
 
Default package conflict

On Sun, Apr 13, 2008 at 01:54:46AM -0500, Ron Johnson wrote:
> On 04/13/08 01:41, NN_il_Confusionario wrote:
> > dpkg had important recent changes in unstable.
> Am I too far behind current?
> Installed: 1.14.16.6
> Candidate: 1.14.18

Linkname: Important changes in dpkg 1.14.18 in sid
URL: http://lists.debian.org/debian-devel-announce/2008/04/msg00004.html

--
Chi usa software non libero avvelena anche te. Digli di smettere.
Informatica=arsenico: minime dosi in rari casi patologici, altrimenti letale.
Informatica=bomba: intelligente solo per gli stupidi che ci credono.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 04-13-2008, 07:14 PM
Ron Johnson
 
Default package conflict

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 04/13/08 10:56, NN_il_Confusionario wrote:
> On Sun, Apr 13, 2008 at 01:54:46AM -0500, Ron Johnson wrote:
>> On 04/13/08 01:41, NN_il_Confusionario wrote:
>>> dpkg had important recent changes in unstable.
>> Am I too far behind current?
>> Installed: 1.14.16.6
>> Candidate: 1.14.18
>
> Linkname: Important changes in dpkg 1.14.18 in sid
> URL: http://lists.debian.org/debian-devel-announce/2008/04/msg00004.html

Thanks. Those packages still install perfectly, though.

- --
Ron Johnson, Jr.
Jefferson LA USA

We want... a Shrubbery!!
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFIAluwS9HxQb37XmcRAv8TAJ9uvT8bBclNWotPG2aFoF iJQQIjKACfdi7D
RxE5g38tND+YTjEpV+cc/AA=
=jVbd
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 04:28 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org