Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian User (http://www.linux-archive.org/debian-user/)
-   -   pam_winbind.so missing when upgrade to wheezy/sid (http://www.linux-archive.org/debian-user/680700-pam_winbind-so-missing-when-upgrade-wheezy-sid.html)

Muhammad Yousuf Khan 07-06-2012 12:35 PM

pam_winbind.so missing when upgrade to wheezy/sid
 
On Fri, Jul 6, 2012 at 5:28 PM, Muhammad Yousuf Khan <sirtcp@gmail.com> wrote:
> i was using Squeeze 6.0.4 and upgraded to wheezy/sid and this machine
> is working as SAMBA server with domain controller authentication.
>
> before the upgrade i had a file "pam_winbind.so" on /lib/security/


> (but no there are other *.so file and others are missing.)
(sorry let me correct the above French phrase :P)

all the *.so files are still present but the mantioned one is missing.




>
> as per the requirement i had mentioned the file path for winbind use.
> in /etc/pam.d/common-auth and /etc/pam.d/common-account
>
> now samba throwing this error
> Jul 6 17:12:40 nasbox smbd[28242]: PAM adding faulty module:
> /lib/security/pam_winbind.so
> Jul 6 17:12:40 nasbox smbd[28242]: PAM unable to
> dlopen(/lib/security/pam_winbind.so): /lib/security/pam_winbind.so:
> cannot open shared object file: No such file or directory
> Jul 6 17:12:40 nasbox smbd[28242]: PAM adding faulty module:
> /lib/security/pam_winbind.so
> Jul 6 17:17:01 nasbox CRON[28243]: PAM unable to
> dlopen(/lib/security/pam_winbind.so): /lib/security/pam_winbind.so:
> cannot open shared object file: No such file or directory
> Jul 6 17:17:01 nasbox CRON[28243]: PAM adding faulty module:
> /lib/security/pam_winbind.so
>
>
> however every thing is working fine. users can access the samba share
> with no issues.
>
> Kindly help to resolve the issaue
>
> Thanks,


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: CAGWVfMnWonkYnuugx80NRQp48yFs94qXa7mHr-8cMGSshK8n-g@mail.gmail.com">http://lists.debian.org/CAGWVfMnWonkYnuugx80NRQp48yFs94qXa7mHr-8cMGSshK8n-g@mail.gmail.com

Camaleón 07-06-2012 03:09 PM

pam_winbind.so missing when upgrade to wheezy/sid
 
On Fri, 06 Jul 2012 17:28:45 +0500, Muhammad Yousuf Khan wrote:

> i was using Squeeze 6.0.4 and upgraded to wheezy/sid and this machine is
> working as SAMBA server with domain controller authentication.
>
> before the upgrade i had a file "pam_winbind.so" on /lib/security/ but
> no there are other *.so file and others are missing.

The mentioned library file is now provided by "winbind4" package (new since
wheezy).

> as per the requirement i had mentioned the file path for winbind use. in
> /etc/pam.d/common-auth and /etc/pam.d/common-account
>
> now samba throwing this error
> Jul 6 17:12:40 nasbox smbd[28242]: PAM adding faulty module: /lib/security/pam_winbind.so
> Jul 6 17:12:40 nasbox smbd[28242]: PAM unable to dlopen(/lib/security/pam_winbind.so): /lib/security/pam_winbind.so: cannot open shared object file: No such file or directory

(...)

If the file is not present the errors look right but I wonder what
windbind implementation are you running :-?, maybe "dpkg -l | grep -i winbind"
can shed some light here.

Greetings,

--
Camaleón


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: http://lists.debian.org/jt6v3j$339$10@dough.gmane.org

Muhammad Yousuf Khan 07-07-2012 08:16 PM

pam_winbind.so missing when upgrade to wheezy/sid
 
On Fri, Jul 6, 2012 at 8:09 PM, Camaleón <noelamac@gmail.com> wrote:
> On Fri, 06 Jul 2012 17:28:45 +0500, Muhammad Yousuf Khan wrote:
>
>> i was using Squeeze 6.0.4 and upgraded to wheezy/sid and this machine is
>> working as SAMBA server with domain controller authentication.
>>
>> before the upgrade i had a file "pam_winbind.so" on /lib/security/ but
>> no there are other *.so file and others are missing.
>
> The mentioned library file is now provided by "winbind4" package (new since
> wheezy).
>
>> as per the requirement i had mentioned the file path for winbind use. in
>> /etc/pam.d/common-auth and /etc/pam.d/common-account
>>
>> now samba throwing this error
>> Jul 6 17:12:40 nasbox smbd[28242]: PAM adding faulty module: /lib/security/pam_winbind.so
>> Jul 6 17:12:40 nasbox smbd[28242]: PAM unable to dlopen(/lib/security/pam_winbind.so): /lib/security/pam_winbind.so: cannot open shared object file: No such file or directory
>
> (...)
>
> If the file is not present the errors look right but I wonder what
> windbind implementation are you running :-?, maybe "dpkg -l | grep -i winbind"
> can shed some light here.


ii libnss-winbind:i386 2:3.6.5-3
Samba nameservice integration plugins
ii libpam-winbind:i386 2:3.6.5-3
Windows domain authentication integration plugin
ii libwbclient0:i386 2:3.6.5-3
Samba winbind client library
ii winbind 2:3.6.5-3
Samba nameservice integration server

i dont know what version is this but this is what i am using and the
OS is Wheezy/sid

>
> Greetings,
>
> --
> Camaleón
>
>
> --
> To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
> Archive: http://lists.debian.org/jt6v3j$339$10@dough.gmane.org
>


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: http://lists.debian.org/CAGWVfM=0QUz8Z4q6Mkk1rLSeGSLYWSOF=dzPsZxnjVDjeF3eb g@mail.gmail.com

Camaleón 07-08-2012 12:16 PM

pam_winbind.so missing when upgrade to wheezy/sid
 
On Sun, 08 Jul 2012 01:16:46 +0500, Muhammad Yousuf Khan wrote:

> On Fri, Jul 6, 2012 at 8:09 PM, Camaleón <noelamac@gmail.com> wrote:

(...)

>> If the file is not present the errors look right but I wonder what
>> windbind implementation are you running :-?, maybe "dpkg -l | grep -i
>> winbind" can shed some light here.

(...)

> ii winbind 2:3.6.5-3 Samba nameservice integration server
^^^^^^^

Okay, there it is.

I guess the winbind package was updated when you upgraded and thus kept,
but in Wheezy it does not provide the mentioned library, present in
winbind4.

> i dont know what version is this but this is what i am using and the OS
> is Wheezy/sid

This is the wheezy version, which is fine. The mess has to be because of
the upgrade, but I'm not sure if winbind4 is required or necessary for
your setup (my wild guess is that NO unless you are using samba4), maybe
PAM is complaining because you are loading a module that now is not
present or is named differently, I can't really tell :-?

I would open a bug report against "winbind" package and wait for a
response from devels.

Greetings,

--
Camaleón


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: http://lists.debian.org/jtbtnb$s8h$8@dough.gmane.org

Muhammad Yousuf Khan 07-09-2012 01:41 PM

pam_winbind.so missing when upgrade to wheezy/sid
 
On Sun, Jul 8, 2012 at 5:16 PM, Camaleón <noelamac@gmail.com> wrote:
> On Sun, 08 Jul 2012 01:16:46 +0500, Muhammad Yousuf Khan wrote:
>
>> On Fri, Jul 6, 2012 at 8:09 PM, Camaleón <noelamac@gmail.com> wrote:
>
> (...)
>
>>> If the file is not present the errors look right but I wonder what
>>> windbind implementation are you running :-?, maybe "dpkg -l | grep -i
>>> winbind" can shed some light here.
>
> (...)
>
>> ii winbind 2:3.6.5-3 Samba nameservice integration server
> ^^^^^^^
>
> Okay, there it is.
>
> I guess the winbind package was updated when you upgraded and thus kept,
> but in Wheezy it does not provide the mentioned library, present in
> winbind4.
>
>> i dont know what version is this but this is what i am using and the OS
>> is Wheezy/sid
>
> This is the wheezy version, which is fine. The mess has to be because of
> the upgrade, but I'm not sure if winbind4 is required or necessary for
> your setup (my wild guess is that NO unless you are using samba4), maybe



> PAM is complaining because you are loading a module that now is not
> present or is named differently, I can't really tell :-?

i also dont know because i am following traditional method to connect
Samba server where winbind and krb5 is required. here is some more
details about my samba. but serprisingly the version of winbind and
samba is same. and secondly i can not understand the version number.
would you please help me in understanding the version number.


root@test:/# dpkg -l | grep samba
ii samba 2:3.6.5-3
SMB/CIFS file, print, and login server for Unix
ii samba-common 2:3.6.5-3
common files used by both the Samba server and client
ii samba-common-bin 2:3.6.5-3
common files used by both the Samba server and client
ii samba-doc 2:3.6.5-3
Samba documentation



>
> I would open a bug report against "winbind" package and wait for a
> response from devels..

Thanks for the help :)

btw this msg is messing my syslog server do you think i should comment
the line in config files?



>
> Greetings,
>
> --
> Camaleón
>
>
> --
> To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
> Archive: http://lists.debian.org/jtbtnb$s8h$8@dough.gmane.org
>


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: http://lists.debian.org/CAGWVfMkFP3JOVA1Y8Uki8nDqxs4h-p2bcsLutVJ1KR91z=4J+w@mail.gmail.com

Camaleón 07-09-2012 02:29 PM

pam_winbind.so missing when upgrade to wheezy/sid
 
On Mon, 09 Jul 2012 18:41:05 +0500, Muhammad Yousuf Khan wrote:

> On Sun, Jul 8, 2012 at 5:16 PM, Camaleón <noelamac@gmail.com> wrote:

(...)

>> PAM is complaining because you are loading a module that now is not
>> present or is named differently, I can't really tell :-?
>
> i also dont know because i am following traditional method to connect
> Samba server where winbind and krb5 is required. here is some more
> details about my samba. but serprisingly the version of winbind and
> samba is same. and secondly i can not understand the version number.
> would you please help me in understanding the version number.
>
>
> root@test:/# dpkg -l | grep samba
> ii samba 2:3.6.5-3 SMB/CIFS file, print, and login server for Unix
> ii samba-common 2:3.6.5-3 common files used by both the Samba server and client
> ii samba-common-bin 2:3.6.5-3 common files used by both the Samba server and client
> ii samba-doc 2:3.6.5-3 Samba documentation

You mean why both, winbind and samba, share the same version number? A
devel or packager will confirm but my guess is that because they come
from the same source (samba) they can be keeping the same numbering for
simple convenience.

Also, note that wheezy has now 3.6.6, you should udpate those :-)

>> I would open a bug report against "winbind" package and wait for a
>> response from devels..
>
> Thanks for the help :)
>
> btw this msg is messing my syslog server do you think i should comment
> the line in config files?

No, I would report it ASAP, maybe the requested library is missing and it
has to be corrected. Mmm, hold on...

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=674853

Maye you are being hit by this, that is, that you need to get "libpam-winbind"
but the library will be placed under "/lib/[arch]-linux-gnu/security/pam_winbind.so"
instead "/lib/security/pam_winbind.so". What a mess :-P

Greetings,

--
Camaleón


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: http://lists.debian.org/jtepro$sc9$11@dough.gmane.org

Muhammad Yousuf Khan 07-10-2012 06:22 AM

pam_winbind.so missing when upgrade to wheezy/sid
 
On Mon, Jul 9, 2012 at 7:29 PM, Camaleón <noelamac@gmail.com> wrote:
> On Mon, 09 Jul 2012 18:41:05 +0500, Muhammad Yousuf Khan wrote:
>
>> On Sun, Jul 8, 2012 at 5:16 PM, Camaleón <noelamac@gmail.com> wrote:
>
> (...)
>
>>> PAM is complaining because you are loading a module that now is not
>>> present or is named differently, I can't really tell :-?
>>
>> i also dont know because i am following traditional method to connect
>> Samba server where winbind and krb5 is required. here is some more
>> details about my samba. but serprisingly the version of winbind and
>> samba is same. and secondly i can not understand the version number.
>> would you please help me in understanding the version number.
>>
>>
>> root@test:/# dpkg -l | grep samba
>> ii samba 2:3.6.5-3 SMB/CIFS file, print, and login server for Unix
>> ii samba-common 2:3.6.5-3 common files used by both the Samba server and client
>> ii samba-common-bin 2:3.6.5-3 common files used by both the Samba server and client
>> ii samba-doc 2:3.6.5-3 Samba documentation
>
> You mean why both, winbind and samba, share the same version number? A
> devel or packager will confirm but my guess is that because they come
> from the same source (samba) they can be keeping the same numbering for
> simple convenience.
>
> Also, note that wheezy has now 3.6.6, you should udpate those :-)

i am using Wheezy SID in production and recently some one has posted
in debian list that his system is crashing on boot after upgrading his
system. and that was the question that i was asking in my last safe
update thread. and all the pros where saying that a system can not be
crash in result of update. now after reading this guy's problem i
think i should wait till stable version. since the system is in
production.
:-(

>
>>> I would open a bug report against "winbind" package and wait for a
>>> response from devels..
>>
>> Thanks for the help :)
>>
>> btw this msg is messing my syslog server do you think i should comment
>> the line in config files?
>
> No, I would report it ASAP, maybe the requested library is missing and it
> has to be corrected. Mmm, hold on...
>
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=674853
>
> Maye you are being hit by this, that is, that you need to get "libpam-winbind"
> but the library will be placed under "/lib/[arch]-linux-gnu/security/pam_winbind.so"
> instead "/lib/security/pam_winbind.so". What a mess :-P

Thanks mate, i think we resolve the issue. i just run the find
command here is the output
root@box:/# find ./ -name '*winbind.so*'
./lib/i386-linux-gnu/security/pam_winbind.so
./lib/i386-linux-gnu/libnss_winbind.so.2

and i change the path accordingly into these files.
/etc/pam.d/common-auth
/etc/pam,d/common-acccount

and restarted the samba service several times. and the specified
errors are gone. lately on every service restart i was getting this
message but now its gone.

thanks for helping me out.





>
> Greetings,
>
> --
> Camaleón
>
>
> --
> To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
> Archive: http://lists.debian.org/jtepro$sc9$11@dough.gmane.org
>


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: CAGWVfMmWJE-upfinvatGT68-f7fm424crwsquLLetptuTUiX6w@mail.gmail.com">http://lists.debian.org/CAGWVfMmWJE-upfinvatGT68-f7fm424crwsquLLetptuTUiX6w@mail.gmail.com


All times are GMT. The time now is 02:57 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.