Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian User (http://www.linux-archive.org/debian-user/)
-   -   i am getting errors when i run aptitude upgrade in debian squeeze (http://www.linux-archive.org/debian-user/678086-i-am-getting-errors-when-i-run-aptitude-upgrade-debian-squeeze.html)

Darac Marjal 06-28-2012 12:21 PM

i am getting errors when i run aptitude upgrade in debian squeeze
 
On Thu, Jun 28, 2012 at 05:43:48PM +0530, Joby Mathew wrote:
> root@test:~# aptitude upgrade�
> The following packages will be upgraded:�
[cut]
> 53 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
> Need to get 0 B/43.5 MB of archives. After unpacking 637 kB will be used.
> Do you want to continue? [Y/n/?] y
> Reading changelogs... Done � � � � � � ��
> Extracting templates from packages: 100%
> Preconfiguring packages ...
> Setting up initscripts (2.88dsf-13.1+squeeze1) ...
> insserv: warning: script 'subversion' missing LSB tags and overrides
> insserv: There is a loop between service munin-node and subversion if
> stopped
> insserv: �loop involving service subversion at depth 2
> insserv: �loop involving service munin-node at depth 1
> insserv: Stopping subversion depends on munin-node and therefore on system
> facility `$all' which can not be true!
> insserv: exiting now without changing boot order!
> update-rc.d: error: insserv rejected the script header
> dpkg: error processing initscripts (--configure):
> �subprocess installed post-installation script returned error exit status
> 1
> configured to not write apport reports
> �� � � � � � � � � � � � � � � � � � �Errors were encountered while
> processing:
> �initscripts
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> A package failed to install. �Trying to recover:
[cut]

OK, so you have a conflict in the LSB headers for subversion and
munin-node[1]. Try updating them first, which should fix their headers,
then the rest of the system.

(Actually, on second thoughts, why does your subversion depend on
munin-node? That seems suspect to me)

D.

[1] Background: init-scripts now use formatted-comments to declare
dependencies, insserv re-orders your init-scripts based on their
dependencies.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120628122124.GB15575@darac.org.uk">http://lists.debian.org/20120628122124.GB15575@darac.org.uk

Mika Suomalainen 06-28-2012 03:28 PM

i am getting errors when i run aptitude upgrade in debian squeeze
 
On 28.06.2012 15:13, Joby Mathew wrote:
> root@test:~# aptitude upgrade
> The following packages will be upgraded:
> acpid at base-files bind9-host dnsutils host libapache2-mod-php5 libapr1
> libbind9-60 libbrlapi0.5 libdns69 libisc62 libisccc60 libisccfg62
> liblwres60 libmozjs2d libmysqlclient16 libpolkit-agent-1-0
> libpolkit-backend-1-0 libpolkit-gobject-1-0 libpq5 libxenstore3.0 libxi6
> libxml2-utils locales mantis mysql-client mysql-client-5.1 mysql-common
> mysql-server mysql-server-5.1 mysql-server-core-5.1 openssh-client
> openssh-server openssl php5 php5-cli php5-common php5-curl php5-gd
> php5-ldap php5-mcrypt php5-mysql php5-xmlrpc php5-xsl policykit-1 procps
> python python-libxml2 python-minimal sudo sysvinit tzdata
> The following partially installed packages will be configured:
> apache2 apache2-mpm-prefork apache2.2-common initramfs-tools initscripts
> linux-image-2.6.32-5-amd64 mdadm module-init-tools moodle nfs-common
> phpmyadmin qemu-kvm samba screen vsftpd x11-common xorg xserver-common
> xserver-xorg xserver-xorg-core
> 53 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
> Need to get 0 B/43.5 MB of archives. After unpacking 637 kB will be used.
> Do you want to continue? [Y/n/?] y
> Reading changelogs... Done
> Extracting templates from packages: 100%
> Preconfiguring packages ...
> Setting up initscripts (2.88dsf-13.1+squeeze1) ...
> insserv: warning: script 'subversion' missing LSB tags and overrides
> insserv: There is a loop between service munin-node and subversion if
> stopped
> insserv: loop involving service subversion at depth 2
> insserv: loop involving service munin-node at depth 1
> insserv: Stopping subversion depends on munin-node and therefore on
> system facility `$all' which can not be true!
> insserv: exiting now without changing boot order!
> update-rc.d: error: insserv rejected the script header
> dpkg: error processing initscripts (--configure):
> subprocess installed post-installation script returned error exit status 1
> configured to not write apport reports
> Errors were encountered while
> processing:
> initscripts
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> A package failed to install. Trying to recover:
> Setting up samba (2:3.5.6~dfsg-3squeeze8) ...
> insserv: warning: script 'subversion' missing LSB tags and overrides
> insserv: There is a loop between service munin-node and subversion if
> stopped
> insserv: loop involving service subversion at depth 2
> insserv: loop involving service munin-node at depth 1
> insserv: Stopping subversion depends on munin-node and therefore on
> system facility `$all' which can not be true!
> insserv: exiting now without changing boot order!
> update-rc.d: error: insserv rejected the script header
> dpkg: error processing samba (--configure):
> subprocess installed post-installation script returned error exit status 1
> Setting up module-init-tools (3.12-2) ...
> insserv: warning: script 'subversion' missing LSB tags and overrides
> insserv: There is a loop between service munin-node and subversion if
> stopped
> insserv: loop involving service subversion at depth 2
> insserv: loop involving service munin-node at depth 1
> insserv: Stopping subversion depends on munin-node and therefore on
> system facility `$all' which can not be true!
> insserv: exiting now without changing boot order!
> update-rc.d: error: insserv rejected the script header
> dpkg: error processing module-init-tools (--configure):
> subprocess installed post-installation script returned error exit status 1
> dpkg: dependency problems prevent configuration of
> linux-image-2.6.32-5-amd64:
> linux-image-2.6.32-5-amd64 depends on module-init-tools; however:
> Package module-init-tools is not configured yet.
> dpkg: error processing linux-image-2.6.32-5-amd64 (--configure):
> dependency problems - leaving unconfigured
> Setting up qemu-kvm (0.12.5+dfsg-5+squeeze8) ...
> insserv: warning: script 'subversion' missing LSB tags and overrides
> insserv: There is a loop between service munin-node and subversion if
> stopped
> insserv: loop involving service subversion at depth 2
> insserv: loop involving service munin-node at depth 1
> insserv: Stopping subversion depends on munin-node and therefore on
> system facility `$all' which can not be true!
> insserv: exiting now without changing boot order!
> update-rc.d: error: insserv rejected the script header
> dpkg: error processing qemu-kvm (--configure):
> subprocess installed post-installation script returned error exit status 1
> Setting up vsftpd (2.3.2-3+squeeze2) ...
> vsftpd user (ftp) already exists, doing nothing.
>
> vsftpd directory (/srv/ftp) already exists, doing nothing.
> insserv: warning: script 'subversion' missing LSB tags and overrides
> insserv: There is a loop between service munin-node and subversion if
> stopped
> insserv: loop involving service subversion at depth 2
> insserv: loop involving service munin-node at depth 1
> insserv: Stopping subversion depends on munin-node and therefore on
> system facility `$all' which can not be true!
> insserv: exiting now without changing boot order!
> update-rc.d: error: insserv rejected the script header
> dpkg: error processing vsftpd (--configure):
> subprocess installed post-installation script returned error exit status 1
> Setting up x11-common (1:7.5+8+squeeze1) ...
> insserv: warning: script 'subversion' missing LSB tags and overrides
> insserv: There is a loop between service munin-node and subversion if
> stopped
> insserv: loop involving service subversion at depth 2
> insserv: loop involving service munin-node at depth 1
> insserv: Stopping subversion depends on munin-node and therefore on
> system facility `$all' which can not be true!
> insserv: exiting now without changing boot order!
> update-rc.d: error: insserv rejected the script header
> dpkg: error processing x11-common (--configure):
> subprocess installed post-installation script returned error exit status 1
> dpkg: dependency problems prevent configuration of acpid:
> acpid depends on module-init-tools (>> 3.1-rel-2); however:
> Package module-init-tools is not configured yet.
> dpkg: error processing acpid (--configure):
> dependency problems - leaving unconfigured
> Setting up screen (4.0.3-14) ...
> insserv: warning: script 'subversion' missing LSB tags and overrides
> insserv: There is a loop between service munin-node and subversion if
> stopped
> insserv: loop involving service subversion at depth 2
> insserv: loop involving service munin-node at depth 1
> insserv: Stopping subversion depends on munin-node and therefore on
> system facility `$all' which can not be true!
> insserv: exiting now without changing boot order!
> update-rc.d: error: insserv rejected the script header
> dpkg: error processing screen (--configure):
> subprocess installed post-installation script returned error exit status 1
> Setting up initscripts (2.88dsf-13.1+squeeze1) ...
> insserv: warning: script 'subversion' missing LSB tags and overrides
> insserv: There is a loop between service munin-node and subversion if
> stopped
> insserv: loop involving service subversion at depth 2
> insserv: loop involving service munin-node at depth 1
> insserv: Stopping subversion depends on munin-node and therefore on
> system facility `$all' which can not be true!
> insserv: exiting now without changing boot order!
> update-rc.d: error: insserv rejected the script header
> dpkg: error processing initscripts (--configure):
> subprocess installed post-installation script returned error exit status 1
> Setting up mdadm (3.1.4-1+8efb9d1+squeeze1) ...
> Generating array device nodes... done.
> update-initramfs: deferring update (trigger activated)
> insserv: warning: script 'subversion' missing LSB tags and overrides
> insserv: There is a loop between service munin-node and subversion if
> stopped
> insserv: loop involving service subversion at depth 2
> insserv: loop involving service munin-node at depth 1
> insserv: Stopping subversion depends on munin-node and therefore on
> system facility `$all' which can not be true!
> insserv: exiting now without changing boot order!
> update-rc.d: error: insserv rejected the script header
> dpkg: error processing mdadm (--configure):
> subprocess installed post-installation script returned error exit status 1
> Setting up mysql-server-5.1 (5.1.61-0+squeeze1) ...
> Stopping MySQL database server: mysqld.
> insserv: warning: script 'subversion' missing LSB tags and overrides
> insserv: There is a loop between service munin-node and subversion if
> stopped
> insserv: loop involving service subversion at depth 2
> insserv: loop involving service munin-node at depth 1
> insserv: Stopping subversion depends on munin-node and therefore on
> system facility `$all' which can not be true!
> insserv: exiting now without changing boot order!
> update-rc.d: error: insserv rejected the script header
> dpkg: error processing mysql-server-5.1 (--configure):
> subprocess installed post-installation script returned error exit status 1
> Setting up apache2.2-common (2.2.16-6+squeeze7) ...
> insserv: warning: script 'subversion' missing LSB tags and overrides
> insserv: There is a loop between service munin-node and subversion if
> stopped
> insserv: loop involving service subversion at depth 2
> insserv: loop involving service munin-node at depth 1
> insserv: Stopping subversion depends on munin-node and therefore on
> system facility `$all' which can not be true!
> insserv: exiting now without changing boot order!
> update-rc.d: error: insserv rejected the script header
> dpkg: error processing apache2.2-common (--configure):
> subprocess installed post-installation script returned error exit status 1
> dpkg: dependency problems prevent configuration of libapache2-mod-php5:
> libapache2-mod-php5 depends on apache2.2-common; however:
> Package apache2.2-common is not configured yet.
> dpkg: error processing libapache2-mod-php5 (--configure):
> dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of php5:
> php5 depends on libapache2-mod-php5 (>= 5.3.3-7+squeeze8) |
> libapache2-mod-php5filter (>= 5.3.3-7+squeeze8) | php5-cgi (>=
> 5.3.3-7+squeeze8); however:
> Package libapache2-mod-php5 is not configured yet.
> Package libapache2-mod-php5filter is not installed.
> Package php5-cgi is not installed.
> dpkg: error processing php5 (--configure):
> dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of mysql-server:
> mysql-server depends on mysql-server-5.1; however:
> Package mysql-server-5.1 is not configured yet.
> dpkg: error processing mysql-server (--configure):
> dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of xserver-common:
> xserver-common depends on x11-common; however:
> Package x11-common is not configured yet.
> dpkg: error processing xserver-common (--configure):
> dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of initramfs-tools:
> initramfs-tools depends on module-init-tools; however:
> Package module-init-tools is not configured yet.
> dpkg: error processing initramfs-tools (--configure):
> dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of nfs-common:
> nfs-common depends on initscripts (>= 2.86.ds1-38.1); however:
> Package initscripts is not configured yet.
> dpkg: error processing nfs-common (--configure):
> dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of xserver-xorg-core:
> xserver-xorg-core depends on xserver-common (>= 2:1.7.7-14); however:
> Package xserver-common is not configured yet.
> dpkg: error processing xserver-xorg-core (--configure):
> dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of xserver-xorg:
> xserver-xorg depends on xserver-xorg-core (>= 2:1.7); however:
> Package xserver-xorg-core is not configured yet.
> dpkg: error processing xserver-xorg (--configure):
> dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of apache2-mpm-prefork:
> apache2-mpm-prefork depends on apache2.2-common (= 2.2.16-6+squeeze7);
> however:
> Package apache2.2-common is not configured yet.
> dpkg: error processing apache2-mpm-prefork (--configure):
> dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of apache2:
> apache2 depends on apache2-mpm-worker (= 2.2.16-6+squeeze7) |
> apache2-mpm-prefork (= 2.2.16-6+squeeze7) | apache2-mpm-event (=
> 2.2.16-6+squeeze7) | apache2-mpm-itk (= 2.2.16-6+squeeze7); however:
> Package apache2-mpm-worker is not installed.
> Package apache2-mpm-prefork is not configured yet.
> Package apache2-mpm-event is not installed.
> Package apache2-mpm-itk is not installed.
> apache2 depends on apache2.2-common (= 2.2.16-6+squeeze7); however:
> Package apache2.2-common is not configured yet.
> dpkg: error processing apache2 (--configure):
> dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of phpmyadmin:
> phpmyadmin depends on libapache2-mod-php5 | php5-cgi | php5; however:
> Package libapache2-mod-php5 is not configured yet.
> Package php5-cgi is not installed.
> Package php5 is not configured yet.
> dpkg: error processing phpmyadmin (--configure):
> dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of moodle:
> moodle depends on libapache2-mod-php5 | php5-cgi; however:
> Package libapache2-mod-php5 is not configured yet.
> Package php5-cgi is not installed.
> moodle depends on apache2-mpm-prefork | httpd; however:
> Package apache2-mpm-prefork is not configured yet.
> Package httpd is not installed.
> Package apache2-mpm-prefork which provides httpd is not configured yet.
> dpkg: error processing moodle (--configure):
> dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of xorg:
> xorg depends on xserver-xorg; however:
> Package xserver-xorg is not configured yet.
> dpkg: error processing xorg (--configure):
> dependency problems - leaving unconfigured
> Errors were encountered while processing:
> samba
> module-init-tools
> linux-image-2.6.32-5-amd64
> qemu-kvm
> vsftpd
> x11-common
> acpid
> screen
> initscripts
> mdadm
> mysql-server-5.1
> apache2.2-common
> libapache2-mod-php5
> php5
> mysql-server
> xserver-common
> initramfs-tools
> nfs-common
> xserver-xorg-core
> xserver-xorg
> apache2-mpm-prefork
> apache2
> phpmyadmin
> moodle
> xorg
>

I had this same problem. I solved it by running these commands in this
order:

1. mv /etc/init.d/munin-node /etc/init.d/munin-node~
2. aptitude update
3. aptitude upgrade

NOTICE: Don't accept to create init script for munin-node!

4. mv /etc/init.d/munin-node~ /etc/init.d/munin-node
5. aptitude upgrade

This is probably wrong way to do this, but at least it worked for me.

PS. Please don't use HTML on this mailing list. It's forbidden by the
mailing list guidelines.

--
[Mika Suomalainen](https://mkaysi.github.com/) ||

NOTICE! I am on mobile broadband with very limited time, so I cannot
read emails very much.
The best time to contact me is probably weekends when I have better
connectivity with good luck.

[gpg --keyserver pool.sks-keyservers.net --recv-keys
4DB53CFE82A46728](http://mkaysi.github.com/PGP/key.txt) ||
[Why do I sign my
emails?](http://mkaysi.github.com/PGP/WhyDoISignEmails.html) ||
[Do you have problems verifying my PGP/MIME signature on mailing
list?](http://mkaysi.github.com/PGP/PGP-MIME.html) ||
[Please don't send
HTML.](http://mkaysi.github.com/articles/complaining/HTML.html) ||
[This signature](https://gist.github.com/2643070#file_icedove.md)

[Please reply below this
line](http://mkaysi.github.com/articles/complaining/topposting.html)

____________________________


All times are GMT. The time now is 07:17 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.