FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 06-21-2012, 11:50 AM
Brian
 
Default Up-gradation problem with gnome 2.14

On Thu 21 Jun 2012 at 11:34:06 +0000, Joy Sankar Sengupta wrote:

> I think it is working now.But still getting some error while installing
> downloaded updates.
>
> dpkg: regarding .../ncurses-base_5.7+20100313-5_all.deb containing
> ncurses-base:
> package uses Breaks; not supported in this dpkg
> dpkg: error processing
> /var/cache/apt/archives/ncurses-base_5.7+20100313-5_all.deb
> (--unpack):
> unsupported dependency problem - not installing ncurses-base
> Errors were encountered while processing:
> /var/cache/apt/archives/ncurses-base_5.7+20100313-5_all.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)

Have done an upgrade *and* a dist-upgrade? Please post the output of

dpkg -l | grep dpkg


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: http://lists.debian.org/20120621115002.GY30016@desktop
 
Old 06-22-2012, 07:51 AM
Joy Sankar Sengupta
 
Default Up-gradation problem with gnome 2.14

I have done both upgrade and dist-upgrade and got the same *type of error.For dist-upgrade, the error is :-"
Errors were encountered while processing:
/var/cache/apt/archives/libc-bin_2.11.3-3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)"


The output of "dpkg -l | grep dpkg":-
client:/home/student# dpkg -l | grep dpkg
ii *apt * * * * * * * * * * * * * * * 0.6.46.4-0.1 * * * * * * * * * * * * Advanced front-end for dpkg
ii *dpkg * * * * * * * * * * * * * * *1.13.25 * * * * * * * * * * * * * * *package maintenance system for Debian
ii *dpkg-dev * * * * * * * * * * * * *1.13.25 * * * * * * * * * * * * * * *package building tools for Debian
ii *type-handling * * * * * * * * * * 0.2.19 * * * * * * * * * * * * * * * dpkg architecture generation script*

Best Regards,
Joysankar Sengupta



On Thu, Jun 21, 2012 at 5:20 PM, Brian <ad44@cityscape.co.uk> wrote:

On Thu 21 Jun 2012 at 11:34:06 +0000, Joy Sankar Sengupta wrote:



> I think it is working now.But still getting some error while installing

> downloaded updates.

>

> dpkg: regarding .../ncurses-base_5.7+20100313-5_all.deb containing

> ncurses-base:

> package uses Breaks; not supported in this dpkg

> dpkg: error processing

> /var/cache/apt/archives/ncurses-base_5.7+20100313-5_all.deb

> (--unpack):

> unsupported dependency problem - not installing ncurses-base

> Errors were encountered while processing:

> /var/cache/apt/archives/ncurses-base_5.7+20100313-5_all.deb

> E: Sub-process /usr/bin/dpkg returned an error code (1)



Have done an upgrade *and* a dist-upgrade? Please post the output of



* dpkg -l | grep dpkg





--

To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org

with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Archive: http://lists.debian.org/20120621115002.GY30016@desktop
 
Old 06-22-2012, 08:53 AM
Dom
 
Default Up-gradation problem with gnome 2.14

On 22/06/12 08:51, Joy Sankar Sengupta wrote:


On Thu, Jun 21, 2012 at 5:20 PM, Brian<ad44@cityscape.co.uk> wrote:


On Thu 21 Jun 2012 at 11:34:06 +0000, Joy Sankar Sengupta wrote:


I think it is working now.But still getting some error while installing
downloaded updates.

dpkg: regarding .../ncurses-base_5.7+20100313-5_all.deb containing
ncurses-base:
package uses Breaks; not supported in this dpkg
dpkg: error processing
/var/cache/apt/archives/ncurses-base_5.7+20100313-5_all.deb
(--unpack):
unsupported dependency problem - not installing ncurses-base
Errors were encountered while processing:
/var/cache/apt/archives/ncurses-base_5.7+20100313-5_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Have done an upgrade *and* a dist-upgrade? Please post the output of

dpkg -l | grep dpkg



I have done both upgrade and dist-upgrade and got the same type of
error.For dist-upgrade, the error is :-" Errors were encountered while
processing:
/var/cache/apt/archives/libc-bin_2.11.3-3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)"


The output of "dpkg -l | grep dpkg":-

client:/home/student# dpkg -l | grep dpkg
ii apt 0.6.46.4-0.1
Advanced front-end for dpkg
ii dpkg 1.13.25
package maintenance system for Debian
ii dpkg-dev 1.13.25
package building tools for Debian
ii type-handling 0.2.19
dpkg architecture generation script



So, it seems the version of dpkg that is currently installed doesn't
support the "Breaks:" option. It must be a very old one.


I suggest that you first upgrade dpkg:

apt-get install dpkg

which should pull in the new version, then you can continue with an
upgrade and dist-upgrade.


--
Dom


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Archive: 4FE4327D.70209@rpdom.net">http://lists.debian.org/4FE4327D.70209@rpdom.net
 
Old 06-22-2012, 09:06 AM
Joy Sankar Sengupta
 
Default Up-gradation problem with gnome 2.14

The outpur is given bellow:-

client:/home/student# apt-get install dpkg
Reading package lists... Done
Building dependency tree... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
*dpkg: PreDepends: libc6 (>= 2.6) but 2.3.6.ds1-13etch7 is to be installed
* * * *PreDepends: xz-utils but it is not going to be installed
*locales: Depends: glibc-2.11-1
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).*
Best Regards,
Joysankar Sengupta



On Fri, Jun 22, 2012 at 2:23 PM, Dom <toyer@rpdom.net> wrote:

On 22/06/12 08:51, Joy Sankar Sengupta wrote:




On Thu, Jun 21, 2012 at 5:20 PM, Brian<ad44@cityscape.co.uk> *wrote:




On Thu 21 Jun 2012 at 11:34:06 +0000, Joy Sankar Sengupta wrote:




I think it is working now.But still getting some error while installing

downloaded updates.



dpkg: regarding .../ncurses-base_5.7+20100313-5_all.deb containing

ncurses-base:

package uses Breaks; not supported in this dpkg

dpkg: error processing

/var/cache/apt/archives/ncurses-base_5.7+20100313-5_all.deb

(--unpack):

unsupported dependency problem - not installing ncurses-base

Errors were encountered while processing:

/var/cache/apt/archives/ncurses-base_5.7+20100313-5_all.deb

E: Sub-process /usr/bin/dpkg returned an error code (1)




Have done an upgrade *and* a dist-upgrade? Please post the output of



* dpkg -l | grep dpkg






I have done both upgrade and dist-upgrade and got the same *type of

error.For dist-upgrade, the error is :-" Errors were encountered while

processing:

/var/cache/apt/archives/libc-bin_2.11.3-3_i386.deb

E: Sub-process /usr/bin/dpkg returned an error code (1)"





The output of "dpkg -l | grep dpkg":-



client:/home/student# dpkg -l | grep dpkg

ii *apt * * * * * * * * * * * * * * * 0.6.46.4-0.1

Advanced front-end for dpkg

ii *dpkg * * * * * * * * * * * * * * *1.13.25

*package maintenance system for Debian

ii *dpkg-dev * * * * * * * * * * * * *1.13.25

*package building tools for Debian

ii *type-handling * * * * * * * * * * 0.2.19

dpkg architecture generation script






So, it seems the version of dpkg that is currently installed doesn't support the "Breaks:" option. It must be a very old one.



I suggest that you first upgrade dpkg:



apt-get install dpkg



which should pull in the new version, then you can continue with an upgrade and dist-upgrade.



--

Dom





--

To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org


Archive: http://lists.debian.org/4FE4327D.70209@rpdom.net
 
Old 06-22-2012, 09:54 AM
Brian
 
Default Up-gradation problem with gnome 2.14

On Fri 22 Jun 2012 at 14:36:42 +0530, Joy Sankar Sengupta wrote:

> The outpur is given bellow:-
>
> client:/home/student# apt-get install dpkg
> Reading package lists... Done
> Building dependency tree... Done
> You might want to run `apt-get -f install' to correct these:
> The following packages have unmet dependencies:
> dpkg: PreDepends: libc6 (>= 2.6) but 2.3.6.ds1-13etch7 is to be installed
> PreDepends: xz-utils but it is not going to be installed
> locales: Depends: glibc-2.11-1
> E: Unmet dependencies. Try 'apt-get -f install' with no packages (or
> specify a solution).

You tried 'apt-get -f install'?

At this stage you might ask youself whether the time and frustration
involved in upgrading from something which is pre-Lenny is really worth
it. Is there any practical reason why you should not do a new Squeeze
install?

If it were me in your situation I'd probably start by looking at what is
on the system now and installing dpkg and its dependencies by hand using
'dpkg -i'. Others might counsel aptitude. Either way it could involve a
a lot more effort from you and us than a new install.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: http://lists.debian.org/20120622095406.GB30016@desktop
 
Old 06-22-2012, 10:10 AM
Jochen Spieker
 
Default Up-gradation problem with gnome 2.14

Brian:
>
> At this stage you might ask youself whether the time and frustration
> involved in upgrading from something which is pre-Lenny is really worth
> it. Is there any practical reason why you should not do a new Squeeze
> install?

ACK. It looks like the OP (inadvertantly?) tried to do something that is
not supported (skip a release) and more or less broke his system. An
experienced user would probably be able to fix it, but doing that
remotely via a mailing list is painful.

J.
--
I worry about people thinking I have lost direction.
[Agree] [Disagree]
<http://www.slowlydownward.com/NODATA/data_enter2.html>
 
Old 06-22-2012, 10:30 AM
Brian
 
Default Up-gradation problem with gnome 2.14

On Fri 22 Jun 2012 at 12:10:24 +0200, Jochen Spieker wrote:

> Brian:
> >
> > At this stage you might ask youself whether the time and frustration
> > involved in upgrading from something which is pre-Lenny is really worth
> > it. Is there any practical reason why you should not do a new Squeeze
> > install?
>
> ACK. It looks like the OP (inadvertantly?) tried to do something that is
> not supported (skip a release) and more or less broke his system. An
> experienced user would probably be able to fix it, but doing that
> remotely via a mailing list is painful.

Not so inadvertantly, I think. I'll shoulder some of the responsibility
for not insisting on /etc/issue being posted and not querying the wisdom
of upgrading from what appears to be a 2006 Gnome.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: http://lists.debian.org/20120622103023.GC30016@desktop
 

Thread Tools




All times are GMT. The time now is 09:36 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org