Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian User (http://www.linux-archive.org/debian-user/)
-   -   Problem updating debian 6 (http://www.linux-archive.org/debian-user/668117-problem-updating-debian-6-a.html)

David Seira 05-18-2012 07:13 AM

Problem updating debian 6
 
Hi,
I'm trying to update and upgrade a debian 6 system. I've run the "aptitude update" command and the output is:
Des:1 http://ftp.es.debian.org squeeze Release.gpg [912 B]

Des:2 http://ftp.es.debian.org/debian/ squeeze/main Translation-en [912 B]99% [2 Translation-en bzip2 0] [Esperando las cabeceras] [Esperando las cabeceras]bzip2: (stdin) is not a bzip2 file.

Ign http://ftp.es.debian.org/debian/ squeeze/main Translation-en * * * * * * * * *Des:3 http://ftp.es.debian.org/debian/ squeeze/main Translation-es [912 B] * * * *

66% [3 Translation-es bzip2 0] [Conectando a ftp.es.debian.org (82.194.78.250)] [Esperando las cabeceras]bzip2: (stdin) is not a bzip2 file.Ign http://ftp.es.debian.org/debian/ squeeze/main Translation-es * * * * * * * * * * * * * * * * * * * **

Des:4 http://ftp.es.debian.org squeeze-updates Release.gpg [912 B] * * * * * * * * * * * * * * * * * * **Des:5 http://security.debian.org squeeze/updates Release.gpg [912 B]

Des:6 http://ftp.es.debian.org/debian/ squeeze-updates/main Translation-en [912 B]66% [6 Translation-en bzip2 0] [Conectando a ftp.es.debian.org (82.194.78.250)] [Esperando las cabeceras]bzip2: (stdin) is not a bzip2 file.

Ign http://ftp.es.debian.org/debian/ squeeze-updates/main Translation-en * * * * * * * * * * * * * * * **Des:7 http://ftp.es.debian.org/debian/ squeeze-updates/main Translation-es [912 B] * * * * * * * * * * **

57% [7 Translation-es bzip2 0] [Conectando a ftp.es.debian.org (82.194.78.250)] [Esperando las cabeceras]bzip2: (stdin) is not a bzip2 file.Ign http://ftp.es.debian.org/debian/ squeeze-updates/main Translation-es * * * * * * * * * * * * * * * **

Des:8 http://ftp.es.debian.org squeeze Release [912 B] * * * * * * * * * * * * * * * * * * * * * * * * **Err http://ftp.es.debian.org squeeze Release * * * * * * * * * * * * * * * * *

**Des:9 http://ftp.es.debian.org squeeze-updates Release [912 B] * * * * * * *Err http://ftp.es.debian.org squeeze-updates Release * *

**Des:10 http://security.debian.org/ squeeze/updates/main Translation-en [912 B]59% [10 Translation-en bzip2 0] [Conectando a security.debian.org (128.101.240.212)]bzip2: (stdin) is not a bzip2 file.

Ign http://security.debian.org/ squeeze/updates/main Translation-en * * * * * * * **Des:11 http://security.debian.org/ squeeze/updates/main Translation-es [912 B] * * *

54% [11 Translation-es bzip2 0] [Conectando a security.debian.org (128.101.240.212)]bzip2: (stdin) is not a bzip2 file.Ign http://security.debian.org/ squeeze/updates/main Translation-es * * * * * * * **

Des:12 http://security.debian.org squeeze/updates Release [912 B] * * * * * * * * **Err http://security.debian.org squeeze/updates Release

**Descargados 10,9 kB en 1seg. (7429 B/s).W: Se produjo un error durante la verificación de las firmas. El repositorio no está actualizado y se utilizarán los ficheros de índice antiguos. El error GPG es: http://ftp.es.debian.org squeeze Release: Las siguientes firms fueron inválidas: NODATA 1 NODATA 2


W: Se produjo un error durante la verificación de las firmas. El repositorio no está actualizado y se utilizarán los ficheros de índice antiguos. El error GPG es: http://ftp.es.debian.org squeeze-updates Release: Las siguientes firms fueron inválidas: NODATA 1 NODATA 2


W: Se produjo un error durante la verificación de las firmas. El repositorio no está actualizado y se utilizarán los ficheros de índice antiguos. El error GPG es: http://security.debian.org squeeze/updates Release: Las siguientes firms fueron inválidas: NODATA 1 NODATA 2


I don't understand this error. I also have another servers with the same distro and the update process was ok. I've tried cleaning the packages list (dpkg --clear-avail) but it doesn't work.


I've seen that the "apt-key list" output is like this:
/etc/apt/trusted.gpg--------------------pub * 1024D/F42584E6 2008-04-06 [caducó: 2012-05-15]

uid * * * * * * * * *Lenny Stable Release Key <debian-release@lists.debian.org>
pub * 4096R/55BE302B 2009-01-27 [caduca: 2012-12-31]

uid * * * * * * * * *Debian Archive Automatic Signing Key (5.0/lenny) <ftpmaster@debian.org>
pub * 2048R/6D849617 2009-01-24 [caduca: 2013-01-23]

uid * * * * * * * * *Debian-Volatile Archive Automatic Signing Key (5.0/lenny)
pub * 4096R/B98321F9 2010-08-07 [caduca: 2017-08-05]uid * * * * * * * * *Squeeze Stable Release Key <debian-release@lists.debian.org>


pub * 4096R/473041FA 2010-08-27 [caduca: 2018-03-05]uid * * * * * * * * *Debian Archive Automatic Signing Key (6.0/squeeze) <ftpmaster@debian.org>



Anyone know what is the problem? How can I fix it?
Thanks,David

Andrei POPESCU 05-18-2012 07:41 AM

Problem updating debian 6
 
On Vi, 18 mai 12, 09:13:05, David Seira wrote:
> Hi,
>
> I'm trying to update and upgrade a debian 6 system. I've run the "aptitude
> update" command and the output is:

[...]

> Anyone know what is the problem? How can I fix it?

First I would try with a different mirror.

Kind regards,
Andrei
--
Offtopic discussions among Debian users and developers:
http://lists.alioth.debian.org/mailman/listinfo/d-community-offtopic

David Seira 05-18-2012 09:33 AM

Problem updating debian 6
 
Hi Andrei,
I've tried to change the mirror but with the same problem. Furthermore, if I try to upgrade the system it shows me the next error:
E: Failed to download http://security.debian.org/pool/updates/main/o/openssl/libssl-dev_0.9.8o-4squeeze13_amd64.deb: The size differs


I don't know what is the problem with the bzip2:
bzip2: (stdin) is not a bzip2 file
Any idea?
Thanks,David



2012/5/18 Andrei POPESCU <andreimpopescu@gmail.com>


On Vi, 18 mai 12, 09:13:05, David Seira wrote:

> Hi,

>

> I'm trying to update and upgrade a debian 6 system. I've run the "aptitude

> update" command and the output is:



[...]



> Anyone know what is the problem? How can I fix it?



First I would try with a different mirror.



Kind regards,

Andrei

--

Offtopic discussions among Debian users and developers:

http://lists.alioth.debian.org/mailman/listinfo/d-community-offtopic

T Elcor 05-18-2012 01:16 PM

Problem updating debian 6
 
--- On Fri, 5/18/12, David Seira <davidseira@gmail.com> wrote:

> From: David Seira <davidseira@gmail.com>
> Subject: Re: Problem updating debian 6
> To: "debian-user" <debian-user@lists.debian.org>
> Date: Friday, May 18, 2012, 2:33 AM
> Hi Andrei,
> I've tried to change the mirror but with the
> same problem. Furthermore, if I try to upgrade the system it
> shows me the next error:
> E: Failed to download http://security.debian.org/pool/updates/main/o/openssl/libssl-dev_0.9.8o-4squeeze13_amd64.deb:

I'm having a problem updating wheezy, perhaps those problems are related. It's been going on for several days now:

http://lists.debian.org/debian-user/2012/05/msg01689.html


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 1337346984.389.YahooMailClassic@web121903.mail.ne1 .yahoo.com">http://lists.debian.org/1337346984.389.YahooMailClassic@web121903.mail.ne1 .yahoo.com

David Seira 05-21-2012 06:50 AM

Problem updating debian 6
 
I still having this problem. It seems like a problem with the repository but I've tried to change it with the same result; I've tried with the UK and Spain repositories.
Has anyone the same problems?


Thanks,David

2012/5/18 T Elcor <telcor@yahoo.com>


--- On Fri, 5/18/12, David Seira <davidseira@gmail.com> wrote:



> From: David Seira <davidseira@gmail.com>

> Subject: Re: Problem updating debian 6

> To: "debian-user" <debian-user@lists.debian.org>

> Date: Friday, May 18, 2012, 2:33 AM

> Hi Andrei,

> I've tried to change the mirror but with the

> same problem. Furthermore, if I try to upgrade the system it

> shows me the next error:

> E: Failed to download http://security.debian.org/pool/updates/main/o/openssl/libssl-dev_0.9.8o-4squeeze13_amd64.deb:





I'm having a problem updating wheezy, perhaps those problems are related. It's been going on for several days now:



http://lists.debian.org/debian-user/2012/05/msg01689.html





--

To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org

with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Archive: http://lists.debian.org/1337346984.389.YahooMailClassic@web121903.mail.ne1 .yahoo.com

Chris Bannister 05-21-2012 04:51 PM

Problem updating debian 6
 
[Please don't top post!]

On Mon, May 21, 2012 at 08:50:03AM +0200, David Seira wrote:
> I still having this problem. It seems like a problem with the repository
> but I've tried to change it with the same result; I've tried with the UK
> and Spain repositories.
>
> Has anyone the same problems?

No.

What is output of following commands:

grep -v ^# /etc/apt/sources.list

ls -al /etc/apt/sources.list.d/

apt-get update


--
"If you're not careful, the newspapers will have you hating the people
who are being oppressed, and loving the people who are doing the
oppressing." --- Malcolm X


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120521165102.GH24726@tal">http://lists.debian.org/20120521165102.GH24726@tal

David Seira 05-22-2012 10:10 AM

Problem updating debian 6
 
Hi Chris,
As I put in the first post the aptitude update output is:




Des:1*http://ftp.es.debian.org*squeeze Release.gpg [912 B]
Des:2*http://ftp.es.debian.org/debian/*squeeze/main Translation-en [912 B]




99% [2 Translation-en bzip2 0] [Esperando las cabeceras] [Esperando las cabeceras]bzip2: (stdin) is not a bzip2 file.
Ign*http://ftp.es.debian.org/debian/*squeeze/main Translation-en * * * * * * * * *




Des:3*http://ftp.es.debian.org/debian/*squeeze/main Translation-es [912 B] * * * *
66% [3 Translation-es bzip2 0] [Conectando a*ftp.es.debian.org*(82.194.78.250)] [Esperando las cabeceras]bzip2: (stdin) is not a bzip2 file.




Ign*http://ftp.es.debian.org/debian/*squeeze/main Translation-es * * * * * * * * * * * * * * * * * * * **
Des:4*http://ftp.es.debian.org*squeeze-updates Release.gpg [912 B] * * * * * * * * * * * * * * * * * * **




Des:5*http://security.debian.org*squeeze/updates Release.gpg [912 B]
Des:6*http://ftp.es.debian.org/debian/*squeeze-updates/main Translation-en [912 B]




66% [6 Translation-en bzip2 0] [Conectando a*ftp.es.debian.org*(82.194.78.250)] [Esperando las cabeceras]bzip2: (stdin) is not a bzip2 file.




Ign*http://ftp.es.debian.org/debian/*squeeze-updates/main Translation-en * * * * * * * * * * * * * * * **
Des:7*http://ftp.es.debian.org/debian/*squeeze-updates/main Translation-es [912 B] * * * * * * * * * * **




57% [7 Translation-es bzip2 0] [Conectando a*ftp.es.debian.org*(82.194.78.250)] [Esperando las cabeceras]bzip2: (stdin) is not a bzip2 file.




Ign*http://ftp.es.debian.org/debian/*squeeze-updates/main Translation-es * * * * * * * * * * * * * * * **
Des:8*http://ftp.es.debian.org*squeeze Release [912 B] * * * * * * * * * * * * * * * * * * * * * * * * **




Err*http://ftp.es.debian.org*squeeze Release * * * * * * * * * * * * * * * * *
**
Des:9*http://ftp.es.debian.org*squeeze-updates Release [912 B] * * * * * * *




Err*http://ftp.es.debian.org*squeeze-updates Release * *
**
Des:10*http://security.debian.org/*squeeze/updates/main Translation-en [912 B]




59% [10 Translation-en bzip2 0] [Conectando a*security.debian.org*(128.101.240.212)]bzip2: (stdin) is not a bzip2 file.
Ign*http://security.debian.org/*squeeze/updates/main Translation-en * * * * * * * **




Des:11*http://security.debian.org/*squeeze/updates/main Translation-es [912 B] * * *
54% [11 Translation-es bzip2 0] [Conectando a*security.debian.org*(128.101.240.212)]bzip2: (stdin) is not a bzip2 file.




Ign*http://security.debian.org/*squeeze/updates/main Translation-es * * * * * * * **
Des:12*http://security.debian.org*squeeze/updates Release [912 B] * * * * * * * * **




Err*http://security.debian.org*squeeze/updates Release
**
Descargados 10,9 kB en 1seg. (7429 B/s).
W: Se produjo un error durante la verificación de las firmas. El repositorio no está actualizado y se utilizarán los ficheros de índice antiguos. El error GPG es:*http://ftp.es.debian.org*squeeze Release: Las siguientes firms fueron inválidas: NODATA 1 NODATA 2




W: Se produjo un error durante la verificación de las firmas. El repositorio no está actualizado y se utilizarán los ficheros de índice antiguos. El error GPG es:*http://ftp.es.debian.org*squeeze-updates Release: Las siguientes firms fueron inválidas: NODATA 1 NODATA 2




W: Se produjo un error durante la verificación de las firmas. El repositorio no está actualizado y se utilizarán los ficheros de índice antiguos. El error GPG es:*http://security.debian.org*squeeze/updates Release: Las siguientes firms fueron inválidas: NODATA 1 NODATA 2




The ouput for "grep -v ^# /etc/apt/sources.list"*is:




deb http://ftp.es.debian.org/debian/ squeeze main
deb-src http://ftp.es.debian.org/debian/ squeeze main




deb http://security.debian.org/ squeeze/updates main
deb-src http://security.debian.org/ squeeze/updates main




deb http://ftp.es.debian.org/debian/ squeeze-updates main
deb-src http://ftp.es.debian.org/debian/ squeeze-updates main




And the*/etc/apt/sources.list.d/ directory is empty.




It seems a problem with the repository but I've tried with several of them and the result is the same.




Thanks,



David
2012/5/21 Chris Bannister <cbannister@slingshot.co.nz>




[Please don't top post!]



On Mon, May 21, 2012 at 08:50:03AM +0200, David Seira wrote:

> I still having this problem. It seems like a problem with the repository

> but I've tried to change it with the same result; I've tried with the UK

> and Spain repositories.

>

> Has anyone the same problems?



No.



What is output of following commands:



grep -v ^# /etc/apt/sources.list



ls -al /etc/apt/sources.list.d/



apt-get update





--

"If you're not careful, the newspapers will have you hating the people

who are being oppressed, and loving the people who are doing the

oppressing." --- Malcolm X





--

To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org

with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Archive: http://lists.debian.org/20120521165102.GH24726@tal

Chris Bannister 05-22-2012 12:52 PM

Problem updating debian 6
 
[Please read http://catb.org/jargon/html/T/top-post.html]

On Tue, May 22, 2012 at 12:10:14PM +0200, David Seira wrote:
> Hi Chris,

> As I put in the first post the aptitude update output is:

For testing purposes I'd like to see the output of

LC=C apt-get update

The LC=C is because this is an English list. :)

> The ouput for "grep -v ^# /etc/apt/sources.list" is:
>
> deb http://ftp.es.debian.org/debian/ squeeze main
> > deb-src http://ftp.es.debian.org/debian/ squeeze main
> > deb http://security.debian.org/ squeeze/updates main
> > deb-src http://security.debian.org/ squeeze/updates main
> > deb http://ftp.es.debian.org/debian/ squeeze-updates main
> > deb-src http://ftp.es.debian.org/debian/ squeeze-updates main

Is that just copy 'n' paste problems or is there a ">" at the begining
of each line?

I know my repository works:
---------------------------------------------------------
deb http://security.debian.org/ wheezy/updates main

deb http://ftp.nz.debian.org/debian wheezy main contrib non-free
----------------------------------------------------------

Just substitute squeeze for wheezy

> And the /etc/apt/sources.list.d/ directory is empty.

That's fine.

> It seems a problem with the repository but I've tried with several of them
> and the result is the same.

That's why I'd like to see the output using apt-get. I know that works,
and I don't use aptitude but there was some talk about aptitude "playing
up" while trying to update.

Is *every* squeeze user having trouble with aptitude?

--
"If you're not careful, the newspapers will have you hating the people
who are being oppressed, and loving the people who are doing the
oppressing." --- Malcolm X


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120522125251.GD25963@tal">http://lists.debian.org/20120522125251.GD25963@tal

David Seira 05-22-2012 02:30 PM

Problem updating debian 6
 
Hi Chris,

2012/5/22 Chris Bannister <cbannister@slingshot.co.nz>
>
>
> [Please read http://catb.org/jargon/html/T/top-post.html]
>
> On Tue, May 22, 2012 at 12:10:14PM +0200, David Seira wrote:
> > Hi Chris,
>
> > As I put in the first post the aptitude update output is:
>
> For testing purposes I'd like to see the output of
>
> LC=C apt-get update

The result in english (sorry) is:

Get:1 http://ftp.es.debian.org squeeze Release.gpg [912 B]
Get:2 http://ftp.es.debian.org/debian/ squeeze/main Translation-en [912 B]
99% [2 Translation-en bzip2 0 B] [Waiting for headers] [Waiting for
headers]bzip2: (stdin) is not a bzip2 file.
Ign http://ftp.es.debian.org/debian/ squeeze/main Translation-en
Get:3 http://ftp.es.debian.org/debian/ squeeze/main Translation-es [912 B]
66% [3 Translation-es bzip2 0 B] [Connecting to ftp.es.debian.org
(82.194.78.250)] [Waiting for headers]bzip2: (stdin) is not a bzip2
file.
Ign http://ftp.es.debian.org/debian/ squeeze/main Translation-es
Get:4 http://ftp.es.debian.org squeeze-updates Release.gpg [912 B]
Get:5 http://security.debian.org squeeze/updates Release.gpg [912 B]
Get:6 http://ftp.es.debian.org/debian/ squeeze-updates/main
Translation-en [912 B]
66% [6 Translation-en bzip2 0 B] [Connecting to ftp.es.debian.org
(82.194.78.250)] [Waiting for headers]bzip2: (stdin) is not a bzip2
file.
Ign http://ftp.es.debian.org/debian/ squeeze-updates/main
Translation-en
Get:7 http://ftp.es.debian.org/debian/ squeeze-updates/main
Translation-es [912 B]
57% [7 Translation-es bzip2 0 B] [Connecting to ftp.es.debian.org
(82.194.78.250)] [Waiting for headers]bzip2: (stdin) is not a bzip2
file.
Ign http://ftp.es.debian.org/debian/ squeeze-updates/main
Translation-es
Get:8 http://ftp.es.debian.org squeeze Release [912 B]
Err http://ftp.es.debian.org squeeze Release

Get:9 http://ftp.es.debian.org squeeze-updates Release [912 B]
Err http://ftp.es.debian.org squeeze-updates Release

Get:10 http://security.debian.org/ squeeze/updates/main Translation-en [912 B]
59% [10 Translation-en bzip2 0 B] [Connecting to security.debian.org
(128.31.0.36)]bzip2: (stdin) is not a bzip2 file.
Ign http://security.debian.org/ squeeze/updates/main Translation-en
Get:11 http://security.debian.org/ squeeze/updates/main Translation-es
[912 B]
54% [11 Translation-es bzip2 0 B] [Connecting to security.debian.org
(128.31.0.36)]bzip2: (stdin) is not a bzip2 file.
Ign http://security.debian.org/ squeeze/updates/main Translation-es
Get:12 http://security.debian.org squeeze/updates Release [912 B]
Err http://security.debian.org squeeze/updates Release

Fetched 10.9 kB in 1s (7872 B/s)
Reading package lists... Done
W: A error occurred during the signature verification. The repository
is not updated and the previous index files will be used. GPG error:
http://ftp.es.debian.org squeeze Release: The following signatures
were invalid: NODATA 1 NODATA 2

W: A error occurred during the signature verification. The repository
is not updated and the previous index files will be used. GPG error:
http://ftp.es.debian.org squeeze-updates Release: The following
signatures were invalid: NODATA 1 NODATA 2

W: A error occurred during the signature verification. The repository
is not updated and the previous index files will be used. GPG error:
http://security.debian.org squeeze/updates Release: The following
signatures were invalid: NODATA 1 NODATA 2

W: Failed to fetch http://ftp.es.debian.org/debian/dists/squeeze/Release
W: Failed to fetch
http://ftp.es.debian.org/debian/dists/squeeze-updates/Release
W: Failed to fetch http://security.debian.org/dists/squeeze/updates/Release
W: Some index files failed to download, they have been ignored, or old
ones used instead.


>
> The LC=C is because this is an English list. :)
>
> > The ouput for "grep -v ^# /etc/apt/sources.list" is:
> >
> > deb http://ftp.es.debian.org/debian/ squeeze main
> > > deb-src http://ftp.es.debian.org/debian/ squeeze main
> > > deb http://security.debian.org/ squeeze/updates main
> > > deb-src http://security.debian.org/ squeeze/updates main
> > > deb http://ftp.es.debian.org/debian/ squeeze-updates main
> > > deb-src http://ftp.es.debian.org/debian/ squeeze-updates main
>
> Is that just copy 'n' paste problems or is there a ">" at the begining
> of each line?
>

Yes, it was a copy 'n' paste problem.

> I know my repository works:
> ---------------------------------------------------------
> deb http://security.debian.org/ wheezy/updates main
>
> deb http://ftp.nz.debian.org/debian wheezy main contrib non-free
> ----------------------------------------------------------
>
> Just substitute squeeze for wheezy

The problem is that I don't want to upgrade to debian testing.

>
> > And the /etc/apt/sources.list.d/ directory is empty.
>
> That's fine.
>
> > It seems a problem with the repository but I've tried with several of
> > them
> > and the result is the same.
>
> That's why I'd like to see the output using apt-get. I know that works,
> and I don't use aptitude but there was some talk about aptitude "playing
> up" while trying to update.
>
> Is *every* squeeze user having trouble with aptitude?
>

This is the only server that I manage that has this problem. This
server has full connectivity with the repositories servers. Maybe a
problem with any signature?

Thanks,
David

> --
> "If you're not careful, the newspapers will have you hating the people
> who are being oppressed, and loving the people who are doing the
> oppressing." --- Malcolm X
>
>
> --
> To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact
> listmaster@lists.debian.org
> Archive: http://lists.debian.org/20120522125251.GD25963@tal
>


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: CAN9kZedt-+LxaeLuoF+BpO_pMG=8w+CdM8KHh2WBp3d7_agMZQ@mail.gma il.com">http://lists.debian.org/CAN9kZedt-+LxaeLuoF+BpO_pMG=8w+CdM8KHh2WBp3d7_agMZQ@mail.gma il.com

Chris Bannister 05-22-2012 03:50 PM

Problem updating debian 6
 
On Tue, May 22, 2012 at 04:30:37PM +0200, David Seira wrote:
> Hi Chris,
>
> 2012/5/22 Chris Bannister <cbannister@slingshot.co.nz>
>
> The result in english (sorry) is:
[...]
> Get:10 http://security.debian.org/ squeeze/updates/main Translation-en [912 B]
> 59% [10 Translation-en bzip2 0 B] [Connecting to security.debian.org
> (128.31.0.36)]bzip2: (stdin) is not a bzip2 file.
> Ign http://security.debian.org/ squeeze/updates/main Translation-en
> Get:11 http://security.debian.org/ squeeze/updates/main Translation-es
> [912 B]
> 54% [11 Translation-es bzip2 0 B] [Connecting to security.debian.org
> (128.31.0.36)]bzip2: (stdin) is not a bzip2 file.
> Ign http://security.debian.org/ squeeze/updates/main Translation-es
> Get:12 http://security.debian.org squeeze/updates Release [912 B]
> Err http://security.debian.org squeeze/updates Release
>
> Fetched 10.9 kB in 1s (7872 B/s)
> Reading package lists... Done
> W: A error occurred during the signature verification. The repository
> is not updated and the previous index files will be used. GPG error:
> http://ftp.es.debian.org squeeze Release: The following signatures
> were invalid: NODATA 1 NODATA 2
[...]
> W: Failed to fetch http://ftp.es.debian.org/debian/dists/squeeze/Release
> W: Failed to fetch
> http://ftp.es.debian.org/debian/dists/squeeze-updates/Release
> W: Failed to fetch http://security.debian.org/dists/squeeze/updates/Release
> W: Some index files failed to download, they have been ignored, or old
> ones used instead.
>
> Yes, it was a copy 'n' paste problem.

OK.

> This is the only server that I manage that has this problem. This
> server has full connectivity with the repositories servers. Maybe a
> problem with any signature?

Those are just warnings, it is the "Err" which is causing update to
fail.

So you have other servers which work ok? With exactly same sources.list?

Under "/var/lib/apt/lists/" is where the index files are kept.
What I'd do is delete those:
i.e. "rm /var/lib/apt/lists/*" then do apt-get update again.

Then worry about the GPG warnings after.


--
"If you're not careful, the newspapers will have you hating the people
who are being oppressed, and loving the people who are doing the
oppressing." --- Malcolm X


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120522155033.GA30857@tal">http://lists.debian.org/20120522155033.GA30857@tal


All times are GMT. The time now is 09:53 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.