FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 05-03-2012, 09:22 AM
"J. Bakshi"
 
Default how to stick with php5 5.3.x ?

Dear list,

This is a debian wheezy and have php 5.4.x.
I need to stick with php 5.3.x and to achieve this I have added
the following at my sources list

` ` ` `
deb http://ftp.debian.org/debian squeeze main contrib non-free
deb http://security.debian.org squeeze/updates main contrib non-free

` ` ` `

After apt-get update; I get both 5.3 and 5.4 of php5. But every time
it calls the 5.4.x of php5. How can I install the 5.3.x series then ?

Any alternative way is also welcome.

Thanks


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120503145204.795d4323@shiva.selfip.org">http://lists.debian.org/20120503145204.795d4323@shiva.selfip.org
 
Old 05-03-2012, 10:32 AM
"J. Bakshi"
 
Default how to stick with php5 5.3.x ?

On Thu, 3 May 2012 14:52:04 +0530
"J. Bakshi" <bakshi12@gmail.com> wrote:

> Dear list,
>
> This is a debian wheezy and have php 5.4.x.
> I need to stick with php 5.3.x and to achieve this I have added
> the following at my sources list
>
> ` ` ` `
> deb http://ftp.debian.org/debian squeeze main contrib non-free
> deb http://security.debian.org squeeze/updates main contrib non-free
>
> ` ` ` `
>
> After apt-get update; I get both 5.3 and 5.4 of php5. But every time
> it calls the 5.4.x of php5. How can I install the 5.3.x series then ?
>
> Any alternative way is also welcome.
>
> Thanks

Well, did some research and founf apt preferences does the trick.

So I have created /etc/apt/preferences.d/php and added

` ` ` `
Package: php5*
Pin: release a=stable
Pin-Priority: 900

` ` ` `

where as the sources list have

` ` ` `
deb http://packages.dotdeb.org squeeze all
deb-src http://packages.dotdeb.org squeeze all

` ` ` `

But apt still installs the 5.4 version of php not 5.3.

Any clue please ?

Thanks


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120503160244.22afe315@shiva.selfip.org">http://lists.debian.org/20120503160244.22afe315@shiva.selfip.org
 
Old 05-05-2012, 10:38 PM
Bob Proulx
 
Default how to stick with php5 5.3.x ?

J. Bakshi wrote:
> But apt still installs the 5.4 version of php not 5.3.

Install it by explicit version.

apt-get install php5=5.3.3-7+squeeze8 php5-common=5.3.3-7+squeeze8
...

And so on for all of the php packages that you wish to install. Make
sure they have the explicit version and you will get exactly that
version.

Bob
 

Thread Tools




All times are GMT. The time now is 03:18 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org