FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 04-19-2012, 09:49 PM
Chris Hiestand
 
Default dpkg fails to install 32-bit adobe acrobat reader on 64-bit wheezy system: depends issue

So this works fine on 64-bit squeeze:
> chiestand@squeeze:/tmp$ sudo dpkg -i --force-architecture adobereader-enu_9.5.1_i386.deb

But not on 64-bit wheezy:
> chiestand@wheezy:/tmp$ sudo dpkg -i --force-architecture adobereader-enu_9.5.1_i386.deb
> (Reading database ... 783153 files and directories currently installed.)
> Preparing to replace adobereader-enu 9.5.1 (using areader.old.deb) ...
> Unpacking replacement adobereader-enu ...
> dpkg: dependency problems prevent configuration of adobereader-enu:
> adobereader-enu depends on libgtk2.0-0 (>= 2.4).
> dpkg: error processing adobereader-enu (--install):
> dependency problems - leaving unconfigured
> Processing triggers for man-db ...
> Errors were encountered while processing:
> adobereader-enu

Notice the dependency failure. But the depend is actually satisfied in wheezy:
> chiestand@wheezy:/tmp$ dpkg -l libgtk2.0-0
> Desired=Unknown/Install/Remove/Purge/Hold
> | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
> |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
> ||/ Name Version Description
> +++-===========================-===========================-================================================== ====================
> ii libgtk2.0-0:amd64 2.24.10-1 GTK+ graphical user interface library

Is this a multi-arch issue? I've tried setting up multi-arch:
> sudo dpkg --add-architecture i386
> sudo apt-get update

But I get the same result. Bob Proulx, maybe you were right ;-)

Any ideas, anyone?

Thanks,
Chris
 
Old 04-20-2012, 04:33 PM
Camaleůn
 
Default dpkg fails to install 32-bit adobe acrobat reader on 64-bit wheezy system: depends issue

On Thu, 19 Apr 2012 14:49:20 -0700, Chris Hiestand wrote:

> So this works fine on 64-bit squeeze:
> chiestand@squeeze:/tmp$ sudo dpkg -i --force-architecture adobereader-enu_9.5.1_i386.deb
>
> But not on 64-bit wheezy:
> chiestand@wheezy:/tmp$ sudo dpkg -i --force-architecture adobereader-enu_9.5.1_i386.deb
(...)
> adobereader-enu depends on libgtk2.0-0 (>= 2.4).

Do you have the 32-bits compat libraries installed ("ia32-libs", "ia32-libs-
gtk")?

> Notice the dependency failure. But the depend is actually satisfied in
> wheezy:
> chiestand@wheezy:/tmp$ dpkg -l libgtk2.0-0
(...)
> ii libgtk2.0-0:amd64 2.24.10-1 GTK+ graphical user interface library

(...)

Similar problem reported here:

http://forums.adobe.com/thread/934740?tstart=3

Anyway, IIRC, debian multimedia provides a compiled binary for 64 bits...

Greetings,

--
Camaleůn


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: jms343$o0u$16@dough.gmane.org">http://lists.debian.org/jms343$o0u$16@dough.gmane.org
 
Old 04-20-2012, 05:27 PM
Chris Hiestand
 
Default dpkg fails to install 32-bit adobe acrobat reader on 64-bit wheezy system: depends issue

On Apr 20, 2012, at 9:33 AM, Camaleón wrote:

> Do you have the 32-bits compat libraries installed ("ia32-libs", "ia32-libs-
> gtk")?

Absolutely.

> chiestand@wheezy:~$ dpkg -l ia32* |grep -E '^ii'
> ii ia32-libs 20120102 ia32 shared libraries for use on amd64 and ia64 systems
> ii ia32-libs-gtk 20120102 GTK+ ia32 shared libraries



> Similar problem reported here:
>
> http://forums.adobe.com/thread/934740?tstart=3
>
> Anyway, IIRC, debian multimedia provides a compiled binary for 64 bits…

Thanks, I might give that a try. But my larger concern is with dpkg. I think I'll try that mailing list next.


Thanks,
Chris
 
Old 04-20-2012, 05:40 PM
Chris Hiestand
 
Default dpkg fails to install 32-bit adobe acrobat reader on 64-bit wheezy system: depends issue

Hey all,

I tried the debian-user list first with no luck so I'm checking with the experts.
This seems like some kind of bug in dpkg.

So this works fine on 64-bit squeeze:
> chiestand@squeeze:/tmp$ sudo dpkg -i --force-architecture adobereader-enu_9.5.1_i386.deb

But not on 64-bit wheezy:
> chiestand@wheezy:/tmp$ sudo dpkg -i --force-architecture adobereader-enu_9.5.1_i386.deb
> (Reading database ... 783153 files and directories currently installed.)
> Preparing to replace adobereader-enu 9.5.1 (using areader.old.deb) ...
> Unpacking replacement adobereader-enu ...
> dpkg: dependency problems prevent configuration of adobereader-enu:
> adobereader-enu depends on libgtk2.0-0 (>= 2.4).
> dpkg: error processing adobereader-enu (--install):
> dependency problems - leaving unconfigured
> Processing triggers for man-db ...
> Errors were encountered while processing:
> adobereader-enu

Notice the dependency failure. But the depend is actually satisfied in wheezy:
> chiestand@wheezy:/tmp$ dpkg -l libgtk2.0-0
> Desired=Unknown/Install/Remove/Purge/Hold
> | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
> |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
> ||/ Name Version Description
> +++-===========================-===========================-================================================== ====================
> ii libgtk2.0-0:amd64 2.24.10-1 GTK+ graphical user interface library

Is this a multi-arch issue? I've tried setting up multi-arch:
> sudo dpkg --add-architecture i386
> sudo apt-get update

But I get the same result.

Any ideas, anyone?

Thanks,
Chris
 
Old 04-20-2012, 05:44 PM
Camaleón
 
Default dpkg fails to install 32-bit adobe acrobat reader on 64-bit wheezy system: depends issue

On Fri, 20 Apr 2012 10:27:44 -0700, Chris Hiestand wrote:

> On Apr 20, 2012, at 9:33 AM, Camaleón wrote:
>
>> Do you have the 32-bits compat libraries installed ("ia32-libs",
>> "ia32-libs- gtk")?
>
> Absolutely.
>
> chiestand@wheezy:~$ dpkg -l ia32* |grep -E '^ii'
> ii ia32-libs 20120102 ia32 shared libraries for use on amd64 and ia64 systems
> ii ia32-libs-gtk 20120102 GTK+ ia32 shared libraries

Okay.

>> Similar problem reported here:
>>
>> http://forums.adobe.com/thread/934740?tstart=3
>>
>> Anyway, IIRC, debian multimedia provides a compiled binary for 64 bits…
>
> Thanks, I might give that a try. But my larger concern is with dpkg. I
> think I'll try that mailing list next.

I see :-)

How about downloading/installing from the "tar.bz2" instead? I think
Adobe provides its own script installer and avoiding the deb (and
thus, dpkg) may give you a clue about where the problem is.

Greetings,

--
Camaleón


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: jms79k$o0u$20@dough.gmane.org">http://lists.debian.org/jms79k$o0u$20@dough.gmane.org
 
Old 04-20-2012, 06:44 PM
Steve Langasek
 
Default dpkg fails to install 32-bit adobe acrobat reader on 64-bit wheezy system: depends issue

On Fri, Apr 20, 2012 at 10:40:13AM -0700, Chris Hiestand wrote:
> I tried the debian-user list first with no luck so I'm checking with the
> experts. This seems like some kind of bug in dpkg.

> So this works fine on 64-bit squeeze:
> > chiestand@squeeze:/tmp$ sudo dpkg -i --force-architecture adobereader-enu_9.5.1_i386.deb

> But not on 64-bit wheezy:
> > chiestand@wheezy:/tmp$ sudo dpkg -i --force-architecture adobereader-enu_9.5.1_i386.deb
> > (Reading database ... 783153 files and directories currently installed.)
> > Preparing to replace adobereader-enu 9.5.1 (using areader.old.deb) ...
> > Unpacking replacement adobereader-enu ...
> > dpkg: dependency problems prevent configuration of adobereader-enu:
> > adobereader-enu depends on libgtk2.0-0 (>= 2.4).
> > dpkg: error processing adobereader-enu (--install):
> > dependency problems - leaving unconfigured
> > Processing triggers for man-db ...
> > Errors were encountered while processing:
> > adobereader-enu

> Notice the dependency failure. But the depend is actually satisfied in wheezy:
> > chiestand@wheezy:/tmp$ dpkg -l libgtk2.0-0
> > Desired=Unknown/Install/Remove/Purge/Hold
> > | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
> > |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
> > ||/ Name Version Description
> > +++-===========================-===========================-================================================== ====================
> > ii libgtk2.0-0:amd64 2.24.10-1 GTK+ graphical user interface library

> Is this a multi-arch issue? I've tried setting up multi-arch:
> > sudo dpkg --add-architecture i386
> > sudo apt-get update

> But I get the same result.

Yes, this is a multiarch issue. It's no longer enough to use
--force-architecture to install packages, because the semantics of forcing
the architecture have changed: it now means, approximately, "install this
package even though it's of an architecture that's not configured", where
previously it meant something more like "pretend this package is of my
system's architecture". The difference is that now, dpkg knows not only
that the package is of the wrong architecture but that its dependencies are
not satisfied.

So to get the previous behavior, you need --force-architecture
--force-depends.

Though hopefully, you will shortly not need to --force at all and will be
able to fully resolve the dependencies using multiarch-enabled library
packages.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
slangasek@ubuntu.com vorlon@debian.org
 
Old 04-20-2012, 06:56 PM
Guillem Jover
 
Default dpkg fails to install 32-bit adobe acrobat reader on 64-bit wheezy system: depends issue

On Fri, 2012-04-20 at 10:40:13 -0700, Chris Hiestand wrote:
> I tried the debian-user list first with no luck so I'm checking with
> the experts.

> This seems like some kind of bug in dpkg.

This is just missing dependencies or an appropriate force-option.

> So this works fine on 64-bit squeeze:
> > chiestand@squeeze:/tmp$ sudo dpkg -i --force-architecture adobereader-enu_9.5.1_i386.deb
>
> But not on 64-bit wheezy:
> > chiestand@wheezy:/tmp$ sudo dpkg -i --force-architecture adobereader-enu_9.5.1_i386.deb
> > (Reading database ... 783153 files and directories currently installed.)
> > Preparing to replace adobereader-enu 9.5.1 (using areader.old.deb) ...
> > Unpacking replacement adobereader-enu ...
> > dpkg: dependency problems prevent configuration of adobereader-enu:
> > adobereader-enu depends on libgtk2.0-0 (>= 2.4).
> > dpkg: error processing adobereader-enu (--install):
> > dependency problems - leaving unconfigured
> > Processing triggers for man-db ...
> > Errors were encountered while processing:
> > adobereader-enu

> Notice the dependency failure. But the depend is actually satisfied in wheezy:
> > chiestand@wheezy:/tmp$ dpkg -l libgtk2.0-0
> > Desired=Unknown/Install/Remove/Purge/Hold
> > | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
> > |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
> > ||/ Name Version Description
> > +++-===========================-===========================-================================================== ====================
> > ii libgtk2.0-0:amd64 2.24.10-1 GTK+ graphical user interface library
>
> Is this a multi-arch issue? I've tried setting up multi-arch:
> > sudo dpkg --add-architecture i386
> > sudo apt-get update
>
> But I get the same result.

Either install libgtk2.0-0:i386 (and any other missing dependencies
from i386), or use also --force-depends (but I don't see how the
package would work if it's missing appropriate shared libraries?).

regards,
guillem


--
To UNSUBSCRIBE, email to debian-dpkg-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120420185603.GA20069@gaara.hadrons.org">http://lists.debian.org/20120420185603.GA20069@gaara.hadrons.org
 
Old 04-20-2012, 09:58 PM
Chris Hiestand
 
Default dpkg fails to install 32-bit adobe acrobat reader on 64-bit wheezy system: depends issue

Thank you for the explanation, that is very illuminating. Perhaps the man
page and dpkg error message should be updated to reflect this? I mean,
in the error message there was no mention of the dependency problem
being arch related.

Actually now that I'm trying to install from scratch instead of upgrade
the message seems to be different (libgtk2.0-0:any instead of libgtk2.0-0):
> chiestand@wheezy:/tmp$ sudo dpkg -i --force-architecture adobereader-enu_9.5.1_i386.deb
> dpkg: warning: overriding problem because --force enabled:
> package architecture (i386) does not match system (amd64)
> Selecting previously unselected package adobereader-enu.
> (Reading database ... 782797 files and directories currently installed.)
> Unpacking adobereader-enu (from adobereader-enu_9.5.1_i386.deb) ...
> dpkg: dependency problems prevent configuration of adobereader-enu:
> adobereader-enu depends on libgtk2.0-0:any.
> dpkg: error processing adobereader-enu (--install):
> dependency problems - leaving unconfigured
> Processing triggers for man-db ...
> Errors were encountered while processing:
> adobereader-enu

Perhaps the upgrade message should say libgtk2.0-0:i386 instead?

In any case, thanks very much.
-Chris
 
Old 04-20-2012, 10:23 PM
Guillem Jover
 
Default dpkg fails to install 32-bit adobe acrobat reader on 64-bit wheezy system: depends issue

On Fri, 2012-04-20 at 14:58:33 -0700, Chris Hiestand wrote:
> Actually now that I'm trying to install from scratch instead of upgrade
> the message seems to be different (libgtk2.0-0:any instead of libgtk2.0-0):

> > chiestand@wheezy:/tmp$ sudo dpkg -i --force-architecture adobereader-enu_9.5.1_i386.deb
> > dpkg: warning: overriding problem because --force enabled:
> > package architecture (i386) does not match system (amd64)
> > Selecting previously unselected package adobereader-enu.
> > (Reading database ... 782797 files and directories currently installed.)
> > Unpacking adobereader-enu (from adobereader-enu_9.5.1_i386.deb) ...
> > dpkg: dependency problems prevent configuration of adobereader-enu:
> > adobereader-enu depends on libgtk2.0-0:any.
> > dpkg: error processing adobereader-enu (--install):
> > dependency problems - leaving unconfigured
> > Processing triggers for man-db ...
> > Errors were encountered while processing:
> > adobereader-enu
>
> Perhaps the upgrade message should say libgtk2.0-0:i386 instead?

Well, certainly at least something clearer than libgtk2.0-0:any. I've
put that on my list of messages to clarify for 1.16.3 or 1.16.4.

thanks,
guillem


--
To UNSUBSCRIBE, email to debian-dpkg-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120420222326.GA25800@gaara.hadrons.org">http://lists.debian.org/20120420222326.GA25800@gaara.hadrons.org
 
Old 04-20-2012, 11:02 PM
Chris Hiestand
 
Default dpkg fails to install 32-bit adobe acrobat reader on 64-bit wheezy system: depends issue

On Apr 20, 2012, at 3:23 PM, Guillem Jover wrote:

> Well, certainly at least something clearer than libgtk2.0-0:any. I've
> put that on my list of messages to clarify for 1.16.3 or 1.16.4.
>
> thanks,
> guillem


Awesome guillem, thanks.


Regarding your previous email:

On Apr 20, 2012, at 11:56 AM, Guillem Jover wrote:

> Either install libgtk2.0-0:i386 (and any other missing dependencies
> from i386), or use also --force-depends (but I don't see how the
> package would work if it's missing appropriate shared libraries?).

I was curious about that too. It turns out that Adobe ships a bunch of libraries
along with the compiled executable and modifies your LD_LIBRARY_PATH.
I can verify that acroread does run under Wheezy.


I tried installing libgtk2.0-0:i386 that but it seems like not all the appropriate
packages in the dependency chain are multi-arch (or maybe the system is misconfigured):
> chiestand@wheezy:/tmp$ sudo apt-get install -f libgtk2.0-0:i386
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
> libgtk2.0-0:i386 : Depends: shared-mime-info:i386 but it is not going to be installed
> Recommends: hicolor-icon-theme:i386 but it is not installable
> E: Broken packages


If I trace the dependency down a couple levels I get this:
> chiestand@wheezy:/tmp$ sudo apt-get install -f libxml2:i386
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> The following extra packages will be installed:
> conky-cli emacs23-nox gcc-4.7-base:i386 icedtea-7-jre-cacao icedtea-7-jre-jamvm libc6:i386 libc6-i686:i386 libgcc1:i386 openjdk-7-jre-headless openjdk-7-jre-lib pcb-lesstif pinentry-curses zlib1g:i386
> Suggested packages:
> apcupsd moc mpd emacs23-common-non-dfsg glibc-doc:i386 locales:i386 sun-java6-fonts fonts-ipafont-gothic fonts-ipafont-mincho ttf-wqy-microhei ttf-wqy-zenhei ttf-indic-fonts pinentry-doc
> Recommended packages:
> xml-core:i386
> The following packages will be REMOVED:
> 3depict abiword abiword-plugin-grammar abiword-plugin-mathview acedb-other-belvu acedb-other-dotter adobe-flashplugin adun.app aeskulap aisleriot akonadi-server akonadiconsole akregator alacarte alien alien-hunter amide amor arduino
> ark audacity avahi-daemon avogadro bamfdaemon baobab bauble bibus bind9 bind9-host bind9utils blinken blogilo bomber bovo brasero cadabra cantor cantor-backend-kalgebra caret cb2bib cba cervisia cheese chemical-mime-data
> chemical-structures chemtool cmake conky-all connectomeviewer context context-modules coq coq-theories coqide ctsim cvsservice dcmtk dconf-tools debhelper default-jdk default-jre deluge deluge-gtk deluge-torrent desktop-base
> dh-autoreconf dh-make dia dia-common dia-libs dicomscope dnsutils dolphin dragonplayer easychem eclipse eclipse-cdt eclipse-egit eclipse-emf eclipse-emf-examples eclipse-emf-sdk eclipse-gef eclipse-gef-doc eclipse-jdt eclipse-mylyn
> …

A ton of packages would be removed, including libxml2 libxml2-dev libxml2-utils. I'm confused about where the conflict comes from. Is there a tool to help narrow down where the conflict arises?

libxml2 source shows that it has "Architecture: any", so I'd imagine that should be not be a conflict even though there is no Multi-Arch field.

-Chris
 

Thread Tools




All times are GMT. The time now is 11:56 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org