Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian User (http://www.linux-archive.org/debian-user/)
-   -   nfs shares have trailing slash in /proc/mounts (http://www.linux-archive.org/debian-user/656755-nfs-shares-have-trailing-slash-proc-mounts.html)

Chris Hiestand 04-16-2012 11:50 PM

nfs shares have trailing slash in /proc/mounts
 
I just upgraded from Squeeze to Wheezy and noticed that now NFS exports
have an extra trailing slash in /proc/mounts (aka /etc/mtab, aka
/proc/self/mounts).

> server:/vol/export1/ on /server/mountpath type nfs (rw,nosuid,nodev,noatimeā€¦)

But the trailing slash is not originated in /etc/fstab.

> server:/vol/export1 /server/mountpath nfs rw,...


The problem is that if you try to umount using the same string as in
/etc/fstab, it will not umount.

> umount: server:/vol/export1: not found

If you add the trailing slash, the umount works.

Similarly, if you try to edit fstab based on exports in /proc/mounts
you may have trouble unless you carefully handle trailing slashes.
I noticed this problem because an automated script started failing.

/var/run/mount/utab does not contain the extra trailing slash.

Googling hasn't returned anything directly relevant for NFS, though this
looks close: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=653630

There was a similar problem on CIFS that was labeled a bug and fixed.

Does anyone know if this change was on purpose? I could imagine that somebody
wants to add trailing slashes to directories to make them more readable.


Thanks,
Chris

linux kernel: 3.2.0-2-amd64
nfs-common: 1:1.2.5-4

--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: D129DE75-3D34-4F31-B72B-A39AC84428B1@salk.edu">http://lists.debian.org/D129DE75-3D34-4F31-B72B-A39AC84428B1@salk.edu

04-23-2012 01:53 PM

nfs shares have trailing slash in /proc/mounts
 
Hi,

I've also been hit by this bug. (using wheezy as well)
>From what I've seen, it only adds a trailing slash when mounting
with the nfsvers=3 (or =2) option.

If you can confirm this behavior then I see no reason not to call it a
bug ! :-)

--
Laurent


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 878vhmeeq6.fsf@ezri.u-picardie.fr">http://lists.debian.org/878vhmeeq6.fsf@ezri.u-picardie.fr


All times are GMT. The time now is 04:02 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.