FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 04-11-2012, 04:10 AM
T Elcor
 
Default OT: Need help compiling C files

Hi,

Any ideas why I'm getting these errors while trying to compile F3 flash memory test program? The source is at:
http://oss.digirati.com.br/f3/

Tried adding "-I /usr/lib/gcc/x86_64-linux-gnu/4.6/include" option, without quotes, but that didn't help. I'm not a C/C++ developer at all. Thanks

$ make linux
gcc -Wall -c utils.c
In file included from utils.c:1:0:
utils.h:4:19: fatal error: stdio.h: No such file or directory
compilation terminated.
make: *** [linux] Error 1


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 1334117456.41192.YahooMailClassic@web121903.mail.n e1.yahoo.com">http://lists.debian.org/1334117456.41192.YahooMailClassic@web121903.mail.n e1.yahoo.com
 
Old 04-11-2012, 04:22 AM
Kumar Appaiah
 
Default OT: Need help compiling C files

On Tue, Apr 10, 2012 at 09:10:56PM -0700, T Elcor wrote:
> Any ideas why I'm getting these errors while trying to compile F3 flash memory test program? The source is at:
> http://oss.digirati.com.br/f3/
>
> Tried adding "-I /usr/lib/gcc/x86_64-linux-gnu/4.6/include" option, without quotes, but that didn't help. I'm not a C/C++ developer at all. Thanks
>
> $ make linux
> gcc -Wall -c utils.c
> In file included from utils.c:1:0:
> utils.h:4:19: fatal error: stdio.h: No such file or directory
> compilation terminated.
> make: *** [linux] Error 1

It works for me.

Please try sudo apt-get install build-essential and then try again; the
headers might not be present.

Kumar
--
The first is to ensure your partner understands that nature has root
privileges - nature doesn't have to make sense.
-- Telsa Gwynne


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120411042219.GA10336@bluemoon.alumni.iitm.ac.in" >http://lists.debian.org/20120411042219.GA10336@bluemoon.alumni.iitm.ac.in
 
Old 04-11-2012, 04:45 AM
T Elcor
 
Default OT: Need help compiling C files

--- On Tue, 4/10/12, Kumar Appaiah <a.kumar@alumni.iitm.ac.in> wrote:

> It works for me.
>
> Please try sudo apt-get install build-essential and then try
> again; the
> headers might not be present.

I'm on Wheezy, installing build-essential appears to be a bit problematic:

# aptitude install make gcc build-essential
The following NEW packages will be installed:
build-essential bzip2{a} dpkg-dev{a} g++{a} g++-4.6{a} libc-dev-bin{a} libc6-dev{a}
libclass-isa-perl{a} libdpkg-perl{a} libfile-fcntllock-perl{a} libstdc++6-4.6-dev{a} libswitch-perl{a}
libtimedate-perl{a} linux-libc-dev{a}
The following packages will be upgraded:
perl perl-base perl-modules
The following packages are RECOMMENDED but will NOT be installed:
fakeroot libalgorithm-merge-perl manpages-dev
3 packages upgraded, 14 newly installed, 0 to remove and 16 not upgraded.
Need to get 23.8 MB of archives. After unpacking 35.2 MB will be used.
The following packages have unmet dependencies:
libtext-charwidth-perl : Depends: perlapi-5.12.4 which is a virtual package.
libuuid-perl : Depends: perlapi-5.12.3 which is a virtual package.
libdbi-perl : Depends: perlapi-5.12.3 which is a virtual package.
liblocale-gettext-perl : PreDepends: perlapi-5.12.4 which is a virtual package.
libdbd-mysql-perl : Depends: perlapi-5.12.4 which is a virtual package.
libperl5.12 : Depends: perl-base (= 5.12.4-6) but 5.14.2-9 is to be installed.
libtext-iconv-perl : Depends: perlapi-5.12.4 which is a virtual package.
The following actions will resolve these dependencies:

Remove the following packages: <list of 144 packages>


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 1334119514.35062.YahooMailClassic@web121906.mail.n e1.yahoo.com">http://lists.debian.org/1334119514.35062.YahooMailClassic@web121906.mail.n e1.yahoo.com
 
Old 04-11-2012, 04:49 AM
Kumar Appaiah
 
Default OT: Need help compiling C files

On Tue, Apr 10, 2012 at 09:45:14PM -0700, T Elcor wrote:
> I'm on Wheezy, installing build-essential appears to be a bit problematic:
>
> # aptitude install make gcc build-essential
> The following NEW packages will be installed:
> build-essential bzip2{a} dpkg-dev{a} g++{a} g++-4.6{a} libc-dev-bin{a} libc6-dev{a}
> libclass-isa-perl{a} libdpkg-perl{a} libfile-fcntllock-perl{a} libstdc++6-4.6-dev{a} libswitch-perl{a}
> libtimedate-perl{a} linux-libc-dev{a}
> The following packages will be upgraded:
> perl perl-base perl-modules
> The following packages are RECOMMENDED but will NOT be installed:
> fakeroot libalgorithm-merge-perl manpages-dev
> 3 packages upgraded, 14 newly installed, 0 to remove and 16 not upgraded.
> Need to get 23.8 MB of archives. After unpacking 35.2 MB will be used.
> The following packages have unmet dependencies:
> libtext-charwidth-perl : Depends: perlapi-5.12.4 which is a virtual package.
> libuuid-perl : Depends: perlapi-5.12.3 which is a virtual package.
> libdbi-perl : Depends: perlapi-5.12.3 which is a virtual package.
> liblocale-gettext-perl : PreDepends: perlapi-5.12.4 which is a virtual package.
> libdbd-mysql-perl : Depends: perlapi-5.12.4 which is a virtual package.
> libperl5.12 : Depends: perl-base (= 5.12.4-6) but 5.14.2-9 is to be installed.
> libtext-iconv-perl : Depends: perlapi-5.12.4 which is a virtual package.
> The following actions will resolve these dependencies:
>
> Remove the following packages: <list of 144 packages>

I don't know how one would get over this. It is possible that you are
caught in the midst of a transition, but I am not sure.

Should you just want the stdio.h header, maybe getting libc6-dev
should do. You could try installing just that.

Kumar
--
Netscape is not a newsreader, and probably never shall be.
-- Tom Christiansen


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120411044959.GA13405@bluemoon.alumni.iitm.ac.in" >http://lists.debian.org/20120411044959.GA13405@bluemoon.alumni.iitm.ac.in
 
Old 04-11-2012, 05:41 AM
T Elcor
 
Default OT: Need help compiling C files

--- On Tue, 4/10/12, Kumar Appaiah <a.kumar@alumni.iitm.ac.in> wrote:

> I don't know how one would get over this. It is possible
> that you are
> caught in the midst of a transition, but I am not sure.
>
> Should you just want the stdio.h header, maybe getting
> libc6-dev
> should do. You could try installing just that.

That worked, thanks for your help.



--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 1334122892.93128.YahooMailClassic@web121904.mail.n e1.yahoo.com">http://lists.debian.org/1334122892.93128.YahooMailClassic@web121904.mail.n e1.yahoo.com
 
Old 04-13-2012, 01:43 AM
Kamaraju S Kusumanchi
 
Default OT: Need help compiling C files

T Elcor wrote:

> --- On Tue, 4/10/12, Kumar Appaiah <a.kumar@alumni.iitm.ac.in> wrote:
>
>> It works for me.
>>
>> Please try sudo apt-get install build-essential and then try
>> again; the
>> headers might not be present.
>
> I'm on Wheezy, installing build-essential appears to be a bit problematic:
>
> # aptitude install make gcc build-essential
> The following NEW packages will be installed:
> build-essential bzip2{a} dpkg-dev{a} g++{a} g++-4.6{a} libc-dev-bin{a}
> libc6-dev{a} libclass-isa-perl{a} libdpkg-perl{a}
> libfile-fcntllock-perl{a} libstdc++6-4.6-dev{a} libswitch-perl{a}
> libtimedate-perl{a} linux-libc-dev{a}
> The following packages will be upgraded:
> perl perl-base perl-modules
> The following packages are RECOMMENDED but will NOT be installed:
> fakeroot libalgorithm-merge-perl manpages-dev
> 3 packages upgraded, 14 newly installed, 0 to remove and 16 not upgraded.
> Need to get 23.8 MB of archives. After unpacking 35.2 MB will be used.
> The following packages have unmet dependencies:
> libtext-charwidth-perl : Depends: perlapi-5.12.4 which is a virtual
> package. libuuid-perl : Depends: perlapi-5.12.3 which is a virtual
> package. libdbi-perl : Depends: perlapi-5.12.3 which is a virtual
> package. liblocale-gettext-perl : PreDepends: perlapi-5.12.4 which is a
> virtual package. libdbd-mysql-perl : Depends: perlapi-5.12.4 which is a
> virtual package. libperl5.12 : Depends: perl-base (= 5.12.4-6) but
> 5.14.2-9 is to be installed. libtext-iconv-perl : Depends: perlapi-5.12.4
> which is a virtual package.
> The following actions will resolve these dependencies:
>
> Remove the following packages: <list of 144 packages>

Do an "apt-get update" and then try the "apt-get install make gcc build-
essential" command?

--
Kamaraju S Kusumanchi
http://malayamaarutham.blogspot.com/


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: jm80cs$hur$1@dough.gmane.org">http://lists.debian.org/jm80cs$hur$1@dough.gmane.org
 

Thread Tools




All times are GMT. The time now is 08:08 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org