Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian User (http://www.linux-archive.org/debian-user/)
-   -   Networking borked on new squeeze install (http://www.linux-archive.org/debian-user/654366-networking-borked-new-squeeze-install.html)

Mat Enders 04-10-2012 02:38 AM

Networking borked on new squeeze install
 
Here is a stumper. I just completed a brand new installation of
Debian, during installation it could not reach the repositories so
only a base installation was completed.

I am logged directly into the machine not via ssh. Network appears to
have configured correctly via dhcp.

ifconfig says I have the correct network address
route -n shows the correct gateway
resolv.conf shows the correct DNS servers

from another machine on the network I can ping the gateway and www.google.com
from the new install attempting to ping the gateway destination host
unreachable and for Google it says unknown host

I can ssh into the machine via its IP address and I can ssh into other
machines on the network, from the newly installed machine, via their
IP address

I am stumped any help would be appreciated.

--
Mathew E. Enders

"Where once Samba and Apache sold Linux to the world they are now just
part of the plumbing. *But that's OK, plumbers make good money."
--Jeremy Allison


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: CAO+61Wg0+Q15s+Lw1Pi-VTbBjUbiMijRM1+TOi2T85_FFH5p-g@mail.gmail.com">http://lists.debian.org/CAO+61Wg0+Q15s+Lw1Pi-VTbBjUbiMijRM1+TOi2T85_FFH5p-g@mail.gmail.com

Steve Mayer 04-10-2012 03:06 AM

Networking borked on new squeeze install
 
On Apr 9, 2012, at 7:38 PM, Mat Enders wrote:
> Here is a stumper. I just completed a brand new installation of
> Debian, during installation it could not reach the repositories so
> only a base installation was completed.
>
> I am logged directly into the machine not via ssh. Network appears to
> have configured correctly via dhcp.
>
> ifconfig says I have the correct network address
> route -n shows the correct gateway
> resolv.conf shows the correct DNS servers
>
> from another machine on the network I can ping the gateway and www.google.com
> from the new install attempting to ping the gateway destination host
> unreachable and for Google it says unknown host
>
> I can ssh into the machine via its IP address and I can ssh into other
> machines on the network, from the newly installed machine, via their
> IP address
>
> I am stumped any help would be appreciated.


Take a look at your /etc/nsswitch.conf file. See if it has anything related to dns for the 'hosts' directive.

If it only has files listed for hosts: you try adding dns after files so it looks like this:

hosts: files dns

Good luck.

Steve Mayer
smayer69@me.com

"The only reason people get lost in thought is because it's unfamiliar territory." -- Unknown

Brad Alexander 04-10-2012 03:34 AM

Networking borked on new squeeze install
 
Sounds like a dns problem, Mat. Can you ping a network address outside
your borders? I like to keep several in the back of my head for that:
GTE/MCI/VZN's dns servers are 4.2.2.1, 4.2.2.2 and 4.2.2.3. Google's
are 8.8.8.8 and 8.8.4.4. Can you ping them by address? what does the
search and/or domain lines in /etc/resolv.conf say?

--b

On Mon, Apr 9, 2012 at 10:38 PM, Mat Enders <mat.enders@gmail.com> wrote:
> Here is a stumper. *I just completed a brand new installation of
> Debian, during installation it could not reach the repositories so
> only a base installation was completed.
>
> I am logged directly into the machine not via ssh. *Network appears to
> have configured correctly via dhcp.
>
> ifconfig says I have the correct network address
> route -n shows the correct gateway
> resolv.conf shows the correct DNS servers
>
> from another machine on the network I can ping the gateway and www.google.com
> from the new install attempting to ping the gateway destination host
> unreachable and for Google it says unknown host
>
> I can ssh into the machine via its IP address and I can ssh into other
> machines on the network, from the newly installed machine, via their
> IP address
>
> I am stumped any help would be appreciated.
>
> --
> Mathew E. Enders
>
> "Where once Samba and Apache sold Linux to the world they are now just
> part of the plumbing. *But that's OK, plumbers make good money."
> --Jeremy Allison
>
>
> --
> To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
> Archive: http://lists.debian.org/CAO+61Wg0+Q15s+Lw1Pi-VTbBjUbiMijRM1+TOi2T85_FFH5p-g@mail.gmail.com
>


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: CAKmZw+Z3HPVLctvXRiufGhxeY=CNQYbMHmY4isadLZ-0pmi8AQ@mail.gmail.com">http://lists.debian.org/CAKmZw+Z3HPVLctvXRiufGhxeY=CNQYbMHmY4isadLZ-0pmi8AQ@mail.gmail.com

Mat Enders 04-10-2012 04:00 AM

Networking borked on new squeeze install
 
On Mon, Apr 9, 2012 at 11:34 PM, Brad Alexander <storm16@gmail.com> wrote:
> Sounds like a dns problem, Mat. Can you ping a network address outside
> your borders? I like to keep several in the back of my head for that:
> GTE/MCI/VZN's dns servers are 4.2.2.1, 4.2.2.2 and 4.2.2.3. Google's
> are 8.8.8.8 and 8.8.4.4. Can you ping them by address? what does the
> search and/or domain lines in /etc/resolv.conf say?
>
> --b
>
> On Mon, Apr 9, 2012 at 10:38 PM, Mat Enders <mat.enders@gmail.com> wrote:
>> Here is a stumper. *I just completed a brand new installation of
>> Debian, during installation it could not reach the repositories so
>> only a base installation was completed.
>>
>> I am logged directly into the machine not via ssh. *Network appears to
>> have configured correctly via dhcp.
>>
>> ifconfig says I have the correct network address
>> route -n shows the correct gateway
>> resolv.conf shows the correct DNS servers
>>
>> from another machine on the network I can ping the gateway and www.google.com
>> from the new install attempting to ping the gateway destination host
>> unreachable and for Google it says unknown host
>>
>> I can ssh into the machine via its IP address and I can ssh into other
>> machines on the network, from the newly installed machine, via their
>> IP address
>>
>> I am stumped any help would be appreciated.
>>

No I can not ping outside of the network at I can not even ping the
gateway with the new machine. I can ping inside the network and use
ssh inside the network with the new machine.

--
Mathew E. Enders

"Where once Samba and Apache sold Linux to the world they are now just
part of the plumbing. *But that's OK, plumbers make good money."
--Jeremy Allison


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: CAO+61WjFdcvCPvnUTxBB3bMs2bvewiHvV02qHJZST9kZLqNXp w@mail.gmail.com">http://lists.debian.org/CAO+61WjFdcvCPvnUTxBB3bMs2bvewiHvV02qHJZST9kZLqNXp w@mail.gmail.com

Brad Alexander 04-10-2012 04:50 AM

Networking borked on new squeeze install
 
Ugh. What does route show? It sounds like your route to your gateway is b0rked.

--b

On Tue, Apr 10, 2012 at 12:00 AM, Mat Enders <mat.enders@gmail.com> wrote:
> On Mon, Apr 9, 2012 at 11:34 PM, Brad Alexander <storm16@gmail.com> wrote:
>> Sounds like a dns problem, Mat. Can you ping a network address outside
>> your borders? I like to keep several in the back of my head for that:
>> GTE/MCI/VZN's dns servers are 4.2.2.1, 4.2.2.2 and 4.2.2.3. Google's
>> are 8.8.8.8 and 8.8.4.4. Can you ping them by address? what does the
>> search and/or domain lines in /etc/resolv.conf say?
>>
>> --b
>>
>> On Mon, Apr 9, 2012 at 10:38 PM, Mat Enders <mat.enders@gmail.com> wrote:
>>> Here is a stumper. *I just completed a brand new installation of
>>> Debian, during installation it could not reach the repositories so
>>> only a base installation was completed.
>>>
>>> I am logged directly into the machine not via ssh. *Network appears to
>>> have configured correctly via dhcp.
>>>
>>> ifconfig says I have the correct network address
>>> route -n shows the correct gateway
>>> resolv.conf shows the correct DNS servers
>>>
>>> from another machine on the network I can ping the gateway and www.google.com
>>> from the new install attempting to ping the gateway destination host
>>> unreachable and for Google it says unknown host
>>>
>>> I can ssh into the machine via its IP address and I can ssh into other
>>> machines on the network, from the newly installed machine, via their
>>> IP address
>>>
>>> I am stumped any help would be appreciated.
>>>
>
> No I can not ping outside of the network at I can not even ping the
> gateway with the new machine. *I can ping inside the network and use
> ssh inside the network with the new machine.
>
> --
> Mathew E. Enders
>
> "Where once Samba and Apache sold Linux to the world they are now just
> part of the plumbing. *But that's OK, plumbers make good money."
> --Jeremy Allison


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: CAKmZw+ZOD__E70VseY3h960T7jOYPjBb=iWyFBN2X8Jt0mu54 w@mail.gmail.com">http://lists.debian.org/CAKmZw+ZOD__E70VseY3h960T7jOYPjBb=iWyFBN2X8Jt0mu54 w@mail.gmail.com

Scott Ferguson 04-10-2012 06:39 AM

Networking borked on new squeeze install
 
On 10/04/12 12:38, Mat Enders wrote:
> Here is a stumper. I just completed a brand new installation of
> Debian, during installation it could not reach the repositories so
> only a base installation was completed.
>
> I am logged directly into the machine not via ssh.

So you've proven the NIC works.

> Network appears to
> have configured correctly via dhcp.
>
> ifconfig says I have the correct network address
> route -n shows the correct gateway
> resolv.conf shows the correct DNS servers

So - provided the gateway allows it, the box should be able to reach the
internet....

>
> from another machine on the network I can ping the gateway and www.google.com

You've proven your gateway works, and your internet connection is
functioning.

> from the new install attempting to ping the gateway destination host
> unreachable and for Google it says unknown host
>
> I can ssh into the machine via its IP address and I can ssh into other
> machines on the network, from the newly installed machine, via their
> IP address
>
> I am stumped any help would be appreciated.
>
Check your the firewall on your gateway device (/var/log/syslog,
possibly dmesg).

Unless you have a really unusual setup (unlikely on a fresh install) the
problem must be at the gateway.


Kind regards

--
Iceweasel/Firefox/Chrome/Chromium/Iceape/IE extensions for finding
answers to questions about Debian:-
https://addons.mozilla.org/en-US/firefox/collections/Scott_Ferguson/debian/


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4F83D5B7.6050006@gmail.com">http://lists.debian.org/4F83D5B7.6050006@gmail.com

Mat Enders 04-10-2012 09:49 PM

Networking borked on new squeeze install
 
On Tue, Apr 10, 2012 at 2:39 AM, Scott Ferguson
<scott.ferguson.debian.user@gmail.com> wrote:
> On 10/04/12 12:38, Mat Enders wrote:
>> Here is a stumper. *I just completed a brand new installation of
>> Debian, during installation it could not reach the repositories so
>> only a base installation was completed.
>>
>> I am logged directly into the machine not via ssh.
>
> So you've proven the NIC works.
>
>> Network appears to
>> have configured correctly via dhcp.
>>
>> ifconfig says I have the correct network address
>> route -n shows the correct gateway
>> resolv.conf shows the correct DNS servers
>
> So - provided the gateway allows it, the box should be able to reach the
> internet....
>
>>
>> from another machine on the network I can ping the gateway and www.google.com
>
> You've proven your gateway works, and your internet connection is
> functioning.
>
>> from the new install attempting to ping the gateway destination host
>> unreachable and for Google it says unknown host
>>
>> I can ssh into the machine via its IP address and I can ssh into other
>> machines on the network, from the newly installed machine, via their
>> IP address
>>
>> I am stumped any help would be appreciated.
>>
> Check your the firewall on your gateway device (/var/log/syslog,
> possibly dmesg).
>
> Unless you have a really unusual setup (unlikely on a fresh install) the
> problem must be at the gateway.
>
>
> Kind regards
>
> --
> Iceweasel/Firefox/Chrome/Chromium/Iceape/IE extensions for finding
> answers to questions about Debian:-
> https://addons.mozilla.org/en-US/firefox/collections/Scott_Ferguson/debian/
>
>
> --
> To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
> Archive: http://lists.debian.org/4F83D5B7.6050006@gmail.com
>

Solved someone on another list remembered for me that I had this same
problem several months ago where existing machines on the network
could get out but not new ones. Rebooting the Netopia gateway solved
the problem. Thanks to those who responded.

--
Mathew E. Enders

"Where once Samba and Apache sold Linux to the world they are now just
part of the plumbing. *But that's OK, plumbers make good money."
--Jeremy Allison


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: http://lists.debian.org/CAO+61Wh2bLzXvb_0vcEZWQ_QpTBJXqeUuD26qvWauAzbU_Q@ mail.gmail.com

Andrei POPESCU 04-12-2012 09:49 AM

Networking borked on new squeeze install
 
On Lu, 09 apr 12, 22:38:59, Mat Enders wrote:
> Here is a stumper. I just completed a brand new installation of
> Debian, during installation it could not reach the repositories so
> only a base installation was completed.
>
> I am logged directly into the machine not via ssh. Network appears to
> have configured correctly via dhcp.

Could you please post the relevant line for your card from 'lspci -nn'?
I suspect firmware is missing (check 'dmesg | grep -i firmware').

Thanks,
Andrei
--
Offtopic discussions among Debian users and developers:
http://lists.alioth.debian.org/mailman/listinfo/d-community-offtopic

Mat Enders 04-12-2012 03:43 PM

Networking borked on new squeeze install
 
Solved someone on another list remembered for me that I had this same
problem several months ago where existing machines on the network
could get out but not new ones. Rebooting the Netopia gateway solved
the problem. Thanks to those who responded.

--
Mathew E. Enders

"Where once Samba and Apache sold Linux to the world they are now just
part of the plumbing. *But that's OK, plumbers make good money."
--Jeremy Allison


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: CAO+61WiWZwvOXTMCkfeNRA+df=HLT5bs553TL4Du6E0XK8VYk w@mail.gmail.com">http://lists.debian.org/CAO+61WiWZwvOXTMCkfeNRA+df=HLT5bs553TL4Du6E0XK8VYk w@mail.gmail.com


All times are GMT. The time now is 08:01 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.