FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 03-31-2012, 10:29 AM
Lisi
 
Default Installing genesys on Debian

Hello, all!

I am trying to install genesys, first in my Lenny box and then in Squeeze.
The SANE website says that my scanner is fully supported.

I have downloaded and extracted the file via the SANE website. I am now
having problems installing it. The main problem is obviously PEBKAC, but any
brainpower I might normally have has deserted me. Here is my least
unsuccessful attempt so far. (* below my signature.)

What destination should I be specifying? I have no idea where in my system I
should be putting it, so that SANE and Xsane can find and use it.

Thanks,
Lisi

* <quote>
Junior:/home/lisi/Scanner/Canon_LiDE-110/sane-backends-1.0.22# ls
acinclude.m4 ChangeLog-1.0.19 configure.in missing
README.openbsd
aclocal.m4 ChangeLog-1.0.2 COPYING mkinstalldirs README.os2
AUTHORS ChangeLog-1.0.20 depcomp NEWS
README.solaris
backend ChangeLog-1.0.21 doc po
README.unixware2
ChangeLog ChangeLog-1.0.3 frontend PROBLEMS
README.unixware7
ChangeLog-1.0.0 ChangeLog-1.0.4 include PROJECTS
README.windows
ChangeLog-1.0.1 ChangeLog-1.0.5 INSTALL README README.zeta
ChangeLog-1.0.10 ChangeLog-1.0.6 install-sh README.aix
sane-backends.lsm
ChangeLog-1.0.12 ChangeLog-1.0.7 japi README.beos sanei
ChangeLog-1.0.13 ChangeLog-1.0.8 lib README.darwin testsuite
ChangeLog-1.0.14 ChangeLog-1.0.9 LICENSE README.djpeg tools
ChangeLog-1.0.15 compile ltmain.sh README.freebsd
ChangeLog-1.0.16 config.guess m4 README.hp-ux
ChangeLog-1.0.17 config.sub Makefile.am README.linux
ChangeLog-1.0.18 configure Makefile.in README.netbsd
Junior:/home/lisi/Scanner/Canon_LiDE-110/sane-backends-1.0.22# sh ./install-sh
install: no input file specified
Junior:/home/lisi/Scanner/Canon_LiDE-110/sane-backends-1.0.22# sh ./install-sh
sane-backends.lsm
install: no destination specified
Junior:/home/lisi/Scanner/Canon_LiDE-110/sane-backends-1.0.22#
</quote>


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201203311129.39362.lisi.reisz@gmail.com">http://lists.debian.org/201203311129.39362.lisi.reisz@gmail.com
 
Old 03-31-2012, 01:41 PM
Lisi
 
Default Installing genesys on Debian

On Saturday 31 March 2012 11:29:39 Lisi wrote:
> /home/lisi/Scanner/Canon_LiDE-110/sane-backends-1.0.22

I have progressed further, but am still not there. The destination needs to
be /etc/sane.d, so:

<quote>
Junior:/home/lisi/Scanner/Canon_LiDE-110/sane-backends-1.0.22# sh ./install-sh
sane-backends.lsm /etc/sane.d
Junior:/home/lisi/Scanner/Canon_LiDE-110/sane-backends-1.0.22#
</quote>

I then ran
#./configure
#make
#make install.

I now realise that only the last needed to be as root, but I just ran straight
through.

But I still can't scan. Xsane gives the following error: no devices
available . I get the same both as myself and as root. :-(

I suspect that all those lovely configured and built files are in the wrong
place in my filesystem. But am back to not knowing where they should be. :-(

Lisi



--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201203311441.15736.lisi.reisz@gmail.com">http://lists.debian.org/201203311441.15736.lisi.reisz@gmail.com
 
Old 03-31-2012, 04:17 PM
Keith McKenzie
 
Default Installing genesys on Debian

On 31/03/12 11:29, Lisi wrote:

Junior:/home/lisi/Scanner/Canon_LiDE-110/sane-backends-1.0.22# sh ./install-sh
install: no input file specified
Junior:/home/lisi/Scanner/Canon_LiDE-110/sane-backends-1.0.22# sh ./install-sh
sane-backends.lsm
install: no destination specified
Junior:/home/lisi/Scanner/Canon_LiDE-110/sane-backends-1.0.22#
No idea about sane; but it looks like you need two parameters for that
command, if you want it in the directory you are in, put a dot '.' for
the second parameter.


Keith


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Archive: 4F772E05.3080608@gmail.com">http://lists.debian.org/4F772E05.3080608@gmail.com
 
Old 03-31-2012, 04:29 PM
Keith McKenzie
 
Default Installing genesys on Debian

On 31/03/12 14:41, Lisi wrote:

I then ran
#./configure
#make
#make install.
'make install' will put the files wherever they should be, that's part
of the makefile.



Junior:/home/lisi/Scanner/Canon_LiDE-110/sane-backends-1.0.22# sh ./install-sh
sane-backends.lsm /etc/sane.d


(/etc/sane.d would probably be your config directory)

Don't know if any of this helps or not; but it just might....

Was there a README to go with it?

Keith


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Archive: 4F7730DF.8030507@gmail.com">http://lists.debian.org/4F7730DF.8030507@gmail.com
 
Old 03-31-2012, 04:36 PM
ntrfug
 
Default Installing genesys on Debian

On Sat, 31 Mar 2012 11:29:39 +0100
Lisi <lisi.reisz@gmail.com> wrote:

> I am trying to install genesys, first in my Lenny box and then in
> Squeeze. The SANE website says that my scanner is fully supported.

Have you seen this web page?

http://man.flashnux.com/en/debian/6/6.0.1/man5/sane-genesys.5.html

It shows that "Canon LiDE 35/40/50/60" are supported, but I don't see
110.

Kevin


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120331113629.3f12fdcd@sirius">http://lists.debian.org/20120331113629.3f12fdcd@sirius
 
Old 03-31-2012, 04:53 PM
Lisi
 
Default Installing genesys on Debian

Thanks, Keith. Your reply is appreciated.

On Saturday 31 March 2012 17:29:19 Keith McKenzie wrote:
> Was there a README to go with it?

Several. But they are of no help at all. :-( All about permissions - which
shouldn't have any effect when one is running as root. I tried running as
root in case permissions were the problem. (They often are with scanners.)

It also says that when you run scanimage -L you will get a result if your
scanner is supported by SANE. I don't get a result - but the SANE website
says explicitly that support for the scanner I have is complete - that is why
I bought it - and the SANE website is the source of the tarball that seems
not to be what I need. :-(

Lisi


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201203311753.27003.lisi.reisz@gmail.com">http://lists.debian.org/201203311753.27003.lisi.reisz@gmail.com
 
Old 03-31-2012, 05:34 PM
Dom
 
Default Installing genesys on Debian

On 31/03/12 17:36, ntrfug wrote:

On Sat, 31 Mar 2012 11:29:39 +0100
Lisi<lisi.reisz@gmail.com> wrote:


I am trying to install genesys, first in my Lenny box and then in
Squeeze. The SANE website says that my scanner is fully supported.


Have you seen this web page?

http://man.flashnux.com/en/debian/6/6.0.1/man5/sane-genesys.5.html

It shows that "Canon LiDE 35/40/50/60" are supported, but I don't see
110.


Running Wheezy here. The standard Debian sane packages seem to have
support for the Canon LiDE 110.


dom@oz:~$ grep -A 1 "LiDE 110" /etc/sane.d/genesys.conf
# Canon LiDE 110
usb 0x04a9 0x1909

I only have a LiDE 60, so can't confirm that it does work as expected.

--
Dom


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Archive: 4F77401F.1090706@rpdom.net">http://lists.debian.org/4F77401F.1090706@rpdom.net
 
Old 03-31-2012, 08:36 PM
Lisi
 
Default Installing genesys on Debian

On Saturday 31 March 2012 17:36:29 ntrfug wrote:
> On Sat, 31 Mar 2012 11:29:39 +0100
>
> Lisi <lisi.reisz@gmail.com> wrote:
> > I am trying to install genesys, first in my Lenny box and then in
> > Squeeze. The SANE website says that my scanner is fully supported.
>
> Have you seen this web page?
>
> http://man.flashnux.com/en/debian/6/6.0.1/man5/sane-genesys.5.html
>
> It shows that "Canon LiDE 35/40/50/60" are supported, but I don't see
> 110.
http://www.sane-project.org/sane-mfgs.html

CanoScan LiDE 110 USB 0x04a9/0x1909 Complete GL124 based, resolution from
75 to 2400 dpi genesys
(1.0-62) sane-genesys

Lisi




--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201203312136.19983.lisi.reisz@gmail.com">http://lists.debian.org/201203312136.19983.lisi.reisz@gmail.com
 
Old 03-31-2012, 09:57 PM
Lisi
 
Default Installing genesys on Debian

On Saturday 31 March 2012 18:34:23 Dom wrote:
> On 31/03/12 17:36, ntrfug wrote:
> > On Sat, 31 Mar 2012 11:29:39 +0100
> >
> > Lisi<lisi.reisz@gmail.com> wrote:
> >> I am trying to install genesys, first in my Lenny box and then in
> >> Squeeze. The SANE website says that my scanner is fully supported.


> Running Wheezy here. The standard Debian sane packages seem to have
> support for the Canon LiDE 110.

**What are you referring to as "the standard Debian Sane packages"?** They
might be in Squeeze backports. I'm due some luck!

I have always before been able to aptitude install sane, sane-backends,
sane-frontends, xsane and get a working LiDE scanner. But this time there
seem not to be suitable packages in either Lenny or Squeeze, so I am trying
to install from the tarball.

> dom@oz:~$ grep -A 1 "LiDE 110" /etc/sane.d/genesys.conf
> # Canon LiDE 110
> usb 0x04a9 0x1909

Yes, I have that, but only because I have added it manually. (It's reassuring
to know that I got the usb id number right!!)

> I only have a LiDE 60, so can't confirm that it does work as expected.

It doesn't here. :-(

Thanks for your input.

Lisi




--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201203312257.17299.lisi.reisz@gmail.com">http://lists.debian.org/201203312257.17299.lisi.reisz@gmail.com
 
Old 04-01-2012, 08:51 AM
Dom
 
Default Installing genesys on Debian

On 31/03/12 22:57, Lisi wrote:

On Saturday 31 March 2012 18:34:23 Dom wrote:

On 31/03/12 17:36, ntrfug wrote:

On Sat, 31 Mar 2012 11:29:39 +0100

Lisi<lisi.reisz@gmail.com> wrote:

I am trying to install genesys, first in my Lenny box and then in
Squeeze. The SANE website says that my scanner is fully supported.




Running Wheezy here. The standard Debian sane packages seem to have
support for the Canon LiDE 110.


**What are you referring to as "the standard Debian Sane packages"?** They
might be in Squeeze backports. I'm due some luck!


Specifically libsane and libsane-common. Wheezy is currently on version
1.0.22-7 of these packages. From the changelog, I am certain that
support for the LiDE was added in one of the early 1.0.22 releases, and
a few fixes applied soon after that.



Thanks for your input.


You're welcome :-)


--
Dom


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Archive: 4F781711.6090309@rpdom.net">http://lists.debian.org/4F781711.6090309@rpdom.net
 

Thread Tools




All times are GMT. The time now is 11:54 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org