FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 03-26-2012, 08:42 PM
Rainer Dorsch
 
Default wheezy: ERROR: could not insert 'zram': No such file or directory

Hello,

cannot load zram using modprobe (worked in the past), but insmod works:

blackbox:~# modprobe zram
ERROR: could not insert 'zram': No such file or directory
blackbox:~# uname -a
Linux blackbox 3.2.0-2-686-pae #1 SMP Tue Mar 20 19:48:26 UTC 2012 i686
GNU/Linux
blackbox:~# find /lib/modules/3.2.0-2-686-pae/ -name zram.ko
/lib/modules/3.2.0-2-686-pae/kernel/drivers/staging/zram/zram.ko
blackbox:~# insmod /lib/modules/3.2.0-2-686-
pae/kernel/drivers/staging/zram/zram.ko zram_num_devices=2
blackbox:~#

Did anything in this area change recently? If not, what could be broken?

Many thanks,
Rainer

--
Rainer Dorsch
http://bokomoko.de/


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201203262242.59380.ml@bokomoko.de">http://lists.debian.org/201203262242.59380.ml@bokomoko.de
 
Old 03-27-2012, 01:55 PM
Camaleón
 
Default wheezy: ERROR: could not insert 'zram': No such file or directory

On Mon, 26 Mar 2012 22:42:59 +0200, Rainer Dorsch wrote:

> cannot load zram using modprobe (worked in the past), but insmod works:
>
> blackbox:~# modprobe zram
> ERROR: could not insert 'zram': No such file or directory

It works fine here (wheezy).

Is there something useful registered in dmesg?

> blackbox:~# uname -a
> Linux blackbox 3.2.0-2-686-pae #1 SMP Tue Mar 20 19:48:26 UTC 2012 i686 GNU/Linux
> blackbox:~# find /lib/modules/3.2.0-2-686-pae/ -name zram.ko
> /lib/modules/3.2.0-2-686-pae/kernel/drivers/staging/zram/zram.ko
> blackbox:~# insmod /lib/modules/3.2.0-2-686-pae/kernel/drivers/staging/zram/zram.ko zram_num_devices=2
> blackbox:~#
>
> Did anything in this area change recently? If not, what could be broken?

Are you running from the same kernel where the module has been built/compiled?

Greetings,

--
Camaleón


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: jksgru$di0$6@dough.gmane.org">http://lists.debian.org/jksgru$di0$6@dough.gmane.org
 

Thread Tools




All times are GMT. The time now is 07:07 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org