FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 03-18-2012, 11:47 AM
T Elcor
 
Default Wheezy: Spellchecker no longer working in Iceweasel 10?

Hi,

For some reason, spellchecker is no longer working for me in text fields in Iceweasel 10 (that is, there is no indication of misspelled words). Iceweasel's preference
layout.spellcheckDefault = 2

"Check my spelling as I type" preference box is checked.

As far as I remember, spellchecker was working fine in Iceweasel 9.

Any ideas? Thanks



$ aptitude show iceweasel
Package: iceweasel
State: installed
Automatically installed: no
Version: 10.0.2-1
Priority: optional
Section: web
Maintainer: Maintainers of Mozilla-related packages <pkg-mozilla-maintainers@lists.alioth.debian.org>
Uncompressed Size: 6,524 k
Depends: libc6 (>= 2.2.5), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.16.0), libgtk2.0-0 (>= 2.10),
libnspr4-0d (>= 1.8.0.10), libstdc++6 (>= 4.1.1), fontconfig, procps, debianutils (>= 1.16),
xulrunner-10.0 (>= 10.0.2-1)
Suggests: ttf-lyx | latex-xft-fonts, xfonts-mathml, ttf-mathematica4.1, mozplugger, libgssapi-krb5-2 |
libkrb53
Provides: gnome-www-browser, www-browser
Description: Web browser based on Firefox


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 1332074863.27126.YahooMailClassic@web121906.mail.n e1.yahoo.com">http://lists.debian.org/1332074863.27126.YahooMailClassic@web121906.mail.n e1.yahoo.com
 
Old 03-19-2012, 03:12 PM
Camaleón
 
Default Wheezy: Spellchecker no longer working in Iceweasel 10?

On Sun, 18 Mar 2012 05:47:43 -0700, T Elcor wrote:

> For some reason, spellchecker is no longer working for me in text fields
> in Iceweasel 10 (that is, there is no indication of misspelled words).

It works here.

> Iceweasel's preference
> layout.spellcheckDefault = 2

I have that value set to "1".

http://kb.mozillazine.org/Layout.spellcheckDefault

> "Check my spelling as I type" preference box is checked.

And this one was unchecked by default but despite of it, it still works
and a misspelled word is underlined in red :-?

> As far as I remember, spellchecker was working fine in Iceweasel 9.
>
> Any ideas? Thanks

(...)

When you right-click over an input text box (or textarea), can you select
the language?

Greetings,

--
Camaleón


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: jk7lsh$6c2$21@dough.gmane.org">http://lists.debian.org/jk7lsh$6c2$21@dough.gmane.org
 
Old 03-19-2012, 05:35 PM
T Elcor
 
Default Wheezy: Spellchecker no longer working in Iceweasel 10?

--- On Mon, 3/19/12, Camaleón <noelamac@gmail.com> wrote:

> It works here.
>
> > Iceweasel's preference
> >***layout.spellcheckDefault = 2
>
> I have that value set to "1".

Yes, I changed that intentionally.


> When you right-click over an input text box (or textarea),
> can you select the language?

That was what fixed it. I have only one language there - English - but apparently I still need to select it now for the spellchecker to work. Weird, I didn't have to do that before.

More importantly, is there a way to configure Iceweasel so it treats all textboxes as English by default and I don't have to remember "selecting" the language, especially since I have only one language there.

Thanks


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 1332182125.65317.YahooMailClassic@web121905.mail.n e1.yahoo.com">http://lists.debian.org/1332182125.65317.YahooMailClassic@web121905.mail.n e1.yahoo.com
 
Old 03-19-2012, 06:05 PM
Camaleón
 
Default Wheezy: Spellchecker no longer working in Iceweasel 10?

On Mon, 19 Mar 2012 11:35:25 -0700, T Elcor wrote:

> --- On Mon, 3/19/12, Camaleón <noelamac@gmail.com> wrote:
>
>> It works here.
>>
>> > Iceweasel's preference
>> >Â*Â*Â*layout.spellcheckDefault = 2
>>
>> I have that value set to "1".
>
> Yes, I changed that intentionally.
>
>
>> When you right-click over an input text box (or textarea), can you
>> select the language?
>
> That was what fixed it. I have only one language there - English - but
> apparently I still need to select it now for the spellchecker to work.
> Weird, I didn't have to do that before.

Well, good :-)

> More importantly, is there a way to configure Iceweasel so it treats all
> textboxes as English by default and I don't have to remember "selecting"
> the language, especially since I have only one language there.

My default is set to Spanish (Castilian), so maybe you need to tweak this:

http://kb.mozillazine.org/Spellchecker.dictionary

>From "about:config" → spellchecker.dictionary → en_US (or whatever you
want as default)

Greetings,

--
Camaleón


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: jk802l$6c2$30@dough.gmane.org">http://lists.debian.org/jk802l$6c2$30@dough.gmane.org
 
Old 03-19-2012, 08:04 PM
T Elcor
 
Default Wheezy: Spellchecker no longer working in Iceweasel 10?

--- On Mon, 3/19/12, Camaleón <noelamac@gmail.com> wrote:

> My default is set to Spanish (Castilian), so maybe you need
> to tweak this:
>
> http://kb.mozillazine.org/Spellchecker.dictionary
>
> >From "about:config" → spellchecker.dictionary →
> en_US (or whatever you
> want as default)

I've already had spellchecker.dictionary set to en_US but with some pages/checkboxes the language still needs to be selected manually. With other pages it just works. Whether the page specifies language with <html lang=...> tag does not appear to have much of an effect.

Still it's a step forward. Thanks for your help.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 1332191081.99019.YahooMailClassic@web121903.mail.n e1.yahoo.com">http://lists.debian.org/1332191081.99019.YahooMailClassic@web121903.mail.n e1.yahoo.com
 
Old 03-19-2012, 08:26 PM
Camaleón
 
Default Wheezy: Spellchecker no longer working in Iceweasel 10?

On Mon, 19 Mar 2012 14:04:41 -0700, T Elcor wrote:

> --- On Mon, 3/19/12, Camaleón <noelamac@gmail.com> wrote:
>
>> My default is set to Spanish (Castilian), so maybe you need to tweak
>> this:
>>
>> http://kb.mozillazine.org/Spellchecker.dictionary
>>
>> >From "about:config" → spellchecker.dictionary →
>> en_US (or whatever you
>> want as default)
>
> I've already had spellchecker.dictionary set to en_US but with some
> pages/checkboxes the language still needs to be selected manually.

You mean with those pages where does not work it defaults to nothing (no
language)? Can you send a sample URI? Just curious :-?

> With other pages it just works. Whether the page specifies language with
> <html lang=...> tag does not appear to have much of an effect.

Mmm, now you say, I'm not sure if the html code of the page can interact
or alter in some way the browser spellchecker.

> Still it's a step forward. Thanks for your help.

You're welcome :-)

Greetings,

--
Camaleón


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: jk889p$6c2$31@dough.gmane.org">http://lists.debian.org/jk889p$6c2$31@dough.gmane.org
 
Old 03-19-2012, 10:27 PM
T Elcor
 
Default Wheezy: Spellchecker no longer working in Iceweasel 10?

--- On Mon, 3/19/12, Camaleón <noelamac@gmail.com> wrote:

> You mean with those pages where does not work it defaults to
> nothing (no language)?

On the pages where it doesn't work, I have to do RMB click, then click on "Languages", then click on "English / Uninted States". After that a bullet appears next to "English / Uninted States" indicating, I guess, that English is now selected/active language and the spellchecker works after that. If I don't click on "English / Uninted States" the spellchecker doesn't work.

> Can you send a sample URI? Just curious :-?

Sure. The following URL leads to "Edit comment" page with a multiline textbox that has "Comment:" label next to it. The spellchecker doesn't work for me in that textbox unless I select the language as described above.

http://linux.slashdot.org/comments.pl?sid=2733961&op=reply&threshold=1&comme ntsort=0&mode=thread&pid=op=reply&threshold=1&comm entsort=0&mode=thread&pid=


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 1332199632.15997.YahooMailClassic@web121903.mail.n e1.yahoo.com">http://lists.debian.org/1332199632.15997.YahooMailClassic@web121903.mail.n e1.yahoo.com
 
Old 03-20-2012, 01:25 PM
Camaleón
 
Default Wheezy: Spellchecker no longer working in Iceweasel 10?

On Mon, 19 Mar 2012 16:27:12 -0700, T Elcor wrote:

> --- On Mon, 3/19/12, Camaleón <noelamac@gmail.com> wrote:
>
>> You mean with those pages where does not work it defaults to nothing
>> (no language)?
>
> On the pages where it doesn't work, I have to do RMB click, then click
> on "Languages", then click on "English / Uninted States". After that a
> bullet appears next to "English / Uninted States" indicating, I guess,
> that English is now selected/active language and the spellchecker works
> after that. If I don't click on "English / Uninted States" the
> spellchecker doesn't work.

I see.

>> Can you send a sample URI? Just curious :-?
>
> Sure. The following URL leads to "Edit comment" page with a multiline
> textbox that has "Comment:" label next to it. The spellchecker doesn't
> work for me in that textbox unless I select the language as described
> above.
>
> http://linux.slashdot.org/comments.pl?sid=2733961&op=reply&threshold=1&comme ntsort=0&mode=thread&pid=op=reply&threshold=1&comm entsort=0&mode=thread&pid=

Thanks :-)

You're right. It neither works here, I have to manually set the language
for the spellcheck to work there. Weird... Oh, it seems it's a known
issue of one of the Slashdot coding horrors, err... I mean "errors" >:-P

http://yro.slashdot.org/comments.pl?sid=2155264&cid=36128554

Greetings,

--
Camaleón


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: jka3vs$v8o$1@dough.gmane.org">http://lists.debian.org/jka3vs$v8o$1@dough.gmane.org
 

Thread Tools




All times are GMT. The time now is 04:02 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org