Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian User (http://www.linux-archive.org/debian-user/)
-   -   Advice for a bug report (http://www.linux-archive.org/debian-user/645152-advice-bug-report.html)

Baruch 03-15-2012 10:27 PM

Advice for a bug report
 
The debian bug reporting system webpage wrote to e-mail this list for advice regarding against which package a bug should be reported, so here goes . . .

I had decided to:
*** apt-get -s purge iceweasel* firefox*


But apt-get insisted:
** The following extra packages will be installed:
* * ** iceape iceape-browser iceape-chatzilla

So I thought I would out-wit apt-get:
** apt-get -s purge iceweasel* firefox* iceape iceape-browser iceape-chatzilla

But apt-get was ready:
** The following extra packages will be installed:
****** epiphany-browser epiphany-browser-data epiphany-gecko

Now, dig this:
* * apt-get -s purge iceweasel* firefox* iceape iceape-browser iceape-chatzilla epiphany-browser epiphany-browser-data epiphany-gecko

Apt-get responds:

The following NEW packages will be installed:
* alacarte apg evolution-data-server folks-common galeon galeon-common gconf-service gir1.2-accountsservice-1.0 gir1.2-caribou-1.0
* gir1.2-folks-0.6 gir1.2-gconf-2.0 gir1.2-gee-1.0 gir1.2-gkbd-3.0 gir1.2-gmenu-3.0 gir1.2-mutter-3.0 gir1.2-networkmanager-1.0
* gir1.2-panelapplet-4.0 gir1.2-polkit-1.0 gir1.2-soup-2.4 gir1.2-telepathyglib-0.12 gir1.2-telepathylogger-0.2
* gir1.2-upowerglib-1.0 gjs gnome-applets gnome-applets-data gnome-contacts gnome-control-center gnome-control-center-data
* gnome-online-accounts gnome-panel gnome-panel-data gnome-power-manager gnome-session gnome-session-fallback gnome-shell
* gnome-shell-common gnome-themes-standard gnome-user-guide libcaribou-common libcaribou0 libebackend-1.2-1 libedata-book-1.2-11
* libedata-cal-1.2-13 libedataserverui-3.0-1 libfolks-eds25 libfolks-telepathy25 libfolks25 libgconf-2-4 libgjs0b
* libgnome-control-center1 libgnome-menu-3-0 libgoa-1.0-0 libgoa-1.0-common libgweather-3-0 libgweather-common libmetacity-private0a
* libmozjs185-1.0 libmozjs2d libmutter0 libpanel-applet-4-0 librest-0.7-0 librest-extras-0.7-0 libsocialweb-client2 libsocialweb0
* libtelepathy-logger2 metacity metacity-common mutter-common notification-daemon xulrunner-1.9.1


My guess is that this is a bug somewhere in the 'alternatives' system, and that it is (against my wishes) trying to force me to have a graphical browser installed.

Against what package should I file the bug? (FWIW - debian wheezy)



--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 1331854075.24735.YahooMailNeo@web110505.mail.gq1.y ahoo.com">http://lists.debian.org/1331854075.24735.YahooMailNeo@web110505.mail.gq1.y ahoo.com

Claudius Hubig 03-15-2012 11:12 PM

Advice for a bug report
 
Hello Baruch,

Baruch <whatmeurgent@yahoo.com> wrote:
> My guess is that this is a bug somewhere in the 'alternatives' system, and that it is (against my wishes) trying to force me to have a graphical browser installed.

Probably not.

> Against what package should I file the bug? (FWIW - debian wheezy)

Probably against none.

iceweasel (and epiphany-browser) both provide two virtual packages,
www-browser and gnome-www-browser. Try

$ aptitude why www-browser
$ aptitude why gnome-www-browser
$ aptitude why iceweasel

to find out why these package need to be provided on your system at
the moment.

Best regards,

Claudius

PS: Does somebody know something similiar for apt-get? rdepends is
not exactly the same thing as why.
--
A shortcut is the longest distance between two points.
Please use GPG: ECB0C2C7 4A4C4046 446ADF86 C08112E5 D72CDBA4
http://chubig.net telnet://nightfall.org:4242

Brian 03-15-2012 11:51 PM

Advice for a bug report
 
On Thu 15 Mar 2012 at 16:27:55 -0700, Baruch wrote:

[Snipped: apt-get doings]

> My guess is that this is a bug somewhere in the 'alternatives' system,
> and that it is (against my wishes) trying to force me to have a
> graphical browser installed.
>
> Against what package should I file the bug? (FWIW - debian wheezy)

The result of 'cat /var/lib/dpkg/alternatives/x-www-browser', please.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120316005146.GG4889@desktop">http://lists.debian.org/20120316005146.GG4889@desktop

Claudius Hubig 03-16-2012 02:45 PM

Advice for a bug report
 
Hello Baruch,

please respond to the list rather than me personally. Please also
don’t top-post (cf. http://www.netmeister.org/news/learn2quote2.html ).

I took the liberty to quote the relevant part of your answer in case
someone else finds this thread:

Baruch <whatmeurgent@yahoo.com> wrote:
> # aptitude why iceweasel
> i** sun-java6-plugin Depends firefox | firefox-2 | iceweasel | mozilla-firefox |
> ************************* **** iceape-browser | mozilla-browser | epiphany-gecko
> ************************* *** | epiphany-webkit | epiphany-browser | galeon | mid
> ************************* *** browser | moblin-web-browser | xulrunner | xulrunne
> ************************* *** r-1.9 | konqueror | chromium-browser | midori | goo
> ************************* *** gle-chrome

I really don’t understand why someone thought this dependency would
be a good idea, because the list containing all supported browsers
can hardly be complete (for example, Opera is missing).

Best regards,

Claudius
--
Kites rise highest against the wind -- not with it.
-- Winston Churchill
Please use GPG: ECB0C2C7 4A4C4046 446ADF86 C08112E5 D72CDBA4
http://chubig.net telnet://nightfall.org:4242

Brian 03-17-2012 06:29 PM

Advice for a bug report
 
On Fri 16 Mar 2012 at 16:45:13 +0100, Claudius Hubig wrote:

> Baruch <whatmeurgent@yahoo.com> wrote:
> > # aptitude why iceweasel
> > i** sun-java6-plugin Depends firefox | firefox-2 | iceweasel | mozilla-firefox |
> > ************************* **** iceape-browser | mozilla-browser | epiphany-gecko
> > ************************* *** | epiphany-webkit | epiphany-browser | galeon | mid
> > ************************* *** browser | moblin-web-browser | xulrunner | xulrunne
> > ************************* *** r-1.9 | konqueror | chromium-browser | midori | goo
> > ************************* *** gle-chrome
>
> I really don’t understand why someone thought this dependency would
> be a good idea, because the list containing all supported browsers
> can hardly be complete (for example, Opera is missing).

Not that I completely understand either but I'd theorise that the
dependency has to be so explicit because Java is involved. It wouldn't
do to have Lynx replace Iceweasel!

As for there being an exact equivalant in apt to 'aptitude why', I do
not think there is. 'apt-cache rdepends' is the best it has to offer at
present.

As you said, there is no bug in the alternatives system but Baruch may
gain a little more understanding from:

http://forums.linuxmint.com/viewtopic.php?f=47&t=82722


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120317192946.GN4889@desktop">http://lists.debian.org/20120317192946.GN4889@desktop


All times are GMT. The time now is 03:49 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.