FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 03-13-2012, 09:05 AM
Andriy Samsonyuk
 
Default X-server problem

Hello,

i am currenttly running debian 6.0 with 2.6.32-5-486 on CF-27 (toughbook)
300MHz Pentium II with 128MB RAM.

I dont need a desktop (gnome, kde, etc) but would like to have X-server running.

X starts for root, but not for non-root user
user is in groups: users, tty, audio, video

/etc/X11/Xwrapper.config is set to
allowed_users=anybody

Every time i start X i get:

Fatal server error:
xf86OpenConsole: Cannot open /dev/tty0 (No such file or directory)

changing of the permissions of /dev/tty0 does not help.

I would appreciate any suggestions!

Kind regards,

Andriy

--
You feel a whole lot more like you do now than you did when you used to.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120313100527.GB11099@theo.chemie.tu-muenchen.de">http://lists.debian.org/20120313100527.GB11099@theo.chemie.tu-muenchen.de
 
Old 03-13-2012, 10:24 AM
Michael Lange
 
Default X-server problem

Hi,

Thus spoketh Andriy Samsonyuk <andriy.samsonyuk@ch.tum.de>
unto us on Tue, 13 Mar 2012 11:05:27 +0100:

(...)
>
> Every time i start X i get:
>
> Fatal server error:
> xf86OpenConsole: Cannot open /dev/tty0 (No such file or directory)
>
> changing of the permissions of /dev/tty0 does not help.
>
> I would appreciate any suggestions!
>

Maybe it is a problem with permissions, as suggested here:

http://ubuntuforums.org/showthread.php?t=1165993

Regards

Michael

.-.. .. ...- . .-.. --- -. --. .- -. -.. .--. .-. --- ... .--. . .-.

Not one hundred percent efficient, of course ... but nothing ever is.
-- Kirk, "Metamorphosis", stardate 3219.8


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120313122410.28a29501.klappnase@freenet.de">http ://lists.debian.org/20120313122410.28a29501.klappnase@freenet.de
 
Old 03-13-2012, 10:26 AM
Andriy Samsonyuk
 
Default X-server problem

Hello,

i am currenttly running debian 6.0 with 2.6.32-5-486 on CF-27 (toughbook)
300MHz Pentium II with 128MB RAM.

I dont need a desktop (gnome, kde, etc) but would like to have X-server running.

X starts for root, but not for non-root user
user is in groups: users, tty, audio, video

/etc/X11/Xwrapper.config is set to
allowed_users=anybody

Every time i start X i get:

Fatal server error:
xf86OpenConsole: Cannot open /dev/tty0 (No such file or directory)

changing of the permissions of /dev/tty0 does not help.

I would appreciate any suggestions!

Kind regards,

Andriy

--
In the stairway of life, you'd best take the elevator.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120313112653.GB12205@theo.chemie.tu-muenchen.de">http://lists.debian.org/20120313112653.GB12205@theo.chemie.tu-muenchen.de
 
Old 03-13-2012, 10:57 AM
Brian
 
Default X-server problem

On Tue 13 Mar 2012 at 11:05:27 +0100, Andriy Samsonyuk wrote:

> i am currenttly running debian 6.0 with 2.6.32-5-486 on CF-27 (toughbook)
> 300MHz Pentium II with 128MB RAM.
>
> I dont need a desktop (gnome, kde, etc) but would like to have X-server running.
>
> X starts for root, but not for non-root user
> user is in groups: users, tty, audio, video

The normal Debian installation doesn't put a user in the users and tty
groups.

> /etc/X11/Xwrapper.config is set to
> allowed_users=anybody

It's usually 'allowed_users=console'.

> Every time i start X i get:
>
> Fatal server error:
> xf86OpenConsole: Cannot open /dev/tty0 (No such file or directory)
>
> changing of the permissions of /dev/tty0 does not help.
>
> I would appreciate any suggestions!

Somebody has walked your path in the past:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=618733


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120313115741.GU4889@desktop">http://lists.debian.org/20120313115741.GU4889@desktop
 
Old 03-13-2012, 05:03 PM
Andrei POPESCU
 
Default X-server problem

On Ma, 13 mar 12, 12:26:53, Andriy Samsonyuk wrote:
>
> Every time i start X i get:
>
> Fatal server error:
> xf86OpenConsole: Cannot open /dev/tty0 (No such file or directory)
>
> changing of the permissions of /dev/tty0 does not help.

Something interesting in /var/log/Xorg.0.log ?

Kind regards,
Andrei
--
Offtopic discussions among Debian users and developers:
http://lists.alioth.debian.org/mailman/listinfo/d-community-offtopic
 
Old 03-13-2012, 06:14 PM
Kelly Clowers
 
Default X-server problem

On Tue, Mar 13, 2012 at 11:03, Andrei POPESCU <andreimpopescu@gmail.com> wrote:
> On Ma, 13 mar 12, 12:26:53, Andriy Samsonyuk wrote:
>>
>> Every time i start X i get:
>>
>> Fatal server error:
>> xf86OpenConsole: Cannot open /dev/tty0 (No such file or directory)
>>
>> changing of the permissions of /dev/tty0 does not help.
>
> Something interesting in /var/log/Xorg.0.log ?

Definitely agree on checking that, also maybe check SUID perms on the
Xorg binary?


Cheers,
Kelly Clowers


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: CAFoWM=-0b4zCuYu=xp7g2LCRWvrO7W+1B60zw9xpoQWToxTQDQ@mail.g mail.com">http://lists.debian.org/CAFoWM=-0b4zCuYu=xp7g2LCRWvrO7W+1B60zw9xpoQWToxTQDQ@mail.g mail.com
 
Old 03-13-2012, 07:08 PM
"Juergen F. Pennings"
 
Default X-server problem

Andriy Samsonyuk wrote:
> Every time i start X i get:
>
> Fatal server error:
> xf86OpenConsole: Cannot open /dev/tty0 (No such file or directory)
>
Hello Andriy,
for me it looks strange that you want to start the X-Server on tty0. The
normal behaviour under debian is to start it on tty7 or higher. As much as
I remember tty0 is inhibited to start the X-Server on it. What is if you
start it on another console, maybe tty5?
Please post the content of your
/etc/inittab
In mine you can find:
# Note that on most Debian systems tty7 is used by the X Window System,
# so if you want to add more getty's go ahead but skip tty7 if you run X.
tty0 is not listed in my /etc/inittab.

--
Schöne Grüße vom Möhnesee

Jürgen


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 72m439-odq.ln1@acer.hebelweg.de">http://lists.debian.org/72m439-odq.ln1@acer.hebelweg.de
 
Old 03-14-2012, 04:47 AM
Chris Bannister
 
Default X-server problem

[CCing Andriy, (I'm guessing he is not subscribed)]

Andriy, if you are subscribed please let us know.

On Tue, Mar 13, 2012 at 12:26:53PM +0100, Andriy Samsonyuk wrote:
> Hello,
>
> i am currenttly running debian 6.0 with 2.6.32-5-486 on CF-27 (toughbook)
> 300MHz Pentium II with 128MB RAM.
>
> I dont need a desktop (gnome, kde, etc) but would like to have X-server running.

Fine. You should consider using a window manager like fvwm though.

> X starts for root, but not for non-root user
> user is in groups: users, tty, audio, video
^^^
Weird, a normal user isn't in that group by default.

> /etc/X11/Xwrapper.config is set to
> allowed_users=anybody

Mmmm, mine is set to:
allowed_users=console

> Every time i start X i get:
>
> Fatal server error:
> xf86OpenConsole: Cannot open /dev/tty0 (No such file or directory)

I have:
root@tal:~# ls -al /dev/tty0
crw------- 1 root root 4, 0 Mar 14 16:04 /dev/tty0

I'm guessing that your results will be different!

> changing of the permissions of /dev/tty0 does not help.

Right. ... Ok. ... My guess is that you couldn't get X to start, and so
decided to have a "play" with things and see if you could fix it. Am I
right or am I right?

> I would appreciate any suggestions!

First of all, Don't Panic! The good thing about Debian is, it is
fixable.

Can you remember the changes you have done?

How are you starting X? We need to know the exact commands.

What is the result of:
apt-cache policy xorg

--
"Religion is excellent stuff for keeping common people quiet."
-- Napoleon Bonaparte


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120314054737.GD2215@tal">http://lists.debian.org/20120314054737.GD2215@tal
 
Old 03-14-2012, 08:51 AM
Andriy Samsonyuk
 
Default X-server problem

Hi,

first of all thanks for help!

On Wed, Mar 14, 2012 at 06:47:38PM +1300, Chris Bannister wrote:
> [CCing Andriy, (I'm guessing he is not subscribed)]
>
> Andriy, if you are subscribed please let us know.
i am indeed subscribed to the list
>
> On Tue, Mar 13, 2012 at 12:26:53PM +0100, Andriy Samsonyuk wrote:
> > Hello,
> >
> > i am currenttly running debian 6.0 with 2.6.32-5-486 on CF-27 (toughbook)
> > 300MHz Pentium II with 128MB RAM.
> >
> > I dont need a desktop (gnome, kde, etc) but would like to have X-server running.
>
> Fine. You should consider using a window manager like fvwm though.
i intend to, but not fvwm, i prefer evilwm. But first i wanted to make sure
X is running.

>
> > X starts for root, but not for non-root user
> > user is in groups: users, tty, audio, video
> ^^^
> Weird, a normal user isn't in that group by default.
you are right, i put the user in the group (it did not helped) ;-)
>
> > /etc/X11/Xwrapper.config is set to
> > allowed_users=anybody
>
> Mmmm, mine is set to:
> allowed_users=console

this did not helped too ;-)

>
> > Every time i start X i get:
> >
> > Fatal server error:
> > xf86OpenConsole: Cannot open /dev/tty0 (No such file or directory)
>
> I have:
> root@tal:~# ls -al /dev/tty0
> crw------- 1 root root 4, 0 Mar 14 16:04 /dev/tty0
>
> I'm guessing that your results will be different!
no its not
>
> > changing of the permissions of /dev/tty0 does not help.
>
> Right. ... Ok. ... My guess is that you couldn't get X to start, and so
> decided to have a "play" with things and see if you could fix it. Am I
> right or am I right?
you are surprisingly right ;-)
i am starting from scratch - reinstalled X + default configuration

>
> How are you starting X? We need to know the exact commands.
i have a xinit line in my .profile and exec /.../evilwm in .xinitrc
usual configuration, that always worked (at least at 5 different PCs)
and here i am getting
X: user not authorized to run the X server

and after playing around with files, permissions i got:
xf86OpenConsole: Cannot open /dev/tty0 (No such file or directory)

>
> > I would appreciate any suggestions!
>
> First of all, Don't Panic! The good thing about Debian is, it is
> fixable.
i know, thats why i like it so much

>
> Can you remember the changes you have done?
mostly, aber i set everything to default configurations, just to
be sure

>
> What is the result of:
> apt-cache policy xorg
xorg:
Installed: 1:7.5+8+squeeze1
Candidate: 1:7.5+8+squeeze1
Version table:
*** 1:7.5+8+squeeze1 0
500 http://ftp.de.debian.org/debian/ squeeze/main i386 packages
100 /var/lib/dpkg/status

--
Q: How many Oregonians does it take to screw in a light bulb?
A: Three. One to screw in the light bulb and two to fend off all those
Californians trying to share the experience.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120314095123.GA29004@theo.chemie.tu-muenchen.de">http://lists.debian.org/20120314095123.GA29004@theo.chemie.tu-muenchen.de
 
Old 03-14-2012, 09:02 AM
Andriy Samsonyuk
 
Default X-server problem

On Tue, Mar 13, 2012 at 09:08:07PM +0100, Juergen F. Pennings wrote:
> Andriy Samsonyuk wrote:
> > Every time i start X i get:
> >
> > Fatal server error:
> > xf86OpenConsole: Cannot open /dev/tty0 (No such file or directory)
> >
> Hello Andriy,
> for me it looks strange that you want to start the X-Server on tty0. The
> normal behaviour under debian is to start it on tty7 or higher. As much as
> I remember tty0 is inhibited to start the X-Server on it. What is if you
> start it on another console, maybe tty5?
> Please post the content of your
> /etc/inittab
> In mine you can find:
> # Note that on most Debian systems tty7 is used by the X Window System,
> # so if you want to add more getty's go ahead but skip tty7 if you run X.
> tty0 is not listed in my /etc/inittab.
/etc/inittab is the same as on my working debian squeeze machine:

***
# /etc/inittab: init(8) configuration.
# $Id: inittab,v 1.91 2002/01/25 13:35:21 miquels Exp $

# The default runlevel.
id:2:initdefault:

# Boot-time system configuration/initialization script.
# This is run first except when booting in emergency (-b) mode.
si::sysinit:/etc/init.d/rcS

# What to do in single-user mode.
~:S:wait:/sbin/sulogin

# /etc/init.d executes the S and K scripts upon change
# of runlevel.
#
# Runlevel 0 is halt.
# Runlevel 1 is single-user.
# Runlevels 2-5 are multi-user.
# Runlevel 6 is reboot.

l0:0:wait:/etc/init.d/rc 0
l1:1:wait:/etc/init.d/rc 1
l2:2:wait:/etc/init.d/rc 2
l3:3:wait:/etc/init.d/rc 3
l4:4:wait:/etc/init.d/rc 4
l5:5:wait:/etc/init.d/rc 5
l6:6:wait:/etc/init.d/rc 6
# Normally not reached, but fallthrough in case of emergency.
z6:6:respawn:/sbin/sulogin

# What to do when CTRL-ALT-DEL is pressed.
ca:12345:ctrlaltdel:/sbin/shutdown -t1 -a -r now

# Action on special keypress (ALT-UpArrow).
#kb::kbrequest:/bin/echo "Keyboard Request--edit /etc/inittab to let this work."

# What to do when the power fails/returns.
pf:owerwait:/etc/init.d/powerfail start
pn:owerfailnow:/etc/init.d/powerfail now
po:owerokwait:/etc/init.d/powerfail stop

# /sbin/getty invocations for the runlevels.
#
# The "id" field MUST be the same as the last
# characters of the device (after "tty").
#
# Format:
# <id>:<runlevels>:<action>:<process>
#
# Note that on most Debian systems tty7 is used by the X Window System,
# so if you want to add more getty's go ahead but skip tty7 if you run X.
#
1:2345:respawn:/sbin/getty 38400 tty1
2:23:respawn:/sbin/getty 38400 tty2
3:23:respawn:/sbin/getty 38400 tty3
4:23:respawn:/sbin/getty 38400 tty4
5:23:respawn:/sbin/getty 38400 tty5
6:23:respawn:/sbin/getty 38400 tty6

# Example how to put a getty on a serial line (for a terminal)
#
#T0:23:respawn:/sbin/getty -L ttyS0 9600 vt100
#T1:23:respawn:/sbin/getty -L ttyS1 9600 vt100

# Example how to put a getty on a modem line.
#
#T3:23:respawn:/sbin/mgetty -x0 -s 57600 ttyS3
***

i am getting this error msg. after allowing user to write in
/var/log/ - not a nice thing to do
and changing the permissions of /usr/bin/X - i have never had to do it before

without this changes
root# xinit
starts the X-server

and
user# xinit
tells me X: user not authorized to run X server


>
> --
> Sch??ne Gr????e vom M??hnesee
>
> J??rgen
>
>
> --
> To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
> Archive: http://lists.debian.org/72m439-odq.ln1@acer.hebelweg.de
>
>

--
Tuesday After Lunch is the cosmic time of the week.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120314100218.GB29004@theo.chemie.tu-muenchen.de">http://lists.debian.org/20120314100218.GB29004@theo.chemie.tu-muenchen.de
 

Thread Tools




All times are GMT. The time now is 04:51 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org