FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 03-08-2012, 12:15 AM
"Ryan J Nicholson"
 
Default libc6.1-dev 2.11.3-3 after Squeeze 6.0.4 DVD install on ia64

I installed ia64 Squeeze 6.0.4 from DVD to an HP Integrity rx1620. I
enabled mirrors during the install - ftp.us.debian.org.

After installation, I updated against ftp.us.debian.org. I attempted to
install build-essential and was blocked:


Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
build-essential :
Depends: libc6.1-dev but it is not going to be installed or libc-dev
Depends: g++ (>= 4:4.4.3) but it is not going to be installed


The 6.0.4 ia64 DVD has

./pool/main/e/eglibc/libc6.1-dev_2.11.3-2_ia64.deb
./pool/main/e/eglibc/libc6.1_2.11.3-2_ia64.deb

However, my newly-installed system has

ii libc6.1 2.11.3-3

The other 2.11.3-3 versions for libc6.1-dev are available, and on a
different rx1620 I downloaded and installed

libc6.1-dev_2.11.3-3_ia64.deb
libc-dev-bin_2.11.3-3_ia64.deb

and was able to do apt-get install build-essential afterwards without the
error.

Why does updating against ftp.us.debian.org not mark libc6.1-dev 2.11.3-3
as the latest version, and pull in all of the 2.11.3-3 packages?

Or, if 2.11.3-2 is the correct "most recent" package for Squeeze ia64..

http://packages.debian.org/squeeze/libc6.1-dev

then how did my DVD install with network mirrors automatically update
libc6.1 to 2.11.3-3?


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 1b51e3b5fc6dd4a01405d74aa1df2640.squirrel@www.moxt rait.com">http://lists.debian.org/1b51e3b5fc6dd4a01405d74aa1df2640.squirrel@www.moxt rait.com
 
Old 03-08-2012, 04:44 PM
Camaleón
 
Default libc6.1-dev 2.11.3-3 after Squeeze 6.0.4 DVD install on ia64

On Wed, 07 Mar 2012 18:15:30 -0700, Ryan J Nicholson wrote:

> The following packages have unmet dependencies:
> build-essential :
> Depends: libc6.1-dev but it is not going to be installed or libc-dev

This says that you have to manually install "libc-dev" first.

> Depends: g++ (>= 4:4.4.3) but it is not going to be installed

For this one I really can't tell why is not marked to be installed :-?

(...)

> Why does updating against ftp.us.debian.org not mark libc6.1-dev
> 2.11.3-3 as the latest version, and pull in all of the 2.11.3-3
> packages?

Just thinking out loud: this is a situation that requires of manual
interaction.

Greetings,

--
Camaleón


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: jjar5q$ek5$12@dough.gmane.org">http://lists.debian.org/jjar5q$ek5$12@dough.gmane.org
 

Thread Tools




All times are GMT. The time now is 04:31 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org