Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian User (http://www.linux-archive.org/debian-user/)
-   -   CUPS and Brother HL-5340D dual whammy (http://www.linux-archive.org/debian-user/638788-cups-brother-hl-5340d-dual-whammy.html)

Joel Roth 02-28-2012 09:05 PM

CUPS and Brother HL-5340D dual whammy
 
After a recent sid dist-upgrade, I'm having problems
printing.

The CUPS test page prints a border with this text only:

Brother HL-5340D Series
3010.106 5
-88807824

That is using the 5240 driver.

I tried a couple other Brother HL-* drivers, but no success.

Now, I've got a PPD file for HL-5340D, but when I try to select
it I get this error:

unable to copy interface script: no such file or directory

Any ideas what I can do with this?

Regards,

--
Joel Roth


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120228220508.GA9560@sprite">http://lists.debian.org/20120228220508.GA9560@sprite

Brian 02-29-2012 12:40 PM

CUPS and Brother HL-5340D dual whammy
 
On Tue 28 Feb 2012 at 12:05:08 -1000, Joel Roth wrote:

> After a recent sid dist-upgrade, I'm having problems
> printing.
>
> The CUPS test page prints a border with this text only:
>
> Brother HL-5340D Series
> 3010.106 5
> -88807824
>
> That is using the 5240 driver.
>
> I tried a couple other Brother HL-* drivers, but no success.

There are also drivers in Generic you could try.

> Now, I've got a PPD file for HL-5340D, but when I try to select
> it I get this error:
>
> unable to copy interface script: no such file or directory
>
> Any ideas what I can do with this?

It might be particular to the ppd you have. Tell CUPS to use one in
/usr/share/ppd. Still the same error?.

Creating /etc/cups/interfaces might be a way round the issue.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120229134038.GA13677@desktop">http://lists.debian.org/20120229134038.GA13677@desktop

Camaleón 02-29-2012 01:21 PM

CUPS and Brother HL-5340D dual whammy
 
On Tue, 28 Feb 2012 12:05:08 -1000, Joel Roth wrote:

> After a recent sid dist-upgrade, I'm having problems printing.
>
> The CUPS test page prints a border with this text only:
>
> Brother HL-5340D Series
> 3010.106 5
> -88807824
>
> That is using the 5240 driver.

If the printer also supports PCL5/6, you can also try with the generic
driver.

> I tried a couple other Brother HL-* drivers, but no success.
>
> Now, I've got a PPD file for HL-5340D,

You got it from here, right?

http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/download_prn.html#HL-5340D

> but when I try to select it I get this error:
>
> unable to copy interface script: no such file or directory
>
> Any ideas what I can do with this?

You can try to install the PPD by following Brother instructions (step 4),
that is, manually, and then proceed as usual:

Install a ppd file
http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/instruction_prn1c.html

Greetings,

--
Camaleón


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: jilc8f$8c5$9@dough.gmane.org">http://lists.debian.org/jilc8f$8c5$9@dough.gmane.org

Joel Roth 03-01-2012 11:56 AM

CUPS and Brother HL-5340D dual whammy
 
On Wed, Feb 29, 2012 at 01:40:38PM +0000, Brian wrote:
> On Tue 28 Feb 2012 at 12:05:08 -1000, Joel Roth wrote:
>
> > After a recent sid dist-upgrade, I'm having problems
> > printing.
> >
> > The CUPS test page prints a border with this text only:
> >
> > Brother HL-5340D Series
> > 3010.106 5
> > -88807824
> >
> > That is using the 5240 driver.
> >
> > I tried a couple other Brother HL-* drivers, but no success.
>
> There are also drivers in Generic you could try.
>
> > Now, I've got a PPD file for HL-5340D, but when I try to select
> > it I get this error:
> >
> > unable to copy interface script: no such file or directory
> >
> > Any ideas what I can do with this?
>
> It might be particular to the ppd you have. Tell CUPS to use one in
> /usr/share/ppd. Still the same error?.
>
> Creating /etc/cups/interfaces might be a way round the issue.

Indeed, this lets me select and install a PPD file.

Now I get an error when attempting to print:

"/etc/cups/interfaces/Brother_HL-5340D_series failed"

I will see if I can find an updated version.

Thanks!

--
Joel Roth


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120301125615.GB23520@sprite">http://lists.debian.org/20120301125615.GB23520@sprite

Joel Roth 03-01-2012 12:01 PM

CUPS and Brother HL-5340D dual whammy
 
On Wed, Feb 29, 2012 at 02:21:03PM +0000, Camale??n wrote:
> On Tue, 28 Feb 2012 12:05:08 -1000, Joel Roth wrote:
>
> > After a recent sid dist-upgrade, I'm having problems printing.
> >
> > The CUPS test page prints a border with this text only:
> >
> > Brother HL-5340D Series
> > 3010.106 5
> > -88807824
> >
> > That is using the 5240 driver.
>
> If the printer also supports PCL5/6, you can also try with the generic
> driver.

Yes, I see that it supports PCL6 and BR-Script3 (Postscript
3) so I should have workarounds, which I hope will support
double sided printing!

> > I tried a couple other Brother HL-* drivers, but no success.
> >
> > Now, I've got a PPD file for HL-5340D,
>
> You got it from here, right?
>
> http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/download_prn.html#HL-5340D
>
> > but when I try to select it I get this error:
> >
> > unable to copy interface script: no such file or directory
> >
> > Any ideas what I can do with this?
>
> You can try to install the PPD by following Brother instructions (step 4),
> that is, manually, and then proceed as usual:
>
> Install a ppd file
> http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/instruction_prn1c.html

Thanks. I appreciate your help, and the amazing community
support.

Joel

> Greetings,
>
> --
> Camaleón
>
>
> --
> To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
> Archive: http://lists.debian.org/jilc8f$8c5$9@dough.gmane.org
>

--
Joel Roth


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120301130153.GC23520@sprite">http://lists.debian.org/20120301130153.GC23520@sprite

Nate Bargmann 03-01-2012 12:03 PM

CUPS and Brother HL-5340D dual whammy
 
* On 2012 28 Feb 16:06 -0600, Joel Roth wrote:
> After a recent sid dist-upgrade, I'm having problems
> printing.
>
> The CUPS test page prints a border with this text only:
>
> Brother HL-5340D Series
> 3010.106 5
> -88807824
>
> That is using the 5240 driver.
>
> I tried a couple other Brother HL-* drivers, but no success.
>
> Now, I've got a PPD file for HL-5340D, but when I try to select
> it I get this error:
>
> unable to copy interface script: no such file or directory
>
> Any ideas what I can do with this?

I think you're the newest member to our growing club! See:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=660420

- Nate >>

--

"The optimist proclaims that we live in the best of all
possible worlds. The pessimist fears this is true."

Ham radio, Linux, bikes, and more: http://www.n0nb.us


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120301130350.GA24050@n0nb.us">http://lists.debian.org/20120301130350.GA24050@n0nb.us

Brian 03-01-2012 12:18 PM

CUPS and Brother HL-5340D dual whammy
 
On Thu 01 Mar 2012 at 02:56:15 -1000, Joel Roth wrote:

> On Wed, Feb 29, 2012 at 01:40:38PM +0000, Brian wrote:
> >
> > It might be particular to the ppd you have. Tell CUPS to use one in
> > /usr/share/ppd. Still the same error?.

Knowing the outcome of doing this would have been useful.

What is the result of

file <your_supposed_ppd_file> ?


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120301131822.GC13677@desktop">http://lists.debian.org/20120301131822.GC13677@desktop

Joel Roth 03-02-2012 06:51 AM

CUPS and Brother HL-5340D dual whammy
 
On Thu, Mar 01, 2012 at 01:18:22PM +0000, Brian wrote:
> On Thu 01 Mar 2012 at 02:56:15 -1000, Joel Roth wrote:
>
> > On Wed, Feb 29, 2012 at 01:40:38PM +0000, Brian wrote:
> > >
> > > It might be particular to the ppd you have. Tell CUPS to use one in
> > > /usr/share/ppd. Still the same error?.
>
> Knowing the outcome of doing this would have been useful.
>
> What is the result of
>
> file <your_supposed_ppd_file> ?

UTF-8 Unicode (with BOM) text

I think it's a good idea to have several different
printers in cups one for each applicable driver
for a given printer.

Cheers,

--
Joel Roth


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120302075109.GA29750@sprite">http://lists.debian.org/20120302075109.GA29750@sprite

Brian 03-02-2012 09:41 AM

CUPS and Brother HL-5340D dual whammy
 
On Thu 01 Mar 2012 at 21:51:09 -1000, Joel Roth wrote:

> On Thu, Mar 01, 2012 at 01:18:22PM +0000, Brian wrote:
> >
> > What is the result of
> >
> > file <your_supposed_ppd_file> ?
>
> UTF-8 Unicode (with BOM) text

This is the norm here:

brian@desktop:/usr/share/ppd/cups-pdf$ file CUPS-PDF.ppd
CUPS-PDF.ppd: PPD file, version "4.3"

The error you got is reproducible by removing the first line of a ppd

*PPD-Adobe: "4.3"


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120302104155.GE13677@desktop">http://lists.debian.org/20120302104155.GE13677@desktop

Joel Roth 03-03-2012 01:30 AM

CUPS and Brother HL-5340D dual whammy
 
On Fri, Mar 02, 2012 at 10:41:55AM +0000, Brian wrote:
> On Thu 01 Mar 2012 at 21:51:09 -1000, Joel Roth wrote:
>
> > On Thu, Mar 01, 2012 at 01:18:22PM +0000, Brian wrote:
> > >
> > > What is the result of
> > >
> > > file <your_supposed_ppd_file> ?
> >
> > UTF-8 Unicode (with BOM) text
>
> This is the norm here:
>
> brian@desktop:/usr/share/ppd/cups-pdf$ file CUPS-PDF.ppd
> CUPS-PDF.ppd: PPD file, version "4.3"
>
> The error you got is reproducible by removing the first line of a ppd
>
> *PPD-Adobe: "4.3"

I see I have a couple leading characters of garbage. Removing them,
I now get "/etc/cups/interfaces/HL-5340D_native_ppd failed"
Worth getting a virgin copy of the ppd to be sure (although
I'm doing fine with the PCL6 driver ATM.)

Thanks for persisting.

--
Joel Roth


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120303023026.GA1956@sprite">http://lists.debian.org/20120303023026.GA1956@sprite


All times are GMT. The time now is 01:12 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.