FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 09-27-2011, 12:23 PM
Csanyi Pal
 
Default Upgraded from Squeeze to unstable - Installing gnash

Hi,

After resolving sudo issue I want to install gnash but get these output:

sudo aptitude install gnash

The following NEW packages will be installed:
gnash gnash-common{ab}
The following packages are RECOMMENDED but will NOT be installed:
gstreamer0.10-ffmpeg gstreamer0.10-fluendo-mp3
0 packages upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/2.980 kB of archives. After unpacking 9.417 kB will be
used.
The following packages have unmet dependencies:
gnash-common: Depends: libavcodec52 (>= 4:0.6-1~) which is a virtual
package. or
libavcodec-extra-52 (>= 4:0.6-1~) which is a
virtual package.
Depends: libavformat52 (>= 4:0.6-1~) which is a virtual
package. or
libavformat-extra-52 (>= 4:0.6-1~) which is a
virtual package.
Depends: libavutil50 (>= 4:0.6-1~) which is a virtual
package. or
libavutil-extra-50 (>= 4:0.6-1~) which is a
virtual package.
Depends: libswscale0 (>= 4:0.6-1~) which is a virtual
package. or
libswscale-extra-0 (>= 4:0.6-1~) which is a
virtual package.
The following actions will resolve these dependencies:

Keep the following packages at their current version:
1) gnash [Not Installed]
2) gnash-common [Not Installed]



Accept this solution? [Y/n/q/?]

What can I do to solve this problem?


--
Regards, Pal
<http://cspl.me>


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 87ehz2xjfq.fsf_-_@debian-asztal.excito">http://lists.debian.org/87ehz2xjfq.fsf_-_@debian-asztal.excito
 
Old 09-28-2011, 12:14 AM
Bob Proulx
 
Default Upgraded from Squeeze to unstable - Installing gnash

Csanyi Pal wrote:
> sudo aptitude install gnash
>
> The following NEW packages will be installed:
> gnash gnash-common{ab}
> ...
> The following packages have unmet dependencies:
> gnash-common: Depends: libavcodec52 (>= 4:0.6-1~) which is a virtual

But Squeeze's gnash-common is version 0.8.8-5 and version 0.8.8-5
depends upon libavcodec52 (>= 4:0.5.1-1) which is different from what
you are showing us here. You must have something strange going on in
your /etc/apt/sources.list file. Version 4:0.6-1~ is from Sid.

> What can I do to solve this problem?

Review /etc/apt/sources.list. Make it contain *only* squeeze archives
and it should be okay. Remove the Sid lines from your Squeeze machine.

Bob
 
Old 09-28-2011, 12:40 AM
Bob Proulx
 
Default Upgraded from Squeeze to unstable - Installing gnash

Bob Proulx wrote:
> Csanyi Pal wrote:
> > sudo aptitude install gnash
> >
> > The following NEW packages will be installed:
> > gnash gnash-common{ab}
> > ...
> > The following packages have unmet dependencies:
> > gnash-common: Depends: libavcodec52 (>= 4:0.6-1~) which is a virtual
>
> But Squeeze's gnash-common is version 0.8.8-5 and version 0.8.8-5
> depends upon libavcodec52 (>= 4:0.5.1-1) which is different from what
> you are showing us here. You must have something strange going on in
> your /etc/apt/sources.list file. Version 4:0.6-1~ is from Sid.

Oops. After I sent that I realized that you were upgrading *from*
Squeeze and not *to* Squeeze. And therefore my answer was bogus.
Sorry about that. Let me try again with Sid as the desired target.

My Sid machine has gnash installed.

$ apt-show-versions | grep gnash
browser-plugin-gnash/sid uptodate 0.8.10~git20110618-3
gnash/sid uptodate 0.8.10~git20110618-3
gnash-common/sid uptodate 0.8.10~git20110618-3

Now dependencies.

$ apt-show-versions | grep libavcodec52
libavcodec52 4:0.6.2-5 installed: No available version in archive

$ apt-cache show gnash-common | grep Depends
Depends: libavcodec52 (>= 4:0.6-1~) | libavcodec-extra-52 (>= 4:0.6-1~), ...

$ apt-cache policy libavcodec-extra-52
libavcodec-extra-52:
Installed: (none)
Candidate: (none)
Version table:

Checking the package page:

http://packages.debian.org/sid/gnash-common
libavformat-extra-52 (>= 4:0.5.1-1)
Package not available

It appears that in Sid libavformat52 has migrated to libavformat53 and
the gnash package hasn't caught up to the change.

Due to this it looks like Gnash is uninstallable in Sid right now. I
will file a bug on it.

To get something that will work for you there are two easy ways. For
one /add/ the Wheezy lines to your sources.list file in addition to
your sid lines. That should make it installable. It will pull the
versions from Testing which are still available there and should get
you going.

For another you can use snapshot.debian.org to point to a previous
snapshot of Sid when the packages were installable. There are
instructions on the front page.

http://snapshot.debian.org/

Or for a third option you could simply download the right package from
the snapshot package page:

http://snapshot.debian.org/package/libav/4%3A0.6.2-5/

The commands would be something like:

wget http://snapshot.debian.org/archive/debian/20110730T152949Z/pool/main/liba/libav/libavformat52_0.6.2-5_i386.deb

dpkg -i libavformat52_0.6.2-5_i386.deb

Note that if you are working with Sid Unstable you will need to become
proficient in dealing with breakages such as this. Using 'snapshot'
is a valuable resource.

Bob
 

Thread Tools




All times are GMT. The time now is 06:39 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org