FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian User

 
 
LinkBack Thread Tools
 
Old 09-21-2011, 06:36 AM
Sthu Deus
 
Default 3D.rendering became slow since moved to wheezy.

Thank You for Your time and answer again, Jörg-Volker:

>so hardware rendering is still used.
>(By the way, glxgears is not good for any performance test or
>comparison.)

Yes. It does - as said, Just became much slower.

Yet it gave me some numbers that agree w/ the situation. But even in
case we leave the utility, I see openarena plays extremely slow than
before.

>In case of problems, I would have expected something like "Direct
>rendering disabled".
>
>I see no clue for reduced performance here.

Me too.

>Does the output of
>
> grep -E '((WW|EE))' /var/log/Xorg.0.log
>
>give some hints?

No...

[ 38.110] (WW) The directory "/usr/share/fonts/X11/cyrillic" does
not exist.
[ 41.173] (EE) Query no Synaptics: 6003C8
[ 41.174] (EE) SynPS/2 Synaptics TouchPad Unable to query/initialize
Synaptics hardware.
[ 41.176] (EE) PreInit returned 11 for "SynPS/2
Synaptics TouchPad"
[ 698.517] (EE) Query no Synaptics: 6003C8
[ 698.517] (EE) SynPS/2 Synaptics TouchPad Unable to query/initialize
Synaptics hardware.
[ 698.540] (EE) PreInit returned 11 for "SynPS/2
Synaptics TouchPad"

I want to try to login w/ failsafe session (just X-terminal available)
but it fails for me - to try openarena there - to be out of K/LX -DEs -
do You know what can be missing?


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4e7985ee.835ce30a.41b5.0e83@mx.google.com">http://lists.debian.org/4e7985ee.835ce30a.41b5.0e83@mx.google.com
 
Old 09-21-2011, 07:43 AM
Jörg-Volker Peetz
 
Default 3D.rendering became slow since moved to wheezy.

Hi,

Sthu Deus wrote, on 09/21/11 08:36:
> Thank You for Your time and answer again, Jörg-Volker:
>
>> so hardware rendering is still used.
>> (By the way, glxgears is not good for any performance test or
>> comparison.)
>
> Yes. It does - as said, Just became much slower.
>
> Yet it gave me some numbers that agree w/ the situation. But even in
> case we leave the utility, I see openarena plays extremely slow than
> before.
>
>> In case of problems, I would have expected something like "Direct
>> rendering disabled".
>>
>> I see no clue for reduced performance here.
>
> Me too.
>
>> Does the output of
>>
>> grep -E '((WW|EE))' /var/log/Xorg.0.log
>>
>> give some hints?
>
> No...
>
> [ 38.110] (WW) The directory "/usr/share/fonts/X11/cyrillic" does
> not exist.
> [ 41.173] (EE) Query no Synaptics: 6003C8
> [ 41.174] (EE) SynPS/2 Synaptics TouchPad Unable to query/initialize
> Synaptics hardware.
> [ 41.176] (EE) PreInit returned 11 for "SynPS/2
> Synaptics TouchPad"
> [ 698.517] (EE) Query no Synaptics: 6003C8
> [ 698.517] (EE) SynPS/2 Synaptics TouchPad Unable to query/initialize
> Synaptics hardware.
> [ 698.540] (EE) PreInit returned 11 for "SynPS/2
> Synaptics TouchPad"
>
> I want to try to login w/ failsafe session (just X-terminal available)
> but it fails for me - to try openarena there - to be out of K/LX -DEs -
> do You know what can be missing?
>
Do you see any error message?
May be the package xterm is missing?
By the way, what is the content of /etc/modprobe.d/radeon-kms.conf?
--
Best regards,
Jörg-Volker.





--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: j5c4hp$4qb$1@dough.gmane.org">http://lists.debian.org/j5c4hp$4qb$1@dough.gmane.org
 
Old 09-21-2011, 11:23 AM
Arnt Karlsen
 
Default 3D.rendering became slow since moved to wheezy.

On Tue, 20 Sep 2011 15:20:22 +0700, Sthu wrote in message
<4e784cc9.5267e30a.3a0f.3273@mx.google.com>:

> Thank You for Your time and answer, Arnt:
>
> >..dunno OpenArena, to help investigate your problem, install and
> >start FlightGear-2.4 and chk the orange number in the lower right
> >hand corner, should match your screen refresh rate, just like
> >glxgears and I _guess_ OpenArena too.
>
> I'm unlucky w/ it: ^)
>
> $ /usr/games/fgfs
> FGMultiplayMgr - No receiver port, Multiplayermode disabled
> KI266 dme indicator #0 initialized
> loading scenario 'nimitz_demo'
> creating 3D noise texture... DONE
> AL lib: pulseaudio.c:612: Context did not connect: Connection refused
> AL lib: pulseaudio.c:612: Context did not connect: Connection refused
> ALSA lib pcm.c:2212snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
> ALSA lib pcm.c:2212snd_pcm_open_noupdate) Unknown PCM
> cards.pcm.center_lfe ALSA lib pcm.c:2212snd_pcm_open_noupdate)
> Unknown PCM cards.pcm.side ALSA lib pcm_dmix.c:957snd_pcm_dmix_open)
> The dmix plugin supports only playback stream Cannot connect to server
> socket err = No such file or directory Cannot connect to server socket
> jack server is not running or cannot be started

..you wanna fix your jack server, if you want fgfs with audio.

> Initializing Nasal Electrical System
> Scaling image
> '/usr/share/games/FlightGear/Textures.high/Signs/black.png' from
> (4096,128) to (2048,128) Scaling image
> '/usr/share/games/FlightGear/Textures.high/Signs/framed.png' from
> (4096,128) to (2048,128) Scaling image
> '/usr/share/games/FlightGear/Textures.high/Signs/yellow.png' from
> (4096,128) to (2048,128) Scaling image
> '/usr/share/games/FlightGear/Textures.high/Signs/red.png' from
> (4096,128) to (2048,12

..these messages are ok, texture scaling works ok.

> May we can use some utilities for the issue?

..yup, try again with "fgfs --disable-audio --disable-ai --disable-mp",
you have an audio server problem that stalls fgfs, and we don't need
multiplayer nor AI traffic, nor the USS Nimitz floating around here.
Disclaimer: Find the correct --disable-* command line switches with
"fgfs -v -h |less ", I'm working from my errorprone memory. ;o)

>
>


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20110921132351.7c6b3731@nb6.lan">http://lists.debian.org/20110921132351.7c6b3731@nb6.lan
 
Old 09-21-2011, 02:25 PM
Sthu Deus
 
Default 3D.rendering became slow since moved to wheezy.

Thank You for Your time and answer, Jörg-Volker:

>> I want to try to login w/ failsafe session (just X-terminal
>> available) but it fails for me - to try openarena there - to be out
>> of K/LX -DEs - do You know what can be missing?
>>
>Do you see any error message?

Yes, this one:
Xsession: X session started for gue at Wed Sep 21 21:20:06 GMT-7 2011
x-terminal-emulator: Fatal IO error: client killed
konsole(13820) Konsole::SessionManager::~SessionManager: Konsole
SessionManager destroyed with sessions still alive

>May be the package xterm is missing?

Yes. It did. I have installed now. But problem remains - just I see a
window then session exits.

>By the way, what is the content of /etc/modprobe.d/radeon-kms.conf?

Just single string:

options radeon modeset=1


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4e79f3dd.8268e30a.7d18.6754@mx.google.com">http://lists.debian.org/4e79f3dd.8268e30a.7d18.6754@mx.google.com
 
Old 09-21-2011, 02:32 PM
Sthu Deus
 
Default 3D.rendering became slow since moved to wheezy.

Thank You for Your time and answer, Arnt:

>you wanna fix your jack server, if you want fgfs with audio.

Do You mean it is not running? If so, how I cam=n start it? - Some MIDI
software asks for that but I have no script in /etc/init.d .

>> May we can use some utilities for the issue?
>
>..yup, try again with "fgfs --disable-audio --disable-ai --disable-mp",
>you have an audio server problem that stalls fgfs, and we don't need
>multiplayer nor AI traffic, nor the USS Nimitz floating around here.
>Disclaimer: Find the correct --disable-* command line switches with
>"fgfs -v -h |less ", I'm working from my errorprone memory. ;o)

Oh. After several tries w/ the game and You not answering me (I thought
You did quit from the thread) I have removed the game. Also, I had no
idea what to do w/ that (how to play ether). So, if the only goal is to
measure my hardware speed may we use some other game/utility that You
know - for glxgears is pretty well for this - as answers what I see in
the 3D game I use. Of course, I myself can see if the speed becomes any
better/worse.

?

Thanks again, for Your time and effort.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4e79f58f.83c9e30a.402b.6c32@mx.google.com">http://lists.debian.org/4e79f58f.83c9e30a.402b.6c32@mx.google.com
 
Old 09-21-2011, 02:57 PM
Arnt Karlsen
 
Default 3D.rendering became slow since moved to wheezy.

On Wed, 21 Sep 2011 21:32:33 +0700, Sthu wrote in message
<4e79f58f.83c9e30a.402b.6c32@mx.google.com>:

> Thank You for Your time and answer, Arnt:
>
> >you wanna fix your jack server, if you want fgfs with audio.
>
> Do You mean it is not running? If so, how I cam=n start it? - Some
> MIDI software asks for that but I have no script in /etc/init.d .

..I dunno jack, hence the --disable-audio workaround.

>
> >> May we can use some utilities for the issue?
> >
> >..yup, try again with "fgfs --disable-audio --disable-ai
> >--disable-mp", you have an audio server problem that stalls fgfs,
> >and we don't need multiplayer nor AI traffic, nor the USS Nimitz
> >floating around here. Disclaimer: Find the correct --disable-*
> >command line switches with "fgfs -v -h |less ", I'm working from my
> >errorprone memory. ;o)
>
> Oh. After several tries w/ the game and You not answering me (I
> thought You did quit from the thread)

..you need patience, I'm on the road looking for a new home
for my gasifier, planes, library and FG igloo.

> I have removed the game. Also,
> I had no idea what to do w/ that (how to play ether). So, if the only
> goal is to measure my hardware speed may we use some other
> game/utility that You know

..yup, just "aptitude install flightgear" and try my --disable
workaround. If you don't wanna learn flying, simply "aptitude
purge flightgear" once we're done diagnosing your box.

..we want that orange number in the bottom right hand corner.

> - for glxgears is pretty well for this -

..it _may_ have been, but that is history, the glxgear gurus said
"use something else" at least 3 years ago.

> as answers what I see in the 3D game I use. Of course, I myself can
> see if the speed becomes any better/worse.
>
> ?
>
> Thanks again, for Your time and effort.
>
>


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20110921165720.1a9d4e82@nb6.lan">http://lists.debian.org/20110921165720.1a9d4e82@nb6.lan
 
Old 09-21-2011, 10:02 PM
Jörg-Volker Peetz
 
Default 3D.rendering became slow since moved to wheezy.

Hi,

Sthu Deus wrote, on 09/21/11 16:25:
> Thank You for Your time and answer, Jörg-Volker:
>
>>> I want to try to login w/ failsafe session (just X-terminal
>>> available) but it fails for me - to try openarena there - to be out
>>> of K/LX -DEs - do You know what can be missing?
>>>
>> Do you see any error message?
>
> Yes, this one:
> Xsession: X session started for gue at Wed Sep 21 21:20:06 GMT-7 2011
> x-terminal-emulator: Fatal IO error: client killed
> konsole(13820) Konsole::SessionManager::~SessionManager: Konsole
> SessionManager destroyed with sessions still alive

So the error is not due to the missing xterm :-(
Seems to be some problem with KDE. I have no clue.

>
>> May be the package xterm is missing?
>
> Yes. It did. I have installed now. But problem remains - just I see a
> window then session exits.
>
>> By the way, what is the content of /etc/modprobe.d/radeon-kms.conf?
>
> Just single string:
>
> options radeon modeset=1
>
>
This seems to me o.k.

Seems, I can't help you further.
--
Best regards,
Jörg-Volker.




--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: j5dmst$h5b$1@dough.gmane.org">http://lists.debian.org/j5dmst$h5b$1@dough.gmane.org
 
Old 09-22-2011, 08:41 AM
Wolodja Wentland
 
Default 3D.rendering became slow since moved to wheezy.

On Thu, Sep 15, 2011 at 14:10 +0700, Sthu Deus wrote:
> Thank You for Your time and answer, Arnt:
>
> >> I have slow 3D rendering on ATI card after full upgrading to wheezy.
> >>
> >> Is there any strategy how I can investigate the bottle neck so that I
> >> might file a bug report against it?

> Hmm. To me whole the problem is strange - I think there should be no 3D
> or it should be at some little variable FPS change after the upgrade,
> but it works as follows : from about 420 in Squeeze down to 60 Wheezy...

Is glxgears your only benchmark for establishing that 3D rendering is slow? If
so, it is most likely that it is a faulty benchmark as I am sure that 60FPS is
due to the FPS being synchronised to the VSYNC (refresh rate) of your TFT
(i.e. 60Hz).

Is it actually slower? What is the output of:

$ glxinfo | grep -e 'direct|renderer'
--
Wolodja <babilen@gmail.com>

4096R/CAF14EFC
081C B7CD FF04 2BA9 94EA 36B2 8B7F 7D30 CAF1 4EFC
 
Old 09-22-2011, 10:20 AM
Sthu Deus
 
Default 3D.rendering became slow since moved to wheezy.

Thank You for Your time and answer, Arnt:

>> Oh. After several tries w/ the game and You not answering me (I
>> thought You did quit from the thread)
>
>..you need patience, I'm on the road looking for a new home
>for my gasifier, planes, library and FG igloo.

Probably the game and me do like each other - look what I've got:

$ fgfs --disable-sound --disable-ai-models
FGMultiplayMgr - No receiver port, Multiplayermode
disabled KI266 dme indicator #0
initialized loading scenario
'nimitz_demo' creating 3D noise texture...
DONE Initializing Nasal Electrical
System Segmentation
fault

With this I have ended up. Please search Your 'errorprone memory' - may
You will find another util. to measure the FPS.

>> - for glxgears is pretty well for this -
>..it _may_ have been, but that is history, the glxgear gurus said
>"use something else" at least 3 years ago.

Do You remember what they did recommend? - Now-days for it works - when
I admit speed change - so glxgears do also.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4e7b0c0b.418bcc0a.6c20.ffffb409@mx.google.com">htt p://lists.debian.org/4e7b0c0b.418bcc0a.6c20.ffffb409@mx.google.com
 
Old 09-22-2011, 03:40 PM
Arnt Karlsen
 
Default 3D.rendering became slow since moved to wheezy.

On Thu, 22 Sep 2011 17:20:45 +0700, Sthu wrote in message
<4e7b0c0b.418bcc0a.6c20.ffffb409@mx.google.com>:

> Thank You for Your time and answer, Arnt:
>
> >> Oh. After several tries w/ the game and You not answering me (I
> >> thought You did quit from the thread)
> >
> >..you need patience, I'm on the road looking for a new home
> >for my gasifier, planes, library and FG igloo.
>
> Probably the game and me do like each other - look what I've got:
>
> $ fgfs --disable-sound --disable-ai-models

..maybe I should have said:
try: "fgfs --disable-sound
--disable-ai-models
--disable-mp ", the idea is disable the USS Nimitz too.
Note to Homeland Securityate: The FlightGear AI demo. ;o)

> FGMultiplayMgr - No receiver port, Multiplayermode
> disabled KI266 dme indicator #0
> initialized loading scenario
> 'nimitz_demo' creating 3D noise texture...
> DONE Initializing Nasal Electrical
> System Segmentation
> fault
>
> With this I have ended up. Please search Your 'errorprone memory' -

..on Wed, 21 Sep 2011 13:23:51 +0200, Arnt wrote in message
<20110921132351.7c6b3731@nb6.lan>:

> Disclaimer: Find the correct --disable-* command line
> switches with "fgfs -v -h |less ", I'm working from my
> errorprone memory. ;o)

> may You will find another util. to measure the FPS.

..why? FG does what I want it to. ;o)

> >> - for glxgears is pretty well for this -
> >..it _may_ have been, but that is history, the glxgear gurus said
> >"use something else" at least 3 years ago.
>
> Do You remember what they did recommend?

..vaguely, "e.g. flightgear or some game that needs OpenGL"

> - Now-days for it works -
> when I admit speed change - so glxgears do also.

..yes, reporting your new vsync.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20110922174040.4a6de8b7@nb6.lan">http://lists.debian.org/20110922174040.4a6de8b7@nb6.lan
 

Thread Tools




All times are GMT. The time now is 07:52 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org